1. Tablet future looks bright! Read more about: Alcatel Xess | Samsung Galaxy View
    New Forums: Alcatel Xess | Samsung Galaxy View
    Dismiss Notice

How to installed flash_image on Android phone?


Last Updated:

  1. adam89

    adam89 Member

    Hi guys,

    I'm not sure if this post belongs here, but I'm having troubles with flashing a new recovery image to my rooted Android. I've searched a lot on Google but tend to just get the same kind of questions with no helpful answers. I want to install a new recovery because ClockworkMod isn't compatible with my "PVT4" Desire.

    I've uploaded the image to the root directory on the SD card, and tried running (file name is correct):

    Code (Text):
    1. flash_image recovery /sdcard/recovery.img
    Which tells me the flash_image command isn't found. Could anybody point me in the right direction of a tutorial that explains how to install it on the phone please?

    Thanks for any help,

    Adam

    Advertisement
  2. SUroot

    SUroot Well-Known Member Developer

    Have you got the android SDK downloaded and are you s-off?

    If you are not s-off, and dont want to be, the easiest thing to do is run unrevoked and point it to amonra recovery image.

    Click the red link in my signature for a link to my rooting FAQ. There is a link to the amon ra image you need. It also tells you about how to choose with unrevoked, the recovery image of your choice.
  3. adam89

    adam89 Member

    Okay I've managed to find the flash_image file, copy it to the root of the SD card, but when I mount system as rewritable (assuming successful as there was no errors) and try to move the file to the /system/bin dir I get the following error:

    Code (Text):
    1. # mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system
    2. # mv /sdcard/flash_image /system/bin/flash_image
    3. failed on '/sdcard/flash_image' - Cross-device link
    Anybody have any idea how to get around this? :/

    Thanks again.
  4. SUroot

    SUroot Well-Known Member Developer

    I've already answered. Did you read my post? You've not answered any of my questions but just as a word of warning, you're doing everything wrong.
  5. Rastaman-FB

    Rastaman-FB Well-Known Member

    you cannot mount system as RW if you dont have s-off as SUroot says its a waste of time anyway as you can do this without s-off by just re running unrevoked and chosing custom recovery before connecting the device
  6. SUroot

    SUroot Well-Known Member Developer

    </invisiblemode> test test
  7. adam89

    adam89 Member

    Thanks for your responses.

    Sorry no I didn't see your reply (used quick reply). I had a go at using unrevoked with the custom recovery, but I got the following error:

    Error: failed to get root. Is your firmware too new?

    However I didn't get that error when I ran it originally yesterday. Could be something to do with ClockworkMod?

    I checked my HBoot and I have S-ON, by the way.

    Thanks again for your help.
  8. EddyOS

    EddyOS Well-Known Member

    If you've already used unrEVOked then you're rooted (assuming it completed and you now have the Superuser app in your app drawer) - you now need to S-OFF to change the recovery
  9. adam89

    adam89 Member

    Yeah it's rooted, the Superuser app's there. How do I "S-OFF"?
  10. adam89

    adam89 Member

    ^ I also ticked the 'disable security' check box when running unrevoked.
  11. kewlbuddy

    kewlbuddy Well-Known Member

  12. EddyOS

    EddyOS Well-Known Member

    Only works with CDMA phones, you need the link above to S-OFF a GSM handset at present
  13. SUroot

    SUroot Well-Known Member Developer

    Like eddy says, you can s-off and then use fastboot commands (or the fastboot flasher utility to flash recovery.

    However, when I first changed recovery, I just used unrevoked as I didnt want s-off at that time and it definitely should work.

    Ive only seen 2 reasons for the firmware too new error.

    1) your firmware IS too new (but if you havent flashed a custom rom, this shouldnt be the case).

    2) You have used the setInstallLocation trick too force apps to install to SD which messes with unrevoked.

    Other than that, not sure what the problem could be so it may well be easier to s-off
  14. adam89

    adam89 Member

    Apologies for the late response to this. I was just curious about the S-OFF process, is it relatively safe? I know there's warnings on the web site, but is that just to make sure no one can try and sue them if they do something stupid? Just anxious about doing it at the moment.
  15. SUroot

    SUroot Well-Known Member Developer

    Its fairly safe. Its not really much more dangerous than rooting your phone.

    As long as you dont break the connection to the pc or lose power to the phone during the process, it should be ok.

Share This Page