How to keep the keypad usable during a call?Support

Last Updated:

  1. toddhd

    toddhd Member

    Good morning,

    I love my Android phone, but if I have one major gripe with it, it is trying to use the keypad during a phone call. This is particularly aimed at calls made to automated phone systems, such as when attempting to refill a prescription.

    When I make a call, the very second that the phone reaches a vertical state, the screen "blanks". I assume this is a "works as designed" issue in order to prevent any contact with your ear or face from accidentally pressing buttons, etc. And that's great.

    The problem is, when I take the phone away from my ear, such as when I need to "press one to continue", the darn thing is blanked. And for whatever reason, a simple shake doesn't seem to unlock it, I have to shake that thing like I'm trying to mix paint before it gets the idea and "wakes up".

    I did find a little program called "screen on" that sometimes helps with this, but for whatever reason, Screen On has stopped working, and half the time doesn't even think it is installed.

    Is there some hidden setting or easy way to prevent this annoying action?

  2. mrcminnesota

    mrcminnesota Active Member

    just touch the blank screen and keypad, etc returns.
  3. tyhart44

    tyhart44 Member

    Mine always seems to wake up when I pull it away from my ear, but when needed I've used the volume rocker, although this is a less than ideal solution.
  4. Netcat

    Netcat Well-Known Member

    The screen blanks out during a call when you put the phone to your face because of it's proximity sensor in the top, left corner. If the screen doesn't come back on when you pull it away from your face, the screen probably timed out before you put it up to your face. To increase the screen off time-out, go to home/menu/settings/display/screen_timeout and increase the time before the screen shuts off.

Share This Page