How to know if you have rooted your phone?


  1. Marvelous0ne

    Marvelous0ne Member

    OK, sorry for the newb question. A lot of this talk just goes right over my head. Got my phone in Feburary. And a while back I manually update my phone to RC33. But I can not remember to which one? The build number is...

    kila-user 1.1 PLAT-RC33 126986 ota-rel-keys,release-keys

    also what is Kernel Version?

    I was happy when I did it. Just followed the instructions someone posted and went off without a hitch. Now I thinking of trying to root my phone to update it to one of the cupcakes things that are out there. Cause it does seem pretty cool what these updates can do. But was thinking of waiting for the official update if my phone wasn't rooted. But I still wonder if I did root my phone? I've tried searching for info in the forum, but just not sure what I am looking at. So was the official update to RC33 issues when one can manually update the phone without waiting for T-Mobile to send it out? Or did I root my phone without knowing it? One reason I'm asking cause after I updated it I did have a touch screen keyboard. Of course it seems to only work when I am at the google search on the main screen.

    Any help would be greatly appreciated!

    Advertisement
    :
  2. RozzaC

    RozzaC Well-Known Member

    Wait...so you are trying to ask whether or not you have rooted your phone?

    What exactly have you done to your phone since you got it?
  3. justjimjpc

    justjimjpc Premium Member VIP Member

    to see is you are "rooted" download or use terminal app

    At the $ prompt type su <enter>
    should return a prompt now of
    #

    now enter cd /data/app-private
    if you can do all that then you are rooted
    VegBerg and Black_Cat like this.
  4. Marvelous0ne

    Marvelous0ne Member

    Ok I tried it and and it did not work. So I guess I am not rooted. bummer. But it's good to know how to check.

    EDIT: OK, Thanks to all the tutorials and videos I have rooted my phone and I have cupcake! Woo Hoo!
  5. dynodroid

    dynodroid Well-Known Member

    Awesome! Good job. Quite the step up from not even knowing if your phone was rooted.
  6. justjimjpc

    justjimjpc Premium Member VIP Member

    I ofter my congrats as well and welcome to the awesum possibilites of a rooted G1

    :cool:
  7. duryard

    duryard Member

    Thanks for the info in this thread. I followed the guide else where but this was the only one to say how to tell if rooted or not. Many thanks I can do the su and get the #. 1. Question. What should happen after cd /data/app-private as when I type that in I return to #
  8. taoqueen

    taoqueen Member

    what's the terminal app? can i get it on market??
  9. damastah

    damastah New Member

    What you're doing is changing to that directory which is considered "classified" information. If you have access to that directory, then you've gotten root access. You can then do what you want, like type ls (list the contents of the directory) if it works, you're good to go!





    1st post on these forums BTW :)
  10. Usta

    Usta Well-Known Member

    Although this is an old topic, the question is still probably valid for some people.

    Here is a simple way to check if you are rooted or not: download Root Checker application from Market and it will tell you if you are rooted or not.
    joesto and bribri301 like this.
  11. rush381

    rush381 New Member

    Hey everyone I'm also a total noob here, just got my first android and have a few questions. I switched from the iphone and really liked the screenshots feature. I downloaded drocap2 and shootme and neither of them work. I downloaded the root checker and it says I'm rooted. It asks to make sure I have root permissions, is that different? I tried the terminal thing as well and it just said" not found" after I typed all that. So am I rooted or no? If so why won't those screencap apps work?
  12. Usta

    Usta Well-Known Member

    If you have not rooted your phone, then most likely it is not rooted.
    Root Checker asks root permissions and checks if you have busybox correctly installed. The result of the check for you should be negative.

    The Screenshots applications require root access, although some phones can do that (from Samsung) without root access.

    There is another way to make screenshots though. You download Android SDK to our PC, connect the phone to PC and make screenshots directly while connected. There must be a guide somewhere here in the forum.
  13. No_u

    No_u Well-Known Member

    Without Superuser you're not getting anywhere.
  14. rush381

    rush381 New Member

    I did attempt to root my phone and everything seems to have went fine but when I try to use apps like shootme they don't work. According to root checker I am rooted so im not sure what's wrong. Im using the Atrix 4G if that makes a difference.
  15. Usta

    Usta Well-Known Member

    There are different methods of rooting. Perhaps you should ask this in Atrix forum.
  16. suhara

    suhara New Member

    'su' works for me but when change the directory using 'cd/....' it says 'not found'. that means mine is not rooted?please help!
  17. jerofld

    jerofld Fixing stuff is not easy VIP Member

    Does the $ sign change to # after you type in SU? If so, you are rooted, but root wasn't properly done or it may be a small possibility that it's a malware attack.

    If not, you're not rooted. What device do you have? Do you want to root?
    EarlyMon likes this.
  18. EarlyMon

    EarlyMon The PearlyMon Moderator

    Also, there needs to be a space between the cd and the / - and I'm assuming that ... means some path name, not ...
Loading...

Share This Page