How to load Zefie's custom kernels (for Dummies)

Last Updated:

  1. Naa that file is totally stock... Stock kernel, stock logo and stock CDMA file (all CJ05).. that is safe.. it is CL14 that you want to watch for.. There is no kernel with root only and no kernel improvements... but ZE02 should be the least amount of modifications adn still give you root.. DO NOT USE THE BTLD_TESTMODE METHOD.. It has and probably will brick your phone

  2. indiana jones

    indiana jones Well-Known Member

    awesome ! thanks for the replies! :) im gonna try to flash today and install that flac codec.
  3. indiana jones

    indiana jones Well-Known Member

    got it done with win7 x64 :) now to install flac.
    installed these drivers from usbdrivers (these were provided by cheesemoo over at the tether thread. followed the instructions , debug mode and the whole nine. rebooted my phone into dl mode and plugged it in. i saw the G device and while the phone was connected on dl mode installed Samsung_PC_Studio_321_GL6 after setup was complete i ran odin but it just hung there for a while. so i restarted the dl mode on the phone 4 times until it finally found it. it seems you gotta plug in the usb as fast as possible. im not sure if the other drivers were necessary but just wanted to let you guys know its possible on x64 win7. GL
  4. NOMster

    NOMster Well-Known Member

    If my comp sees my phone for pdanet do I still need to dl other drivers? Or will those work?
  5. Pertinax

    Pertinax Well-Known Member

    I would like to start by saying that I think its great that someone is creating these custom kernels. I am also grateful for the simplified installation instructions.

    I haven't decided to try the custom kernels because it's difficult to determine the risk vs. benefit of the upgrades due to the way the kernel information is presented.

    As someone that is new to the Android platform the list of features in the kernels doesn't mean much to me. It also seems that you have to read through the list of features for each version and try to keep track of what has been added and removed to form your own mental list of current features. A list of all features for the most current version with descriptions that make it easy to understand the benefit of each might help more people to understand the benefits and make the change.
  6. Well I am new, but I did manage to install the 8.2 kernel.
    Now that's the only one that i did install and it does say that i am using it on my phone info screen.
    I downloaded it using XP. I had to make sure that New Studio PC was not running in the bottom task bar. Left click it to close it.
  7. Gizmodo

    Gizmodo Well-Known Member

    I have done everything listed in this thread plus other info sites. Everything. Odin finds my phone, the install starts, then...hangs. I have waited up to 15 minutes...nothing. No phone reboot. It just hangs. I have now done this at least 10 times. I give up. I will wait for Android 2.1.:(
  8. Well I am new, but I did manage to install the 8.2 kernel.
    Now that's the only one that i did install and it does say that i am using it on my phone info screen.
    I downloaded it using XP. I had to make sure that New Studio PC was not running in the bottom task bar. Left click it to close it.
    But when i installed, i still have issues with the battery. I put it on the charger and got it fully charged, then as soon as i pulled it off it was down to 95. Plugged it back in and left it overnight. Got up this morning and unplugged, said it was fully charged, went down to 95. I've been doing stuff on it for about and hour and my battery says that i have 70.
    Am I supposed to download all the previous ones first? Did i do something wrong here?
    I also have the screen flashes, and I have noticed that my reception has been jumping from none to full. Using my browser i notice that things are jumpy... not really smooth.

    Don't get me wrong, i appreciate someone trying to fix the phone, especially with samsung providing tech support the equal of a coconut.....
  9. indiana jones

    indiana jones Well-Known Member

    did it already come up as a g device? did you install pc studio when that happened. today i flashed to 8.2 and i had to pull out the battery and get into dl mode 3 times before it worked. apparently the phone maps to different ports sometimes . once it was in 5 then in 6 then in 7 is when it worked. if you got to the yellow box then all you have to do is reinsert the battery and plug the phone in quick then try odin a few times. if it doesnt work repeat. youll get it.
  10. Gizmodo

    Gizmodo Well-Known Member

    I did everything exactly as described in this thread; even tried other links posted in our forum. It hung up every single time. I waited for 15 minutes more than once...nothing. Guess I will wait for Android 2.1. <sigh>
  11. Hung up in odin?

    Ya i should have documented that better... the code works like this.. 100- >97.5 = 100% reported.. 97.5 -> >92.5 = 95% that is how i had to make the stepped profile.. the first 2.5% is lost immediately when you disconnect teh charger (due to a very very sharp decrease in voltage before it gets into the nominal region)
  12. Does anyone else have the sharp drop in battery life?
    From 95 to 70 in an hour?
    Did a master reset just to make sure....
    Maybe an app is hogging?
  13. Gotta be an app because with 8.2 that drop is almost impossible...
    I attached a zip file with teh battery spreadsheet in it.. there is a graph in book 1 that will show you exactly how the battery meter reports vs voltage

    Note: If the battery is not holding the voltage, you might just have a bad battery and should go get a new one (repair centers will swap the battery out for you)

    Attached Files:

  14. Could there be a possibility that some aspects of the program did not download properly?
    Would downloading them again maybe solve the issue? Or would this cause issues with the phone?
    Right now, I'm trying to kill my battery, and recharge from death.
    Problem is that I have already swapped the phone once and I can't do it again.
    So anything I do comes out of pocket.
  15. BirdieMN

    BirdieMN Active Member

    OK, so I have installed PC studio 3, made sure it isn't running in the background...
    I am using Odin 3.98 and it recognizes my phone just fine...
    I extracted the kernel file using WinRar...
    I've tried with USB Debugging both enabled and disabled...
    I've tried every USB port on my laptop...

    This is what I get every time:

    Code (Text):
    2. Download Start...
    3. <0> Create File...
    4. <1> StartThread Detected : 1
    5. <2> StartThread Detected : 0
    6. <3> StartThread Detected : 0
    7. <4> StartThread Detected : 0
    8. <5> StartThread Detected : 0
    9. <6> StartThread Detected : 0
    10. <7> StartThread Detected : 0
    11. <8> StartThread Detected : 0
    12. <1> Begin Thread..
    13. <1> Engine RUN!!!
    14. <1> e - dll cannot open the usb serial port. code: 87
    Sooooooooo... What am I missing here?


    It appears in my case having a Firefox browser window open was mucking things up. I did a reboot and tried it again with Firefox closed and now I'm happily running ZE08.3!
  16. agent0014

    agent0014 Well-Known Member

    Had you tried previously rebooting and have it fail with FF open? I don't doubt you, but that's really random. I can't imagine anything that FF would normally do that would interfere with Odin. Unless you have some pretty wild add-ons installed? :)
  17. I wouldn't doubt it.. firefox does some pretty wild things (like eat a huge amount of resources for one)... Don't get me wrong i love firefox and would uninstall IE for good if it wouldn't cause windows to go into a meltdown mode, but the sucker is usually eating 200+ mb of mem by itself and sometimes likes to allocate other resources for its own purposes...
  18. agent0014

    agent0014 Well-Known Member

    yeah I've definitely noticed some of the system drain FF causes, just surprised that it would extend itself to the point where it's interfering with serial devices. Personally I'm trying to make the switch to chrome... if only chrome would support tree-style side tabbing (and our company wiki's full suite of editing features worked) I'd be permently on it. Unfortunately for most of my work day I've got both browsers open... which isn't helping matters at all lol.
  19. BirdieMN

    BirdieMN Active Member

    Yep, I had tried rebooting my PC about half a dozen times. I had actually kind of given up on it for the night and dozed off in my recliner for awhile. When I woke up I thought "ahh, screw it I'll give it one more shot". Rebooted the PC, brought up download mode, and viola, I was running on the new kernel.

    Maybe it was all the porn I was looking at... :eek: LOL
  20. I was trying to download the cl14? new rom this morning and i noticed that all the files in zefie's file server are converted to .7z and not .tar.
    I tried to get odin to transfer to my phone but it doesn't see the file when I try and search for it.
    Do I need to convert .7z to .tar somehow?

    Thanks in advance...
  21. NOMster

    NOMster Well-Known Member

    mine is stopping at the found new hardware and asking for "ssdbus.sys" on samsungusb composite. any ideas?
  22. Warlock

    Warlock Well-Known Member

    .7z files are opened with 7-zip. Extract the .tar file just like with windows or winzip.
  23. Ok so now I unzipped the file cl14 working system only and I tried to use odin to upload, but it freaked out and said it didn't recognize a file and odin shut itself down.
    i'm currently running the 8.3 kernel....
    Do i have to reinstall the original rom to get this to work?
  24. NOMster

    NOMster Well-Known Member

    i thinkk i could get this to work...if i could just see the bottom of odin. lol.
  25. Warlock

    Warlock Well-Known Member

    I didn't. I just placed the CL14 file in the "one package" field and followed the rest of the instructions for installing the custom kernels...

    Same process for the cdma_only file to update the modem.

Share This Page