how to make adb list my galaxy?Support


  1. gie62001

    gie62001 Well-Known Member

    hi all,
    i know you all gona say that i should have used forum search which actually i did and i still cant find the answer of how to root (most resent or best methods).
    today i decided to go the way most of you went and root my galaxy so i could enjoy some of the features or customise the devise for it to be either faster or better somehow (particularly im interested in fixing HW acceleration of openGL).
    but my main problem is still that ADB doesnt show my device in the devices list after adb_devices command... i think ive tried everything: reinstalling drivers and NPS, SDK 1.5 r1 putting in debbuging, restarting phone even using USBdeview soft to uninstall all android and samsung drivers and try to make it work but still nothing... all day wasted, many forums read, downloaded KAM187s drivers and still nothing
    im on H8 firmware
    please can anyone help me with this (how to make adb recognise my phone and list it) plus i want some info on how to push this openGL fix on my phone after i root it (if ever :) )
    by the way tried on Windows 7 and XP
    sorry for making a new thread but i think im not the only one whose phone is not listed by adb as i read it on other forums.
    thanx for any info

    Advertisement
    :
  2. Rastaman-FB

    Rastaman-FB Well-Known Member

    32bit or 64bit?
    use the adb testing interface driver from the 1.5 sdk.
    it does work as ive done it on many pcs

    makesure you dont just point it to the folder
    make sure you do "select from list" "have disk" then point it to android-sdk-windows-1.5_r3\usb_driver\whatever os you are using\android_usb

    in the list you will see adb test interface (or something close)
    select that.

    then disconnect and reconnect the phone and when you do adb devices you should see it listed
    makesure you have the device in debugging mode.

    you will need to do the same for fastboot as it will ask for android 1.0. do exactly the same but be prepared as you only have 15 seconds to do it so have device manager ready :p

    good luck
  3. gie62001

    gie62001 Well-Known Member

    thanx rastaman for quick reply and guess what it WORKS! yeay yoohooooo :) at long last my phone is recognised by adb hehe. thanx again to everyone. so will start playing with my phone now (rooting and stuff :) )
  4. Rastaman-FB

    Rastaman-FB Well-Known Member

    well done mate, glad i could help
  5. scollie

    scollie Active Member

    Hi Rastaman-FB, hopefully you or one of the other guides can help me.
    I am on II5 and had rooted my phone and installed GalaxoHero ROM and had ADB working successfully on Win XP.

    I have now upgraded to Win 7 x64 and I can't get ADB to see the phone any more - I get the error: device not found message.
    In device manager it shows ADB Interface\SAMSUNG GALAXY but the drivers were shown as being in C:\Windows\system32\...

    So I followed your advice from one of your posts above as follows:

    32bit or 64bit?
    use the adb testing interface driver from the 1.5 sdk.
    it does work as ive done it on many pcs

    makesure you dont just point it to the folder
    make sure you do "select from list" "have disk" then point it to android-sdk-windows-1.5_r3\usb_driver\whatever os you are using\android_usb

    in the list you will see adb test interface (or something close)
    select that.

    then disconnect and reconnect the phone and when you do adb devices you should see it listed
    makesure you have the device in debugging mode.


    I selected from the list and said I had the disk and Win 7 asked whether I was sure that I wanted to install the drivers and once I confirmed that I did the ADB Interface then showed ADB Testing Interface but it still doesn't work and checking the drivers shows that they are still showing as C:\Windows as before!

    When uninstalling the drivers, there is an option to delete them, should I do that or am I missing some other step?

    Cheers
    Stan
  6. devan963

    devan963 Active Member

    Hark likes this.
  7. Matenrou

    Matenrou Well-Known Member

    THIS IS FOR 64-bit

    I had problems with it myself but got help with a modified android_usb.inf file.

    I downloaded the 1.5 SDK, put the android_usb file in "/usb_driver/amd64" and tried to install it like a normal driver by browsing to that folder and it worked, previously it had not even detected the file.

    Keep in mind that if you have the 1.6 SDK the file structure of the usb folder is changed I think, so I dont know if it'll work.

    If you want to give it a try go ahead, I did not modify the file myself. I only tested and it worked for me. I also tried to install the NPS using vista sp2 compatibility mode. I don't know if that added something to the result but I think you only need the file.

    MEGAUPLOAD - The leading online storage and file delivery service

    I tested this using Windows 7 Professional 64-bit.

    Also included a short readme file but it basicly says the same thing as my post. If you cant find the 1.5 sdk check the readme file for the full filename to search for.

    If anyone tries this please post the result for us, I hope this will help someone.
  8. Rastaman-FB

    Rastaman-FB Well-Known Member

    1.6 sdk drivers do not work

    btw just to let you know i know my method works as im on windows7 x64 professional and ive done the same on a vista ultimate 64 bit aswell
    you need to make sure you are the full administrator on the machine
  9. Matenrou

    Matenrou Well-Known Member

    Cool, well couldnt see from your post if it worked on 64bit so I posted the way I did :p
  10. carthesis

    carthesis Well-Known Member

    This is ABSOLUTE threadomancy, but I don't suppose you've still got the modified drivers required to make a Samsung i7500 talk to Windows 7 Pro over ADB lurking about have you?

    Since the Americans got stroppy over MegaUpload, you can't get anything from there anymore, and the downloads from the Verizon site and such that are linked don't actually seem to work anymore.

    Cheers in advance for the help!
Loading...

Share This Page