[HOW-TO] Manually deodex your phone.


  1. SimsDelt

    SimsDelt Well-Known Member

    I AM NOT RESPONSIBLE FOR WHATEVER HAPPENS TO YOUR PHONE!

    You must be rooted!


    Credit for
    Webst3r on alldroid for posting this.

    This is a guide on manually deodexing, you phone. (Duh!)

    The reason I am making this tutorial is because I could not get my theme to work with Teenfaces deodexed android. You may want to follows this if you have the same probalem as me, or if you just want to take a shot at doing it.

    What you'll need:
    A Windows based machine
    xUltimate v2.2
    Patience

    Process:

    1. Unzip xUltimate v2.2, and launch "Main.exe"
    2. If everything goes well you xUlt should recognize the phone and make a connection. You now should see a list of options.
    3. Run option 1. After option 1 is done, run option 2.
    4. Now these well take a while. Run option 3.
    5. IMPORTANT: After you have run option 3, you MUST navigate to the xUltimate folder and find "origi_frame" folder, and delete "guava.odex". It's a bad file, and interferes with deodexing process.
    6. Now run option 4, and wait.
    7. Exit xUltimate, and put the phone in USB mass storage.
    8. Go back into the xUltimate folder and copy "done_frame", and "done_app", and move them to the root of the sdcard.
    9. Open a command prompt, and do the following:
    Code (Text):
    1.  
    2. adb shell
    3. su
    4. stop
    5. mount -o rw,remount -t ext3 /dev/block/mmcblk1p21 /system
    6. cp /sdcard/done_app/* /system/app/
    7. cp /sdcard/done_frame/* /system/framework/
    8. rm /system/app/*.odex
    9. rm /system/framework/*.odex
    10. mount -o ro,remount -t ext3 /dev/block/mmcblk1p21 /system
    11. reboot
    12.  
    Your phone should now be deodexed!

    You may notice an increase in speed, and you now have the ability to edit certain files for effectively. (i.e. services.jar)

    Credits:
    Rainabba and Mike919: For initially working with me to get a white clock, and later deodex.
    toxman: For testing, and being a huge risk taker.
    teenfaces: For letting me use his services.jar
    And especially Xeudoxus: For letting me a guinea pig, for xUltimate, and answering my questions. And also for the making the xUltimate tool. It defiantly makes thing easier.

    Advertisement
    jkolbenson, soapinmouth and BLK MAJK like this.
  2. D13

    D13 Well-Known Member

  3. Airmaxx23

    Airmaxx23 Well-Known Member

    I did some looking around and really couldn't find much, what are the advantages to deodexing the phone?
  4. D13

    D13 Well-Known Member

    from what i understand it allows you to theme
  5. SimsDelt

    SimsDelt Well-Known Member

    Yep... themeing is the big thing. I used the other method of doing this that I released earlier. The one where you use Koush's bootstrap loader to recover a nand that is Froyo 2.2 rooted and deodexed already. Just simpler.
  6. D13

    D13 Well-Known Member

    you mean you posted or did you make this?
  7. SimsDelt

    SimsDelt Well-Known Member

    Sorry... released to this forum. I didn't make it at all. Just transfered from one forum to another after I found out it actually worked (by doing it myself).
  8. D13

    D13 Well-Known Member

    lol:D
    I was about to be like damn you got skills, why do you need my help:D
  9. SimsDelt

    SimsDelt Well-Known Member

    Haha... no sir... noob still... but learning a ton... my wife is going insane with all the time I spend on my phone and/or on the forums. Can you pm me the link again for the current RSD with the right .ini in it. I am back on my laptop now, did all that on Saturday with her laptop (while on vacation, btw)...
  10. D13

    D13 Well-Known Member

    yeah I just sent it:D
    SimsDelt likes this.
  11. Piiman

    Piiman Well-Known Member

    I'm with you man this is like when I got my C64 all over again. I learned everything I could about that little 1mhz box and learned to code for it in every language I found. (I love assembler).You could say that little computer lead me to my current profession, AS400 administrator, and this thing has me all hyped up to learn just like I did back then. I'm thinking of learning to code for this thing. But I haven't coded in years and not sure I have the time to take it up again. But it has me thinking hard about it.
  12. haevn

    haevn Well-Known Member

    im gonna try it to see if it makes a difference, but when i run option 3 i get errors on some files dunno if it supposed to do that =/
  13. chrlswltrs

    chrlswltrs Well-Known Member

    I finished everything and after reboot my X is stuck at the MOTO logo, any ideas?
  14. haevn

    haevn Well-Known Member

    mine did the same too. so i had to flash and reinstall froyo /cry lol im gonna try again because i deleted some apps and i think that might be the cause
  15. chrlswltrs

    chrlswltrs Well-Known Member

    I did sbf, universalandroot, update, then deodexed using Koush's recovery. Everything done now, just restoring everything with mybackup pro. This stuff is starting to get really easy to me
  16. soapinmouth

    soapinmouth Well-Known Member

    how would deodexing result in a speed increase? I thought it just let you edit the files
  17. rdubbs007

    rdubbs007 Well-Known Member

    Another stuck at motorola logo here... damn.

    If it means anything, when I tried to do the commands:
    cp /sdcard/done_app/* /system/app/
    cp /sdcard/done_frame/* /system/framework/
    the cmd prompt said:
    cp: /sdcard/done_app/* No such file or directory
    cp: /sdcard/done_frame/* No such file or directory

    Good thing I can boot to stock recovery, select reboot system and the phone boots back into clockwork...

    nandroid is HUGE at this point in the game [​IMG]
  18. irishpride

    irishpride Well-Known Member


    I got the same thing, was stuck at the Moto logo, then just booted into CMrecovery and loaded my backup. The easiest way to do it is just to flash the rooted, deodexed version that is floating around the forums.
  19. irishpride

    irishpride Well-Known Member

    Hey droider13, can you pm me a copy of the current rsd and .ini as well? Thanks
  20. D13

    D13 Well-Known Member

    yep just sent it:D
    irishpride likes this.
  21. haevn

    haevn Well-Known Member

    nvm i found it a few post down from this one lol
  22. D13

    D13 Well-Known Member

    there is another thread here for it
  23. haevn

    haevn Well-Known Member

    ya thats the one i was talking about, i posted something then i found the thread when i scrolled down lol
  24. HalfFrozen

    HalfFrozen Well-Known Member

    ...So do I plug my phone into my computer or what? lol

    I need more in-depth instructions. I am not too bright when it comes to this stuff.. lol


    I have my phone plugged in and it says Waiting for Phone...
  25. pinhead875

    pinhead875 Well-Known Member

    I'm getting "no such file or directory" on the first cp command.
    Any thoughts?
Loading...

Share This Page