[how to] manually update to ICS without losing data


Last Updated: 2012-08-25 22:01:48
  1. scotty85

    scotty85 Guides Guide

    aha! maybe we are on to something here. the stock recovery is capable of wiping parts of the phone that amon is not,so maybe that had something to do with it.

    also,you were defiantly trying to install stage2,correct? its easy to get them mixed up once theyre both named "update" :eek:

    if im understanding you correctly,if you
    -restore newt backup
    -flash viperrez with no data wipe(but with cache and dalvik)
    -reboot

    your apps would have tried to have been there,but i dont believe the frameworks of these 2 roms are close enuff to work. i believe this is what caused the bootloops and prollems with your other thread. at the least,when you "dirty flash" a rom overtop of another thats not compatible,youll end up with FCs and potentially crashed,reboots,and loss of other functionality.

    even if youre installing drastic differences in versions of the same rom,you can experience this. thats why most rom devs always reccomend a full wipe for their updates,so that folks dont blame code incompabilties as rom bugs.

    as for getting your app data back,see the other thread :)

    last and not least,thanks for the extra detail and info :)

    Advertisement
  2. obscuro

    obscuro Well-Known Member

    That is what I am thinking, especially since I don't think I wiped the cache between update1 and update2.

    I definitely installed phase 1, deleted it from SDCard, then put phase 2 on sdcard and renamed it update.zip

    However, darksideofjae never got phase1 to work. Hope he can follow our train of thought with these recent posts.

    Basically, try 'fastboot flash [stock recovery]" per scotty's original post, launch stock recovery (adb reboot recovery) and use the wipe cache option in there before trying to reboot and install the update. See if that works!
    scotty85 likes this.
  3. darksideofjae

    darksideofjae Member

    Here's what's my getvar all states

  4. scotty85

    scotty85 Guides Guide

    good idea on asking for this info,obscuro. :cool:

    darksideofjae,id be willing to bet it wont take becasue you are not on 2.01.605.11 firmware(indicted by 2.10 hboot).

    i believe to get this to work,you will need to:
    -backup your data as described
    -relock and run full ruu for 2.01.605.11
    -reunlock
    -relaunch recovery and restore data

    i believe that then step 4 will work

    2.10 is the hboot for 1.02.605.6. so,alternately, restoring that may let you OTA to 2.01.605.11,then to 2.01.605.12,then to 3.14.605.12 :eek: :p
    darksideofjae likes this.
  5. darksideofjae

    darksideofjae Member

    Trying those steps now, just downloaded the fullRUU so will follow up when done. Following the steps you have listed on your root made easy thread.
  6. scotty85

    scotty85 Guides Guide

    awsome! :smokingsomb:

    looking forward to hearing your results
  7. darksideofjae

    darksideofjae Member

    So I just got done following the FullMUU and this is what my getvar all states. Just wanted to make sure everything was kosher before moving on.
    H:\mini-adp_vigor>fastboot getvar all
    INFOversion: 0.5
    INFOversion-bootloader: 2.11.0000
    INFOversion-baseband: N/A
    INFOversion-cpld: None
    INFOversion-microp: None
    INFOversion-main: 2.01.605.11
    INFOserialno:
    INFOimei:
    INFOproduct: vigor
    INFOplatform: HBOOT-8260
    INFOmodelid: PH9810000
    INFOcidnum: VZW__001
    INFObattery-status: good
    INFObattery-voltage: 4194mV
    INFOpartition-layout: Generic
    INFOsecurity: on
    INFObuild-mode: SHIP
    INFOboot-mode: FASTBOOT
    INFOcommitno-bootloader: dirty-bc948b45
    INFOhbootpreupdate: 11
    INFOgencheckpt: 0
    all: Done!
    finished. total time: 0.500s

    So now i'm going to do the unlock from the tutorial. Since I have no data to backup (titanium backup) I'm going to then go straight into step 4. Do I need to have a main version of 2.01.605.11 or the 1.00.000.01?

    *EDIT* After doing that and then reunlocking my phone, after it booted up, I was prompted with the OTA install. It looks like I'm good to go so far. Starting phase 1 now.
    scotty85 likes this.
  8. scotty85

    scotty85 Guides Guide

    you would want mainver to be 2.01.605.11

    any luck? did you OTA,or apply updates manually?
  9. 95wolverine

    95wolverine New Member

    Guess I'm destined to stay on Scott's CleanROM GBE 1.7

    I verified I've got HBOOT version 2.11.0000

    I'm Unlocked, S-ON, and

    I followed this guide from the beginning thru Step 2 of post 1 till I got to THIS POINT:

    C:\mini-adb>fastboot oem rebootRUU
    ... OKAY [ 0.000s]
    finished. total time: 0.016s

    C:\mini-adb>fastboot flash zip miniRUU2.01.605.11.zip
    sending 'zip' (463936 KB)... FAILED (remote: not allowed)
    finished. total time: 0.000s

    If I key in the failed command a second time, it just says sending zip, and never clears. I have to pull the usb cable and when I do, the phone says "RUU" of which never clears till I pull the battery.

    What am i doing wrong?

    All I want to do is update to ICS WITH the new radios, and if possible keep my data - if I'm going about this the hard way, someone please show me the way, or shoot me now.

    Edit: Just for fun, I tried to reflash the OEM recovery...

    -flash stock recovery
    fastboot flash recovery recovery_signed_stock_2.01.605.11.img

    and that failed too

    C:\mini-adb>fastboot flash recovery recovery_signed_stock_2.01.605.11.img
    sending 'recovery' (5598 KB)... FAILED (remote: not allowed)
    finished. total time: -0.000s


    If I key it in again, it starts: I get the green bar rising on the right side, it gets close to the top and just hangs there. I have to pull the usb cable to get it to clear.

    Any suggestions?
  10. scotty85

    scotty85 Guides Guide

    are you sure youre still unlocked? :confused:

    as far as the mini-ruu,did you flash the main version tool prior to running it?

    some basic things to check:
    -make sure htc sync,pda net,or any other program capable of comunicating with the phone is not runing
    -try different usb ports
    -try different usb cables

    a copy of the entire session may be helpful.
    95wolverine likes this.
  11. 95wolverine

    95wolverine New Member

    Guess I was too tired, it was EasyTether. I turned that off, and everything went according to plan. I did forget to turn on debugging after flashing the miniRUU, but figured it out after a couple of "adb devices" not finding anything.

    Thanks SOOO much Scotty.

    It was very difficult for me to give up Cleanrom GBE 1.7 - that rom has done me right in ever which way possible since I installed it. I never even had any force closes. Let's see if Rooted Stock ICS will treat me as well.

    Thanks again for the help.
  12. scotty85

    scotty85 Guides Guide

    your quite welcome :) glad you got it.

    did you use the OTAs,or did you manually apply the files?
  13. obscuro

    obscuro Well-Known Member

    I have the cached zip for the new, second ICS OTA. I'm not sure that I made a backup for stock ICS, but I have the android police zip of the first OTA. Now that I'm on ICS firmware, can I just flash those two zips to get up-to-date?
  14. scotty85

    scotty85 Guides Guide

    im confused... i thot you had allready done both OTAs? what is your current baseband?
  15. 95wolverine

    95wolverine New Member

    Scotty, I couldn't get the first ota update to take - it just acted like there was no update to be applied and did nothing.

    I needed my phone for work, so I just rebooted it stock (2.01.605.12 with my data restored) and let it pull the OTA from the web via my wifi here at home - it's rock solid stable, so I didn't fear any connection issues. The update went without issue.

    I had some odd behaviour, and have read that doing a factory reset after getting the OTA has helped many. So I booted Ra and did a data backup, then did a factory reset, rebooted... gmail, etc, let it settle, then did Ra and a restore of data. All seems to be better - like many have said on other forums (all of whom did the automated OTA, not manual).

    Interesting thing... I was thumbing around this morning, snooping for info about the followup 104mb OTA that's rumored to be out... and found this site:

    http://http://www.androidpolice.com...lobal-capabilities-installation-instructions/

    What was of particular interest to me, were the manual flashing instructions (I copied them from the site word for word):

    "Okay, I flashed it. Here's how:
    1. Install the ICS OTA full firmware.
    2. Boot it up at least once. I skipped setup and just let it boot.
    3. Extract the firmware.zip out and rename to PH98IMG.zip. (Don't remove it, just extract a copy.)
    4. Place the PH98IMG.zip on the SDCard.
    5. Rename the entire package to Update.zip and put it on the SDCard.
    6. Reboot to recovery (which should now be stock.)
    7. Press vol up and power.
    8. The update will start and patch your files.
    9. The phone will reboot to HBOOT and load the PH98IMG.zip file you put there.
    10. Vol up to install.
    11. PWR to reboot.
    12. Profit!
    Enjoy playing!"

    Notice the capital "U" on "Update.zip" ? I wonder if that was my flashing problem for this user's guide?
  16. scotty85

    scotty85 Guides Guide

    funny... i was just about to link that out in the forum :smokingsomb: i saw a rom based onit on xda and went a-searchin as well :D

    when you say you rebooted to "stock 2.01.605.12" wsa that a typo? if not,then the first update had somehow applied itself allready. :eek: stock, pre OTAs, was 2.01.605.11

    as far as update vs Update,i couldnt say for sure that it makes a difference on s-on devices. i went thru the procedure i outlined twice on my s-off phone and it went smoothly,and i had mine named "update". i person could certainly try Update and UPDATE if they wish...

    i also didnt extract the firmware packages. if youre using the stock recovery to apply the Otapkg,im not sure why they did that... the stock recovery will extract and install the firmware

    im downloading OTapkg now... i plan to play with it later of course :D
  17. 95wolverine

    95wolverine New Member


    Typo? Me? Are you serious? Why, yes, yes it was. lol

    As for the update, please report back as to what else is included besides making the Rezound "World Capable".

    Flashing is fun... when it fricking works! lol
  18. obscuro

    obscuro Well-Known Member

    I'm talking about the new world phone OTA that started rolling out this week. It contains new radios. But I think I am just going to wait until viperrez updates to include them, I have no desire to go to stock ICS so I might as well just wait since it seems like this is more of a bug fix update anyway.
  19. obscuro

    obscuro Well-Known Member

    I named mine update.zip while S-ON and it worked fine, don't think it matters. One thing we sort of theorized while helping another poster who was having trouble getting the first ICS OTA update to install was that you need to clear the phone cache from the stock recovery before trying to flash the first update.zip (and then again before you try to install the second.)

    Glad you got it work the automated way. The above tip probably needs to be done for the OTApkg, but I'm going to let Scotty test it out first :)
  20. scotty85

    scotty85 Guides Guide

    yes,dont mess with it yet... i stopped at the house for a second and flashed the firmewar. there are new radios and takes you to hboot 2.27

    installed only the firware and my phone wont boot :eek:

    more later...
  21. obscuro

    obscuro Well-Known Member

    Ruh-roh. I am having issues of my own with viperrez, so I figured now is as good a time as any to go back to stock and get the new OTA. Hope you get your issues sorted out.
  22. scotty85

    scotty85 Guides Guide

    i flashed the firmware and it wouldnt boot. i assumed it was becasue of some sort of mismatch,since i was on viperrom. so i flashed back some older firmware and rebooted. still no boot :eek: so i popped my sim in the thunderbolt and took them both with me.

    wiped system/boot/cache/data/dalvik cache and restore the 3.14.605.12 backup. that time it booted :)

    so now im running the 3.14.605.12 ruu so i can install the OTAPkg. afterward ill flash a rom and make sure that i dont have any "no booting" issues
    NEXTLOVER and obscuro like this.
  23. NEXTLOVER

    NEXTLOVER Active Member

    Okay scotty, I think I'm about to go the route you're on since my battery just plain ol' sucks on Viper Rez :( I loved that ROM, too.

    To run the 3.14.605.12 RUU, do I follow the same instructions on your post from method #2)"full ruu" method to unroot? Do I still need to flash SetMainVersionLOW.zip? I did make a Nandroid backup of the stock (OTA) ICS; maybe I can just use that Nandroid backup instead of the full RUU?

    Thanks in advance :)
  24. scotty85

    scotty85 Guides Guide

    yes,you can use those directions,just substitue the ruu for 3.14.605.12

    you can prolly forgo the main version tool,i doubt anything youve installed as changed your main version to something higher than 3.14.605.12 :)

    as long as you OTAed and have the matching 3.14 firmware,you are prolly fine in just restoring a stock nandroid.

    if you want the whole update,youll need to install it just like described in the OP:
    *charge your phone to 100%!

    -place OTAPkg_stage1 onto the root of your sd card. rename it to "update"

    -boot to the factory recovery via adb reboot recovery (optionally,you can select recovery from the hboot menu if you dont wish to use cmd)

    -youll see a yellow error message about cache. dont worry,this is normal

    -hold vol UP and power until you see blue writing that is the stock recoverys menu

    -using the vol rocker and power button,wipe cache

    -select apply update from sd card

    -choose "update.zip"

    *sit your phone down and let it do its thing. youll see yellow writing as the update applies patch files,then a couple different screens as it makes firmware changes.

    you dont need to extract firmware and rename it PH98IMG as the android police directions state. the stock recovery will apply all firmware and software all by itself :)

    alternately,you can keep checking for system updates and just apply it OTA
    NEXTLOVER and obscuro like this.
  25. NEXTLOVER

    NEXTLOVER Active Member

    Thank you so much for the writeup scotty, but I ran into a problem.

    First, I followed all the steps above, but whenever I get to step "-select apply update from sd card" it doesn't give me the option to choose the update.zip. I get this yellow message "Invalid something (maybe operation) then underneath that in yellow: "Rebooting now... OEM..." I'm not really sure what it said.

    The update didn't install with that method. So I read the androidpolice method, followed the steps, only I DID NOT put the extracted firmware.zip (renamed to PH98IMG.zip) on the sdcard, only the renamed update.zip (former OTAPk-sumthin.zip).

    I went into HBOOT menu via vol. down, power up method, and my phone right away installed the update. I couldn't stop it. I let it install, it rebooted, got past the green HTC, beats audio screens, but I'm now stuck on the 4G LTE screen.

    Edit: SOLVED :)

    After trying again to install via HBOOT menu and ending up on that 4g LTE screen, I just grabbed a card reader, plugged it in to PC so I can put the PH98IMG.zip there, took a shower (optional), pulled battery, went into HBOOT menu via the vol.down, power.up method, updated again and everything updated correctly this time.

    scotty, for sum reason it was looking for a boot image file so I said what the hey, might as well try it the "original" method's way. I guess maybe b/c I came straight fr. a fresh RUU that I was missing a boot image or something? But everything's smooth as silk now!

    Big big THANK YOU again. You've helped me out so many times :D
    scotty85 likes this.

Share This Page