How to Odin and Galexo ROM

Is this information usefull?

Poll closed Nov 14, 2009.
  1. Yes

  2. No

    0 vote(s)
  3. Who Cares

    0 vote(s)

Last Updated:

  1. devan963

    devan963 Active Member

    Here is a link for another guide about Odin, thanks to Bomberman for the link.

    Most of the Below information has been taken from this forum so I would like to thank kam187 and Rastaman-FB for providing the majority of this information, drakaz for supplying the ROM’s, and everybody else here for being so bloody helpful I have only written this to put it all together in one place, so if this works and like it (you will) register and thank these lovely people on the forum for helping you to do this.[/FONT]

    [FONT=&quot]I have now done this several times and a few have not worked first time around and sometimes I needed to start from scratch again as it did not work, so if you’re short of time come back when you have more.[/FONT]

    [FONT=&quot]#######[/FONT][FONT=&quot]If you flash your phone you may void your warranty, do this at your own risk, myself or anybody here cannot be held responsible if the information below is incorrect or causes damage to your phone, i suggest you read it all in full and make sure you know what you are doing. if you are unsure or unwilling to take the risks leave it and do not go further as nobody wants a

    edin1, bisanu, sameertayade and 2 others like this.
  2. spottyelephant

    spottyelephant Well-Known Member

    This is v helpful - i havent even considered loading a custom rom (or updating normal firmware) because instructions have been so fragmented.

  3. ASukker

    ASukker Member

    I agree with you spotty. I have been reluctant to install Galaxo or any other custom rom because the instructions were over my head and assumed I knew things I didn't already or nonexistent. Thank you for providing this thread.
  4. T1m0thy

    T1m0thy New Member

    I'm having some problems. I'm running 64-bit Windows 7 and i've installed the drivers from the link you gave which worked fine. For the ADB driver, i browsed to the file in \tools\usb_driver\amd64 and then i'm givin a list of models. I chose ADB Testing Interface, is that correct? Because on the recovery image part it says < Waiting for device > but when i load my phone in fast boot nothing is transferred..
  5. devan963

    devan963 Active Member

  6. oconradsen

    oconradsen Member

    Thank you for very helpfull information
    This entry was easy to follow and easy instruction install and use ODIN,

    / Ole
  7. spottyelephant

    spottyelephant Well-Known Member

    Right, im having issues at the first part:
    [FONT=&quot]How to Install Drivers (ex ADB)[/FONT]

    [FONT=&quot]First things first, you will need to install the Samsung drivers for your device if you are using Windows 7 (or probably Windows Vista (God Forbid)) all you need to do is plug in phone to the USB port, mount the Drive by dragging the top bar down and selecting mount.[/FONT]

    [FONT=&quot]Then go to Settings >> Applications >> Development and select USB Debugging and them mount the drive again.[/FONT]

    [FONT=&quot]If you have problems install Samsungs latest PC Suite from [/FONT][FONT=&quot][/FONT]
    [FONT=&quot]Select the device it will be called Samsung Galaxy, Samsung &#8211;i7500 or maybe even Samsung GT-i7500, the naming convention used is inconsistent so it depends on what time of day it is or something like that.[/FONT]

    [FONT=&quot]If problems still remain or you run 64x look [/FONT][FONT=&quot][/FONT]

    [FONT=&quot]If all you want to do is update firmware via Odin you can stop there for the ROMS there is another driver you need but see below for that.[/FONT]

    When i mount in debuging mode, XP picks up the phone and launched the New HArdware Wizard, but cant do it automatically, and i dont have any driver files to point it to. Simultaneously, NPS launches with a GT-i7500 icon which when i click on, pops up a "device not supprted" notification. What am i doing wrong??

  8. devan963

    devan963 Active Member

    Odin nor NPS offer a back up,

    You cant really back up you phone, you alredy have your contacts calender and emails backed up with google if you are using the google sync.

    You apps will all be deleted however if you go on to My Downloads from the market as soon as you start with your new firmware it will keep a list of prevoisly installed apps (download them all at once)

    If you were just to flash using Odin to II5 you phone would not be rooted,
    If you were to go to the GalexyHero ROM it would be,

    ADB (Android Debug Bridge) is a tool that comes with the Android SDK that allows you to control and interface with your Android device

    ADB is not necessary to flash to II5

    Its difficult to say i have flashed and reflashed my phone on many occasions and when i did run in to problems it was easly fixed by re-flashing the phone again, what i have read from other forums is that if the phone was to loose power during flashing a certain file it may brick the phone. it suggests having at least 30% battery.
  9. spottyelephant

    spottyelephant Well-Known Member

    Thanks Devan, I got up the courage to do it, but do yuo have any ideas on my edited issue!?
  10. devan963

    devan963 Active Member

    NPS says that if you have the most up to date firmware, it is useless, all it can be used for is updating firmware you can
  11. spottyelephant

    spottyelephant Well-Known Member

    Yep, all good now. So i did that and the phone rebooted. On checking my firmware version it says that ii5 is the firmware - do i still need to do a factory reset as per the instructions?
  12. devan963

    devan963 Active Member

    Yes mate, otherwise you get random reboots and encounter problems.
  13. spottyelephant

    spottyelephant Well-Known Member

    New problem! I can't do this bit:

    The hardware installation wizard always pops up. When i say "dont search, i will choose the driver to install", i get to the choose manufacturer and model screen, where the phone obv isnt shown, so i just leave it and click "have disk" straight away, go to the file, and then it says "the specified location does not contain information about your device". So i'm a bit stuck :confused:
    [FONT=&quot]ADB Driver[/FONT]

    [FONT=&quot]So right click unknown device and update driver software, you must choose browse my computer for software >> Let me pick from a list of drivers >> next >> have disk then browse to the file which is \tools\usb_driver\x86 [/FONT]
    [FONT=&quot]It may not be exactly the above it depends on your OS so keep searching for the have disk option.
  14. devan963

    devan963 Active Member

    The file you need is in that folder called android_usb
  15. spottyelephant

    spottyelephant Well-Known Member

    Em, I can't find the password for the ROM's not in the txt file??!

    Edit: Duh!!, found it.

  16. spottyelephant

    spottyelephant Well-Known Member

    How long does the recovery boot take - iv got a screen with an exclamation mark and the phone beside it...

    edit: i was going to take the battery out and when i turned it back over for one last look at the screen it was doing a normal boot..I can't figure this bit out. Please can you explain it a bit?

    [FONT=&quot]Boot into recovery (VOL DOWN >> CALL >> END CALL) and do a G.apps backup. It should take 10 to 12 seconds. Anything like 1 or 2 seconds means it failed - reboot into recovery and go again[/FONT]

    [FONT=&quot]- Wipe in recovery, it'll reboot into recovery when done[/FONT]
    [FONT=&quot]- Apply it'll reboot into recovery when done[/FONT]
    [FONT=&quot]- restore g.apps (if this keeps failing then mount the SD card and format it on your PC)
    - reboot[/FONT]
  17. devan963

    devan963 Active Member

    Sounds like the samsung recovery image, i would suggest try to do the image flash again
  18. spottyelephant

    spottyelephant Well-Known Member

    Ye my command prompt never left "waiting for device". Maybe the transfer didnt happen properly. Ill try that again, thanks.

    Edit: im getting a "found new hardware" notification saying found "android 1.0". What's going on there?? Thing is i think i did the adb driver correctly - the computer recognises the debugging mode when mounted and sees the phone as a removable disk.
  19. Rastaman-FB

    Rastaman-FB Well-Known Member

    you need to install adb driver again for fastboot, its a nightmare as you have to do it within 15 seconds and point it to the adb driver
  20. devan963

    devan963 Active Member

    I think this may be my fault i think i have uploaded the wrong Driver, i am updating it now but itull be 5 mins, download the new tools menu when i update the link
    (ill PM you when done spotty)
    Sorry! my bad,
  21. spottyelephant

    spottyelephant Well-Known Member

    edit: It seems i have the adb installed as its reckognising in device manager. Am i meant to be turning off the phone before booting recovery ye? I dont see why its asking for drivers for android 1.0 when fastboot starts.

    edit2: just saw ur post devan. Cheers, ill try when uv done that.
  22. devan963

    devan963 Active Member

    Sorry again mate, I have now updated the post to be correct so if you download the tools folder again.

    Now you need to uninstall the incorrect driver so just go to device manager, right click and uninstall SAMSUNG GALAXY Composite ADB Interface,
    You get the option to delete it as well so you may as well as it is no good
  23. Rastaman-FB

    Rastaman-FB Well-Known Member

    re read what im saying
    fast boot is a seperate driver but you can use the adb driver for it.
    its asking for 1.0 as its another driver type but it can use the same adb driver to run
  24. spottyelephant

    spottyelephant Well-Known Member

    Trying to update the driver it says it couldnt find a newer version than the one i have installed. On opening the inf file with notepad i noticed: DriverVer=06/25/2009,1.0.0010.00001 does that means that's android 1.0? Should i try 1.5 from android sdk?

    edit: on deleting opld driver and re-installing the new one, the found new hardware notification doesnt come up, but command prompt stays on waiting on device, and the phone just ends up booting normally after the 15secs or so. I might give up for the night and try again tomorrow!
  25. devan963

    devan963 Active Member

    Uninstall the incorrect driver from device manager as above then install the new one

Share This Page