1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

How to open apps instead of websites (or other options)?Support


  1. NeoteriX

    NeoteriX Well-Known Member

    So on my Evo 3D and OG Evo, I used to be able to be on a Youtube video or in Google Maps on my PC, hit my "chrome to phone" icon on my Chrome browser, and then it would send the link to the phone and automatically be intercepted by the Youtube native app or Maps native app on my Android phone.

    With the LTEvo, it seems that the links are instead being sent to the default browser and opening up as a mobile webpage (which is vastly inferior). Any thoughts on this?

    Advertisement
    :
  2. Doomstang

    Doomstang Well-Known Member

    You may want to go to Settings - App associations and have a look at which default programs interact with which types of links.
  3. NeoteriX

    NeoteriX Well-Known Member

    I should've clarified that I looked at the "apps associations" already. "Physical address" and "Map address" are set to Maps, while "Web URLs" are set to Chrome Beta. Nothing else qualifies.

    I think the problem is, the phone is treating a Chrome to Phone message as a Web URL and nothing else.
  4. BradSl

    BradSl New Member

    Greetings all - First time poster (I searched before posting)

    Switched from an EVO 4G to the LTE version and have been very happy with it. I have been having one small, yet painful issue -

    When I do a google search for a business name in the search widget, and I open the browser, when I click on the Directions Button or the address I expected it to open in Google Maps APP, however it just open in the Browser.

    I like the Maps APP for their overlays and traffic and I am asking because this behavior is not what I would have expected.

    I have checked my associated apps in setting and Maps links are supposed to open in the Maps App.

    Any suggestions? It has been plaguing me for days

    Thanks,

    Brad
  5. EarlyMon

    EarlyMon The PearlyMon Moderator

    Welcome to the forums! :)

    I just tried this with Boat Browser, and for maps, I got a dialog to choose between the browser and Maps, and when tapping on the push pin next to the address below the map, it went straight to Maps.

    I don't know if it's a stock browser issue, but give it a try with Boat, report back.
    marctronixx likes this.
  6. BradSl

    BradSl New Member

    The resolution to the problem was to uninstall the Google Apps Maps updates - once I did this everything returned to "expected behavior"

    Thanks for the help.
    marctronixx and EarlyMon like this.
  7. brooklyntyger

    brooklyntyger New Member

    I'm having the same exact problem. I was sending an address to my phone from google maps in chrome, and it opened in a browser on my phone. I tried clearing the data from the app. No change.
  8. NeoteriX

    NeoteriX Well-Known Member

  9. PyroSporker

    PyroSporker Well-Known Member

    It is unclear to me if the new 'App Associations' work below, in conjunction with, or supersede the old way of 'app defaults'.

    I would have said check the App Associations but it has been tried. This has probably been tried already too but you could try going to Settings -> Apps -> All -> Internet -> Clear Defaults.

    :confused:
  10. NeoteriX

    NeoteriX Well-Known Member

    I normally run Chrome as my default browser, and I can clear the default app associations for Chrome and clear the app associations for Internet in each's App Settings, and when I chrome-to-phone a map, it goes straight to the stock Internet browser.
  11. EarlyMon

    EarlyMon The PearlyMon Moderator

    Chrome to phone is just an sms, as you know. If you send yourself an address, it'll open maps.

    Anything with an http in front of it is going straight to the browser, obviously.

    If you root and turn off Apple compliance (search the pre-release thread for linkify ;)) then when an sms comes in with a youtube link or a map link, you get the familiar pop-up to choose a browser or maps/youtube, depending.

    It's broken by court order.
  12. Will Rickards

    Will Rickards Well-Known Member

    So I think this limitation may be because of ITC issues with apple. But instead of opening the app links seem to open the browser. Any body know how to fix. Examples are calendar invites in gmail. They open the browser instead of the calendar app. Youtube links open in the web versus the youtube app.
  13. cooper1010

    cooper1010 Well-Known Member

    Noticed this with YouTube. OG Evo did it right, this one doesn't. No likey.
  14. EarlyMon

    EarlyMon The PearlyMon Moderator

    Topics merged, see post 11.
    falconey and marctronixx like this.
  15. AM2

    AM2 Well-Known Member


    I've done this with no success. it makes the link completely unresponsive . are there additional steps necessary?
  16. OstrichSaK

    OstrichSaK Well-Known Member

    Why is it that whenever I click a YouTube link somewhere it automatically launches in a browser? Used to be on previous devices I would get a pop-up that would request how I wanted to open it and at least give me the option to open in the YouTube app and now... nothing. It launches the YouTube site within the browser which is much more clumsy than the native app for video watching. How can I get this again?
  17. EarlyMon

    EarlyMon The PearlyMon Moderator

  18. EarlyMon

    EarlyMon The PearlyMon Moderator

  19. airdog

    airdog Well-Known Member


    THE NO ROOT METHOD...
    OK, after much frustration and searching I found this thread that helped me fix the "linking" problem I had with Google Maps and YouTube. I was able to do this without Rooting my phone. I run my EVO 4G LTE bone stock for the time being. I may root it down the road, but for now I have it in the stock configuration.

    Like many, I started experiencing this issue after I upgraded to the EVO 4G LTE. I never had this problem with my original EVO or my EVO 3D. I use Google maps almost daily. I often text other people addresses and map links (especially my wife). She also upgraded to the EVO 4G LTE. You receive the text, click on the link and it opens maps and it sets your navigation point. Simple and effective.

    I never used the Chrome to phone option but I think the issues are related. I simply opened Google Maps and then went to a location or address. From the menu bar I would select
    mbstd1 and Mr. Ed like this.
  20. dr g

    dr g Well-Known Member

    It does this with boat browser too, but it still doesn't work with incoming maps via chrome to phone. I think the issue may be it uses "gstatic" domain now? I don't think it used to do that.
  21. airdog

    airdog Well-Known Member

    Yeah, I never used chrome to phone. I just use google maps to look up locations in and send them to people by SMS (which now works great along with YouTube links).

    What is gstatic domain?
  22. Corymo

    Corymo Member

    On my OG Evo, anytime I would select a video (google, youtube, ect.) It would prompt me to download or stream. And now on my new LTEVO it doesn't prompt at all.. just streams, I don't have any problems with it, but sometimes I would like to save the video to watch later. Anyone know how to download the videos instead of streaming? Not just youtube, but any video on the browser.
  23. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    I don't think that was a default action for the OG EVO. Sounds like something else was involved.

    Was it rooted?

    Maybe I just don't remember that feature :confused:
Loading...

Share This Page