[How-to] Overclock that survives a reboot


  1. FreeWELL

    FreeWELL Well-Known Member

    I also suggest keeping only known to be stable settings in setscaling.sh and using testscaling.sh for testing settings...
    humungus likes this.
  2. D13

    D13 Well-Known Member

    Updated OP with Root Explorer directions, thanks to FreeWELL
  3. humungus

    humungus Well-Known Member

    That's an excellent idea.
  4. itsTee

    itsTee Well-Known Member

    So your saying remove the setscaling file. Then just go into terminal and just iinput a new freq. And volt. Will that create a new setscaljng file in the phone
  5. D13

    D13 Well-Known Member

    no you can edit the setscaling.sh either on your computer or in Root Explorer and then overwrite the old one

    I recommend using Notepad++ for editing the file on your computer
    itsTee likes this.
  6. FreeWELL

    FreeWELL Well-Known Member

    testscaling.sh people
    keep setscaling.sh safe
    I'm just sayin tho...

    Here's a nugget i find useful... menu+home
  7. Airmaxx23

    Airmaxx23 Well-Known Member

    It is necessary to have a setCPU profile set up to go along with the overclocking? This is pretty new to me so I really not sure how to set up a profile.
  8. humungus

    humungus Well-Known Member

    menu+home?
  9. LexusBrian400

    LexusBrian400 Well-Known Member

    Getting A LOT of reboots with the scaling script. The voltage must be too low.
  10. D13

    D13 Well-Known Member

    Yeah I thought I could do 1.2 ghz at 34 voltage but I got a couple reboots so I changed it to 1.15 and no reboots yet
  11. FreeWELL

    FreeWELL Well-Known Member

    If you press the Menu and Home buttons at the same time, it brings up a display of your most recent apps, making switching between RE, terminal emulator, SetCPU and your browser quick and easy...
  12. D13

    D13 Well-Known Member

    I think you are referring to holding the home button, you don't have to hold menu also
  13. FreeWELL

    FreeWELL Well-Known Member

    LOL.... i'm new to android... not new to *nix... Operating Systems of the Unix variety for the n00bs... maybe i should take the android tutorial... lol
  14. bosox2k1

    bosox2k1 Well-Known Member

    I am doing EVERYTHING to the T (as far as I know)

    I run it through ADB, when I reboot--the OC doesn't stick. I look on my SD card via root explorer and I see both the setscaling and install recovery files....

    When I am done step 3 (adb) do I just shut it off without exiting out of cmd prompt? Or do I have to write in a specific command before I shut off the phone to try the reboot.


    I am in charge mode and I have tried it in mass storage mode, but when I did the latter, the install recovery and setscaling files didn't stick onto the SD card after removing the phone from my computer.
  15. D13

    D13 Well-Known Member

    First try doing it in Pc mode that is what I did
  16. bosox2k1

    bosox2k1 Well-Known Member

    Since I rebooted, do I have to do step 1 (fabolous' post) or can I just start at step two?
  17. D13

    D13 Well-Known Member

    Assuming everything went well with just setting up the overclocking part yes you can start at step 2
  18. bosox2k1

    bosox2k1 Well-Known Member

    Yea it did, because I tested it by just doing it the original way and not the save for reboot way---and my setcpu showed an increase to 1.1ghz.

    Ok, testing in PC mode, brb.
  19. bosox2k1

    bosox2k1 Well-Known Member

    Yea, same thing...reboot and nothing--attached is a copy of my command line, not sure if you can see if anything is wrong with it or not. I am confused because I am almost positive I am doing everything correctly, but clearly I am not.


    Picasa Web Albums - bosox2k1

    Just make sure you zoom in using the magnifier, otherwise it's too small.
  20. D13

    D13 Well-Known Member

    can you open up the install-recovery.sh you are using and make sure there are two lines at the bottom of it. The first one starts with insmod and the second one with setscaling are those there
  21. bosox2k1

    bosox2k1 Well-Known Member

    Looks like it's there...That's what is in my sdk/tools folder...


    #!/system/bin/sh
    if ! applypatch -c MTD:recovery:2048:37dc5be28fe8cdeb61eae1347fdccf2e201af07e; then
    log -t recovery "Installing new recovery image"
    applypatch MTD:boot:4194304:0c459f9fab93d51a3b09516c415f63352ec9eb02 MTD:recovery 22727909bf9e1f0f844f41484d2a9cf9b6cc49ee 5242880 0c459f9fab93d51a3b09516c415f63352ec9eb02:/system/recovery-from-boot.p
    else
    log -t recovery "Recovery image already installed"
    fi

    insmod /system/lib/modules/overclock.ko
    setscaling.sh
  22. D13

    D13 Well-Known Member

    Okay thats there
    You already have overclock.ko and .sh installed

    Tell me what happens when you do
    adb shell
    su
    cat /system/bin/setscaling.sh
  23. auracle2g

    auracle2g Member

    using terminal emulator

    typing in

    busybox rmmod overclock

    when i enter the command i receive this

    rmmod: chdir(/lib/modules): No such file or directory

    am I missing a file? (Because I dont remember downloading any files every named busybox or rmmod) OR is there more to the command? im confused i want to fine tune my overclock on my Droid X.

    Please help me out my knowledgeable friends.
  24. bosox2k1

    bosox2k1 Well-Known Member

    wish i could cut and paste, haha

    echo 1150000 > /proc/overclock/max_rate
    echo 1 400000000 22>
    echo 2 600000000 26
    echo 3 900000000 30
    echo 4 1150000000 38
    echo 0 1150000000


    etc etc
    Obviously I left out a lot, let me know if you need exactly what happened.
    Does that mean it worked?
  25. D13

    D13 Well-Known Member

    See if typing in "su" first helps
Loading...

Share This Page