[How-To] Overclock your Droid X


Last Updated:

  1. Dulaney22

    Dulaney22 Member

    Many thanks to Hilbe. I got his script running and posted a 1409. I'm very interested to see how this affects battery life.

    [​IMG]

    Advertisement
  2. Airmaxx23

    Airmaxx23 Well-Known Member


    Thanks, I've done the commands in the 1st post to allow over-clocking already and have had good results. With me being new to the command line stuff could you please give me all of the commands for getting your script up and running? I tried the setclock.sh command and got an error so I'm missing something even with that.

    Again, I apologize but this is new to me and I don't want to mess something up.
  3. humungus

    humungus Well-Known Member

    1: Download thishttp://androidforums.com/all-things-root-droid-x/145209-how-overclock-your-droid-x.html#post1340714 file.

    2: Extract it to your sdcard.

    3: Move the extracted file (setscaling.sh) to /system/bin. If using Root Explorer, make sure /system/bin is read/write (R/W). After moving, make sure /system/bin is again set to read only (R/O).

    4: Set permissions. If using RE, long press on setscaling.sh and make sure the permissions are as follows:

    User: Read/Write/Execute
    Group: Read/Execute
    Other: Read/Execute

    5: Open up terminal emulator on your X and type:

    su
    insmod /system/lib/modules/overclock.ko

    This should put you at another su prompt (#).

    6: Then type:

    setscaling.sh

    Again, you should be at another su prompt (#).

    Now you should be good. Go to SetCPU and verify that your max speed is 1.15 GHz.

    This mod gets wiped at every reboot, so you'll have to do steps 5 and 6 each time you start up your X.
    Airmaxx23 and Pocalypse like this.
  4. humungus

    humungus Well-Known Member

    Again, thanks for the setscaling file Hilbe. I've been running it today and it's been perfectly stable. I ran a fairly long SetCPU stress test and had no problems. Have you noticed any change in battery life? It's going to take me awhile before I'd notice anything.
  5. Hilbe

    Hilbe Well-Known Member

    I think I'm seeing better battery. Since I have less than 1 day using these speeds/voltages I don't want to rule out placebo just yet. I'm at 60% after my normal everyday use. Usually I've put it on the charger by now (meaning <30%).

    Maybe others can chime in on their battery results after using the low voltages for some time.
  6. soapinmouth

    soapinmouth Well-Known Member

    Can someone explain to me why motorolla has this chip running at double the necessary voltage?
  7. tmushy

    tmushy Well-Known Member

    I also have been running it fine at 1.15ghz @ 34

    This could porbably give me a few more hours of phone use.

    Does anyone know how to make this automatically start at boot?
  8. Airmaxx23

    Airmaxx23 Well-Known Member


    I was having issues with the 1150000 34 max setting (lots of lag) and since I was having real good results earlier with 1125000 45 I edited the values of the setscaling.sh in RE and everything is now really stable. I'm getting Qaudrant scores in the 1380-1410 range consistently now.

    I'll keep track of my battery usage tomorrow and see how it goes.
  9. Hilbe

    Hilbe Well-Known Member

    You have to add the scripts to /init.rc. I'm not comfortable doing it yet. I'll let someone else add the 2 lines below to it and report back.

    /system/bin/insmod /system/lib/modules/overclock.ko
    /system/bin/setscaling.sh

    These modifications are dangerous and could brick your phone.
  10. kastleberg

    kastleberg Well-Known Member

    I would be willing to do this pending a few answers. First, i would need to know the exact commands. I am pretty new at all this. Here's what i would guess if had to:

    Su
    cp /system/bin/insmod /system/lib/modules/overclock.ko /init.rc/overclock.ko
    cp /system/bin/setscaling.sh /init.rc/setscaling.sh

    Maybe a reboot afterward? Also, i suppose this is the buggy, could i use the sbf to recover in the case of a brick? I would hope to be able to back my rom image up as it stands right now. Can this be done? Like, can i get it back to the way i have it now, or would i have to go back to factory settings and redo it all? This bread seems to have some pretty good help in here so i will leap if people are willing to continue the help.
  11. kastleberg

    kastleberg Well-Known Member

    I would also like to adjust the setscaling.sh befoe i attempt any of this. Would i just dl the setscale zip file and do it all from the beginning again?
  12. Hilbe

    Hilbe Well-Known Member

    Basically pull /init.rc to your desktop, edit it to add the 2 lines to the bottom, and push it back. I think you're going to have to copy it to /sdcard first since it is owned by root. You're also going to have to remount the root file system to read/write since it is read only.

    insmod /system/lib/modules/overclock.ko
    setscaling.sh
    Dulaney22 likes this.
  13. tmushy

    tmushy Well-Known Member

    After a bit more testing 1150000 34 max setting is NOT STABLE on my phone. Random reboots
  14. kastleberg

    kastleberg Well-Known Member

    Okay, got it copied to /sdcard/init.rc. Opened up and ready to add in those two lines. One more assurance. Can I recover if this bricks? And if so, can I recover to where i was prior, or just back to factory settings?

    Also, would the mount remount commands used in the op work to remount the root file system as you stated above? If so, I am assuming I would sandwich the insmod lines between them just as in the op. That correct?
  15. Hilbe

    Hilbe Well-Known Member

    You're going to pull (adb pull) to your desktop, edit it (add 2 lines), push back (adb push) to your sdcard, use a command similar to the OP to remount rootfs read/write, cp init.rc from sdcard to /, check permissions didn't get jacked up, remount rootfs read only. You're going to need to use the sbf to restore back to factory in case of issues. That is why I'm not touching it.
  16. kastleberg

    kastleberg Well-Known Member

    Can I just do this with RE? Adding it into /init.rc with that?
  17. Hilbe

    Hilbe Well-Known Member

    Never used RootExplorer. I'm more of a cmd line guy.
  18. D13

    D13 Well-Known Member

    You can just edit the file on your computer with Notepad++. Thats what Fab and I did
  19. kastleberg

    kastleberg Well-Known Member

    Okay, be a few minutes. Putting the kids down and preparing for some work time in case this bombs.
  20. Dulaney22

    Dulaney22 Member

    Highest I've gotten is 1422. I've been running Hilbe's mod since early this afternoon and no issues yet.
  21. kastleberg

    kastleberg Well-Known Member

    I used RE for this. That being said, i will get ur opinion droider13, think i can just edit the init.rc with RE and ha e the same outcome?
  22. D13

    D13 Well-Known Member

    I would say that you would be fine. With the original Droid, at one point or another, Pete(maker of Bugless Beast, a well known dev and winner of the Droid X from Alldroid) released, can't remember exactly, some type of script that had to deal with overclocking. In the directions you could either pull to your computer the file and push the new one or use RE. I used both and everything worked fine.

    Long story short yes you will be fine, matter a fact I really don't care if I have to flash a sbf file and start over so I am probably going to do it tonight.:D

    Edit: If you do use the computer method, edit it with Notepad++
    Edit 2: Remember to save changes before you exit
  23. Hilbe

    Hilbe Well-Known Member

    Whoever does add it to init.rc and gets it working, please keep a log (how-to) on the commands you used. It's going to be a very frequently requested how-to.

    Thanks.
  24. kastleberg

    kastleberg Well-Known Member

    So, just add these two lines:

    /system/bin/insmod /system/lib/modules/overclock.ko
    /system/bin/setscaling.sh

    at the end of init.rc? just like they are? Sorry to annoy anyone. Just trying to make sure.
  25. Hilbe

    Hilbe Well-Known Member

    I'm not sure you need the full paths. I see them using chmod in init.rc which is in /system/bin, so I'm guessing "/system/bin" is not necessary. I'd try:

    insmod /system/lib/modules/overclock.ko
    setscaling.sh

Share This Page