[How-To] Overclock your Droid X


Last Updated:

  1. kastleberg

    kastleberg Well-Known Member

    Joined:
    Jul 15, 2010
    Messages:
    577
    Likes Received:
    207
    find it droider?

    With RE:

    I went to
    root/../etc/install-recovery.sh
    mount to rw
    open install-recovery.sh with text editor
    add two lines:

    insmod /system/lib/modules/overclock.ko
    setscaling.sh

    save and exit
    reboot, and there you go...

    Also, thanks Hilbe for guiding me through all that.
     

    Advertisement
    humungus likes this.
  2. D13

    D13 Well-Known Member

    Joined:
    May 28, 2010
    Messages:
    2,088
    Likes Received:
    234
    No what is wrong?
    I checked in /system/etc
    and /etc
    :mad:
    Even tried a reboot
     
  3. PJ.

    PJ. Member

    Joined:
    Aug 8, 2010
    Messages:
    19
    Likes Received:
    1
    Not showing up for me either..

    When I adb pull /system/etc/install-recovery.sh

    I get

    adb: not found

    Can't find in RE, either.
     
  4. Hilbe

    Hilbe Well-Known Member

    Joined:
    Jan 31, 2010
    Messages:
    193
    Likes Received:
    105
    My how-to assumes the user has a computer with ADB installed.
     
  5. PJ.

    PJ. Member

    Joined:
    Aug 8, 2010
    Messages:
    19
    Likes Received:
    1

    I've got adb, lol.

    It's what I've been using to OC and execute the setscaling.sh scripts lol.

    I can't locate the install-recovery.sh, not even in RE.
     
  6. D13

    D13 Well-Known Member

    Joined:
    May 28, 2010
    Messages:
    2,088
    Likes Received:
    234
    Take off that period at the end of step one to avoid confusion. I am sure when people start copying and pasting this there will be problems;)

    You need to add the .sh to setscaling;)
    P.s I still can't find it
     
    kastleberg likes this.
  7. kastleberg

    kastleberg Well-Known Member

    Joined:
    Jul 15, 2010
    Messages:
    577
    Likes Received:
    207
    Good call! I have no clue what to say. Are you using RE? I'm assuming actually that you are trying every way.
     
  8. humungus

    humungus Well-Known Member

    Joined:
    May 23, 2010
    Messages:
    124
    Likes Received:
    39
    Thanks guys. I got this running at boot as well.
     
  9. D13

    D13 Well-Known Member

    Joined:
    May 28, 2010
    Messages:
    2,088
    Likes Received:
    234
    Yeah I even tried making it in notepad++ because it has that option and it still doesn't work. I wish there was a crying "smiley"
     
    asrun likes this.
  10. Hilbe

    Hilbe Well-Known Member

    Joined:
    Jan 31, 2010
    Messages:
    193
    Likes Received:
    105
    Took the "." off my how-to for you guys. Also, there are a few other scripts called on startup, but I'm not sure if they will work as well as install-recovery.sh. Here are some others to try:

    /data/misc/wifi/forward_start.sh
    /data/misc/wifi/forward_stop.sh
     
  11. PJ.

    PJ. Member

    Joined:
    Aug 8, 2010
    Messages:
    19
    Likes Received:
    1
    I searched RE for install-recovery.sh

    No sign of it at all. I'm not sure what's going on here...lol
     
  12. D13

    D13 Well-Known Member

    Joined:
    May 28, 2010
    Messages:
    2,088
    Likes Received:
    234
    Something is wrong I looked in RE too

    C:\Users\Jeff\Desktop\tools>adb pull /data/misc/wifi/forward_start.sh
    remote object '/data/misc/wifi/forward_start.sh' does not exist

    C:\Users\Jeff\Desktop\tools>adb pull /data/misc/wifi/forward_stop.sh
    remote object '/data/misc/wifi/forward_stop.sh' does not exist
     
  13. kastleberg

    kastleberg Well-Known Member

    Joined:
    Jul 15, 2010
    Messages:
    577
    Likes Received:
    207
    Well, this is all very strange.
     
  14. D13

    D13 Well-Known Member

    Joined:
    May 28, 2010
    Messages:
    2,088
    Likes Received:
    234
    Lets see...
    I am running .604
    I have Nextheme but I don't think this could be causing this...could it? Who has nextheme? PJ.?
    thats about it :(
    What is wrong?!?!?!?!?!?
     
  15. PJ.

    PJ. Member

    Joined:
    Aug 8, 2010
    Messages:
    19
    Likes Received:
    1
    Yeah, I'm running nextheme.

    I can't find it, I'm stumped.
     
  16. D13

    D13 Well-Known Member

    Joined:
    May 28, 2010
    Messages:
    2,088
    Likes Received:
    234
    kastleberg, what about you?
     
  17. Hilbe

    Hilbe Well-Known Member

    Joined:
    Jan 31, 2010
    Messages:
    193
    Likes Received:
    105
    Maybe nextheme removed it? I don't run nextheme, I'm bone stock.
     
  18. Dulaney22

    Dulaney22 Member

    Joined:
    Jul 25, 2010
    Messages:
    21
    Likes Received:
    1
    Can't find it in mine either. Search yields nothing as well.
     
  19. Hilbe

    Hilbe Well-Known Member

    Joined:
    Jan 31, 2010
    Messages:
    193
    Likes Received:
    105
    For those that don't have it, here is my install-recovery.sh. Unzip, drop in /system/etc, and use at your own risk. Permissions look like:

    -r-xr--r-- root root 470 2010-08-09 22:04 install-recovery.sh

    What is that? chmod 644? It is late, I'm heading to bed. Best of luck.
     

    Attached Files:

    D13 likes this.
  20. ooja3k

    ooja3k Well-Known Member

    Joined:
    May 19, 2010
    Messages:
    45
    Likes Received:
    1
    yeah no install-recovery.sh to be found. lame
     
  21. Hilbe

    Hilbe Well-Known Member

    Joined:
    Jan 31, 2010
    Messages:
    193
    Likes Received:
    105
    My copy should resolve your issues. Please try and post your results.
     
  22. ooja3k

    ooja3k Well-Known Member

    Joined:
    May 19, 2010
    Messages:
    45
    Likes Received:
    1

    Trying it now.

    WORKED for me! I didn't do ANYTHING except move it to the root/etc/ folder no changing the chmod or permissions or anything.

    To all:
    I was one of you guys that could not locate install-recovery.sh for the life of me.

    I used his uploaded file, extracted to root, moved it to root/etc/ and rebooted.

    works perfectly with my modded setscaling.sh @ 1.1ghz @ 34
     
  23. Dulaney22

    Dulaney22 Member

    Joined:
    Jul 25, 2010
    Messages:
    21
    Likes Received:
    1
    Just dropping yours in worked. Many thanks!
     
  24. humungus

    humungus Well-Known Member

    Joined:
    May 23, 2010
    Messages:
    124
    Likes Received:
    39
    I've had a few random reboots running 1.15 at 34. They didn't show up for awhile, so keep an eye out. I'm trying 1.125 at 34 right now.
     
  25. LexusBrian400

    LexusBrian400 Well-Known Member

    Joined:
    Mar 3, 2010
    Messages:
    699
    Likes Received:
    154
    Hibe, if you ever get the time... I think you should post your own thread with your instructions. To anyone that hasn't been following along this is thread is all fragmented and all over the place. Its confusing as hell, and I've been here since day 1 :) Just a suggestion. Thanks for your work guys
     

Share This Page

Loading...