How to partition sd card


  1. Game Error

    Game Error New Member

    I recently rooted my htc desire using revoked 3.21 but and inserted a new 8 GB sd-card, the thing I am wondering now is how to partition this sd-card to use the mod apps to SD. I thought there should be an option in the Clockworkmod screen, but I cant find it.

    Advertisement
    :
  2. Rastaman-FB

    Rastaman-FB Well-Known Member

    yeah, i dont know why but its no longer included in clockworkmod
    download the free version of rom manager from the market
    click flash recovery (its a fake flash not a real flash so its safe dont worry. needs to be done for this to work)

    click partition sdcard
    512 ext and 0 swap

    it will reboot and format the sdcard then partition it.

    job done


    the alternative is using a linux live cd use gparted or use gparted live cd
    Gruntplace and JonoSavage like this.
  3. Mobilez6600

    Mobilez6600 New Member

    you can partition your sd card using two ways:

    1) by partitioning it from your pc (linux is better than windows, because you must create an ext3 partition and a fat partition);

    2) this is second way:
    - download and install amon RA 1.9 recovery image
    - enter fastboot, connect pc and use sdk
    "fastboot flash recovery recoveryname.img"
    - enter recovery mode
    - select partition sd
    - set at least 512mb for ext
    - accept to create
    - convert sd ext to ext3

    I suggest a full wipe

    then you can install your rom.
  4. Rastaman-FB

    Rastaman-FB Well-Known Member

    you can only do number 2 if you have s-off
    the only way to flash a recovery without soff is using unrevoked 3.21 and doing custom recovery

    also ext2 is the minimum requirement for a2sd and is accepted
  5. Game Error

    Game Error New Member

    And how can I upgrade this to ext3
  6. Rastaman-FB

    Rastaman-FB Well-Known Member

    you cant without gparted
    ext2 is still preferred by most devs and mods anyway
  7. InfernalByte

    InfernalByte Well-Known Member

    Dowload a Linux Distro and use Gparted. Once you've used Linux you'll understand how slow, cumbersome and obsolete Windows is.
  8. Rastaman-FB

    Rastaman-FB Well-Known Member

    what has windows slowness got to do with it?

    lets not get into a linux vs windows argument

    obsolete ? rofl, research that word as its incorrect for your usage.
    unfortunately something that is default in most households cannot be obsolete regardless of how crap it is
  9. SkinJob

    SkinJob Well-Known Member

    I'm having similar troubles right now. Hoping to install LeeDroid (with apps2sd), I successfully managed to root my Desire using UnRevoked and a Clockwork 2.5.0.1 custom image for SLCD. But trying to format the SD card does not work in ROM Manager, nor does flashing a new image work there (both the sd card and original recovery remained, after trying). Not even after reinstalling several times. Far as I can tell, ROM Manager is incompatible with the clockwork image. But 2.5.0.1 is working, and I don't know if the 2.5.0.7-bravo image is compatible with my SLCD Desire, or how to flash it in a way that is compatible with ROM Manager.

    Is there some way for me to partition the SD card with an ext3 and FAT32 partition, without the complications of using ADB/SDK or a Linux CD?
  10. Rastaman-FB

    Rastaman-FB Well-Known Member

    ??? which unrevoked did you use?
    3.21 comes with 2.5.0.7
    what hboot are you on?
    im on slcd rooted with unrevoked and it came with 2.5.0.7
  11. SkinJob

    SkinJob Well-Known Member

    FYI: I'm on HBOOT 0.83.001 (a Telus Desire). I used v3.1 of Unrevoked, and I got the image file from a link on a page, of the Droid Den guide on rooting. At the time (ie. a few hours ago...) I didn't know no nuthin' about version numbers and their differences, or the importance of getting the latest.

    HOWEVER, all that is copacetic because I just fixed the problem. Turned on SYNC via HTC Sync, and then ROM Manager allowed me to both flash the latest 2.507 recovery image, and partition the SD card. Hope this helps anyone having the same problem. (I know the wipe worked, but I've yet to confirm the partition worked. As it says I have 6.92GB free, but its the 8gb card that came with the Desire, and I specified a 512mb partition. ROM Manager does not specify wether its EXT2 or EXT3, but LeeDroid himself recommended using RM for the format, so....).

    After two FULL days of intense research on ROMS, RUU's, rooting, hacking and hair-tearing and frozen HTC screens and whatnot.... I think I'm finally ready for step 4: Installing LeeDroid 2.2a! (I thought that would be my biggest problem. I expect that to go like clockwork). :cool:
  12. SUroot

    SUroot Well-Known Member Developer

    I use step 3 of an a2SD tutorial to partition my card.

    It states the whole process only works if you followed their guide to root. Not technically true because I only partitioned the card and didn't root using their guide. BUT YOU CANNOT USE THIS GUIDE TO INSTALL A2SD

    However, I think this will only work if traditionally rooted, not unrevoked.

    Droid Den - Phone Guide: How To Add Apps2Sd To The HTC Desire - Droid Den
  13. Rastaman-FB

    Rastaman-FB Well-Known Member

    well done for fixing it, synch will have nothing to do with it though. it was coincidence
  14. SUroot

    SUroot Well-Known Member Developer

    Hmmm. Putting it in sync could have taken it out of disk drive mode. This would explain why it wouldnt work
  15. Rastaman-FB

    Rastaman-FB Well-Known Member

    oh you're right, if he mounted it as a disk drive to pc then it wouldnt load the files to sdcard.
    didnt think of that
  16. SkinJob

    SkinJob Well-Known Member

    I'm a newb to hacking a smartphone so, at the time (ie. yesterday...), I had no idea what "unrevoked" was, and that you couldn't use it to install an A2SD ROM. But as I learned on another forum, an 8gb SDCard is only good for 7.45gb. If you minus the 512mb for the EXT3 partition, it appears that my partitioning worked, and I will be able to install an A2SD ROM. Also, the recovery menu showed me that I now have the 2.5.0.7 image (installed by ROM Manager). But I will read your A2SD guide attentively, though! Thanks for the guides, yours are the clearest and best I have seen out there! :D


  17. SkinJob

    SkinJob Well-Known Member

    I guess that did it, because I know it couldn't have been a coincidence. I had tried numerous times with ROM manager, and two seconds after it failed to work, it succeeded just as soon as I switched to sync. (I had synced while I was still in the app).
  18. SUroot

    SUroot Well-Known Member Developer

    No don't use this guide for a2SD, it may get you on a boot loop. I posted it just for partitioning.
  19. Archea

    Archea Member

    Can I just potentially provide an update? It appears you now can partition the SD card from the ROM Manager on ClockworkMod well, seems to have done so for me at the least. Can't remember if its the stock ROM Manager or one I downloaded though.

    Just out of interest, how do you know when you have successfully formatted your SD card to have an EXT partition?
  20. Rastaman-FB

    Rastaman-FB Well-Known Member

    try and mount it via recovery, see what it says
  21. SUroot

    SUroot Well-Known Member Developer

    Or the application "quick system info" will tell you how much space is used or free. If the partition is not correct it will say something like "not available"

    Try this as its a good app to keep an eye on your ext partition use.
  22. Gruntplace

    Gruntplace New Member

    You are a life saver, have been farting around for hours wondering why ROM manager wouldn't partition my card and couldn't find anything. As soon as I tried flashing recovery and then partitioning it worked straight away.

    Legend
  23. Gruntplace

    Gruntplace New Member

    Rastaman-FB

    Thanks so much, flashing recovery before partitioning with rom manager worked for em after hours of trying and searching
  24. SUroot

    SUroot Well-Known Member Developer

    Please dont use rom manager. Delete it immediately.
  25. Rastaman-FB

    Rastaman-FB Well-Known Member

    we no longer recommend this, its a bad egg
Loading...

Share This Page