[How-To] Prevent FRG83G OTA Update


Last Updated: 2012-08-14 05:11:45
  1. kratos

    kratos Back on my throne!!! VIP Member

    1. In Root Explorer, go to /system/

    2. Tap Mount R/W at the top, then long-press on build.prop and scroll down to Open in Text Editor

    3A. Once the file is open as a text file, scroll down until you see the line that says: "ro.build.fingerprint=verizon/voles/sholes/sholes:2.2.1/FRG83D/75603:user/release-keys" (or something similar; the numbers may not be the exact same for you) and CHANGE it to read as follows:
    ro.build.fingerprint=verizon/voles/sholes/sholes:2.2.2/FRG83G/91102:user/release-keys

    3B. Find the following (located just before the line listed in step 3A): ro.build.description=voles-user 2.2.1 FRG83D 75603 release-keys (or something similar; the numbers may not be the exact same for you) and CHANGE it to the following: ro.build.description=voles-user 2.2.2 FRG83G 91102 release-keys

    4. Tap the back key and say "Yes" when it asks you to save (it will automatically back up the original file for you)

    5. Tap Mount R/O at the top

    6. Reboot

    Please note that your original numbers listed may not be the same as listed above because you may be coming from a different build. However, the lines will be the same (different numbers) and as long as you change it to read as listed above, you will be fine.

    Kratos

    Advertisement
  2. DapCorderman

    DapCorderman Well-Known Member

    Just checking: In line 3B. should you not be changing

    ro.build.description=voles-user 2.2.1 FRG83D 75603 release-keys

    to

    ro.build.description=voles-user 2.2.2 FRG83G 91102 release-keys

    Or does the original version number remain intact?
    kratos likes this.
  3. kratos

    kratos Back on my throne!!! VIP Member

    I seem to have missed that...

    Kratos
  4. Lock-N-Load

    Lock-N-Load Well-Known Member

    ro.build.description=voles-user 2.2.2 FRG83G 91102 release-keys
    ro.build.fingerprint=verizon/voles/sholes/sholes:2.2.2/FRG83G/91102:user/release-keys

    some good info on this update here
  5. Tek34

    Tek34 Active Member

    Thanks for this. Do you know if this will still work if my device has already started to prompt me to install the update? I keep hitting <install later> but I'm afraid it may still install some the update, possibly downloaded and queued to install, despite changing these values at this point in time. Do I need to somehow manually remove some downloaded update files already queued to install?
  6. cubsfanaz

    cubsfanaz Member

    When I woke up this morning, I was prompted to install the update. I hit install later a few times until I found this thread. I followed the steps Kratos listed (thanks!). Once I rebooted, I still had the "update available" icon in my status bar, but I think it was just there because I had never cleared it before going through these steps. So, I cleared it from the status bar after reboot, and I have not been prompted to install the OTA update again.

    This process worked great for me.

    Thanks again Kratos!
    Tek34 likes this.
  7. Lock-N-Load

    Lock-N-Load Well-Known Member

    yes, your fine. installing later puts it off. just hit the install later, clear the notification, make the above changes, reboot
  8. railrode1

    railrode1 Active Member

    I'm currently rooted just to use wireless tether. My OG Droid is running FRG83D. I have already received notification of the FRG83G update. If I accept this update, will I lose the use of "wireless tether" app ? This is all I want right now. I tried to purchase "root explorer" from the market but it's in euros or something and both my cards decline payment.
  9. kratos

    kratos Back on my throne!!! VIP Member

    You can use thee link posted by Lock-n-Load to flash a rooted version of this. Just scroll down a little and you will see the files listed.

    Kratos
  10. Zarniwhoop

    Zarniwhoop New Member

    Hey everyone. I'm new to the forums and really not too well-versed in the tech aspects of this phone.

    I've only had it a few months and I rooted it with superoneclick mainly so I could tether (using Barnacle for that).

    I got the update notification last night and stupidly accepted. This morning Barnacle won't work and I assume I am no longer rooted even though I still have the superuser icon.

    What can I do? I also don't have the root manager app referred to earlier.

    Can I use superoneclick again? I haven't tried it, or anything yet.

    Thanks!
  11. Tek34

    Tek34 Active Member

    Try Super Manager Free from the app market. It has a Root Explorer. You may need another app like ASTRO or something to actually edit a copy of the system file. But once you have an edited copy of the file, Super Manager should be able to switch to R/W and replace the file with your changes.
  12. Tek34

    Tek34 Active Member

    Thanks all. Worked here too. I got the update notification message again after reboot, despite clearing the notification prior to booting. However no more constant nags to update and everything seems right.
  13. kratos

    kratos Back on my throne!!! VIP Member

    You can try rooting again. The update broke root, but it doesn't remove apps like superuser. I have read a few people stating that this update patches the exploits used for rooting.

    You can always try rooting again. If it works great, if not no harm done.

    If rooting again doesn't work, use RSD Lite and revert back to 2.1 and then root. Then use the link above from Lock-n-Load to flash a rooted version of this update.

    Kratos
  14. Zarniwhoop

    Zarniwhoop New Member

    I was a bit hesitant to just retrying root via superoneclick. I didn't know what it would do and didn't want to really mess things up.

    So what I was looking for was someone with more knowledge than I to basically not say "NO NO NO Don't do that!!"

    So with the "go ahead and give a try" approval I did. And it worked perfectly. No problems at all. So a big thanks Kratos (BTW my name on Full Tilt Poker is Kratos - Great name)

    I'm still rocking the 2.2.2 version so I assume that all is well as far as that goes as well.

    Thanks again!
  15. railrode1

    railrode1 Active Member


    There are two files in the link, DEODEXED and ODEXED. What's the difference between the two?
  16. kratos

    kratos Back on my throne!!! VIP Member

    I couldn't every really explain it properly, so here is the down and dirty explanation from a member on this forum:


    Hope that helps,

    Kratos
  17. c0nn13

    c0nn13 Member

    Bought my OG Droid about 4 months ago. 2.2.1 FRG83D. Rooted the phone. Im on page plus so only use data for mms. But today, after downloading a pic, I got the notice that a download of 2.2.2 FRG83G is available for download. I did the above prodeedure, but didnt seem to take. I rebooted with data off. Then rebooted with data on. Same thing. Do u hafta change every occurance of 2.2.1 FRG83D 75603 in the script? When u Settings>About Phone It still shows 2.2.1 FRG83D.
  18. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    After you change the settings in the build.prop file, you need to reboot, then clear the notification. It should then not come back.

Share This Page