How to properly format internal SD?Support


  1. sayginjedi

    sayginjedi Member

    Hi,
    I have corrupted files on the internal sdcard and wish to delete them. I tried to format the whole sd but could not succeed. Here is what I've tried:

    - Format using the Settings->SD Card->Unmount, then Format: This doesn't give any error but files are still there
    - Mount the phone SD to the PC, use gparted on PC delete partition: Partition is deleted but still nothing happens
    - Tried to use parted on adb shell, but it is not installed (I have Drakaz 2.2)
    - No relevant item in Drakaz recovery menu

    What else can you suggest? And one more thing, what must I care before formatting the card? Can I boot the phone when the card is empty? Then I can put Drakaz recovery image etc. after the phone is booted.

    Advertisement
  2. Lelouch

    Lelouch Well-Known Member

    Yes, you can boot in it. You just format the rest of inner SD card partition (6.x GB one). And regarding Recovery.image, you don't need to flash it again just copy Rectools back on internal SD card, easy as that.

    Did you try to format the disk in Ubuntu (FAT 32 is your target)? And remember to plug your phone in the bask USB port, not in the front (doesn't work so great). Use standard format disk (I think Win 7 doesn't format disk in FAT 32).
  3. sayginjedi

    sayginjedi Member

    ok, I have installed parted manually. now when I run:

    parted /dev/block/mmcblk0

    I get:

    Model: Unknown (unknown)
    Disk /dev/block/mmcblk0: 8053MB
    Sector size (logical/physical): 512B/512B
    Partition Table: msdos

    Number Start End Size Type File system Flags
    1 1049kB 8053MB 8052MB primary boot, lba

    is this my internal sd card? If so I think I don't need to do partitioning, how can I directly format it?

    What I want to achieve is to format the space I see when I mount the phone as a USB drive, I don't want to touch other information. And again, if so, can I boot the phone properly and when it's running connect it to PC and put recovery image (and nand backups etc.) again?

    @Lelouch: When I mount the phone on PC (and turn on USB storage) I see that it is mounted as:

    /dev/sdb on /media/NO_NAME type vfat (rw,nosuid,nodev,uhelper=udisks,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,flush)

    Now, do I need to format /dev/sdb ? On Ubuntu I cannot see any partitions on /dev/sdb with fdisk, is that normal? And if I need to format it under Ubuntu, what is the proper way? (fdisk and gparted do not see the partition, mkfs.vfat under Ubuntu?)


    Thanks.
  4. Lelouch

    Lelouch Well-Known Member

    How much in size is that NO_NAME (that is the internal SD card - I renamed it to Galaxy so I know)? it must have 6,54 GB or some similar value, the rest of it's 8 GB is for Android system, phone, baseband, and etc... I other words just format that NO_NAME part.

    But first copy your Nandroid backup folder to PC so you can later return it back. When you mount your phone do you see NO_NAME as a external drive (Windows and Ubuntu)? If you do just right click on it (Windows) and use format (choose FAT 32). In Ubuntu you must mount it also and just format that NO_NAME drive (also FAT 32).

    Nadroid folder, pictures, movies, apk if you have any, copy them first to PC so you don't loose them. After the formatting just copy them back, don't forget Rectools also. :p
    sayginjedi likes this.
  5. imjohnson

    imjohnson Member

    Dear All,

    I got some trouble and might need to fix filesystem or format my internal-SD on i7500.
    Could anyone help for the part?

    I got the trouble because I copy all files/Director from internal-SD to PC and move back again.
    It impacts the filesystem in internal-SD I guess, then I can't access the internal-SD anymore.
    I can't download file, can't take photo, etc...

    Could I fix the owner and permissions of the filesystem on internal-SD?
    Could I format the internal SD(All filesystem including OS) and re-upgrade Recovery/ROM by myself?

    ps:
    I only have PC with windows 7.
    I have upgraded i7500 using gaosp Nightly (Recovery: 6.4) (Android 2.2.1)

    [​IMG]
    [​IMG]
    [​IMG]
  6. imjohnson

    imjohnson Member

    Dear Lelouch,
    I've tried to format internal-SD using windows7 but got trouble.

    1. entering recovery mode, then choose "mount SD on PC"
    2. Saw external device on windows7.
    3. I can see internal-SD data correctly at the moment.
    4. "Right click" the external device and choose "format".

    At the moment, the internal-SD was disappeared.
    I still can see the volume of the disk (ex: disk E), but there's no files in the disk.

    How could I solve it?



  7. Lelouch

    Lelouch Well-Known Member

    Well, there is a couple of things you could try.

    1. if you connect the Galaxy to PC via USB from the front, connect it to the back side (Win 7 issue)
    2. try via Ubuntu (linux)
    3. Partition Manager is also one of the choices, but... (read the first point)
    4. using "Terminal" in GAOSP/Galaxo, input these commands
    Su
    mkdosfs /dev/block/mmcblk0p2


    There is also the driver issues (in which I doubt), but try first 2 (3???) points first, or you can also try with another PC (note: must have USB 2.0 support)
    imjohnson likes this.
  8. imjohnson

    imjohnson Member

    Thanks, the issue has been fixed.
    After odin and reset to factory default, I can format the internal-SD card finally.

Share This Page