[How To] Regain Root With S-Off or HTC unlocked bootloader


  1. iowabowtech

    iowabowtech root@android:/ # Moderator

    Please note, the files listed here should only be used on the original Droid Incredible.

    So you accepted the Gingerbread OTA or decided to run an RUU and now Unrevoked 3 doesn't work. If you're still S-Off from being rooted previously, here's how to get back to root:

    1/19/12 update: If you unlocked your bootloader via the HTC website, you will still be s-on but these instructions may be used. Skip straight to step #2 now if this describes your situation.

    1.) Unsure of s-off status? Power off phone, hold volume down while pressing power button to enter hboot. Look near top of the screen. If it says s-off, you're good.

    2.) SD card must be formatted to FAT32. Once that's done, download the following file, rename to PB31IMG and place on the root of the SD card:
    http://pvillecomp.com/wp/wp-content/uploads/Clockwork/recovery-clockwork-5.0.2.0-inc_PB31IMG.zip

    Mirror:
    http://www.box.com/shared/r0xk9p8o8cu8bt0l8gae

    3.) Download Superuser and place the zip on the SD card also. This does NOT need to be renamed:
    http://downloads.androidsu.com/superuser/Superuser-3.0.7-efgh-signed.zip

    4.) With both files on SD card, power off phone. Then press and hold volume down and the power button simultaneously until the hboot screen appears. PB31IMG should now be auto-recognized. When prompted, press volume up to load it. When done, follow the instructs to reboot.

    5.) Remove the PB31IMG from the SD card.

    6.) Power down, then go back to hboot. Use the volume keys to select "Recovery", press power button to select and enter Clockwork. Now select "Install zip from SD card", then "Choose zip from SD card", then navigate to the Superuser zip you placed on the card in step 3. Select and load it. (NOTE: For those that don't typically load zips directly in CWM, use the trackpad button to make selections in CWM, the power button brings you back one menu.)

    7.) With Superuser now loaded, choose the Clockwork option to reboot to system. If you don't see it at first, press the power button once to go back one menu and it'll be there. Now should be rooted with Clockworkmod recovery.

    Advertisement
    BSH, Raindeux, louvega and 17 others like this.
  2. sdrawkcab25

    sdrawkcab25 Guides Guide

    made this an external sticky for now as i'm sure it will become a hot topic when *official* gingerbread is made available to everyone.
    jmar likes this.
  3. Phaedrus49er

    Phaedrus49er New Member

    Timely post. Just started digging for info on this today as I've reached my tolerance limit with the 2.3.4 OTA. Many thanks.
  4. iowabowtech

    iowabowtech root@android:/ # Moderator

    Let us know how it goes. I have done the procedure but I used cwm 3.0.0.8 rather than the newer 5.0.2.0 I linked here. Should work the same but just want it verified. First person to verify results gets a guaranteed thanks button press from yours truly.
    jmar likes this.
  5. jmar

    jmar Nexican VIP Member


    Works with RA recovery, too. Just did it for giggles. May I have a thank you sir?
    iowabowtech likes this.
  6. iowabowtech

    iowabowtech root@android:/ # Moderator

    You may indeed. Thanks Jmar.
    jmar likes this.
  7. answerman

    answerman Well-Known Member

    Nice writeup. I expect lots of people are going to be directed here once they give up on the OTA.

    Just curious (doesn't matter much to me because I am rooted and on Nils): once this process is followed, where are you? Back at rooted 2.2?
  8. euph_22

    euph_22 Well-Known Member

    This is for people who were rooted, unrooted (leacing S-off) then received the OTA update (or applied one of the non-rooted manual update methods). This lets them reroot the phone.

    So they end up with the stock 2.3 Rom, only with root.
  9. PKZ1

    PKZ1 New Member

    I rooted while on 2.2 and confirmed that the phone had "S-off" before manually upgrading to 2.3.4. However, I have been experiencing difficulty restoring the root (Clockwork and Superuser). I downloaded both files, but when they download on my Mac they download as uncompressed folders (and I think their file names may change too). At any rate, I've tried different combinations and have had no luck installing Clockwork via the boot loader.

    Someone off chat recommended I try downloading the ROM Manager and Superuser versions available in the Market, but I haven't been sure how to properly integrate those with the phone.

    Any/all assistance would be greatly appreciated!

    Here are some of my specs currently:
    Android 2.3.4
    Baseband version: 2.15.10.07.07
    Kernel version: 2.6.35.10-g5e15ac4
    Build number: 4.06.605.2
    Software number: 4.06.605.2
  10. sdrawkcab25

    sdrawkcab25 Guides Guide


    Try downloading the file directly from your phone browser and use a file manager (astro) to rename and move the clockwork image to the root of your SD card.
  11. PKZ1

    PKZ1 New Member

    Thank you so much! That worked flawlessly!

    :)
  12. tiger505

    tiger505 New Member

    What a find...finally was able to get Superuser back and get rooted again.
  13. 6StringDave

    6StringDave Well-Known Member

    Thanks, that was easy and quick! Probably easier than Unrevoked, which requires either Windows drivers or a Linux session, plus the fear of losing your USB line while it's installing.

    Actually, I did use Unrevoked with Froyo, and now that I see a different "Superuser" icon, I'm wondering what it is that I just installed. Who makes this? Is it a standalone root manager like Unrevoked, or do I need to install that too?
  14. iowabowtech

    iowabowtech root@android:/ # Moderator

    Superuser is just an app that can be found on the market. Icon probably looks different because this may be a newer version than you were used to. Unrevoked is not a root manager, it's just an automated root exploit but it is not designed to work with Gingerbread. When the Unrevoked team integrated s-off (Unrevoked Forever back then) into the root tool, it gave us the ability to reroot in these instances, even now when the Unrevoked tool itself is obsolete, simply by loading a custom recovery and applying Superuser to allow root apps to work.
    lukkypuggy likes this.
  15. LordSith77

    LordSith77 New Member

    I tried this (I still have S-Off on my DINC after GB update), but the HBOOT scanns, I can see the PB31IMG.zip scanned but doesn't do anything. Keeps saying no image or wrong image. Any ideas? I really want to get root and SU back on this phone.
  16. sdrawkcab25

    sdrawkcab25 Guides Guide


    is your sd card formatted to fat32? Is the file on the root of the sd card?
    Did you confirm the md5 hash of the file?
    LordSith77 likes this.
  17. LordSith77

    LordSith77 New Member

    Yes to both fat32 & the file on the card. I didn't however check the hash. I had quite the difficulty downloading the file to begin with (I hate those fileshare sites, they give a lot of fake download options LOL)

    I'll check the hash, and see if that answers my problem. Thanks.
  18. iowabowtech

    iowabowtech root@android:/ # Moderator

    Sounds most likely like the fat32 format didn't take properly. If the md5 matches and the file is on the root of the SD card, try reformatting again or try another card.
  19. bprice

    bprice Active Member

    By doing this method, will it remove my programs and settings?
  20. iowabowtech

    iowabowtech root@android:/ # Moderator

    No, it wont affect your apps or settings.
  21. kree

    kree New Member

    Has anyone had problems with wireless tether after this reroot?
  22. mmolitor87

    mmolitor87 Well-Known Member

    This is no different from other root methods, except it is manual.

    The problem likely is with superuser. Go into settings -> applications -> superuser -> clear data. Make sure superuser is up to date through market. Open superuser, go to settings and check the binary to make sure it is up to date.
  23. JoeSchmoe007

    JoeSchmoe007 Well-Known Member

    I was following this but hboot wouldn't appear. This was my problem in step 4): I would press "Power" and "Volume down" and then released them, when I should've held them pressed until hboot screen appears.

    May I recommend rephrasing step 4) to something like this:

    "Now simultaneously press the "Volume Down" button and the "Power" button, holding till the HBOOT screen appears" (found at http://androidforums.com/incredible...ivers-adb-bootloader-disk-drive-htc-sync.html in step 5)?
  24. iowabowtech

    iowabowtech root@android:/ # Moderator

    Edited for clarity.
  25. timewarnerguy1

    timewarnerguy1 New Member

    does this method work if one has restored to stock 2.3.4 version 4.08? i have s-off and want to regain root.

Share This Page