How To: Remove (Almost) Every Trace of AT&T

Last Updated:

  1. kpenning

    kpenning Well-Known Member

    Here you go! Ripped straight from my article: How To: Remove AT&T From Captivate.


    WARNING: I am not responsible for any bricked, messed up, ruined devices. You modify your phone at your own risk. These processes are not necessarily safe for your Samsung Captivate or any other device.

    Root the Samsung Captivate

    First things first. You’ll need to root your device to continue with many of the modifications listed below. For our “How to Root the Samsung Captivate” guide, click here. It’s very very easy. Even a total noobie can do it! If you have questions, post a comment and we’ll get back to you A.S.A.P. Look below if you get the idea, check out our “How to Root the Samsung Captivate” guide if you don’t.

    1. Plug in your Captivate to your computer. When the phone notifies you that the USB has been plugged in, scroll down your notifications bar and click on “USB connected: Select to copy files to/from your computer.”
    2. Click “Mount”
    3. Now, you’ll probably see a popup telling you a new USB drive has been inserted, open it up on your computer. In Windows, click “Open folder to view files.”
    4. Drag into the Captivate USB drive (on the top level… do not navigate into folders)
    5. Turn off the Captivate (Power Off)
    6. Hold down the Volume Up/Down rocker and the power button until you see some action. Your phone is now booting into recovery.
    7. Use the volume down button to scroll down to “Reinstall packages”
    8. Click the power button to select that option

    Enable App Sideloading

    AT&T has some weird reservations against app sideloading. That means, AT&T Android users can not use any apps not downloaded on the Android Market. Have no fear! You can remove this restriction easily. Check below for the basic instructions, or click to go to our “Enable Captivate App Sideloading” guide.

    1. Turn on USB debugging: Settings >> Applications >> Development
    2. Plug in your Samsung Captivate
    3. Open up Command Prompt on your computer (Windows: start, search, type “cmd”, right click cmd, Run as Administrator)
    4. Type in: cd _____PATH TO ANDROID SDK FOLDER______\tools
      Example: cd C:\Users\USERNAME\Desktop\android-sdk-windows\tools
    5. Type in: adb shell
    6. Type in: su
    7. Type in: cp /dbdata/databases/ /sdcard/settings.db
    8. Type in: cp /dbdata/databases/ /sdcard/settings.db.backup
    9. Type in: exit
    10. Type in: exit
    11. Type in: adb pull /sdcard/settings.db %userprofile%\desktop
      Leave Command Prompt open
    12. Open SQLite Manager in Firefox by pressing Tools >> SQLite Manager
    13. Click “Database”
    14. Then click “Connect Database”
    15. Navigate to “settings.db” on your Desktop
    16. Expand the tables
    17. Click “Secure” on the panel
    18. Scroll down to ID 6, “install_non_market_apps”
    19. Double click it and change “value” from 0 to 1.
    20. Close SQLite Manager
    21. Go back to the command prompt window, type in: adb push %userprofile%\desktop\settings.db /sdcard
    22. Type in: adb shell
    23. Type in: su
    24. Type in: cp /sdcard/settings.db /dbdata/databases/
    25. Type in: chmod 777 /dbdata/databases/
    26. Type in: reboot
    27. Disconnect your Captivate from your computer while your phone reboots.

    Remove AT&T Bloatware Apps

    Must have root and BusyBox installed before performing this process!

    1. Open up Android Market and search/download “Titanium Backup”
    2. Make sure your phone is not “Mounted” with USB
    3. Press the Backup/Restore button
    4. Click on each app and press un-install if you’d like to get rid of it. Do not delete apps off of this list, unless you know it is safe! This deletes these potentially forever… so be sure about things!
      • AT&T Navigator
      • AT&T Radio
      • AT&T Maps
      • AT&T Music
      • AT&T Mobile Hotspots
      • Mobile Banking
      • Mobile Video
      • Where
      • YPmobile
      • AT&T FamilyMap
      • Mini Diary
      • MobiTV
      • Write and Go

    Remove AT&T Market Restrictions

    Market restrictions? What? You mean AT&T really censors what apps I can and cannot see on my Samsung Captivate? Yes they do. But, no problem. Android developer Andrea Baccega has developed an app called "Market Enabler" to remove the censorship by emulating the T-Mobile market on the Samsung Captivate as well as other devices. Instructions below if you've already got root access:

    1. Download “Market Access” and install the latest version of the APK file on your Captivate.

      • Don't know how to install .apk files? Copy the file to your phone and then install "Apps Installer" or "Astro File Manager" from the market. It's easy! Just double click the .apk when you find it!
    2. Close the Market down fully. If you were running the Market previously, reset the phone so it is not a running task. Or use a task killer and end the Market app.
    3. Open up the Market Access application and go to "Backup value" in case you need to get back to the AT&T market
    4. Then click "Providers" and find: "T-Mobile [US]"
    5. Click and hold that option until it says "Emulate "T-Mobile" SIM?" -- click "Yes" there
      1. You may have to Allow Market Access in Superuser Permissions
    6. Click back to "Settings" click the checkbox next to "Emulate on boot"
    7. All done. Now your Market is uncensored.

    Remove AT&T and/or Samsung Logos on the Device

    Not quite yet! Check back later. We are working with some chemistry-experts to see if we can dissolve those logos. Have you seen how sexy the Captivate is without logos? Click here to check out the video.


    Big thanks to the XDA-Developers forum users for all their hard work on posting Captivate guides. User: nbs11 – bloatware removal. User: clubtech – market censorship removal application. User: blackjackboy – original root guide. User: kirbo20 – app sideloading.

    wisin15, geeve420, loupape and 12 others like this.
  2. trant01

    trant01 Active Member

    This needs to be a sticky!
  3. optendo

    optendo Member

    I am getting an error on you're market enabler. "There is a problem parsing the package".
  4. phlunkie

    phlunkie New Member

  5. jadashouse

    jadashouse New Member

    thanks worked with no problems
  6. optendo

    optendo Member

  7. Wreckoncile

    Wreckoncile Well-Known Member

  8. kpenning

    kpenning Well-Known Member

    EDIT: Now you use Market Access instead. View original post...
  9. Benclayton

    Benclayton Active Member

    What can I do if I enabled the T-Mobile store before backing up the AT&T version in MobileEnabler? Is there a setting I can use to revert back?
  10. kpenning

    kpenning Well-Known Member

    The market will revert back if you reboot the phone. Writing up a more permanent "emulate T-Mobile US on boot" guide.
  11. kpenning

    kpenning Well-Known Member

    Market restrictions updated to allow for "emulate on boot" option. Good luck all!
  12. choji

    choji New Member

  13. looksbetterinred

    looksbetterinred Well-Known Member

    I have followed the steps but have been beating my brains out for the past 2 days. I have a file in my phone root named settings.db. I have been back and forth with the steps and I am totally lost now. I'm not sure what to do next. When I try either:
    # Type in: cp /dbdata/databases/ /sdcard/settings.db OR
    # Type in: cp /dbdata/databases/ /sdcard/settings.db.backup

    I get "no such file or directory". AHHHHHHHHHHHHHHHHHHHHHHHHH
  14. ScaGin

    ScaGin Well-Known Member

    You can delete or freeze these with Titanium Backup.
  15. looksbetterinred

    looksbetterinred Well-Known Member

    I have Titanium loaded but I don't know what you mean by "freeze" and what that will do for me? I don't have a backup copied or the file on my desktop.
  16. Chromag

    Chromag Well-Known Member

    I never realized Titanium allowed me to uninstall applications! Thanks! Bloatware is now gone without having to shell into my phone and remove it manually.
  17. looksbetterinred

    looksbetterinred Well-Known Member

    Well I finally muddled my way through it. Works great!!! Thanks!!!!!
  18. vapor311

    vapor311 Well-Known Member

    worked nicely, could you tell me some apps i wouldnt have seen if i hadnt have done this? First thing I did notice is the ATT tab is now gone from my standard market tab! Fug em :D
  19. loupape

    loupape New Member

    Hi, I love my rooted captivate! I'm wondering if there will be concerns or If I will have to manually upgrade my OS when Froyo is release for it next month?
    Thanks in advance...
  20. darkendandroid23

    darkendandroid23 Well-Known Member

    I did it and i got the supervisor to load up but for some reason it when i load up that app it never loads has a blank screen.
  21. darkendandroid23

    darkendandroid23 Well-Known Member

    Ok also i do also see the at and t app thing too, i did from the system itself not the sd card.
  22. darkendandroid23

    darkendandroid23 Well-Known Member

    Wow no help here at all huh.
  23. iTylerA

    iTylerA New Member

    I followed the "Enable App Sideloading" from this thread and used i on my Motorola Backflip. The value is chaged to 1, but I still can't install non market apps.

    Someone brought up in the file, but idk what that is or what it does...
  24. ZombieEinstein

    ZombieEinstein New Member

    So I ran into trouble when I type "su", if I don't copy and paste the next line in fast enough, I get permission denied (yes I rooted the phone, and yes I have Busybox installed), and if I do get the next line in in-time, I run into similar issues with the next line, and it always end, no matter how fast I get input, with:
    "permission denied
    $ cp: not found
    $ cp: not found"

    I tried going ahead with it, did the two exit lines:
    "$cp: exit

    I then copied and pasted this line, as is, into cmd:
    adb pull /sdcard/settings.db %userprofile%\desktop

    but when I went onto the next steps, I realized that I do not have "settings.db" on my desktop.

    anyone know what's wrong?

    when I do plug in "adb pull /sdcard/settings.db %userprofile%\desktop" , I get something that looks somewhat akin to what you get when you type "help" in cmd, only for Android.
  25. smpl_sid

    smpl_sid Member

    Well, if anyone could help it's everyone in this forum. I'm ready to root and uninstall all this bloatware from my Captivate. But when I connect the usb to my computer and phone, they both recognize it, ( some of the time), and when I go to my notifications and click on "usb connected" nothing happens. The menu just hides itself like if you swipe your finger to get it out of the way. It doesn't "mount". What can I do?

Share This Page