How to revert back to an earlier version of HBOOT


  1. adrynalyne

    adrynalyne Well-Known Member

    This mostly applies to folks who have flashed the leaked ota and want to go back to legit stock. There is generally a problem with that, because we cannot use the RUU due to the upgraded Hboot (no radio has nothing to do with it).

    Through my travels, I found a way to do it.

    This is not without its risks, and I take no responsibility for any broken phones, knocked up cats, or homeless hamsters caused from the havoc it may wreak.

    It did work for me, quite well. I was able to flash to an old RUU without issue like nothing ever happened.

    First, the link I used, and then the english version.

    [HOW-TO] Downgrade HBOOT - HTCPedia.com forums

    Need the RUU?
    http://www.mediafire.com/?ld1gm3bbddcbwdw

    Now, my instructions, which will hopefully simplify it. I take no credit for this by the way, credit is due to the original thread.

    1. Download and unzip the files I have attached to this thread and put them somewhere that you can push them with adb.
    2. You must used Unrevoked's latest tool to install clockwork.
    3. Boot into clockwork recovery, go to partitions, and mount data.
    4. Type this code:

    Code (Text):

    adb push flash_image /data
    adb push mtd0.img /data
    adb shell
    chmod 777 /data/flash_image
    cd /data
    flash_image misc mtd0.img
    exit
    adb reboot oem-78
     
    Watch for your phone to reboot to a silver HTC logo.

    Then type:
    Code (Text):

    fastboot devices
     
    Verify your device shows up/responds/etc.

    Start the RUU. It will complain that battery life is too low to continue. Hit Exit, and it will reboot your phone. Run the RUU again. It should successfully flash your phone, downgrading you successfully.


    Having troubles with the RUU giving connection errors? Do this.

    Go to start, and in the search/run box, type

    %temp%

    Delete all that you can. Make sure the RUU is not running in the background.

    Now run the RUU again. Once it starts to the first screen, it has extracted the files to the temp directory. You can then copy them to a safe place. It will be a long winded numbered folder, with a similar subfolder.

    Once you have copied it to a safe place, you can then copy adb.exe, fastboot.exe, and adbwinapi.dll from the latest SDK into it, overwriting the older copies. Then start the RUU by executing ARUWizard.exe. This fixed the problem for me.

    You can also rename the rom.zip contained within the extracted files to PB31IMG.zip and put it on your sd card. Booting to HBOOT will scan it and offer to install.





    Good luck!

    Attached Files:


    Advertisement
    :
    Casbah, DeeBG, mahkee and 22 others like this.
  2. contagous

    contagous Well-Known Member



    So this is easiest way to go back to RUU, so can apply update and re-root?
  3. yojoe600

    yojoe600 Well-Known Member

    good to know thanks you have always been awesome
  4. adrynalyne

    adrynalyne Well-Known Member

    Well if you haven't applied update yet, you can simply use an RUU without going through this nonsense.
  5. rmk

    rmk Well-Known Member Developer

    Awesome. Has anyone tried this and confirmed it works?
  6. borgey401

    borgey401 Member

    or you can just wait it out since it's most likely the real version of it
  7. SoCalMiles

    SoCalMiles Well-Known Member

    confirmed...works...Thanks!
    adrynalyne and The_Law2 like this.
  8. adrynalyne

    adrynalyne Well-Known Member

    What if you need warranty work and cannot remove root?


    Thats part of the reason I posted it.
  9. borgey401

    borgey401 Member

    lol forget it nevermind
  10. contagous

    contagous Well-Known Member

    Oh awesome this is way to get back even after the update is applied, nice work bro :)
  11. ganesha71

    ganesha71 New Member

    I've almost got this working. I had connection problems with the RUU so I copied the files like you said. That worked and I got the battery warning, hit exit and it reboots. I run ARUWizard again and I get the connection problem again?

    Any ideas?
  12. DiegoMejia

    DiegoMejia Well-Known Member

    Worked for me :), i didnt use the exe to revert back though. i used the PB31IMG.zip on the downgrade sticky
  13. adrynalyne

    adrynalyne Well-Known Member

    ganesha, you might be better off using the zip method Diego mentioned. The RUU program is downright finnicky.
  14. hbk5585

    hbk5585 Active Member

    Question, I mount data from clockwork recovery, do I then do adb there or do I restart the phone and then do adb? I can't get it either way, from clockwork, it does it but nothing happens & if I restart the phone, it denys me access to flash image...what am I doing wrong?

    NM, whatever I did worked...it let me restore using PB31IMG.zip...that's interesting since it didn't follow exactly what you wrote lol
  15. adrynalyne

    adrynalyne Well-Known Member

    Actually, running it from clockwork did the trick for ya. It doesn't tell you its doing anything, just does it :D

    Please note there are a few ways to do this and my way may not be the best. Good to know the zip method works, because before a couple of you posted about it, I had no idea it would work.
    hbk5585 likes this.
  16. OurWorldsGreatest

    OurWorldsGreatest New Member

    Sorry if this is a dumb question, but what exactly is this "RUU" and where can I get it? I do have the PB31IMG.zip file but I'm not sure how I would implement it after running the commands you posted.
  17. adrynalyne

    adrynalyne Well-Known Member

    Put it on your sdcard and boot into the HBOOT.
  18. Mezmryz03

    Mezmryz03 Well-Known Member

    Just spent about 20 minutes with adrynalyne trying to fix my screw up and he got me working again with this method. Many thanks for that and if anyone has any questions on how to do it feel free to PM me and I'll be happy to pass on the good deeds.
  19. OurWorldsGreatest

    OurWorldsGreatest New Member

    I did. I was following this tutorial: YouTube - Droid Incredible Downgrade

    Basically when just getting into HBOOT it doesn't automatically read the zip like it does for the guy in this video.. and this is where I am stuck. Haven't really heard any suggestions from anyone on any of the forums on how to get past this.
    xmBill likes this.
  20. adrynalyne

    adrynalyne Well-Known Member

    If its not reading the zip its either:

    In fastboot mode or more likely, corrupt.
  21. OurWorldsGreatest

    OurWorldsGreatest New Member

    I figured out the problem. It was not reading the .zip because my SD card was in FAT format and I had to reformat to FAT32.

    Sorry for the redundant questions but since this method worked at unrooting my phone and bringing me back to stock, will this method of flashing the PB31IMG.zip folder also work to bring me back to stock after flashing the leaked OTA or would I have to use your method posted above?
  22. adrynalyne

    adrynalyne Well-Known Member

    This is a one time shot so if you need to revert again, you will need to follow this procedure again.
  23. joepip43

    joepip43 New Member

    Thanks to adrynalyne - you saved the day!
  24. Outatime

    Outatime Well-Known Member Contributor

    Ok this is weird. My SD card is formatted to FAT32. Everything goes like the video up to the point where it checks the zip file. Instead of saying "Do you want to update? Volume up Yes" it is saying "Main Version is older! Update Fail! Do you want to reboot?"

    Any ideas where this is going wrong?
  25. wcx86

    wcx86 Well-Known Member

    I plugged the phone in and enabled debugging but it's still not reading the device. Any suggestions?
Loading...

Share This Page