[How To] Root 2.3.4/downgrade and Get S-off


Thread Status:
Not open for further replies.
  1. Baloobear86

    Baloobear86 Member

    I just got a incredible 2 it has 2.3.4 im so lost i wanna root it but all the roots i found are for 2.3 or 2.2 im hella confused and don't really know what im doing i read every thing i don't understand. is there a cool video that shows how to root 2.3.4 successfully? Thanks!
  2. Rooter28

    Rooter28 Member

    If you have a dinc 2 head over to alpharevx's revolutionary tool and enjoy one click root. This is for the original incredible.
    scotty85 likes this.
  3. Baloobear86

    Baloobear86 Member

    Its not a orginal Incredible its a Incredible 2 and how do I head over there?
    Thanks.
  4. scotty85

    scotty85 Guides Guide

    Revolutionary

    however...


    check your hboot version by entering hboot via power on/vol down from a powered off state. revolutionary only works with the .97 hboot,so if your inc 2 has the most current firmware with the .98 hboot,youll need to either purchase an expensive xtc clip,or youll need to downgrade to older firmware with the .97 hboot using as procedure similar to this.

    you can find the downgrade procedure here: [Tool] Downgrade VivoW with hboot 0.98
    iowabowtech likes this.
  5. Baloobear86

    Baloobear86 Member

    Cool let me check that out. Thanks.
  6. iploya

    iploya Well-Known Member

    Windows cannot complete the extraction.

    PB31IMG.zip is invalid
  7. Mr. Boom

    Mr. Boom Well-Known Member

    You aren't trying to unzip the file before you put it on the SD card, are you?

    Leave it zipped, and if windows has file extensions hidden, then the file should just be PB31IMG
    leave off the .zip, unless extensions are shown in your computer.
  8. iploya

    iploya Well-Known Member


    Oh, yes <embarrassed laugh>

    Thanks for the tip and quick reply.
  9. BrennanU

    BrennanU Member

    I am looking to root my DInc using the process in this thread. I am just curious, from anyone who has followed this procedure, has anyone ended up with a completely bricked phone?

    Thanks,
    Brennan
  10. Mr. Boom

    Mr. Boom Well-Known Member

    I was scared to even root my phone. For a long time! I got the bad update, and wanted to go back. I read the instructions several times. Downloaded all the necessary files, and it worked perfectly.

    As long as you follow the directions, you'll be fine!
  11. iploya

    iploya Well-Known Member


    Oh wait, here's why I attempted that. Step 1 is downloading all the files. Step 2 begins:

    2)root with unrevoked 3.22
    -open the recovery-clockwork-5.0.2.0-inc_PB31IMG download. extract it first if you need to. inside there is an image called "recovery-clockwork-5.0.2.0-inc". right click on this image,then click "copy". navigate to a directory you can easily find it,then right click in that directory,then "paste". alternatively,you can drag it from the extracted folder to a convienient spot(i personally like to drag files around,but its fine either way).

    So I was trying to extract it on my PC. Hmmm....
  12. scotty85

    scotty85 Guides Guide

    sorry if this caused confusion.

    unfortunately,for ANY file to be flashed in hboot on the incredible 1,it needs to be named EXACTLY "PB31IMG.zip",wether its a radio,a recovery,or a whole RUU.

    obviously keeping a bunch of PB31IMG files on your PC would be hard to keep track of whats what without any further description :eek: so we keep add description to the file name to be able to keep our downloads and files straight,and then change the name at the last second,before flashing on the phone.

    the part of the directions your quoting are simply telling you to take the recovery download(wich also has PB31IMG in its name,since it is an hboot flashable file) and extract it to get to the image inside. in this case extraction was needed because we wanted to put the image inside somewhere on the PC we could easily find it ,so we can point unrevoked 3.22 to it.

    if we had an s-off device,we could have renamed that file to "PB31IMG" and flashed it hboot,just as we flash the whole RUU for the downgrade.

    the dowgrade RUU does not get extracted,and gets renamed "PB31IMG" becasue we are flashing it in hboot.

    hope that helps clear it up some :)
    iowabowtech and iploya like this.
  13. Baloobear86

    Baloobear86 Member

    I cant even get my phone to hboot i power down and wait a few and then power up holding the volume down and power at the same time it just boots up normal sorry im ******ed 0_o
  14. sdrawkcab25

    sdrawkcab25 Guides Guide


    Pull the battery for a minute to power down or turn off fastboot in the settings.
    iowabowtech likes this.
  15. Baloobear86

    Baloobear86 Member

    Bummer it has .98 im screwed
  16. scotty85

    scotty85 Guides Guide

    No you're not... Just use the xda tool to downgrade :)
    iowabowtech likes this.
  17. iploya

    iploya Well-Known Member

    I get "Error Processing ROM Manager Script . . . please verify you have ROM Manager v 4.4.0.0 or higher...."

    This happens after I have finished performing these steps:
    "2)root with unrevoked 3.22
    . . . .
    extract the contents of the unrevoked 3.22 .zip. open the folder, right click on "reflash" and run as administrator if possible.
    -click on "file" in the corner of the relfash window
    -click custom recovery
    -navigate to,and select your "recovery-clockwork-5.0.2.0-inc" image and select it. at the bottom of your reflash app window, it should now say "recovery:custom" and "waiting for device"
    -plug in your phone,and assuming you installed the drivers correctly,unrevoked 3.22 will start. let it do its thing. it will reboot a couple of times."


    Since the error message mentioned "ROM Manager" I went and downloaded ROM Manager, to see if I somehow needed that installed on my phone. (I previously had purchased ROM Manager in the market for my previous Inc). I ran thru the above steps again, and still got the error message at the top of this post.

    Any ideas?
  18. scotty85

    scotty85 Guides Guide

    youre getting this error when running unrevoked 3.22? sounds like you have an issue with the clockwork image.

    -double check the md5 for the download of "recovery-clockwork-5.0.2.0-inc_PB31IMG" and make sure it matches the one listed,and double check the md5 of the image,and make sure it matches the one listed as well.
    -make sure you are selecting the image from inside that download for the optional recovery in 3.22,NOT the .zip file

    thats about all i can think of off the top of my head.

    if you have an amoled incredible,you can just run unrevoked without doing the steps to select a custom recovery image,and let it install an older version of clockwork. these steps are mainly for the slcd users that will see the old version as a black screen.

    do you have the superuser app in your drawer? if so,you can clear data and make sure its working. if you dont care about making a backup,you can just continue with the downgrade.
    iowabowtech likes this.
  19. iploya

    iploya Well-Known Member

    Yes - running Unrevoked 3.2.2.

    I unzipped and dragged the file "recovery-clockwork-5.0.2.0-inc" to my desktop from the unzipped folder. That is the file I am pointing to when I select File - Custom Recovery - [recovery-clockwork-5.0.2.0-inc]. Then I plug in the phone (error bugging on, charge only mode) and start Unrevoked 3.2.2. The phone goes through one or more reboots before returning the error.


    I have the LCD version (I'm almost certain - it was a recent refurb from Asurion, and Asurion applies different serial nums so the usual method of looking for the "3" digit doesn't apply).

    When I go into SuperUser, all the options are greyed out - there is nothing to select from.

    I don't know how to verify MD5, but I just downloaded all of the files from the links in the original post within the last 24 hours. [EDIT: just found the link to the summer]

    EDIT: Oh, and the first time I tried running 322 I did *not* select the custom ROM, and it DID return a black screen. So I rebooted the phone and tried it again when I figured out that I was supposed to point to the custom ROM.
  20. BrennanU

    BrennanU Member

    Hey, I just wanted to report another successful root & ROM. Thanks to all who worked to perfect this method.

    Brennan
    scotty85 likes this.
  21. iploya

    iploya Well-Known Member

    EDIT: Or maybe it DID work and I am rooted? I downloaded Open Garden WiFi Tether and it works....so is that confirmation of root? So weird...

    And now after trying out WiFi, I went back to SuperUser and there WAS data to be cleared and the buttons worked...so maybe I hadn't accumulated any "data" yet, so all the options were grayed out...

    G'bye, I'm going out to play.
    scotty85 likes this.
  22. scotty85

    scotty85 Guides Guide

    awsome. glad you got it working. after reading your response i have a theory. maybe when you ran it the second time,it realized that you were allready rooted,and just tried to install the recovcery,tho i still have no idea why it needed or even referenced rom manager. maybe when using it as a "recovery only" tool since you were allready rooted,it goes about the task of installing the recovery differently? :confused:

    did you procede with the downgrade? running root apps definately means youre rooted :D download titanium backup and back up your apps so when you get to flsahing a new rom its easier to set up. :cool:
    iowabowtech and iploya like this.
  23. iploya

    iploya Well-Known Member

    Thanks very much -I appreciate you taking the time to read my posts and offer your input.

    I'd be content with just G'bread and the ability to tether, but I think I will still take the next step and downgrade to F'yo because it seemed like the G'bread update screwed up the voice search tool while driving (I've made related posts). Hopefully going back to 2.2 will restore my voice search.
  24. scotty85

    scotty85 Guides Guide

    the 2.3.4 update did alot of things to peoples perfectly working phones. it made my friends phone pretty much unusable because of the constant "low memory" warnings,and then her texts stopped working. vzw told her these were "among the known issues" of the 2.3.4 update and sent her in incredible 2. shed had a bad experience with rooting prior and wouldnt let me fix it for her,lol.

    its too bad,as pure,unmolested GB is good. its smarter,got better power management. its when you lug it down with sense that things get complicated ;)

    if youre a sense fan,try some of the custom roms based on the update. no doubt developers have tweeked them to run much metter than the stock OTA.

    if youre not so attached to sense,try OMGB for a completely vanilla AOSP experience,and then try cm7 for AOSP with some really clever and invaluable tweeks :)
    iowabowtech likes this.
  25. DaddyJax44

    DaddyJax44 Member

    long time follower, first time trying to downgrade. was able to get root yesterday from OTA 2.3.4, but am stuck during the mini-adb process. all the way to just before downgrading and i get:

    cd /data/local
    # ./flash_image misc /sdcard/mtd0.img
    ./flash_image misc /sdcard/mtd0.img
    ./flash_image: permission denied
    #

    help please ... thanks!
Loading...
Thread Status:
Not open for further replies.

Share This Page