1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

[How To] Root 2.3.4/downgrade and Get S-off


Thread Status:
Not open for further replies.
  1. scotty85

    scotty85 Guides Guide

    Make sure your sd card is not mounted to the pc. i.e.,phone is in charge mode :)
    iowabowtech likes this.
  2. DaddyJax44

    DaddyJax44 Member

    thanks ... phone is in 'charge only' mode
  3. scotty85

    scotty85 Guides Guide

    Usually you get that message when the sd card is not accessible. Is the sd card mounted to the phone?

    Did your Md5 sums match? Did the outputs to the other commands match mine in the code box on the first post?

    If you can copy your session and paste it into a code box it may tell us something.
    iowabowtech likes this.
  4. DaddyJax44

    DaddyJax44 Member

    Microsoft Windows [Version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation. All rights reserved.

    C:\Users\?????????????>cd c:\mini-adb_inc

    c:\mini-adb_inc>adb devices
    * daemon not running. starting it now *
    * daemon started successfully *
    List of devices attached
    HT045HJ01112 device


    c:\mini-adb_inc>md5sums mtd0.img

    MD5sums 1.2 freeware for Win9x/ME/NT/2000/XP+
    Copyright (C) 2001-2005 Jem Berkes - PC-Tools.Net: Tools and utilities for Windows, Unix/Linux, DOS
    Type md5sums -h for help

    [Path] / filename MD5 sum
    -------------------------------------------------------------------------------
    [c:\mini-adb_inc\]
    mtd0.img 34307be744275f1db1dd16af04c37839

    c:\mini-adb_inc>md5sums flash_image

    MD5sums 1.2 freeware for Win9x/ME/NT/2000/XP+
    Copyright (C) 2001-2005 Jem Berkes - PC-Tools.Net: Tools and utilities for Windows, Unix/Linux, DOS
    Type md5sums -h for help

    [Path] / filename MD5 sum
    -------------------------------------------------------------------------------
    [c:\mini-adb_inc\]
    flash_image 0098a7dd6600b55fac34fc6645be5d7a

    c:\mini-adb_inc>adb push flash_image /data/local/
    1726 KB/s (76044 bytes in 0.043s)

    c:\mini-adb_inc>adb push mtd0.img /sdcard/
    2570 KB/s (655360 bytes in 0.249s)

    c:\mini-adb_inc>adb shell
    $ su
    su
    Permission denied
    $ su
    su
    # cd /data/local
    cd /data/local
    # ./flash_image misc /sdcard/mtd0.img
    ./flash_image misc /sdcard/mtd0.img
    ./flash_image: permission denied
    # ./flash_image misc /sdcard/mtd0.img
    ./flash_image misc /sdcard/mtd0.img
    ./flash_image: permission denied
    #
  5. DaddyJax44

    DaddyJax44 Member

    > SD card is mounted to the phone
    > The Md5's did match
    > As per above post the other outputs did match your OP, only hickup was phone was not 'awake' for 1st su so I was not able to 'accept', but when I 'woke up' the phone I was able to 'accept'

    Any clues ... thanks!

    ps: I even took the phone and connected it to the PC as 'disk drive', then back to 'charge only', but still same result
  6. scotty85

    scotty85 Guides Guide

    unless there is more that you havent pasted,looks like youve forgotten the following commands:

    cd /data/local
    chmod 0755 /data/local/flash_image


    this is what makes it possible to write the new misc image.

    after pushing the flash_image and mtd0.img,you need to enter that,prior to
    cd /data/local
    ./flash_image misc /sdcard/mtd0.img


    check the steps and the code box in the first post again,hopefully that gets it working for ya :)

    Code (Text):
    Microsoft Windows [Version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

    C:\Users\Scott>[COLOR="Red"]cd c:\mini-adb_inc[/COLOR]

    c:\mini-adb_inc>[COLOR="red"]adb devices[/COLOR]
    List of devices attached
    HT07DHJ02777    device


    c:\mini-adb_inc>[COLOR="red"]md5sums mtd0.img[/COLOR]

    MD5sums 1.2 freeware for Win9x/ME/NT/2000/XP+
    Copyright (C) 2001-2005 Jem Berkes - http://www.pc-tools.net/
    Type md5sums -h for help

    [Path] / filename                              MD5 sum
    -------------------------------------------------------------------------------
    [c:\mini-adb_inc\]
    mtd0.img                                       34307be744275f1db1dd16af04c37839

    c:\mini-adb_inc>[COLOR="red"]md5sums flash_image[/COLOR]

    MD5sums 1.2 freeware for Win9x/ME/NT/2000/XP+
    Copyright (C) 2001-2005 Jem Berkes - http://www.pc-tools.net/
    Type md5sums -h for help

    [Path] / filename                              MD5 sum
    -------------------------------------------------------------------------------
    [c:\mini-adb_inc\]
    flash_image                                    0098a7dd6600b55fac34fc6645be5d7a

    c:\mini-adb_inc>[COLOR="red"]adb push flash_image /data/local/[/COLOR]
    1547 KB/s (76044 bytes in 0.048s)

    c:\mini-adb_inc>[COLOR="red"]adb push mtd0.img /sdcard/[/COLOR]
    1662 KB/s (655360 bytes in 0.385s)

    c:\mini-adb_inc>[COLOR="red"]adb shell[/COLOR]
    $ [COLOR="red"]su[/COLOR]
    su
    # [COLOR="red"]cd /data/local[/COLOR]
    cd /data/local
    # [COLOR="red"]chmod 0755 /data/local/flash_image[/COLOR] [COLOR="Blue"]<----[/COLOR]
    chmod 0755 /data/local/flash_image [COLOR="blue"]<----[/COLOR]
    # [COLOR="red"]cd /data/local[/COLOR]
    cd /data/local
    # [COLOR="red"]./flash_image misc /sdcard/mtd0.img[/COLOR]
    ./flash_image misc /sdcard/mtd0.img
    # [COLOR="red"]exit[/COLOR]
    exit
    $ [COLOR="red"]exit[/COLOR]
    exit

    c:\mini-adb_inc>[COLOR="red"]adb reboot bootloader[/COLOR]

    c:\mini-adb_inc>
    iowabowtech likes this.
  7. DaddyJax44

    DaddyJax44 Member

    thanks ... all that worked. phone now in a loop of rebooting from the HTS splash screen to the Droid Eye ... over and over ... ??? before i can run unrevoked 3.32

    edit: took the battery out, still in the loop of rebooting from HTS Quietly Brilliant screen to the Droid Eye ... ???

    edit 2: took out battery again, went back to hboot and reinstalled PB31IMG, and this time it worked ... now on to unrevoked 3.32 ... tomorrow, getting late tonight ... thanks !!!

    edit 3: OK ... it's officially 'tomorrow' by the clock, and i could not wait ... ran unrevoked 3.32 and am officially ROOTED !!! Thanks for the help !!!
    TheGrandpappy and scotty85 like this.
  8. Rooter28

    Rooter28 Member


    Awesome! Enjoy your phone again.
    scotty85 likes this.
  9. scotty85

    scotty85 Guides Guide

    glad you got it working :)
    iowabowtech likes this.
  10. McDastardly

    McDastardly Member

    Pretty sure the answer to this question is yes, but I just want to make sure :)

    If I follow these instructions half-ways, I'll have a rooted phone running 2.3.4 with s-on correct? I'm only looking to get root on my phone for now and might take the plunge to do custom ROMs later. Also if I only complete the first half, my phone won't be formatted in the process right?
  11. sdrawkcab25

    sdrawkcab25 Guides Guide

    correct on both counts.
    However you can still install custom roms with s-on if you wanted.
    iowabowtech and McDastardly like this.
  12. McDastardly

    McDastardly Member

    So forgive my newbie question, but is the only purpose of really turning the s-off to make the phone always rootable even after a OTA update? If I get an OTA update after running the instructions halfways, will it will break the root?
  13. sdrawkcab25

    sdrawkcab25 Guides Guide


    That is part of the reason to go s-off, but it also allows you to flash other radios and some root only apps work properly with s-off (some tether apps, ad-away/ ad-block, meta-morph, any root app that requires writing to the system partition while booted)
    iowabowtech likes this.
  14. McDastardly

    McDastardly Member

    Aww really? I was looking to use the ad-block program... maybe I'll have to follow through the whole guide. Thanks!
  15. sdrawkcab25

    sdrawkcab25 Guides Guide


    There is work arounds to get it to work without s-off, there is a thread on it around here somewhere.
    iowabowtech likes this.
  16. scotty85

    scotty85 Guides Guide

    i wouldnt worry so much about losing your data. thats the good thing about unrevoked 3.22 working. it gives you su access and a recovery,so you can backup apps and app data with titanium backup before the downgrade,and if youre happy with 2.3.4(some arent) you have the option to make a nandroid backup,so after the downgrade and re-root you can restore what you have.

    a nandroid is an exact photo,so to speak,of your current setup. when you restore it it will be like you never left :D

    id pretty highly reccomend to go ahead and downgrade and become s-off. in addition to what sdraw said,no security checks means you can flash ruus in either direction,older or newer. may give you some extra options if youre ever in a soft bricked,recovery situation :)
    iowabowtech likes this.
  17. McDastardly

    McDastardly Member

    Alright... Seeing how easy it is to make a backup I'll try and go for it. Would you recommend staying with Verizon's ROM or would you suggest another?

    As of this post I've rooted my phone and made a nandroid backup. :)
  18. noaster

    noaster New Member

    Hello, I am a new user here. Thanks in advance for the help.

    Unrevoked did not work for my droid incredible 2, so I tried the second set of instructions.

    When I get to the line "./flash_image misc /sdcard/mtd0.img" I get: "error scanning partitions"

    I am having trouble finding other resources that cite this problem, any help would be greatly appreciated.

    EDIT: is this not for the incredible 2? The error I got from unrevoked was vivwow not supported
  19. scotty85

    scotty85 Guides Guide

    Correct. This is for the incredible 1. There is some incredible 2 info a few posts back. You'll have to downgrade to .97 hboot then run revolutionary
    iowabowtech likes this.
  20. scotty85

    scotty85 Guides Guide

    That is completely a matter of preference. If you like vzw's rom,nothing wrong with staying with it.

    I personally am not fond of sense,so I run AOSP.usually cm7

    Best bet is t look at the rom threads,look at the screenshots,read the changelogs to see what's working and what's not.then skim the last few pages of the thread and see if folks are having any prollems with it.

    Pick out a few and try them each out for few days. Remember you're only a nandroid away from your favorite :)
    iowabowtech likes this.
  21. iploya

    iploya Well-Known Member

    I rooted, and am doing the downgrade steps. I placed the adb folder onto the root of C and I changed to mini-adb_inc direction okay....but I am getting errors.

    For example, typing adb shell <ENTER> I get error: device not found.

    I am also not sure if the push commands did the correct thing.

    Windows XP. I tried it in charge mode AND then in disk mode, neither works...
  22. iploya

    iploya Well-Known Member

    And the command adb devices just returns "List of devices attached" but no devices.
  23. iowabowtech

    iowabowtech root@android:/ # Moderator

    Sounds like you're lacking the USB driver. Have you checked device manager for device recognition?
    scotty85 likes this.
  24. scotty85

    scotty85 Guides Guide

    Make sure you have USB debugging checked on :)
    iowabowtech likes this.
  25. iploya

    iploya Well-Known Member

    This was probably it; I did Phase I on another computer and didn't consider that I needed to install the drivers on this one.
Loading...
Thread Status:
Not open for further replies.

Share This Page