[How To] Root 2.3.4/downgrade and Get S-off


Thread Status:
Not open for further replies.

Last Updated:

  1. iploya

    iploya Well-Known Member

    On step adb reboot bootloader this will boot your phone to "fastboot" select "bootloader" with the power button.

    The phone does its thing, considers P31IMG for a moment,

    then says Main version is older?
    Update Fail!
    Do you want to reboot device?


    ugh


    I give up for today...

    Advertisement
  2. McDastardly

    McDastardly Member

    Only took an hour for me to complete the second half of the walk through and it worked like a charm. I'm back running 2.3.4 VZW with s-off :). Thanks for the great guide and for convincing me to do it! Now to play with all the different choices...
    scotty85 likes this.
  3. scotty85

    scotty85 Guides Guide

    sorry youre having trouble with it. :( "main version older" is what you will typically get when you try and flash an older RUU with an s-on hboot. this indicates that there was fault with some of the steps prior,and the misc image dint get re-written.

    when youre up for it again,just go slow,make sure you get every command,and you can double check each comand with my session at the bottom of the first post to make sure they are all getting the correct output.

    you can copy the text in the command box by right clicking,then click "mark". higlight everything and then hit the enter key. on a post, click the # up top to get the code tags,then right click and paste the ouput.

    seeing what your commands and responses will help us find out how it went wrong :)
    iowabowtech likes this.
  4. iowabowtech

    iowabowtech root@android:/ #

    Yep, that's exactly the situation iploya. You're doing the old bait and switch with the misc.img to avoid the "older version" fail. If you're still getting that error, the misc flash didn't take.
    scotty85 likes this.
  5. iploya

    iploya Well-Known Member

    Got it guys! I deleted the PB31.... file from the SD Card...ran Unrevoked....confirmed S-off.

    (did this back on my home computer - newer OS Windows7 instead of old XP...less finnicky)

    Thanks for sticking with me thru this process. Go pour yourselves some frosty beers.
    scotty85 and iowabowtech like this.
  6. Cloud Walker

    Cloud Walker New Member

    I just registered to give a big thanks to the creators and contributors of this thread. I tried Unrevoked 3.23 and 3.21 and other things and finally came here to discover something that worked.

    I would also like to give some tips: install the unrevoked drivers in all forms of connection from phone to PC. In other words, install them during the HBOOT USB PLUG step, and when you're connected with "charge only" and "USB debugging." Basically, install them whenever Windows prompts you to install drivers, even if in the middle of the Unrevoked3 rooting process.

    When I finally got through all of this, I bought Titanium Pro and froze all of the bloatware. Battery life has at least tripled. AT LEAST. I'm blown away. And to think, all I got into this for was to get rid of that damn annoying "DROID" startup sound. Now I have a new splash and a shorter boot time and the phone feels faster overall. It's like I have a whole new phone.

    Cheers!
    scotty85 likes this.
  7. scotty85

    scotty85 Guides Guide

    thanks for the comments and the tips :) indeed the hardest part of adb,unrevoked,or just about any program that needs to interface with your phone(or any device :eek:) is getting the drivers installed.

    i spent several fustrated hours trying to get adb to see my nook color one night. a few days later it just started working and im not really even sure why!

    glad it worked out and youre able to enjoy your phone again :cool:
    iowabowtech likes this.
  8. Mike W

    Mike W Active Member

    OK, guys, I REALLY want to do this but am having some troubles. I tried the first method and it didn't work. There's something funny about this PB31IMG file. I can't get Winzip to extract it. I found another program (Powerdesk) and I think that did extract it, but it didn't work. Is this one of those deals where you leave it as a zip file? I'm trying the zerg method tonight and running into the same issue. The file doesn't say "PB31IMG of 2.2", it's the same PB31IMG.zip file. Should I use that? Do I really rename it as PB31IMG with no ".zip" extension? Any help would be appreciated.
  9. FinalStorm

    FinalStorm Active Member


    No need to unzip. Just place it on the root directory of your SD card and make sure it is named PB31IMG.zip and reboot into hboot. It should automagicly start the downgrade process. Just let it do its thing. If it boot loops like mine did after the downgrade flash, it may just need to be reflashed. Make sure you nandroid.
  10. scotty85

    scotty85 Guides Guide

    as was said,do not extract.

    if youre using windows,it prolly needs to be "PB31IMG" as windows adds,and hides,the file extention. typing in the .zip on a windows machine usually results the the file not being found by the phone since it is named "PG05IMG.zip.zip" :eek:

    let us know if you have any other troubles :)
    iowabowtech likes this.
  11. nalynch

    nalynch Member

    I rooted my DINC with 2.3.4, slcd, and s-on the other day using this guide.

    I didn't run into any problems. I was rooted and I downloaded rom manager and hit the first option "Flash ClockworkMod recovery" and it was successful and it said current and last recovery: ClockworkMod 5.0.2.0

    Also, i left s-on and didn't downgrade...

    Now here's where my problem happened. I downloaded the full titanium backup app and I froze some bloatware. Nothing serious, just skype, footprints, friendstream etc. NExt thing I know, I don't have the taskbar up top. So I restart my phone. Now it's in boot loop, going from the HTC quietly brilliant screen to the droid screen. I pulled the battery several times (not for very long) and tried rebooting, but the same thing happens.

    What do I do?!??

    Any help is much appreciated!
  12. scotty85

    scotty85 Guides Guide

    Can you still get to recovery?

    If so,wipe and restore a backup(you did make one,right?)

    If you don't have a backup,wipe and flash a rom.
    iowabowtech and nalynch like this.
  13. nalynch

    nalynch Member

    Nope. never made a back up. Sucks to be stupid!!!! lol. Okay well I flashed a stockish gingerbread and restored all my apps. All is well now, as soon as I go make a backup.. Thanks for the help!
    scotty85 likes this.
  14. scotty85

    scotty85 Guides Guide

    glad you got back to a working phone :) lesson learned! always have a good backup :D
    iowabowtech likes this.
  15. Mike W

    Mike W Active Member

    Back at it and still no luck.
    I started over with the unrevoked method.
    "extract the contents of the unrevoked 3.22 .zip. open the folder, right click on "reflash" and run as administrator if possible."
    I get this "central directory not found" error with winzip, but as before I found another program to extract.
    "navigate to,and select your "recovery-clockwork-5.0.2.0-inc" image and select it. at the bottom of your reflash app window, it should now say "recovery:custom" and "waiting for device"
    As before, the file only says "recovery" so I used that.
    It rebooted a couple of times and left me with a red triangle with an exclamation point. Pulled the battery and rebooted. Found superuser, cleared data, but titanium and clockwork both say I don't have root.
    Tried zergrush, but when I get to the step of md5sums zergRush I get a different number than listed, so I didn't proceed.

    Any ideas?

    Edit: tried anyway, get "permission denied" when I get to running zergRush
  16. h4xb0x

    h4xb0x New Member

    +1 for awesomeness. :)
    I successfully downgraded from 2.3.4 to 2.2 and then rooted to get s-off.


    Thanks,
    H4xb0x.
    scotty85 likes this.
  17. rebajr

    rebajr Member

    EXTREME NEWBY HERE!!

    Have many questions:

    1. Where do we copy & paste "recovery-clockwork-5.0.2.0-inc" file? On the sd card or computer?

    2. Just under that you have "place your phone in charge mode...." and then a couple lines down you have "plug in your phone". When were we suppose to unplug it?

    3. What does "install the drivers as described on unrevokeds page above" actually mean? Am I going to unrevokeds page and installing unrevoked 3.22???

    Okay, that's enough to get me started, but this whole language stuff like "flash this" and "boot that". very confusing....

    Oh and yes, my md5's all match so I have downloaded the correct files. (at least I got that part right!!)

    Thanks for your help.
  18. Mike W

    Mike W Active Member

    Me again.
    Did I mention this is my first root?
    Not being able to leave it alone, I had to keep trying today. For some reason it started to work a little better for me. I now get beyond the black screen, triangle (!) screen to a clockwork mod screen. There is an error shown: error processing ROM manager script, Verify you have v4.4.0 or higher...
    When I get back to the phone, I see the superuser permissions, but when I load it I get "the application Superuser has stopped unexpectedly". I get that again when I try Titianium or clock work mod.
    Any suggestions?
    scotty85 likes this.
  19. sdrawkcab25

    sdrawkcab25 Well-Known Member


    Clear the data for the superuser app.
    iowabowtech and scotty85 like this.
  20. 6StringDave

    6StringDave Well-Known Member

    Thanks for your monumental effort to help in escaping this Gingerbread rabbit-hole!

    Is there any hope that I would be able to downgrade without the use of a PC? My problem is that, with the expiration of my one-year warrantee (and another still left on my contract), my phone stopped talking to PCs (yes, I have the default connection set for Disk Drive). Not just the one which I am typing on now, but all computers, even when running Linux. Apparently something went wrong with my phone connector - I have since felt lucky that I can still charge my phone, and I have been transferring files to my SD card by switching it into a multi-card reader. So I can install files from my SD card, but I cannot run processes through my USB cable.

    I really hope there's a way back without the USB, as I depend on my phone for a lot of things which it will not be able to do anymore considering what Gingerbread did to my battery life. Three hours from full charge to dead while idle is just absolutely horrible!
  21. rebajr

    rebajr Member

    Is anyone going to help me?

    I joined this forum b/c everyone seemed so helpful. I'm sorry I don't understand a lot of your language, but verizon totally screwed up my phone with that piece of crap gingerbread update. my only option is to root.

    Could someone please address my confusion in post #292?
  22. scotty85

    scotty85 Guides Guide

    you will only select "disk drive" to transfer files to your sd card. place your phone in cahrge only mode,install the drivers,and enable usb debugging. open a command window and change to mini-adb_inc as described in step 4. hopefully adb devices will return a serial number.

    if you cannot communicate with your phone at all via USB,there isnt a way that i know of at this time to do it without :(

    edit: if your phone talks to adb,then you can still do this. youll just have to move files to your sd via a card reader.
    iowabowtech and rebajr like this.
  23. scotty85

    scotty85 Guides Guide

    sorry,i must have been typing. ill add support as best i can,but you may need to do some research outside of this thread to get yourself some knowledge and background.

    hopefully my answers above helped. try not to be too fustrated.others here will try and help you as well,and you can look for replies from me either later in the eveing,or early in the morning as im not usually able to give detailed replys while im working.

    good luck :)
    iowabowtech and rebajr like this.
  24. rebajr

    rebajr Member

    thanks scotty. i'm just really frustrated with verizon. I have been researching for weeks (literally). I've read the comments to this thread, other posts, etc. I just don't get all that jargon you guys use.

    Gotta make some important phone calls this morning and then I will try it. (thot I better make the phone calls first in case I brick it!!) ;-)
  25. scotty85

    scotty85 Guides Guide

    for what its worth,you guys that are fustrated with GB can try calling vzw. if you throw enuff of a fit,they may send you an inc 2. a good friend had issues-"low memory" warnging constantly,and then her texts quit working. after spending an hour and a half on the phone with them,jumping thru their hoops doing factory resets and whatnot,they sent her an inc 2.
    iowabowtech likes this.
Thread Status:
Not open for further replies.

Share This Page