[How To] Root 2.3.4/downgrade and Get S-off


Thread Status:
Not open for further replies.
  1. Mike W

    Mike W Active Member

    Superuser permissions is in the app drawer. When I click it, I get "superuser permissions stopped unexpectedly, try again". If I go to settings>manage applications it doesn't show up.

    Wait! Got it! It was on "downloaded" tab instead of "all". Looks like a go for me! Thanks so much for all your help.
  2. rebajr

    rebajr Member

    okay, I don't know if I'm completely stuck or not.

    Installed drivers. (thanks for the leading me to the correct path.)

    On to unrevoked 3.22..... it is not a zip file. It is a exe file. So, per your instructions, I simply just said to "run as administrator". Finally able to click on "custom recovery" and then after a while it said "Done" on the computer and had quite a few choices on my phone. I let it sit the a while, but gave up, pulled the battery, unplugged the phone. I restarted my phone as usual and looked in my app drawer and I now have superuser. I went to clear data and there wasn't any.... is that right?
    I clicked on "superuser" in the app drawer and it just gave me a blank screen. Is that normal??

    Next question: how do I download rom manager? I can't go to the market to get it b/c of the "low on space" message I have. It doesn't think I have enough memory to do squat!!

    Thanks again. At least I haven't bricked it yet!!:eek:
  3. rebajr

    rebajr Member


    really? mine was in the "all" instead of the downloaded" tab..... interesting. wish I understood this stuff better.:cool:
  4. scotty85

    scotty85 Guides Guide

    sounds like you are well on your way :)
    iowabowtech likes this.
  5. scotty85

    scotty85 Guides Guide

    iowabowtech and rebajr like this.
  6. rebajr

    rebajr Member


    Ha Ha!! yep, you anticipated my next question correctly!! I will get those files and get to work.

    Thanks so much. Seriously. This is a very unselfish thing for you to take your time to help us. :)
    scotty85 likes this.
  7. scotty85

    scotty85 Guides Guide

    you are quite welcome :) glad to help.
    iowabowtech likes this.
  8. rebajr

    rebajr Member

    oh boy..... I was able to get ROM manager. For the first few times I tried to open it, it kept "force closing". (many of my apps do this since gb!) anyway, after a while, I was able to open it and selected Flash Recovery. It ran like it was doing it's thing, but at the end it gave me "An error occured while attempting to run privileged commands." I also scrolled down and clicked "Fix Permissions" and got the same error message..... UGH!!!

    Any suggestions?
  9. scotty85

    scotty85 Guides Guide

    did superuser ask if you wanted to give rom manaer permissions? try deleting data from the superuser app now that youve run rom manager.

    its not so important that you get rom manager to flash clockwork,you just want to see a window pop up and ask for permissions and then tell it yes. its important for superuser and root to be working to complete the downgrade steps :)
    iowabowtech likes this.
  10. rebajr

    rebajr Member

    no, superuser never asked for permissions.... do I need to re-do unrevoked 3.22? or am I just screwed? :mad: oh and there was only 8 kb of data in superuser.
  11. scotty85

    scotty85 Guides Guide

    did you try and clear data after running rom manager? this has worked for bout everyone so far. you shouldnt have to rerun unrevoked 3.22.
    iowabowtech likes this.
  12. rebajr

    rebajr Member

    Clear data from where? superuser or boot into Hboot and go through that "Clear data", "clear cache" jargon? but I'm pretty sure it's my data that's bogging this process. I can't download anything from the market or even from my phone when I'm on the internet with it. Very frustrating.
    Edit: no data in superuser app. and it is only a 24 kb app. is that right?

    Just a sidenote, (and I don't know if it matters) but my superuser permission app looks like some "kung-foo fighter" guy with a gun all in black. when I've researched this stuff before I saw superuser pics and they looked mostly green (like the android guy).
  13. scotty85

    scotty85 Guides Guide

    clear data in superuser(settings/applications/manage apps/superuser). make sure youve cleared data there after trying to run a root only app like rom manager. go ahead and clear it in rom manager as well.

    1)clear data in rom manager
    2)run rom manager. pay close attention for a pop up asking for superuser permissions.
    3)attempt to flash clockwork recovery
    4)if you didnt get a superuser pop up,erase daTa in superuser. do steps 1-3 again

    hopefully it starts working,and when you look in superuser youll see rom manager listed with a green +. if its there,but with a red -,tap the - to change it to a +. now try steps 2 and 3 again

    alternatively,you can download or sideload a "root checker" app that will tell you if root is working or not.

    and no,it doesnt matter that you have kung fu superuser :)
    iowabowtech likes this.
  14. scotty85

    scotty85 Guides Guide

    alternatively,you can go ahead and procede with step 4. after entering adb devices go ahead and enter adb shell this should change your prompt to a $ now type su. you should get the pop up on your phone asking for superuser permissions. make sure "always" is checked and tap "allow" if your prompt changes to a # then youre good to go. type exit then exit again to get back to the "mini-adb_inc>" prompt.

    continue on with the rest of the guide. just go slow,make sure you get all the commands in the correct order,and you can look at my session at the bottom of post 1 to see what the output of each should be.

    good luck :)
    iowabowtech likes this.
  15. rebajr

    rebajr Member

    I haven't done step 3 yet. Am I skipping over that?
  16. rebajr

    rebajr Member

    you would not believe how screwed up my phone is.... I can't even open superuser now. it force closes all the time. but yes, I did clear data from superuser but no change.

    but no, when running ROM manager it only gave me a prompt that said "ROM manager is not responsible for any damage to your phone, blah blah blah...." I clicked okay and the next prompt was just welcome to ROM manager 4.0. There was never a superuser permission prompt. I think verizon just needs to send me a new phone. This is ridiculous.:mad:

    just fyi, I went into hboot last night and I have clockwork recovery 2.5.0.5. I don'thave the 5.0.2.0. Could that be the problem?
  17. rebajr

    rebajr Member

    okay, I called verizon again today and demanded they fix this issue! They offered me a replacement phone of either the Inc 2, Droid X, Samsung Fascinate and a few others (those are the only ones that appeal to me.) Any advice on which one is the better one to go with? (preferably rootable so I don't run into this issue again!!)

    Thank you.
  18. scotty85

    scotty85 Guides Guide

    Inc 2,for sure. At least in my opinion... The Inc 2 is a really nice phone if you don't need 4g.
    iowabowtech likes this.
  19. Mike W

    Mike W Active Member

    Well, my joy at getting to "root" was short lived and now I'm struggling with the downgrade steps.

    Thing seem to go fine. I copy and paste each line and get the appropriate responses. When I boot the phone at the end, I get a white screen. Fastboot is highlighted in red and bootloader is highlighted in blue. I hit the top power button to select bootloader and I get a screen that says fastboot. I never get to

    a blue status bar as your phone finds the PB31IMG,unpacks it,checks it,then asks if youd like to update.

    This makes me think the problem is in this PB31IMG file stuff. I downloaded it as a zip file. I copy it to the root of the sd card then rename it, taking the .zip off the end. Is that correct or am I screwing up this part?

    The other odd thing is when I swiched the phone to disc drive to copy the file, I get two drives, like it's partitioned. To mimimize this problem, I got a different card and put the PB31 file on it like above.

    Sorry to be so thick about this. I'll keep trying as long as you don't mind helping me along.

    Mike
  20. scotty85

    scotty85 Guides Guide

    1) make sure SD card is FAT32
    2) make sure you didn't put PB31IMG on the internal memory(the second "SD card" that pops up)
    3)PB31IMG.zip has to be exactly named. Check it on your phone(it may be PB31IMG or it may be PB31IMG.zip.zip)
    iowabowtech likes this.
  21. Mike W

    Mike W Active Member

    It is fat32. I may have misunderstood you before. It says PB31IMG.zip now and I'll try that. Having gone through all the steps, can I just skip to the reboot step?
  22. scotty85

    scotty85 Guides Guide

    If you haven't rebooted,then yes,you can go right to flashing pb31img. If you have,I believe the misc img is back to stock. You can try it if you want. Worse case scenario is "main version higher" error when pb31img tries to run,in wich case you'll just have to reboot and run the adb commands again.

    Sorry for the short.answers,I'm at work on my phone :)
    iowabowtech likes this.
  23. Mike W

    Mike W Active Member

    I think it's working now. You may want to change this:

    place the PB31IMG of 2.2 on the root of your sd card. rename PB31IMG. now is a good time to verify that your SD card is formatted "FAT32"...

    To make it clear that it should be PB31IMG.zip on the SD card.

    Thanks again.
  24. scotty85

    scotty85 Guides Guide

    you are welcome. :)

    as has been explained previously in the thread,the reason it is like that is due to the fact the windows natuarally adds,and hides,the file extension. if i change it to say "rename PB31IMG.zip" then folks type in the ".zip" resulting in just as much confusion when the file isnt found becuase it is names "PB31IMG.zip.zip" :eek:

    im sorry you had some confusion and headache,but most of the time people are using windows and renaming "PB31IMG" with the hidden file extension is correct.

    at any rate im glad you got it working :)
    iowabowtech likes this.
  25. rebajr

    rebajr Member


    I was mistaken, it was the droid 2, not the inc 2. UGH! I really want my inc 1 to work.
Loading...
Thread Status:
Not open for further replies.

Share This Page