[How To] Root 2.3.4/downgrade and Get S-off


Thread Status:
Not open for further replies.
  1. scotty85

    scotty85 Guides Guide

    Go to settings/applications/manage application/superuser and clear data.

    Then try rom manager again. This time hopefully it will ask for permissions.
    iowabowtech likes this.
  2. rebajr

    rebajr Member

    Hey guys,

    I'm back. I haven't proceeded any farther b/c I've been battling it out with Verizon... with NO luck. Anyhoo----

    I was able to flash the new clockworkmod, did a batch backup with titanium. I extracted the mini-adb_inc file onto the computer..... was I suppose to extract it to the phone? I get VERY confused when you say to put stuff on the c: drive. I don't know which one you are referring to. Thanks.
  3. scotty85

    scotty85 Guides Guide

    mini adb_inc gets extracted and placed on the root of the C drive on your PC.
    iowabowtech likes this.
  4. rebajr

    rebajr Member

    yeah, that's where I put it. In the command prompt it said "cannot find path specified" (or something to that affect). geez, why am I not getting this! grrr....

    edit: okay, got it going. only stuck at adb shell. I get the $ and type su but I get "permission denied". Huh?
  5. scotty85

    scotty85 Guides Guide

    pay attention to your phone. when you type su,the phone will ask you for permissions,and if the screen is off,it may not light up so you can see it. try waking the phone up,then type su

    you have successfully run unrevoked 3.22, and gotten superuser working,correct?
    iowabowtech and rebajr like this.
  6. rebajr

    rebajr Member

    yep, the phone was black and didn't pop up. I turned it on and then typed su again. my bad!

    and yes to unrevoked 3.22.

    I'm getting there. Thanks for hanging in there with me.
  7. scotty85

    scotty85 Guides Guide

    no prollem :) sounds like you are almost there!
    iowabowtech likes this.
  8. rebajr

    rebajr Member

    Small snag.... back to froyo, but when I ran unrevoked3, I got an error msg 'communication with phone unexpectedly interrupted. Try again.' I tried it twice with same outcome. I did notice it was 'waiting for reboot...' and my phone sat on the HTC incredible screen. Any suggestions? I noticed when I started unrevoked it said make sure HTC sync is not installed.... I've never installed it, but isn't it already there? Or do I just need to disable sync in the settings menu? Thanks again. I'm almost there!
  9. scotty85

    scotty85 Guides Guide

    hmmm,not 100% sure on this one. make sure youre phone is in charge only mode when running unrevoked 3.32,and make sure you have usb debugging enabled.

    might try a different usb cable,and/or a different port on your PC.

    hopefully the guys have some idea what could be going on here with unrevoked 3.32.

    but youve got yourself back to froyo,wich was the tricky part :cool: congrats!
    iowabowtech likes this.
  10. rebajr

    rebajr Member

    Yeah, thanks. I got the hard part done but stuck on the easy part.... or at least the YouTube videos I watched about running 3.32 looked easy. Only small difference is on the older version I right clicked on unrevoked and 'ran as administrator'. Think that could be the difference?
  11. scotty85

    scotty85 Guides Guide

    could be... did you try it that way? did you extract it like you did the other,or are you just clicing on the download?
    iowabowtech likes this.
  12. rebajr

    rebajr Member

    No, didn't try it that way. Just remembered that was how I did the first one. I extracted it, opened it up, checked to make sure phone security was disabled, and then plugged in my phone. A pop up came on about running unrevoked etc, I clicked ok, it ran for a while, phone went into hboot, ran thru a couple things, then said waiting to reboot.... you know the rest.
  13. rebajr

    rebajr Member

    I've tried unrevoked 5 times, with NO success. Do I need to reinstall my drivers? You would think it would still be there! This is frustrating! Or perhaps I should just try z4 root?

    Edit: I reinstalled the drivers but that didn't work either! Doesn't anyone know how to get this rooted?
  14. RewindByChance

    RewindByChance Active Member

    I have successfully gained root access, however at the very end of the command prompt steps when I click the power button to select "bootloader" nothing really happens. A few green lines pop up really fast, and I think I caught a few of them saying "no image found" or something similar, but that's it. I have the PB31IMG.zip on my sd card and it is formatted as FAT32. Any suggestions?

    Edit: After reading a few replies, I assumed this would work for a phone that never had S-OFF. Maybe I'm wrong for assuming that? I have never rooted my phone before accepting the OTA.
  15. scotty85

    scotty85 Guides Guide

    i got a visitor message from someone that said he was hving trouble with unrevoked 3.32,and figured out it was becasue his phone was trying to update itself to 2.3.4 as he was running it.

    he said putting the phone in airplane mode did the trick to fix it,so you might try that :)

    otherwise,search the forum,maybe put up a new thread about this particular issue with unrevoked 3.32. its been the root standard for a long time,and the guys should be able to help you figure it out,your issue just isnt getting many views inside this thread :(

    no,you assumed correctly. this is intended for s-on,2.3.4 phones to root and downgrade back to "s-offable" firmware.

    again,there are only 2 reasons a PB31IMG is not found on the root of the sd card:
    1)not named correctly. the phone muse see "PB31IMG.zip". due to the way windows sutomatically adds and hides file extensions,it is usually correct to name the file "PB31IMG" with windows. common errors are for the file to be names "PB31IMG" or "PB31IMG.zip.zip". check your file with a file manager on your phone and see how its seeing it.

    2)sd card not formatted FAT32. if it is plain FAT or anything else,PB31IMG is invisible. on rare occasion,i have seen claims that a bad sd card,or card that needs reformatted(even tho it may be FAT32) will have the same affect.

    several folks have used the downgrade method successfully,no reason it wont work for you :) just need to figure out wich of the 2 things above is keeping PB31IMG from flashing.
    iowabowtech likes this.
  16. rebajr

    rebajr Member

    tried it Scotty..... same result. I will try to put up a new thread.... I've seached and searched with about a dozen various suggestions.... next attempt is to remove sd card and try it. other than that, I've found nothing that works. Keep your fingers crossed....
  17. scotty85

    scotty85 Guides Guide

    Hmm. If your SD card has an "update.zip" from an ota attempt,that could definitely be screwing with the hboot/fastboot part of unrevoked.

    Check your SD card and see an "update.zip" is there somewhere. If so,delete it and see what happens :)

    Edit: if this is the prollem,then removing the SD should work also.

    Keep us advised :)
    iowabowtech likes this.
  18. iowabowtech

    iowabowtech root@android:/ #

    Not sure if this was discussed already but make sure you don't have HTC Sync installed on your PC. A few other programs were also faulted back in the day but not sure if it was ever truly verified...PDAnet, Doubletwist, Dropbox (can just exit this program, not uninstall) to name a few, basically anything that may try to sync with your phone while connected. Also, try a different USB port and even a different cable if you happen to have another micro to USB patchcord laying around.


    As a last ditch effort, go to device manager, right click on every instance of USB hub > Properties > Power management > uncheck "allow the computer to turn off this device to save power".
    scotty85 likes this.
  19. Not sure if this has been convered or not, 8 pages is a lot to look through.

    I loaded the recovery just as the directions said, followed everything as close as i possibly could. Not I got the recovery loaded and working, but my phone gets stuck in a reboot loop when trying to actually boot it up. I can get into boot loader and recovery but thats it. I get the htc Incredible screen for a few seconds, goes black, then the htc screen comes back. Don't know how to fix it or where to go from here. Any advice would be greatly appreciated.

    Thanks in advance.

    Edit: I should probably add that I have done everything from pulling the battery to rebooting to trying to reflash the recovery but cannot get into the phone to do that.
  20. scotty85

    scotty85 Guides Guide

    Try wiping cache and dalvik cache and see if that stops the bootloop.

    If it doesn't,you should be able to perform the adb commands with the phone in recovery,then just downgrade.

    An alternative to getting a working phone back would be to do a full wipe then flash a rom.
    iowabowtech likes this.
  21. scotty85

    scotty85 Guides Guide


    Sdraw,just making sure I understand... the rom manager error isn't really of relevance correct? Unrevoked 3.22 still placed superuser,its binary,and installed a working clockwork?
    iowabowtech likes this.
  22. I wiped the cache and dalvik cache. Still in the boot loop. I will try the adb commands and see what happens and let you know.
  23. Ok so I am going through the adb commands and get to the adb push flash command and get the following:

    c:\mini-adb_inc>adb push flash_image /data/local/
    failed to copy 'flash_image' to '/data/local/': Is a directory

    Can't get any further than this. Kinda stuck here.

    For your worst case scenario wipe and flash rom, how would I go about doing that? Could I just try flashing the OTA 2.3.4 update? would that work?

    Sorry I am a semi-noob. Havent rooted since I had a G1 and really wanted to root my Inc.
  24. sdrawkcab25

    sdrawkcab25 Guides Guide

    correct, just got the error but everything worked fine.
    iowabowtech likes this.
  25. RewindByChance

    RewindByChance Active Member

    Ah, so my sd card is formatted as FAT, not FAT32. I thought there was no difference. Can I just copy the files on to my computer, reformat, then paste them back on? Or will that cause errors?

    Edit: Just went back to the first post and saw you already answered that very question. So once I reformat and get everything back on to to card, I'm guessing I can just do the last step you typed out for the command prompt?
Loading...
Thread Status:
Not open for further replies.

Share This Page