[How To] Root 2.3.4/downgrade and Get S-off


Thread Status:
Not open for further replies.
  1. scotty85

    scotty85 Guides Guide

    nope no errors,thats all you need to do.just copy all the files to the pc,reformat,copy them all back :)

    if you have rebooted the phone since entering the prior commands,youll prolly have to re-enter the adb commands again,as i believe the misc image is re-written back to stock during the reboot. if you want to try just entering the command,you can- in a best case it will work,in a worse case it will just result in a "main version higher" error and youll have to reboot and start over with the adb commands :)
    iowabowtech and RewindByChance like this.
  2. scotty85

    scotty85 Guides Guide

    did you get the correct outputs for the prior commands? in particular,did "adb devices" return your serial number?

    if you havent figured out how to flash a rom yet,you just need to place it on your sd card(you can toggle sd card storage in recovery),then wipe data/factory reset,wipe cache,wipe dalvik cache,then flash your zip from your sd card. i dont normally use clockwork,so the exact menus escape me,but im sure the guys can give some more specifics on exactly how to flash a rom.
    iowabowtech likes this.
  3. iowabowtech

    iowabowtech root@android:/ # Moderator


    Crackmonkey,
    Place the rom on the card (can be called anything). Then boot into recovery and then the clockwork options to use are:

    -Wipe data (factory reset)
    -Wipe cache partition
    -Install zip from SD card
    -Choose zip from SD card

    Now navigate to your rom (zip) and select it to load.

    ProTip:
    In Clockwork, use the trackpad button to select menu items. The phone's power button brings you backward one menu. Different from hboot where the power button is used to make selections and is confusing to first time users.
    RewindByChance and scotty85 like this.
  4. RewindByChance

    RewindByChance Active Member

    Thanks so much for your help! It seemed to be working, except after pressing reboot, my phone's screen turned black and isn't responding to anything anymore. Did I just brick it? :(
  5. sdrawkcab25

    sdrawkcab25 Guides Guide


    Doubtful... Pull the battery and put back in.
    iowabowtech likes this.
  6. iowabowtech

    iowabowtech root@android:/ # Moderator

    Can u get to hboot at least?
  7. scotty85

    scotty85 Guides Guide

    do you mean,you let the downgrade flash,then pressed power to reboot,then got the black screen?

    if thats what happend,give it a couple minutes. if nothing happens,pull the battery and try turning it on normally. hopefully it boots to froyo :)

    if it still doesnt boot,try doing the PB31IMG flash again. you did check the md5 of the PB31IMG downgrade,right?
    iowabowtech likes this.
  8. rebajr

    rebajr Member

    holy cow. i have removed just about everything that might interfere with this. still NOTHING! it just says waiting to reboot for a while and then gives me the communication unexpectedly interrupted. i only have this computer so changing computers isn't an option..... unless I can do this at the local library. but they probably have it protected against doing something like this!!
  9. RewindByChance

    RewindByChance Active Member

    Nothing at all, just a black screen.

    Yes, after flashing the downgrade, I pressed reboot. If I remember correctly, a red progress bar might have came up after that maybe, and then a black screen. I pulled the battery and tried to turn on my phone, it vibrated and then nothing happened. I pulled the battery again and now it seems like my phone is on and working, but I can't see anything on the screen. For example, the home, menu, etc. buttons light up, and when I press the volume up button, it makes the progressively louder sound as the volume increases (I should mention, it's the "old" volume up sound and not the newer one that came with 2.3.4).

    Edit: Also, yes, I did check the md5 of the PB31IMG downgrade.
  10. scotty85

    scotty85 Guides Guide

    almost sounds like you have flashed an old 2.1 rom on an slcd device.

    if you give it a few minutes after booting,push the phone part of the dialer,then push where the buttons would be and see if it makes noises like youre pushing buttons :eek:

    the important thing is did you wait untill the ruu had flashed before pulling the battery?

    did it finish and give you the "press power to reboot" message?

    and just to confirm,turn the phone off,then power/volume down takes you to a black screen?
    iowabowtech likes this.
  11. iowabowtech

    iowabowtech root@android:/ # Moderator

    This sounds like the slcd downgraded to 2.1 problem. You used the 2.2 file Scotty posted right?

    Edit: scotty ninja'd me.
  12. iowabowtech

    iowabowtech root@android:/ # Moderator

    We should really move to irc for this one. Soooo much easier to diagnose.

    irc.andirc.net

    /join #incredible

    Anyone?
  13. RewindByChance

    RewindByChance Active Member

    That's most likely the problem... As I now just recall I don't think I used the file Scotty posted because for some reason the download link kept timing out. I looked for the file elsewhere and must have forgot to check the md5 of the download, thinking I had checked it already.

    I tried pressing on the screen for the dialer, nothing happens. It seems as though the touch screen itself does not work.

    Pressing power and volume down seems to do nothing, unfortunately.

    I didn't see any message about pressing power to reboot. After around 45 minutes of just a black screen and multiple attempts to turn the phone on, I decided to pull the battery after reading to do so in the forums.

    Man, I really messed this up. Sorry for my ignorance, guys.
  14. iowabowtech

    iowabowtech root@android:/ # Moderator

    You got a USB card reader or a laptop with an SD slot? Anything to move files back and forth to your card? Sounds to me like you're in a position where you'll have to blind flash the 2.2 PB31IMG or you could try running the 2.2 RUU.

    Froyo RUU can be found here:
    http://pvillecomp.com/?page_id=22

    Download to PC, then launch. Plug phone into USB port and follow the instructs. Unless anybody else has other recommendations. I'm thinking this may be the easist route.
    scotty85 likes this.
  15. RewindByChance

    RewindByChance Active Member

    My laptop has a 4 in 1 reader. I can try to find an adapter for the micro SD card I suppose?
  16. iowabowtech

    iowabowtech root@android:/ # Moderator

    Keep that possibility open. Instead, I'd try the RUU I linked above first. Then you can see what you're doing since it's a Windows program that accesses your phone.
    scotty85 likes this.
  17. RewindByChance

    RewindByChance Active Member

    Great, thank you so much. I'll edit my post with results.
  18. scotty85

    scotty85 Guides Guide

    i agree completely. the RUU is definately the easiet way to do it.

    if you try and blind flash a PB31IMG,youll basically have to:
    -boot to hboot. wait a few minutes
    -push volume up to update,after waiting long enuff for the phone to have found,and checked the file.
    -wait several more minutes.
    -push power to reboot,after waiting long enuff for the PB31IMG to flash all partitions.

    trust me,it will be very nervracking to wait and not know whats going on.

    one small bit of advice:
    if the ruu "waits for bootloader" for a long time,then give you a comunication error,just run the RUU again. ive had that happen several times,and it always works the 2nd time. the device will still be in RUU mode(tho you wont be able to see it on your black screen :eek:)
    iowabowtech likes this.
  19. scotty85

    scotty85 Guides Guide

    wish i could be of more help,but i have no idea. :(

    what happened when you tried it with no sd card? same thing?

    a couple other thots:
    -it wouldnt hurt to try z4root.
    -it also wouldnt hurt to try unrevoked 3.22,since it worked for you on GB(right?). it may not give you s-off right away,but if it at least installs clockwork,your in :D forever patch can easily be flashed in recovery.
    iowabowtech and rebajr like this.
  20. RewindByChance

    RewindByChance Active Member

    Using the Froyo download, the program can't locate my Droid, but after using the Gingerbread version it asks me to update. Is this right?
  21. iowabowtech

    iowabowtech root@android:/ # Moderator

    Not sure I understand the question but I wouldn't update to GB again unless it were a last resort. Then you're back to square one again. Try a battery pull, then press the power button only. We don't want hboot here, just like you're turning on the phone normally.

    Possible caveat...can't remember of USB debugging is necessary for this. Was is selected by default in 2.2 b/c I'm pretty sure it is in 2.3.4. That COULD be what's going on here, not sure. Anyway, report back after the reboot effort and retry the 2.2 RUU.
  22. scotty85

    scotty85 Guides Guide

    not really sure why GB would work and froyo wouldnt. you can use the GB ruu,but youll be back to square 1 with gingerbread. but at least you should have a working phone again.

    might try starting the RUU with the phone in fastboot. if its booted into the OS currently, go to your command window and type "adb devices" and see if you get a serial number. if you do,then "adb reboot bootloader" wait a couple minutes,then close the command window,and then start the froyo ruu.
    iowabowtech likes this.
  23. RewindByChance

    RewindByChance Active Member

    Still a connection error, I guess debugging isn't turned on... Should I resort to going back to gingerbread?
  24. iowabowtech

    iowabowtech root@android:/ # Moderator

    Up to you. Personally, I'd blind flash before going back to GB although you do know the routine now. But if it were possible, I'd ditch the current 2.1 PB31IMG off the card, and replace it with the 2.2 PB31IMG (file needs to be named exactly the same as before), then use Scotty's blind flash info a few posts up and give that a go. Should take about a half hour total with a 20 minute wait time for the file to load to be on the safe side. Either way, you're going to come out of this just fine so the big thing is don't get antsy. You will prevail.
    RewindByChance likes this.
  25. iowabowtech

    iowabowtech root@android:/ # Moderator

    Come to think of it, I wonder if you have the phone recognition driver on your pc? I know you probably did the modified unrevoked driver for hboot but I'm not sure that alone would cut it. Might be able to cure this recognition problem by downloading HTC sync for the phone driver. Then run the ruu.
    scotty85 likes this.
Thread Status:
Not open for further replies.

Share This Page