[How To] Root 2.3.4/downgrade and Get S-off


Thread Status:
Not open for further replies.
  1. RewindByChance

    RewindByChance Active Member

    Sounds good, I'll update my PRL and wait a while. I'll post back here with results.
  2. pepuhz13

    pepuhz13 New Member

    after i do command /data/local/zergrush i get an error " [-] Cannot copy boomsh : No such file or directory" how can i fix this
  3. Josh2

    Josh2 Well-Known Member

    Mine says error: unable to read file/directory zergRush when attempting to downgrade to 2.2

    Any help would be much appreciated.
  4. scotty85

    scotty85 Guides Guide

    that error comes from running zergrush twice. reboot your phone,push and run zergrush again,then when you get the error,enter the following:
    rm /data/local/tmp/booms
    rm /data/local/tmp/sh
    then
    /data/local/zergRush


    it should look something like this(just pretend that miniadb_merge says mini-adb_inc :eek:):
    Code:
    c:\miniadb_merge>[COLOR="Red"]adb push zergRush /data/local/[/COLOR]
    735 KB/s (23052 bytes in 0.030s)
    
    c:\miniadb_merge>[COLOR="red"]adb shell[/COLOR]
    $ [COLOR="red"]chmod 755 /data/local/zergRush[/COLOR]
    chmod 755 /data/local/zergRush
    $ [COLOR="red"]/data/local/zergRush[/COLOR]
    /data/local/zergRush
    
    [**] Zerg rush - Android 2.2/2.3 local root
    [**] (C) 2011 Revolutionary. All rights reserved.
    
    [**] Parts of code from Gingerbreak, (C) 2010-2011 The Android Exploid Crew.
    
    [-] Cannot copy boomsh.: Permission denied
    $ [COLOR="red"]rm /data/local/tmp/booms[/COLOR]
    rm /data/local/tmp/booms
    rm failed for /data/local/tmp/booms, No such file or directory
    $ [COLOR="red"]rm /data/local/tmp/sh[/COLOR]
    rm /data/local/tmp/sh
    $ [COLOR="red"]/data/local/zergRush[/COLOR]
    /data/local/zergRush
    
    [**] Zerg rush - Android 2.2/2.3 local root
    [**] (C) 2011 Revolutionary. All rights reserved.
    
    [**] Parts of code from Gingerbreak, (C) 2010-2011 The Android Exploid Crew.
    
    [+] Found a Froyo ! 0x00015108
    [*] Scooting ...
    [*] Sending 149 zerglings ...
    [+] Zerglings found a way to enter ! 0x10
    [+] Overseer found a path ! 0x00015108
    [*] Sending 149 zerglings ...
    [+] Zerglings caused crash (good news): 0x401219e4 0x006c
    [*] Researching Metabolic Boost ...
    [+] Speedlings on the go ! 0xafd1598f 0xafd1adb3
    [*] Sending 149 zerglings ...
    
    [+] Rush did it ! It's a GG, man !
    [+] Killing ADB and restarting as root... enjoy!
    
    c:\miniadb_merge>adb shell
    # exit
    exit
    iowabowtech likes this.
  5. scotty85

    scotty85 Guides Guide

    im not sure what youre doing,or why youre seeing that message when downgrading. what guide are you following and what step are you on?
    iowabowtech likes this.
  6. RewindByChance

    RewindByChance Active Member

    Gingerbread has been running fine, and I'm rooted/S-OFF except I still can't send/receive any texts or calls. When I try to make a call it tells me to dial #8899. Should I just do that?
  7. timelord65

    timelord65 Well-Known Member

    Ok, I rooted 2.3.4 successfully. I'll do the whole downgrade/s off part next. However when I got root, I didn't tell the program to look for the new CWM you posted. Yet I didn't get any black screen. It rooted and installed CWM 2.5.0.5 (I have the lcd 003 version)

    Do I just flash the newest CWM now? I used the 2.5.0.5 to back up my stock 2.3.4. So it must be working. I thought we lcd owners needed to include the newest CWM? when rooting 2.3.4 with unrevoked 3.22?

    Thanks

    Edit: I have root, but I can't delete or rename apks with root explorer or root browser, both keep crashing and rebooting my phone????
  8. scotty85

    scotty85 Guides Guide

    odd... im not sure why you didnt get the black screen :eek:

    yes,just install the new clockwork with rom manager.

    try clearing data in superuser in settings/apps/manage apps/superuser.

    also you can open the superuser apps and make sure that root explorer/browser have permissions(a green +)

    i had trouble with root explorer on an early release rom on my TB one time,and simply reflashed superuser in recovery,so if all else fails try that. you can get the superuser file in iowas "regain root with s-off" thread.
    iowabowtech likes this.
  9. scotty85

    scotty85 Guides Guide

    i think i would try flashing a different rom,and see if the prollem still exists. youre s-off now,so you dont need to be real afraid of what you do. you should always be able to ruu back to stock and/or re-root in worse case scenarios.

    are you running the GB ruu? or a GB custom rom? if youre running a custom rom that no one else is having issue with,you might try #8899 and see what happens! :D
  10. hugoqzd123

    hugoqzd123 Member

    When I execute $ /data/local/zergRush, I get this:
    $ /data/local/zergRush
    /data/local/zergRush
    Σa: permission denied
    t╖z
  11. iowabowtech

    iowabowtech root@android:/ #

    You can. It's a customer service number I think. Anyway, I just directed you to the new OTA rom since I figured most people were moving to it. I'm actually still using the rom from the previous OTA and the only problem I have is using voice search while moving in a car (known bug on that build). If you're interested, it may be less glitchy for you and there's very little difference between the two I'd guess.

    [ROM] ◄ Stock Plus ► v3.01 11/22/2011 Based off of New OTA - xda-developers
    RewindByChance likes this.
  12. RewindByChance

    RewindByChance Active Member

    I'm running a custom ROM, this one to be specific.

    [Rom] Official Inc OTA 4.08.605.2 [Updated:23Nov2011] New build is Ready! - xda-developers

    It doesn't seem like anyone else is having this problem...
  13. RewindByChance

    RewindByChance Active Member

    Awesome, I'll try it. Thanks! And Happy Thanksgiving to everyone as well!

    Edit: Calls/texts still not working. :(
  14. iowabowtech

    iowabowtech root@android:/ #

    At this point the only thing I have left is to flash a different baseband from hboot. Either that or I'm wondering if your actual radio (internal hardware) is roached. Hope not but its starting to seem a possibility.
    RewindByChance and scotty85 like this.
  15. RewindByChance

    RewindByChance Active Member

    You don't think it's just a problem that some work on Verizons end could fix? I saw a lot of people had the same texting problem on Sprint and most of them got something updated from Sprints end and things went back to normal.

    How would I go about flashing a different baseband?
    scotty85 likes this.
  16. scotty85

    scotty85 Guides Guide

    i think you might try and reflash the PB31IMG for 2.2. if you have some sort of kernel/boot/baseband mismatch of some module or something,running the the ruu may fix it.

    try that,and see if they are working after that. if so,then flash recovery, and flash one of the roms iowa has linked above. :)

    if the problem persists,let the phone ota back to gingerbread,and then call vzw and see what they say. its always good to have a fresh factory rom when you need to deal with vzw customer service ;)
    iowabowtech and RewindByChance like this.
  17. scotty85

    scotty85 Guides Guide

    iowabowtech likes this.
  18. RewindByChance

    RewindByChance Active Member

    So, use the file you provided in the original post then?

    Edit: Flashed to 2.2, calls/texts still not working.

    If I accept the OTA to talk to Verizon, will I need to unroot my phone as well?
  19. scotty85

    scotty85 Guides Guide

    Nope... You are unrooted after flashing the ruu and ota-ing. No need to turn s-on unless it comes down to having to send it back to vzw.
    iowabowtech likes this.
  20. RewindByChance

    RewindByChance Active Member

    Alright. Guess it looks like I'm gonna have to call Verizon tomorrow. Thanks for your help guys.
  21. hugoqzd123

    hugoqzd123 Member

    Okay I downloaded zergRush again. But the problem was fixed after I ran the latest RUU for the incredible(RUU_Incredible_C_Gingerbread_S_VERIZON_WWE_4.08.605.2_Radio_2.15.10.07.07_NV_1.70_release_222194_signed.exe). This upgraded my phone to the latest verizon build. Then follow the instructions from this thread again and every step worked successfully.

    I was previously not able to do a factory reset with 4.06.605.3, I would select factory reset and the phone would reboot but it didn't actually reset anything. I believe 4.06.605.3 is a buggy release from HTC/Verizon, but I could never get the update and install properly. It would download but not install.

    Anyway, I running Cyanogen 7.1. Thanks for this great guide. You guys are awesome.
    scotty85 likes this.
  22. scotty85

    scotty85 Guides Guide

    Cool,I'm glad it worked for you :)
    iowabowtech likes this.
  23. rootnewbie

    rootnewbie Member

    Help!

    I followed the instructions in the original post for my Droid Incredible 1 and am no longer receiving text messages. I can send/receive calls, but only send texts.

    I downloaded the 5 files, ran unrevoked, and let it do its thing. I never got the "blank screen" but did have to run it twice, getting the success notification the second time.

    I then had superuser as an app, and at the suggestion of the instructions, I could stop if all I wanted was to root/kill bloatware.

    All seemed well, but yesterday my girlfriend hits update on the new OTA. It seems that I'm no longer receiving texts (Happy Thanksgiving!). Further investigation lead me to realize I haven't gotten texts since the "pseudo-root."

    I believe that to be the origin of my issues, maybe I did something wrong or didn't finish a last, critical step? Another thought is that the OTA yesterday may have unrooted me and now I can't properly restore now that I'm not rooted again??

    I only have a cursory knowledge of rooting, mostly picked up from reading before my one attempt!

    I use text messages heavily with my business; any help is greatly appreciated!
  24. sdrawkcab25

    sdrawkcab25 Guides Guide


    Not receiving texts is a bug in the gingerbread release you are running. Update to the latest version.
    iowabowtech and scotty85 like this.
  25. rootnewbie

    rootnewbie Member

    I'm assuming I'm using the latest gingerbread release, and even verified the software number with Verizon tech support (4.06.605.3).

    My software Information screen shows:
    version 2.3.4
    Baseband 2.15.10.07.07
    Kernel:
    2.6.35.13-g55a06e5
    htc-kernel@and18-2 #1
    Thu Aug 18 16:33:55 CST 2011
    Build 4.06.605.3 CL140944 release-keys
    Software 4.06.605.3
    Browser WebKit/533.1
    PRI 1.28_002
    PRL 52608
    ERI 5

    Is there a download for the most current gingerbread? I wouldn't know where to look nor how to install/flash(?) it.
Thread Status:
Not open for further replies.

Share This Page