[How To] Root 2.3.4/downgrade and Get S-off


Thread Status:
Not open for further replies.
  1. redbean25

    redbean25 Member

    Yup. Already have it installed. Just have to pull the battery right now to get it to power back on. Annoying yes, but a lot better than it was without root access! That required pulling battery and leaving it out.
    scotty85 likes this.
  2. MrBluefin

    MrBluefin New Member

    Hi all. Just wanted to say thanks for this thread. After lurking here for several weeks watching the progress of this thread, I jumped in and went for it. Process went flawlessly. I'm now back to 2.2 and s-off. I had been thinking of rooting and roming for quite some time, just never got to it. Then the first GB update came out (I accepted it :eek:) and I thought I was hosed. So again, thanks to Scotty & all those that have put time and effort into this thread! Now I'm off to find a new rom.
    scotty85 likes this.
  3. scotty85

    scotty85 Guides Guide

    glad it worked out for you :)
    iowabowtech likes this.
  4. Hello, thanks Scotty for this manual. I have followed your instructions up until this point:

    "hopefully what you will see now,is a blue status bar as your phone finds the PB31IMG,unpacks it,checks it,then asks if youd like to update. select yes to update with the volume up rocker. if youve never installed a full ruu in hboot,it will take a few minutes,so dont panic. place the phone gently down somewhere where it wont fall and spit out the battery. let it do its thing. push power to reboot when prompted.

    let the phone fully boot..."

    Once the phone rebooted, it gets stuck at the android eye icon with the two red dots to the right side of it. It freezes for a while, then I get the white HTC screen, the android eye icon with the two dots, it freezes again, then reboots on and on.

    Scotty, do you or does anyone else have any suggestions as to how to proceed from this point forward?

    At every step up until this point, as far as I can tell, everything was working as it should flawlessly.

    Please help. I am totally lost now.

    Thanks for anyone who can help.
  5. scotty85

    scotty85 Guides Guide

    thats called a "bootloop" and several have experienced it,for some reason. in all cases thus far,this has fixed it: simply pull the batter,boot to hboot(power/vol down) and flash PB31IMG again.
  6. redbean25

    redbean25 Member

    Yep. I got this when I tried to install Froyo via the executable. Then I put the zip on the SD card and booted to HBOOT and let it install from there. Then all worked just fine. So just try it from HBOOT again.
    scotty85 and richteratmosphere like this.
  7. Thanks Scotty and redbean. I pulled out the battery. Put battery back in and tried hboot. It seemed to just automatically work it's way out then. As far as I can tell, it worked correctly, and I now have s-off. I've been trying to install cyanogenmod 7.1 using ROM manager, and it doesn't seem to be working. I get errors.

    Here's the ClockworkMod Recovery v2.5.1.2 screen message:

    ClockworkMod Recovery v2.5.1.2
    Waitingfor SD Card to mount (20s)
    E:Can't mount /dev/block/mmcblk1p1 (or /dev/block/mmcblk1)
    (No such file or directory)
    Waiting for SD Card to mount (19s)
    SD Card mounted...
    /tmp/recovery.log was copied to /sdcard/clockworkmod/recovery.log. Please open ROM Manager to report the issue.

    Is there a particular way to install cyanogenmod 7.1 that is recommended when using the rooting method detailed in this thread?

    Maybe this should go in another thread, but I'm so close to installing a custom ROM and am not sure if maybe the rooting process didn't work and that may be causing the inability to install cyanogenmod 7.1.

    Thanks again for everyone's help on this.
    scotty85 likes this.
  8. redbean25

    redbean25 Member

    Also did not work for me via ROM Manager. place the Cyanogenmod 7.1 zip file on the SD card as well as the Google apps zip file if you want those. Then boot to recovery (clockworkmod). Clear the cache, phone data, then install the cyanogen zip file from the SD card followed by the Google apps zip. Then reboot and you should be good to go. Just went through this process this morning.
    richteratmosphere and scotty85 like this.
  9. scotty85

    scotty85 Guides Guide

    i would advise against using rom manager. at least until you are comfortable booting to recovery and using those menus to backup/wipe/flash.

    rom manager is an app,and thus requires a working rom to function. if you get stuck in a bootloop,or a non working rom with no way to get rom manager,knowing how to enter recovery thru hboot and use the menus to fix it by reflashing a rom or restoring a backup will save you several moments of terror from not knowing what to do ;) :D

    after your comfortable with clockwork recovery,then you can use rom manager if you really want to. i personally dont use it at all. :)
  10. Thanks again redbean and Scotty. So, here's where I'm at with redbean's instructions...

    I downloaded 7.1 from the cyanogen site as a zip file and the google apps for 7 from the cyanogen wiki page and copied and pasted them to the root of my sdcard.

    As far as this instruction: " Then boot to recovery (clockworkmod)."

    I turned the phone off, held down the power and volume down buttons. Selected recovery.

    With regards to the "Clear the cache, phone data" instruction from redbean...

    I don't see this exact verbage on my screen. There are some options that are close, but appear to be kind of scary and I don't want to select something that I shouldn't.

    Here's what the screen says:

    " ClockworkMod Recovery v2.5.1.2

    - reboot system now
    - apply sdcard:update.zip
    - wipe data/factory reset
    - wipe cache partition
    - install zip from sdcard
    - backup and restore
    - mounts and storage
    - advanced "

    Am I on the right screen? Am I supposed to select "wipe cache partition" and then "wipe data/factory reset?"

    Then for redbean's "then install the cyanogen zip file from the SD card followed by the Google apps zip" instruction....

    Would I select "install zip from sdcard" and select the 7.1 zip then do the same for the google apps zip and then reboot?

    Thanks for your patience in clarifying this. There's a lot of new terminology that's used in rooting and putting on custom ROMs that I'm not familiar with...
  11. redbean25

    redbean25 Member

    Select wipe data/factory reset
    Select wipe cache partition
    Select install zip from SD card then choose the cyanogen file.
    When complete repeat for the apps zip
    Select reboot system now
    richteratmosphere likes this.
  12. Thanks very much redbean and Scotty! It worked. I'm running Cyanogenmod 7.1 now!
    redbean25 likes this.
  13. redbean25

    redbean25 Member

    Awesome. Glad it worked out and you are up and running. Enjoy life without the bloat.
  14. dhs2011

    dhs2011 Member

    ok, i have not had time to review all of the forum yet, but can anyone answer a quick help question for me. I got the wifes dinc rooted and clockwork available but when i launch into clock work i can not access anything. Clock work is there but i can not run back up and restore. I select the option and it just gives me the rom manager logo idle. no choices. So i have not been able to turn the s-off( unless done automatically!?) what options do i have now? can i flash right to a nightly or at least cm 7.1 or do i need to downgrade first? thanks for any help and patience for not being able to get through entire thread.
  15. ignoref8

    ignoref8 Member

    so I'm a total noob at all of this, just got a refurb and was hoping it wouldnt be on 2.3.4 so I could root but oh well. I got most of the way through unrevoked once, got a failed message and a black screen on the Dinc, now any time I try again it says failed to push recovery. Any ideas? thanks
  16. redbean25

    redbean25 Member

    Is it on 2.3.4? If so you will have to reflash to the 2.2 Froyo version, then the unrevoked3 will work. Place the 2.2 zip file on the root of your SD card and boot into HBOOT. Wait for it to find the zip file and then press the volume up button to confirm loading the 2.2 image.

    Scotty85 posted the link to the zip files in post #488 of this thread found here:

    Link to Stock ROMs
  17. lovejess

    lovejess Member

    Hi :) I'm brand new.... ;)

    I spent hours last night reading about how to root my Incredible.... only to find that it would have been SO much easier if I hadn't taken the ota update to Gingerbread...

    So I tried the instructions on the first page, but I have a Mac and a lot of those links/files didn't work for me... I don't know enough about all of this to troubleshoot it on my own.... basically I was just intent on being able to follow instructions exactly... :)

    What can I do? I see that link for the Froyo ruu.... is that a work-around to get me easily downgraded to 2.2, and then I can just go ahead and use unrevoked 3.32?? It sounds a lot simpler than the instructions on the first page here....

    Any help would be awesome. :) Thanks! :D
  18. scotty85

    scotty85 Guides Guide

    The easiest thing would be to borrow a windows laptop,or go to a friends house to use a windows desktop. All the files are small and unobtrusive, with exception of PB31IMG,wich you could download before hand and take with you an an SD card or flash drive.

    Failing that,you should be able use the directions in post 2,wich does not utilize unrevoked 3.22. You will have to find a tutorial for getting adb and fastboot working on a Mac,and the adb commands will be a lil different. You'll need to take the stuff out of "mini-adb_Inc" and place it into whatever folder adb is in after setting up the sdk. Usually "tools" or "platform tools"

    Hope that helps :)
    iowabowtech and lovejess like this.
  19. scotty85

    scotty85 Guides Guide


    Use the optic trac thingy, not power,to scroll and select.

    Yes you will have to downgrade to froyo to get s-off.
    iowabowtech likes this.
  20. scotty85

    scotty85 Guides Guide


    Are you using 3.22? You can't use 3.32 until you're back on froyo
    iowabowtech likes this.
  21. lovejess

    lovejess Member

    thank you! i will probably just wait until i can use a friend's computer... haha. but i will also check out the info you mentioned about post #2... i had started to try that last night, but i felt like post #1 would be a little easier for me to understand.
  22. lovejess

    lovejess Member

    do you think it would work for me to use unrevoked 3.14 instead of 3.22? i found the 3.14 version for mac, but i can't find 3.22 anywhere.
  23. scotty85

    scotty85 Guides Guide


    Maybe? We have no idea why 3.22 works,lol. Someone on xda just started trying them one at a time and 3.22 happened to work. 3.21 didn't.

    Wont hurt you to try it l. if it happens to work,please report back. :)
    iowabowtech likes this.
  24. lovejess

    lovejess Member

    ok... i will probably try that! .... one more question... at the moment :)

    so i have an old droid incredible that was unfortunately also updated to 2.3.4........ i did a factory reset...when the screen came on again, it showed the green arrow circle that you see when its doing an ota update.... so then i held down volume and power button as soon as that started... is it possible that this is actually stopping the update?

    i;m wondering if i could put the .zip that i want on the sd card, and choose the option to "apply update from sd card", rather than letting that green arrow update continue...

    do you have any idea if that would work?
  25. lovejess

    lovejess Member

    nevermind, that didn't work. BUT i found unrevoked 3.22 for mac FINALLY, and it worked..... well... now I'm on a screen with a hat and an orange arrow.... hope thats good news so far...
Loading...
Thread Status:
Not open for further replies.

Share This Page