[How To] Root 2.3.4/downgrade and Get S-off


Thread Status:
Not open for further replies.
  1. mdbc

    mdbc New Member

    Where did you find it?
  2. lovejess

    lovejess Member

    Oh I can't believe I didn't post it here.... sorry!
    It took some extensive clever google searching..... ;)

    Mac Unrevoked 3.22: http://downloads.unrevoked.com/recovery/3.22/Reflash.dmg

    IF that one is not correct, let me know (I had a few versions downloaded before I found the right one).

    Good luck! It worked great for me. :)
    gkinsella2 and scotty85 like this.
  3. Neverdrift12

    Neverdrift12 Member

    Ok. I'm ready to pull my hair out. I read this and was fired up that I could root my inc1. I did everything on the first part and now my phone,when I turn it on goes to the white HDTV screen buzzes then resets back to the screen again. I've tried the hboot pb31img deal and I get a error like everyone else has I've read about. The only thing I know about rooting is what I've read from you. So I'm going to need a lot of help I think. My phone is a inc1 s is on version 2.3.4. Thanks
  4. ignoref8

    ignoref8 Member

    Ive been using 3.22, and I tried one last time last night and got all the way to clockwork recovery screen before unrevoked told me it failed again. Can I just flash the ROM from here now? I can keep getting back to it through hboot.
  5. mdbc

    mdbc New Member

    Thanks, worked like a charm. Tested it out with barnacle, works beautifully. Next stop CM7.
    I can't wait for CM9. Wonder how it will do on the incredible. I don't see why it shouldn't run great, the code is supposed to be more efficient than Gingerbread. I guess it also depends on drivers, adaptation to the specific hardware, etc. It runs on the G1, (like crap but still, thats arm 11).

    Alright, enough derailing the thread.

    Thank you lovejess, scotty85, and everyone else

    M
  6. scotty85

    scotty85 Guides Guide

    Do you have a working clockwork recovery?

    Do you have superuser in your app drawer? If so,don't worry about the failed message.
    iowabowtech likes this.
  7. scotty85

    scotty85 Guides Guide


    Need more specific info. What have you done? What error are you getting,when?
    iowabowtech likes this.
  8. scotty85

    scotty85 Guides Guide


    Thanks... I will add that to the op when I get a minute :)

    If you get the SDK installed,and do the second part so you can downgrade,give as much info as you can about that. Quite a few Mac owners would prolly be pretty greatful for any info you cab provide :cool:
    iowabowtech and gkinsella2 like this.
  9. ignoref8

    ignoref8 Member

    I do have working clockwork recovery, I do not have superuser. Just did the same thing again. Screen said rebooting to recovery, then communications interupted, but it leaves the phone in CWM
  10. dhs2011

    dhs2011 Member

    i managed to get the clockwork all set, but now when i go to enter the promt commands it does not recognize the first command. only thing i can think of is that i didn't place the mini adb in the proper place. so should where should it be exactly?

    thanks.
  11. Neverdrift12

    Neverdrift12 Member

    I've done just the first part of your install, just to get it rooted. When I go to start it, by pushing the power is, a white screen that says the Htc incredible buzzes then resets back to that screen again. If I use the recovery option I get the black screen with white outlines. So I tried the pb31img.zip on hboot and it tells me the version is old. So I tried a new one and it have me a error. My phone is a slcd I found out. It also tells me errors on the img when it reads on hboot. I've tried everyone option ppl have done in the messages on here and nothing has worked. Thanks for the reply
  12. lovejess

    lovejess Member

    I realized that I didn't need to do s-off for what I wanted, so I decided to quit while I was ahead.... ;) but as I get more familiar with all of this, I will probably do that and report back. ;)
    scotty85 likes this.
  13. scotty85

    scotty85 Guides Guide


    Just flash superuser in clockwork
    iowabowtech likes this.
  14. scotty85

    scotty85 Guides Guide

    Easiest place is on the root of your c drive(top level,Not inside other folders)

    Make sure you unziped it
    iowabowtech likes this.
  15. scotty85

    scotty85 Guides Guide

    Run a gb ruu. One is linked a few pages back,I believe.
  16. Neverdrift12

    Neverdrift12 Member

    Yea thAts one thing I havet tried, but I didn't see a link. Do you know we're one is at or could you get a hold of the link I need? Thanks again for your fast replys
  17. ignoref8

    ignoref8 Member

    where do I find that? I searched and did find an app in the market but I'm not sure how I would flash that....

    *nevermind, I found it on another post by you on xda. I'm rooted!!
    scotty85 likes this.
  18. scotty85

    scotty85 Guides Guide

    I'm on my phone so I can't really find it right now. Hopefully one of the guys can find it for you.
    iowabowtech likes this.
  19. iowabowtech

    iowabowtech root@android:/ # Moderator


    RUU:
    Stock Gingerbread (2.3.4. build 4.08.605.2 final Gingerbread)
    http://www.megaupload.com/?d=BJZX5B1Q
    MD5: d25483fc58cc344a5b23aba3813f1341

    Looks like megaupload server may be down. Alternate:

    http://www.multiupload.com/XF7EG5F2I7
    scotty85 likes this.
  20. ignoref8

    ignoref8 Member

    ok so now ive got superuser, flashed to 2.2, tried to run unrevoked 3.32 and it gets to "running root..." then just stops and doesnt do anything...
  21. ignoref8

    ignoref8 Member

    can i just flash cm7 and get s-off through that?
  22. redbean25

    redbean25 Member

    **Deleted reply**

    I was mistaken, and corrected by iowabowtech, so I deleted this post so as not to mislead anyone.
  23. iowabowtech

    iowabowtech root@android:/ # Moderator

    You can flash a Rom without s-off but you would be well served to diagnose the problem and get s-off. If you are rooted with a custom recovery, you can install s-off using the zip on the unrevoked forever wiki page. It installs just like a Rom in recovery.
    scotty85 and redbean25 like this.
  24. krisdr

    krisdr Active Member

    I should be following the tread how to teach granny to root but I made the unfortunate mistake of OTA and now I have 2.3.4. I could not even get past the first step in downgrading. I can not open (extract) PB31IMG.zip. I get an error message telling me that it is invalid. HELP! I am in way over my head but I really, really want to root! I am running vista 32.
  25. sdrawkcab25

    sdrawkcab25 Guides Guide

    The first step is not downgrading, it is getting root on 2.3.4... reread the instructions a few times (extremely carefully!), then read them again, then figure out a game plan if something goes wrong. every step has to be followed exactly.

    What i did first was download ALL the necessary files first and check their md5 hashes. I organized/labeled every file so i knew what each one was for, and put them all into a single folder which was in an easy to find location on my pc.

    Your sd card also has to be formatted to FAT32.
    iowabowtech, krisdr and scotty85 like this.
Thread Status:
Not open for further replies.

Share This Page