1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

[How To] Root 2.3.4/downgrade and Get S-off


Thread Status:
Not open for further replies.
  1. razgriz24

    razgriz24 New Member

    so I followed the instructions to the letter, and I'm stuck at this step below. It finds the update, but gives me a Main Version is older! error. what do I do from here?

    hopefully what you will see now,is a blue status bar as your phone finds the PB31IMG,unpacks it,checks it,then asks if youd like to update. select yes to update with the volume up rocker. if youve never installed a full ruu in hboot,it will take a few minutes,so dont panic. place the phone gently down somewhere where it wont fall and spit out the battery. let it do its thing. push power to reboot when prompted.
  2. scotty85

    scotty85 Guides Guide

    you did not successfully rewrite the misc image. check the md5s of all your downloads,then start at step 3,if you use the unrevoked 3.22 method and still have root access. if not,youll have to start over.

    make sure the outputs to each command match the ones in my code box on the first post.

    after your done,copy the whole thing and paste it here by:

    right click in the command window,click mark. highlight everything in white. hit enter.

    then,in your reply to thread box here,click the "#" up top and paste everything between the
    Code (Text):
     tags.

    then if it doesnt work,we should be able to see where you went wrong with the comands :)
    iowabowtech and razgriz24 like this.
  3. razgriz24

    razgriz24 New Member

  4. gkinsella2

    gkinsella2 Member

    OK, I'm finally s-off via Mac Terminal!

    For those using a Mac, you will need to download the Android SDK starter package as well as the platform-tools addition (platform-tools is not part of the starter package, but is easily obtained by running the android command in the terminal once you've downloaded SDK and downloading it from the menu). The platform contents will automatically be saved in your SDK folder. You can get the SDK here: Android SDK | Android Developers

    Also, you still need to download the mini-adb-inc package that Scotty has on the OP because you still need the flash_image and mtd0.img files to push to your phone. After that, the steps are the same, but with a few minor tweaks that I'll detail below.

    So, I'll begin at step 2: "2)root with unrevoked 3.22" worked flawlessly, just make sure to use the unrevoked 3.22 link for Mac that Jess found and Scotty added to the bottom of the OP. This will simply get you root with s-on.

    GREEN instructions are what I tweaked...if it's bold, it's code
    3)prepare to downgrade
    -extract the mini-adb_inc .zip. place the mtd0 and flash_image in your Android SDK platform-tools folder. (no real need to put anything at root directory if you don't want, I'll explain why in a moment)
    -place the 2.2 downgrade on the root of your sd card...this part of step 3 is the same.

    4)downgrade with adb. This is where things get more interesting. :D
    At this point, I've assumed the Mac users know how to get to your terminal...if not, go to Applications->Utilities->Terminal. Go ahead and check your md5's...the command in Terminal is simply md5, not md5sums. OK, moving along...

    -make sure phone is plugged in and usb debugging checked on,in charge only mode
    -at the promt in your Terminal window:

    cd <after the space, drag the platform-tools folder from the Finder window and drop it into the command line...this will automatically load your path and why you don't necessarily need to place everything in your root directory> Here's what mine looked like:

    gkinsellas-imac:~ gkinsella$ cd /Users/gkinsella/AndroidSDK/platform-tools
    gkinsellas-imac:platform-tools gkinsella$

    ./adb devices must use ./ in front of the command to execute the adb commands from the platform-tools folder

    md5 mtd0.imgmd5 flash_image
    for both of these, type the md5 command followed by a space, and then drag and drop each file to automatically include the path for the file. These will return the same numbers Scotty has on the OP

    ./adb push flash_image /data/local/
    ./adb push mtd0.img /sdcard/


    ./adb shell your prompt should change to a #. if it changes to a $,then type su note your phone may pop up a message asking you to allow permissions the first time you do this (the first time I did this, I received a "Permission denied" message...I typed su again and got the # prompt). if it does check "always" and touch "allow" on the superuser request on the phone screen.

    cd /data/local
    chmod 0755 /data/local/flash_image

    cd /data/local
    ./flash_image misc /sdcard/mtd0.img
    NOTE:
    no changes to these commands because you're now in the phone!

    you can now downgrade back to 2.2,so you can run "unrevoked forever" to regain s-off

    exit to get back to $ prompt
    exit to get back to the "platform tools" prompt

    ./adb reboot bootloader this will boot your phone to "fastboot" select "bootloader" with the power button.

    And that's it! Follow everything after the bootloader instruction as Scotty outlined. I'll put a copy of my session on the next post. I hope this helps...Scotty, I'm not sure how you want to add this to your OP as it's not much different code-wise obviously, but definitely a few different steps than what you had.
  5. scotty85

    scotty85 Guides Guide

    thats awsome! lots of mac users will be extremely greatful :cool:

    as far as integrating it,there are a few ways we could do it... if you want to make up your own complete post,using most of my guide or parts,or none,we can link from the first post to wherever it is,or if rooter28 doesnt mind we can grab his post(#3) and put the mac guide there. only prollem with doing that is that only the guides and mods can edit it,so if you need to make changes youll have to get one of us to do it. wich is not a big deal to me,just pm me or sdraw or any of us if you need to make a change.

    i could also just take what you posted above,and either link to it,or add it to post #3.

    id like to have all of it in the first few posts,but if you want to keep it your post so you can change it,its no biggie to link it.

    however you want to do it,sir. your contributions are greatly appreciated. :D
    iowabowtech and gkinsella2 like this.
  6. gkinsella2

    gkinsella2 Member

    Code (Text):
    gkinsellas-imac:~ gkinsella$ [COLOR=SeaGreen][B]cd /Users/gkinsella/AndroidSDK/platform-tools [/B][/COLOR]
    gkinsellas-imac:platform-tools gkinsella$ [B][COLOR=SeaGreen]./adb devices[/COLOR][/B]
    List of devices attached
    HTXXXXXXX    device

    gkinsellas-imac:platform-tools gkinsella$ [B][COLOR=SeaGreen]md5 /Users/gkinsella/mini-adb_inc/mtd0.img   [/COLOR][/B][COLOR=Blue]NOTE:  I ran the md5 before I moved these to my platform-tools folder.  That's why it shows a different path.    [/COLOR]
    MD5 (/Users/gkinsella/mini-adb_inc/mtd0.img) = 34307be744275f1db1dd16af04c37839
    gkinsellas-imac:platform-tools gkinsella$ [COLOR=SeaGreen][B]md5 /Users/gkinsella/mini-adb_inc/flash_image   [/B][COLOR=Blue]same reason as above for different path[/COLOR][/COLOR]
    MD5 (/Users/gkinsella/mini-adb_inc/flash_image) = 0098a7dd6600b55fac34fc6645be5d7a
    gkinsellas-imac:platform-tools gkinsella$ [COLOR=SeaGreen][B]./adb push flash_image /data/local/[/B][/COLOR]
    1747 KB/s (76044 bytes in 0.042s)
    gkinsellas-imac:platform-tools gkinsella$ [B][COLOR=SeaGreen]./adb push mtd0.img /sdcard/[/COLOR][/B]
    2106 KB/s (655360 bytes in 0.303s)
    gkinsellas-imac:platform-tools gkinsella$ [B][COLOR=SeaGreen]./adb shell[/COLOR][/B]
    $ [COLOR=SeaGreen][B]su[/B][/COLOR]
    Permission denied  [COLOR=Blue]as mentioned above, not sure why I was denied[/COLOR]
    $ [B][COLOR=SeaGreen]su  [/COLOR][/B][COLOR=SeaGreen][COLOR=Blue]however, I knocked twice and got in![/COLOR]  :D[/COLOR]
    # [COLOR=SeaGreen][B]cd /data/local[/B][/COLOR]
    # [B][COLOR=SeaGreen]chmod 0755 /data/local/flash_image[/COLOR][/B]
    # [COLOR=SeaGreen][B]cd /data/local[/B][/COLOR]
    # [COLOR=SeaGreen][B]./flash_image misc /sdcard/mtd0.img[/B][/COLOR]
    # [B][COLOR=SeaGreen]exit[/COLOR][/B]
    $ [COLOR=SeaGreen][B]exit[/B][/COLOR]
    gkinsellas-imac:platform-tools gkinsella$ [COLOR=SeaGreen][B]./adb reboot bootloader[/B][/COLOR]
    gkinsellas-imac:platform-tools gkinsella$
    scotty85 likes this.
  7. scotty85

    scotty85 Guides Guide

    added
    Code (Text):
     tags to your session :) might want to x out some or all of your serial number,but thats up to you. :)
    iowabowtech and gkinsella2 like this.
  8. gkinsella2

    gkinsella2 Member

    I don't think I'll need to edit it...if I do, I can add by "replies" and you guys can update it if need be. I agree with you though, keep it in the first few posts. It'll be more centralized that way and easier for others to find/follow. Glad I could help out!
    scotty85 likes this.
  9. gkinsella2

    gkinsella2 Member

  10. teerex

    teerex Member

    Hello all:
    Thanks to Scotty for posting these instructions and for continuing to answer everyone's questions. After downloading all the files and verifying their MD5 sums, I ran into a problem installing the Unrevoked USB drivers. According to their instructions below, one needs to go into the HBOOT menu to install the drivers.

    • Turn off your phone, then boot it into the HBOOT menu by holding power and volume down.
    • Connect the phone to your Windows machine with a USB cable and wait for the phone to say HBOOT USB PLUG on screen.
    However, my phone already has the OTA 2.3.4 without having previously rooted, or, done S-off. So pressing Power and Vol. down does not give the HBOOT menu. As a result, I don't have the Bootloader Interface driver loaded as described. All I have is the Android Composite ADB Interface driver. Is there a way to circumvent this and load the Unrevoked drivers as they have described ?

    Any advice/insight would be greatly appreciated.
    Thanks
  11. scotty85

    scotty85 Guides Guide

    that should be an easy fix. just go to settings/power uncheck "fastboot". :)

    having this checked prevents you from getting to hboot via power/vol down. freaked me out bigtime first time it happened to me on my thunderbolt :eek: :D
    iowabowtech, schott12521 and teerex like this.
  12. teerex

    teerex Member

    Thanks much, Scotty. That worked perfectly and now I've got root. I can't believe how easy that was. So far I haven't downgraded and am doing the Titanium and Nandroid backups.

    After the Titanium backups, I tried to remove some of the extra apps (CityID, VZW NAvigator, etc) using Titanium. However, even though Titanium reports the apps as having been removed, they are still present in the App drawer and still work. I'm not sure what I'm doing wrong here. I have the free Titanium app.

    Cheers,
  13. sdrawkcab25

    sdrawkcab25 Guides Guide

    you need s-off to remove the apps with titanium unless you use the "recovery exploit". Or buy the paid version and you can freeze them.
    iowabowtech and scotty85 like this.
  14. schott12521

    schott12521 New Member

    Sorry for the REALLY noobie-ness here, but a few questions.

    I've never rooted before, never S-off'ed or whatever. I have 2.3.4 on my Dinc and I want to root that little f'er! I assume this is the post to use?

    Also, what are the odds of me completely messing up, and not getting having working phone?

    Thanks scotty85 and all others who helped, looks really informative!
  15. scotty85

    scotty85 Guides Guide

    Yup,this is the post to use for 2.3.4. The chances of bricking really are slim to none,if you follow the directions.

    Just read thru the directions a couple of times and ask any questions you can't find the answers to prior to getting yourself in a bind. Download all the files,check their ms5s,and organize yourself so you can find them all. Don't skip the part about checking ms5s because you don't understand it,or know how to do it,as using corrupt files is the only way you *could* potentially brick it.

    Once you've downloaded and checked everything,just carefully procede. Make sure the outputs match and you don't miss any steps,and you'll be fine. :)
    iowabowtech likes this.
  16. hazelnut

    hazelnut Member

    I think you're saying I should follow step 2 on the original page, which directs me to public:windows_hboot_driver_install [RootWiki] . But that page contains instructions for a Windows machine. I have only a Mac, running 10.6.8. Do I need a Windows machine in order to continue at this point? I can reach the HBOOT USB PLUG screen on the Incredible, but running ./adb devices from platform-tools does not show any connected devices at this stage.

    Thanks for your patience.

    [Edit:] I do have the unrevoked Recovery Reflash Tool for Mac, as described in the original post.
  17. redbean25

    redbean25 Member

    MAC instructions on post 629
  18. scotty85

    scotty85 Guides Guide

    i believe that on a mac,your phone is naturally,magically compatible,you dont need to install drivers :eek: you can skip over the part about installing drivers.

    start on step 2,and use unrevoked to root your phone. make sure to change the recovery if youre on an slcd,as described in step 2. i dont believe this part will be much different on a mac. youll still need to place the recovery image somewhere you can find it,then point the unrevoked to it.

    then,as was said,directions for the downgrade adb commands are in post 629 :)
    iowabowtech likes this.
  19. redbean25

    redbean25 Member

    Sorry if I sounded rude. I was simply pointing to the correct post for the Mac adb instructions.
  20. hazelnut

    hazelnut Member

    Thanks. Yes, I've been following the instructions in post 629; that's what my original quote was to.

    Step 2 of that post is now done. For the benefit of any other Mac users as slow-witted as I am, I'll describe what I did in that step.

    After confirming the checksum of recovery-clockwork-5.0.2.0-inc.img, I installed the Mac version of Reflash from http://downloads.unrevoked.com/recovery/3.32/Reflash.dmg . I copied Reflash from the .dmg to a regular directory and ran it from there.

    With Reflash running but phone not plugged in, select File -> Custom Recovery , and choose "recovery-clockwork-5.0.2.0-inc" from the place it was saved to. Reflash screen-bottom now says "Recovery image: custom". Only then did I plug in the phone. Reflash found the phone and after asking for my confirmation, began installation and a series of reboots.

    After all was finished, I got an error "Error verifying extendedcommand", but on reboot (from a blue, not green, menu on the phone), I was able to go to Settings -> Applications -> Manage Apps , choose "all" pane, -> Superuser Permissions version 2.1; from there I cleared the data, and root checkers confirm that I am rooted.

    Many thanks to all!

    On to step 3 of post 629 now.
  21. hazelnut

    hazelnut Member

    In Step 3 of the instructions, it says, 'place the 2.2 downgrade on the root of your sd card,and verify it is named "PB31IMG".' The 2.2 downgrade is not "Android 8" from the Android SDK Manager, but the directory called "PB31IMG" that was downloaded from PB31IMG.zip , correct? That directory contains a file "android-info.txt" containing

    Code (Text):
    modelid: PB3120000
    cidnum: VZW__001
    mainver: 3.26.605.1
    hbootpreupdate:3
    correct?
  22. hazelnut

    hazelnut Member

    Pushing flash_image is successful, but I am getting a permissions error when I try to push mtd0.img .

    [Edit:] From within the adb shell, I can see that /sdcard/ has permissions of 000. Trying to write to it or change the permissions brings me "Unable to chmod /sdcard/: Read-only file system". Any idea how I can change the permissions?

    Thanks for your patience.
  23. knobby

    knobby New Member

    Whoo Hoo, S-OFF! Finally got it to work. Somewhere in all the posts I was reading, I got the wrong image I tried to flash, and I think I missed the (completely didn't see) the Charge only, and had it in disk mode.

    Tried again tonight when I was fresh and all went the first time (after replacing the bad PB31IMG.zip that was way too small.

    Went right through and now I am looking for a OS to load.

    Thanks for the instructions at the beginning of the thread! Great Job.
  24. gkinsella2

    gkinsella2 Member

    Hazelnut, did you change your shell prompt from '$' to '#'?
  25. boodawg95

    boodawg95 New Member

    amazing write up my man you saved me from punting many puppies 0_o
    scotty85 likes this.
Loading...
Thread Status:
Not open for further replies.

Share This Page