[How To] Root 2.3.4/downgrade and Get S-off


Thread Status:
Not open for further replies.
  1. scotty85

    scotty85 Guides Guide

    agreed. you possibly needed to "su" to get your "#" prompt. a copy/paste of your session would be helpful. see post #627 to copy paste your session here
    iowabowtech likes this.
  2. Kirru

    Kirru New Member

    Did it this afternoon and drove 4 hours and picked up where I left off.. no problems other than getting it to go back to 2.2 but that is done. Glad it is done... now to learn what I can do with it
  3. teerex

    teerex Member

    Thanks for the reply, sdrawkcab25. I ended up going in through the ADB shell and moving all the unwanted .apks out of /system/apps into a temp discard folder. Now, a week later everything seems to be working fine so it's time to permanently remove them.

    I have one final question. My wife's phone still has 2.2. Will the same unrevoked binary work on hers as well, or, should I use the latest unrevoked (3.3.x) ?

    Cheers
  4. scotty85

    scotty85 Guides Guide

    if she is still on 2.2,just run the latest unrevoked,and make sure it turns s-off. if it does not,just flash the "forever" patch linked in the first post.

    no need to make it more complex than it needs be... unrevoked 3 has been the inc root standard for a looooong time :)
    iowabowtech likes this.
  5. sixit

    sixit New Member

    Thank you, Scotty!

    For those, like me, that use Linux instead of Windows, here is a link to the Linux version of unrevoked3 3.22 reflash.tar.gz :
    http://downloads.unrevoked.com/recovery/3.22/reflash.tar.gz

    I haven't gotten far enough in your instructions to see if there are any other Linux downloads needed. However, if I do find any I will post here to help other Linux users.

    Cheers,
    Robert~
    andish and scotty85 like this.
  6. scotty85

    scotty85 Guides Guide

    Cool,I will add that to the OP later :)
    iowabowtech likes this.
  7. BamaDave

    BamaDave Member

    Well after going through this process successfully a couple of weeks ago, I wound up going for the free upgrade to a Dinc 2 this weekend at Best Buy. LOL. I was somewhat hesitant due to lack of 4G capability, but I honestly don't see that as an issue for me during the next 20 months until I can upgrade again. Lovin' the Dinc 2 a lot, and my daughter is enjoying the original as an Android game/music/social networking toy. :D

    Now to decide whether I want to do all of this again with the Dinc 2. I may not for awhile... would love to ditch the Verizon Crapware, but it was really the low data memory issue that prompted me to root the original Dinc.

  8. OandresQ

    OandresQ Member

    Wow that was easier than I expected, thank you so much!!! Finally rooted :D thanks again!!
  9. nk21590

    nk21590 New Member

    So this is my first time trying to root the inc.

    I was following all the instructions perfectly until it got to the point of downgrading.

    The phone tries to load [Pb31IMG.zip] and then checks it but there is no prompt asking me to update. I loaded the image onto the root of my memory card, and the memory card is FAT 32. I have root access from the second step of the guide.

    Thanks for the help and sorry for the hassle
  10. clipperqb

    clipperqb Well-Known Member

    I'm about to get started doing this today and have been reading the directions to make sure I understand. The first item under step 2, how do I do that? Is that on the phone or am I opening one of the programs I downloaded to my PC?
    Thanks
  11. scotty85

    scotty85 Guides Guide

    On your phone,sir :)
    iowabowtech likes this.
  12. scotty85

    scotty85 Guides Guide

    One of those 2 things is not right,or your card is possibly bad or needs reformatted. This has been addressed several times,I can't go into more detail at the moment(working)
    iowabowtech likes this.
  13. clipperqb

    clipperqb Well-Known Member

    That was my first inclination lol, but why am I too dumb to find it? (I don't see power under settings) :confused:
  14. scotty85

    scotty85 Guides Guide


    Are you on 2.3.4?
    iowabowtech likes this.
  15. clipperqb

    clipperqb Well-Known Member

    yes at least thats what it says under software
    2.3.4 android
    2.15.10.07.07 baseband
    2.6.35.13... aug 18 2011 kernel
    4.06.605.3 CL140944 release keys

    I am notified every few days about a system update but I dont think it ever gets installed because of my low space condition
  16. chupajr

    chupajr New Member

    So, I'm starting to panic... I am trying to un-root, per the instructions.

    I'm currently stuck in HBOOT as it's applying the .ruu. I know you said it will take "a few minutes", but it's now been an hour and the progress bar has stopped moving.

    It's on the SYSTEM step, and the bar is at about 95%.

    Should I just pull the battery and start over?

    (Sorry if anyone has asked this, I tried skimming through the thread but I might have missed it)

    UPDATE:
    Pulled the battery, re-applying it now, we'll see how it goes...

    UPDATE #2:
    It worked, and is booting now! Hooray!
  17. clipperqb

    clipperqb Well-Known Member

    I decided to reset phone so that I could get that last update (changed from August to October) Still no Power option under settings, however under Applications is a setting to turn off fast boot.
  18. clipperqb

    clipperqb Well-Known Member

    So now I got into HBOOT USB PLUG and installed drivers exactly as shown. Device manager shows same as screenshot. So phone is currently plugged in and next step is "place your phone in charge mode,and make sure usb debugging is checked ON in settings/applications/development." The fast boot screen is still on phone and am unsure what to do? I'm assuming need to unplug phone as there is a step coming up to plug in your phone.

    Anyway so I unplugged, rebooted from the fast boot screen, made sure I had charge only selected in settings. started-up unrevoked tool and plugged phone in. Phone drivers don't kick in, shows up in device manager as ADB other device and mounts phone as Q:CDROM

    sorry to clutter the thread, any help is appreciated.
  19. royfranz

    royfranz New Member

    I am having the same problem, although I think I got there a different way. I don't think that it is an SD card problem. I have 2 formatted fat32, and hboot finds the PB31IMG.zip file, checks it, (blue progress bar and all) and then does nothing. This when trying to upgrade to a newer clockwork mod. (I messed up and got one that doesn't support SLCD.) If I try to flash a new image, after hboot checks the image, after it checks it I get an error about the version being too old.

    I don't seem to be able to flash anything, either from hboot (version 0.92, says S-ON on top of screen.) or clockword mod recovery. I have to use the the 'ddms' program to see the screen when clockwork is running. The phone does not boot past recovery, which is a black screen with white bars on the side.

    The phone was stock with the OTA gingerbread update.

    I'm not sure what to try next, as I have tried every way I have found information on to burn something new to the flash, but seem to be unable to do so.

    Any suggestions? Can it really still be an SD card problem if I get all the way through checking and the progress bar (or the version error?)

    Thanks,
    Roy
  20. scotty85

    scotty85 Guides Guide

    if you get a status bar,the file is being checked. your sd card formatted correctly,and it is named correctly.

    the prollem is the file itself. make sure you didnt unzip it, and double check the md5 sum to make sure its not corrupt.

    ive seen claims that bad sd cards prohibited RUUs from flashing(with different error messages,or no message like youre experincing) but never personally experienced it. wouldnt hurt to reformat an extra card and give it a shot.
    iowabowtech likes this.
  21. scotty85

    scotty85 Guides Guide

    make sure you enable "usb debubbing" on the phone in settings/apps/development
    iowabowtech likes this.
  22. scotty85

    scotty85 Guides Guide

    sorry i didnt see this earlier... im glad it worked for you the 2nd time. :cool: also thanks for reporting back
  23. scotty85

    scotty85 Guides Guide

    i dont have an inc 1 with 2.3.4 to double check,but i thot when i had last looked,it was just like my thunderbolt and inc 2,with "power" having its own setting in the main menu(little battery icon).

    sorry if its different and caused you confusion. the important thing is that you found it,and unchecked it :)
    iowabowtech likes this.
  24. royfranz

    royfranz New Member

    Thanks. I finally got something to flash from hboot - the official gingerbread image that was extracted from the RUU exe (md5sum of the zip 4b7e23b052520978dcd100f008880f82 can't post links)

    I think the problem was that I was trying to burn unsigned images from hboot with s-on. Is this even possible? I'm not clear on exactly what s-on restricts.

    It looks like I'm back to stock, don't know if I'll try to root again :)
  25. scotty85

    scotty85 Guides Guide

    s-on basically is "security on" and checks for signed by htc official files.(why we want s-off ;))

    i think you were using the wrong download,or there was some issue with it,as if you were on GB and trying to flash the 2.2 ruu,you would typically get a "main version higher" or "main version newer" error,as the s-on will not go backwards in firmware.

    i believe that you have prolly done the first parts of the guide correctly,since you didnt get one of those errors.

    the PB31IMG is a signed version,just like the GB image that you flashed. if you get a good download,i think you will be able to completel the guide and get s-off :)
    iowabowtech likes this.
Loading...
Thread Status:
Not open for further replies.

Share This Page