[How To] Root 2.3.4/downgrade and Get S-off


Thread Status:
Not open for further replies.

Last Updated:

  1. n7okn

    n7okn New Member

    I have spent the last 3 hours reading and skimming this entire thread. Wow what a lot of information. Unfortunately when you are only reading for information purposes, a lot goes over your head unless you're following post by post actually doing the steps. I see there have been a variety of processes that can accomplish the same thing over the evolution of this thread, I just haven't really discovered which one is best for me. My Droid X got a big gulp of seawater, and that ended its life for good. I purchased a dinc on Craigslist, and this is what the boot menu says: IncredibleC XD SHIP X-ON
    hboot 0.92.0000
    Radio 2.15.10.07.07

    I don't know if OTA or factory installed GB, but it is definately GB. Can someone point me to the post number in this forum for the easiest and best way for THIS phone to be rooted and S-OFF? I used RadioComm and RSD to completely make my life heaven with my DX, and now this incredible is a completely different animal, I'm afraid I need to learn how to crawl all over again. I could dive into the first post and follow the instructions, but along the way I see that others have made it simpler, so I'm not looking for a rehash, just a good starting point for the latest, for my particular phone.

    Advertisement
  2. clipperqb

    clipperqb Well-Known Member

    After a little trial and error getting drivers to load it looks like a got root access. Superuser permissions shows up in app drawer. I installed a file explorer to test. Thanks!
  3. vitod

    vitod New Member

    Follow the instructions in post 1. This was my first time rooting a phone and it is now running flawlessly with cyanogenmod 7.

    There was one hiccup, and I found the answer in the middle of this thread somewhere, so I will mention it again here: when windows asks for drivers for new hardware during the unrevoked process, install the drivers every time it asks, even if you have already installed them.

    Thanks for this great thread.
    n7okn likes this.
  4. robotarmy

    robotarmy New Member

    i'm having a problem at this step:

    Code (Text):
    1. # /data/local/flash_image misc /sdcard/mtd0.img
    i searched this thread and google and haven't found an answer, hope someone here can help.

    after inputting that above command in the ADB shell, i get the following response:

    Code (Text):
    1. [1]   Illegal instruction     ./flash_image misc /sdcard/mtd0.img
    if it matters, i'm doing this thru Ubuntu. in the ADB shell, i can cd to /sdcard/ and see mtd0.img and PB31IMG.zip. i did the chmod 0755 on /data/local/flash_image. i hooked the phone up to windows and confirmed the sdcard is fat32. i am connecting to the ADB shell with the phone in charge only mode and with usb debugging enabled.

    thoughts? help, please :)

    EDIT: NEVERMIND, I RE-DOWNLOADED flash_image AND mtd0.img AND NOW IT WORKS.
  5. n7okn

    n7okn New Member


    OK I feel much better about starting this Thanks for the great advice. I only had reservations about doing it post 1 because others later on had hinted to a far easier way but didn't know if it applied to me.

    I'll report on how I manage.
    Stacheapalooza and scotty85 like this.
  6. Sorry if this has been fixed before but I haven't seen it.
    The info I see at the hboot screen is this.

    INCREDIBLE XD SHIP S-ON
    HBOOT-0.92.0000
    MICROP-0417
    TOUCH PANEL-ATMEL224_16ab
    RADIO-2.15.10.07.07
    Jul 23 2010, 18:06:51

    I have formatted the sdcard to FAT 32 and placed the PB31IMG zip on the card.
    It loads and when it goes to check it says "Main Version is older! Update Fail! Do you want to reboot device? <VOL UP> Yes <VOL DOWN> No"

    When I choose yes it goes to the HTC Incredible white screen and stays for a bit then goes right back. It is stuck in that loop until I take out the battery and go back to the hboot.

    The only way my computer (PC Vista 32bit) recognizes it is when I use the Android SDK and go into DDMS and mount it as a USB drive.

    If anyone could please help I'd truly appreciate it.
    I have not been able to use my phone properly since last night.
  7. scotty85

    scotty85 Guides Guide

    Are youable to get to clockwork recovery thru hboot?

    If so try wiping cache and dalvik cache and see if that lets it boot. If not,you can restore a backup or flash a Rom
    iowabowtech and Stacheapalooza like this.
  8. When I wiped the cache partition it showed a white box with an arrow coming out and pointing to the little green android guy.
    After that, before I wiped the Dalvik cache, it showed a message stating "E:Can't mount /dev/block/mmcblk1p2
    (File exists)"
    What does that mean? Also, it still says "Main Version is older! Update Fail!"
  9. scotty85

    scotty85 Guides Guide

    Did you try restoring a backup or flashing a Rom?
    Stacheapalooza likes this.
  10. I apologize for my ignorance but I'm very new to this.
    How would I go about flashing a rom? I don't believe a backup was created.

    When I try to use unrevoked recovery tool it says the following:
    Device "/sbin/sh: getprop: notfound" is not supported at this time.
  11. scotty85

    scotty85 Guides Guide

    rest assured,your phone is not dead. the main version higher error is simply becasue at some point your adb steps failed to rewrite the misc image so that the downgrade will be allowed.

    the cant mount error is not a crucial one.

    you cant use unrevoked on a non-operable phone :eek:

    there are lots of guides and tutorials on flashing roms,so i cant really go into that here. you may have to search the forum,or start a new thread if you cant find what you need.

    the basic steps are:
    -find a rom(id just pick a stock one for now)
    -put it on the root of your sd card(not inside a folder) with a card reader,or toggling usb storage in recovery
    -use the menus in recovey to wipe data/factory reset
    -wipe cache and dalvik cache(even if you still get the errors)
    -flash the rom

    sorry i cant be more specific on the menu selection,but i dont use clockwork on my phone,and my memory isnt what it used to be :eek:

    that should get you back to a working phone,and you can retry the adb steps to downgrade.

    in an absolute worse case scenario,you just need to run a gingerbread ruu to restore your phone to factory gingerbread. this will unroot you,however,so youll have to start from square one with unrevoked 3.22 to root again.
    -
    iowabowtech and Stacheapalooza like this.
  12. When you say flash the rom, do you mean pull the battery out and get back to hboot and let it run/check?

    If so, it still brings me to that main version is older error.

    Also, I have the froyo RUU but HTC sync and the RUU don't recognize my phone even when the SDK DDMS does.

    How would I go about having it recognized?
  13. entsc

    entsc New Member

    hi all - this is my first time trying to root on a s-led incredible.

    so far i've followed the guide and i'm currently rooted with s-on. i'm looking to do the rest of the steps for s-off and put CM7 on my dinc, but i have a question in step 4 about unrevoked. it says to use unrevoked forever, but the link goes to unrevoked3. should i just use the link in the guide, or follow the steps in this one - unrevoked.com/forever (sorry, cant post the link since it's my first post..)

    i'm just asking because if it's in the link above, the radio baseband version on my phone, 2.15.10.07.07, is not listed on that list.

    apologies if this is a silly question, but just wanted to be sure since the guide says use unrevoked forever but the link goes to unrevoked3. appreciate the guide and and thanks for your help!
  14. sdrawkcab25

    sdrawkcab25 Well-Known Member


    You need to follow the steps that rewrite your misc.img then run the froyo PB31IMG.zip to downgrade.. then you can run unrevoked forever.
  15. sdrawkcab25

    sdrawkcab25 Well-Known Member


    Scotty is assuming you have clockwork recovery installed on your phone, is that correct? When you boot into hboot and select the recovery option, what appears on your screen?
    If you don't have clockwork you need to start from the beginning of the guide.

    PS remove the PB31IMG.zip file you have on your SD card, you are not ready for that step yet..
  16. A black screen with white lines on the sides.
    When I use the sdk/DDMS it says clockwork recovery.

    Am I perhaps doing something wrong?
    I am very unfamiliar with this and not sure if I am flashing the rom correctly or not.
    What I currently have on my phone's sd root is the PB31IMG from the first step of the first post on this thread.

    I also have the Froyo RUU and read somewhere that I should put that on my sd card root and either rename it update.zip or PB31IMG.zip.

    Is that true?
    I appreciate the responses as I've been stuck with my phone like this for almost two days now.
  17. scotty85

    scotty85 Guides Guide

    no,you flash the rom in clockwork recovery.

    -remove your sd card,remove PB31IMG from it.
    -place a stock rooted rom on your sd card.
    -boot into hboot
    -select recovery with the volume rocker and power button after the green writing flashes
    -in clockwork recovery:
    --use the menus in recovey to wipe data/factory reset
    --wipe cache and dalvik cache(even if you still get the errors)
    --flash the rom

    dont worry about your phone being seen right now.
    iowabowtech and Stacheapalooza like this.
  18. sdrawkcab25

    sdrawkcab25 Well-Known Member

    You have an incompatible version of clockwork on your phone, head to pvillecomp.com and go to the recoveries section. Download the latest clockwork recovery and rename it to PB31IMG.zip and install with hboot. This will give you a working recovery where you will be able to install a working from.

    Again, remove the file you currently have on your SD card.

    Alternatively you can download the gingerbread PB31IMG.zip file and this will put you back where you started.
  19. scotty85

    scotty85 Guides Guide

    sdraw,that is correct... im assuming he has clockwork based on this post:

    maybe it would be better to to just flash a GB PB31IMG since you are becoming fustrated with a non working phone.
    iowabowtech and Stacheapalooza like this.
  20. scotty85

    scotty85 Guides Guide

    he wont be able to do that,he hasnt completed the downgrade,so hes still s-on.

    i think at this point we need to find a PB31IMG for 2.3.4 so he can get his phone working again.

    edit:
    download this PB31IMG of gingerbread

    check its md5. should be: 25ec451e08cd98c9495971bcb37e6582

    rename PB31IMG and put it on yuor sd card in place of the froyo one.
    iowabowtech and Stacheapalooza like this.
  21. sdrawkcab25

    sdrawkcab25 Well-Known Member


    Oh yeah, not thinking lol
    Gingerbread file can be found here:
    http://pvillecomp.com/?page_id=22

    Put the PB31IMG.zip on your SD card and install in hboot, easiest just to start from scratch

    Edit again: all yours Scotty lol
  22. Thanks for the help! I'm currently downloading the gingerbread stock you linked me to.
    I hope this works. I have about 19 mins left in the download.
    Now if this works, how should I go about rooting this phone or should I not even try?
  23. scotty85

    scotty85 Guides Guide

    The other thing we need to be concerned with is your battery charge. I would power the phone off and plug it in... I'm not sure if it will charge in its current state or not. Do you have an external charger or extra batteries?

    You don't want to attempt an ruu flash without at least 40% charge(I always reccomend 100%)
    iowabowtech and Stacheapalooza like this.
  24. I have a wall charger and can use that. I've had it hooked to the computer for a good amount of time.
    Is there a way to check the charge to see how much battery life I have left?
  25. It's aliiiiivvvveeee!!! :D

    If I do indeed want to risk rooting again. How should I go about it?
Thread Status:
Not open for further replies.

Share This Page