[How To] Root 2.3.4/downgrade and Get S-off


Thread Status:
Not open for further replies.

Last Updated:

  1. sdrawkcab25

    sdrawkcab25 Well-Known Member


    You'd follow the steps in the first post again. Just make sure you don't miss any details. The one important one is to put the correct version of clockwork into unrevoked before you start rooting.(that is where you fouled up last time). *Before* you plug the phone into your PC, start unrevoked and you'll be able to click the menu option in the top left of the program to select an alternate recovery. Then you can plug the phone into the PC.

    Another key step is to get organized, download all of the files necessary and put them all in one spot, make sure you can easily identify what each one is for(rename them if you have to). Only change the file names to PB31IMG.zip when you are about to use the file and immediately delete it off your SD card when done. Checking the md5 of every file is also EXTREMELY important and will save you from a brick.

    When rewriting the misc.img, make sure you are getting the same responses that Scotty posted in the first post.

    Advertisement
  2. Thanks! I believe that's what happened the first time. I had it plugged in the whole time so it brought up an outdated/incorrect version of clockwork.

    Now it is rooted and has superuser permissions.

    I don't think I'm going to downgrade at this time as I just wanted to be rooted and I'm afraid of doing much more to it at this time.

    Do you think I should downgrade or is this fine?

    Once again, thanks to you and Scotty for all your help!
  3. I tried the steps to downgrade it and two things happened.
    When trying these steps: cd /data/local
    chmod 0755 /data/local/flash_image

    cd /data/local
    ./flash_image misc /sdcard/mtd0.img


    It said "bad substitution" but when I checked the md5 sums they were correct and the mtd0.img file is on my sdcard.

    Secondly, when in hboot and after the blue status bar is finished loading and it is checking the PB31IMG file, it says "Main Version is Older! Update Fail!".


    I rebooted and the phone appears fine and is recognizable by my computer.
    I'm just wondering if I should go through with the unrevoked forever since it didn't update as it was supposed to or what I can do to fix the issues I mentioned.
  4. sdrawkcab25

    sdrawkcab25 Well-Known Member

    you can't do the downgrade via pb31img.zip UNTIL you successfully rewrite the misc.img. Those files don't go on your sd card, they stay on your computer in the same folder as mini adb. Unless you get the same outputs that are in the first post you will not be able to downgrade.
  5. Thanks! I was entering the commands wrong.
    I do have a question about unrevoked forever.

    According to the information it does not list my radio baseband as being supported.
    My radio baseband is 2.15.10.07.07. Will this change after it is done downgrading?

    I have another question but this is about titanium backup (not pro).
    When I go to forcibly remove app it brings me to the clockwork screen and doesn't remove the app I selected.
    Is there a better way to remove the built in apps like skype, slacker, and amazon mp3?

    Also, not sure if I should ask here but how would I go about removing carrieriq?
  6. beckettcj

    beckettcj New Member

    I'm having a bit of the same problem.

    I'm in ClockworkMod Recovery v5.0.2.0 which, as far as I can tell, is the most up-to-date version. However, when I click on one of the options, it brings me to a black screen with the tophat, orange arrow logo and doesn't do anything else. When I attempt to install the zip file from the sdcard, it brings me to the same screen. I have to end up removing the battery to get the phone to do anything.

    Any thoughts? This is my first time rooting my phone and it's a bit confusing but I've figured my way this far. I'm just totally stuck at the moment.
  7. beckettcj

    beckettcj New Member

    Oh wait, I figured it out. I gotta use the camera button.

    And here I thought it was a super complex problem!
    scotty85 likes this.
  8. sdrawkcab25

    sdrawkcab25 Well-Known Member


    The downgrade changes your radio to a compatible version. You can't remove apps with titanium until you have downgraded and achieved s-off.

    Carrier IQ doesn't exist on the incredible.
  9. I cannot say it enough. Thank you and Scotty so much for the help and the quick responses.

    I was not aware that my phone never had carrieriq. Glad to hear it, though.
  10. scotty85

    scotty85 Guides Guide

    i am of the fairly firm opnion that it is much better to be s-off,as long as this power is used responibly ;) it offers many advantages by being able to flash unsigned by htc files thru the bootloader. this means you can flash older RUUs if you want,and you can flash hboots,radios and recoverys in hboot.

    in the case of a soft brick,there are many more options for recovery. for example your situation before. if you were s-off,sdraws suggestion to simply flash the latest clockwork recovery in hboot would have been a good one,even the best one :D. you could have done that and had a recovery you could see,so you could wipe cache and dalvik,and be able to falsh a new rom and stayed rooted.

    since you were s-on,our only choice was htc signed files. since you cant flash older ones(as you found out from trying to flash the froyo one and getting the main version higher error) our only option to save you was the PB31IMG of GB that you flashed. luckily it worked ;) (j/k i had faith it would) while it got you back to a working device it wipe out all your root,your recovery, and personal data.

    technically you could stay rooted and s-on and flash roms,etc,but IMO its worth the effort to downgrade and get s-off,even if you only plan to run a stock rooted,debloated rom.

    as sdraw said,there was error somewhere in the adb steps. when youre feeling up to trying it again,follow the directions in the first post to copy the text in your command window before you let it close.

    then if the PB31IMG fails,as it did this time, paste it into a reply at the end of this thread,and we can figure out where it went wrong. i find seeing the paste of the code to be very helpful in determining adb errors :)
    iowabowtech likes this.
  11. hsxpunisher

    hsxpunisher Member

    well, i have spent the last 4 hours reading this entire thread and so far i can't fix my problem: whenever i try booting i get the black screen with the white bars. from what i understand this means that my phone is slcd. in the second step of it says to change the phone to debug and make sure that it is in charge only mode. i did that and then kept following the instructions to open unrevoked and then i was unable to do file>custom recovery. from what i can tell this means that i didn't get the update version of cwm. i've tried all the things that have been mentioned. the last thing i tried was getting the updated recovery image from pvillecomp and putting it on the sd card. that seems to load fine. then i try recovery and i get the black screen and white bars again. at the top of the screen i have:

    hboot 0.92.0000
    radio 2.15.10.07.07

    any ideas? if nothing fresh, could someone please consolidate things i should try? maybe i missed something

    thanks
  12. scotty85

    scotty85 Guides Guide

    you can just run unrevoked 3.22 again. this time do not plug i your phone until after youve selected custom recovery on the unrevoked screen.

    or you can just continue with the downgrade. having a working clockwork is not important to the process of downgrading,its an extra bonus in case you want to make a backup of your current setup. :)
    iowabowtech likes this.
  13. hsxpunisher

    hsxpunisher Member

    when i try to run 3.22 it says "device '/sbin/sh: getprop' is not supported at this time". and i've also tried to continue with the downgrade but when i put 2.2 on the sd, it loads and then gives me the message about it being and older version and i can't figure out what to do about that. and when i do "adb devices" it doesn't find any
  14. scotty85

    scotty85 Guides Guide

    if youre not getting a reply at "adb devices" then none of the rest of the commands are going to work,resulting in the "main version higher" error since the misc img isnt being re written

    make sure you have usb debugging checked,and you have the phone in charge only mode. if you do,then you prolly dont have the drivers installed.
    iowabowtech likes this.
  15. hsxpunisher

    hsxpunisher Member

    yup when i started the whole thing i made sure that i checked usb debugging. what drivers do i need? the htc sync ones?
  16. scotty85

    scotty85 Guides Guide

    unrevokeds drivers should work. link is in the first post :)
    iowabowtech likes this.
  17. hsxpunisher

    hsxpunisher Member

    oh the ones so that i can see the phone in device manager? i went through that too. the GB ruu exe starts up but then tells me i need at least 30% battery. when i started this i had a full battery and i don't think it would have gone down that fast. guess i will just try again tomorrow after its plugged in all day and if it says the same thing i will take it to the store to have it charged
  18. scotty85

    scotty85 Guides Guide

    will your phone not boot after pulling the battery on the black screen? if not,just leave it off and plugged in for a couple hours. that should charge you enuff to runthe RUU
    iowabowtech likes this.
  19. hsxpunisher

    hsxpunisher Member

    it pops up a white screen that says htc incredible and stays like that for like 20 seconds and then makes a buzzing sound kind of like a camera zoom and then the screen either goes completely black or black with white on the sides.
  20. scotty85

    scotty85 Guides Guide

    ahh. leave it plugged in while off a couple hours and you should be good to go to run the ruu. worse case,you may have to take your battery to vzw to charge for you
    iowabowtech likes this.
  21. hsxpunisher

    hsxpunisher Member

    alrighty. thanks for your help!
  22. hsxpunisher

    hsxpunisher Member

    well the store didn't have any phones to charge it in and no other ways either. when i checked it this morning after having been plugged in during the night, it had a green light. when i plugged it into the computer the light was red again. maybe i just totally messed it up. oops
  23. scotty85

    scotty85 Guides Guide

    maybe your battery is shot? or maybe its just not getting anuff of a charge with the rom not working. if you can find a way to charge your battery you should be good to go,nothing youve done should have resulted in parmanent damage. :)
    iowabowtech likes this.
  24. hsxpunisher

    hsxpunisher Member

    alright. i found a wall charger that you just put the battery in on amazon for like 5 bucks so i guess i will try that out. i sure hope its just a problem with charging
  25. franklin0819

    franklin0819 New Member

    Hello everyone. I am new here. I am trying to reroot my phone. I was trying to get the newest update to happen and was unable to. So I removed the root and turned s back on.. Well after the update I was not able to reroot. I should of read the fourms before doing this. I would of left it alone and rooted in the first place. Well I was reading the fourms here and was able to get my super user permission installed by following steps from scoyyt85. But would like s-off. I am confused by this part.extract the mini-adb_inc .zip. place the extracted folder on the root of your c\ drive. it comtains mtd0,flash_image,and some adb tools. does this mean I take the 8 folders and place them into the c drive of my computer??????? Because if so I can't get the command to reconize the commands when I copy the bold text. :mad:
Thread Status:
Not open for further replies.

Share This Page