[How To] Root 2.3.4/downgrade and Get S-off


Thread Status:
Not open for further replies.
  1. scotty85

    scotty85 Guides Guide

    Yup... it was tried on the original xda thread. Results in a "baseband not supported" error. :(

    Downgrade still needed to s-off. At least until unrevoked supports the new one,or we figure out how to change basebands in recovery.
    iowabowtech likes this.
  2. iowabowtech

    iowabowtech root@android:/ # Moderator

    Agreed, downgrade needed. Tweeted Unrevoked last night, never know. I think the chance of changing basebands in recovery is zero, must be done through hboot.
  3. PSUBALL10

    PSUBALL10 Well-Known Member

    Im stuck after the command prompt where it takes me to HBOOT. When i select "bootloader" I am getting these messages:
    SD Checking........
    Loading.....<PB31DIAG.zip>
    No image!
    Loading.....<PB31DIAG.nbh>
    No image or wrong image!
    Loading.....<PB31IMG.zip>
    No image!
    Loading.....<PB31IMG.nbh>
    No image or wrong image!
    (I think this is what it is saying, it flashes quickly)

    Any idea what i am doing wrong?
  4. scotty85

    scotty85 Guides Guide

    Either your SD card is not formatted FAT32, or your PB31IMG is not named correctly.it must be seen by the phone as "PB31IMG.zip".

    Common error is to name the file "PB31IMG.zip.zip" since windows automatically adds,and hides,the file extension. If you're not using windows,you'll need to add the ".zip" file extension wen naming the file :)

    Edit: those images are exactly what you should see. After they quickly flash is when you'll see the blue status bar when the SD is correctly formatted,and the file named correctly.
    iowabowtech likes this.
  5. PSUBALL10

    PSUBALL10 Well-Known Member

    I will try and reformat the card, but it was FAT32 and the name of the file is PB31IMG.zip i have windows set up so it doesnt hide the extension.
  6. scotty85

    scotty85 Guides Guide

    did you verify the md5 of PB05IMG.zip?

    are you sure it was FAT32,and not just FAT?

    assuming the file is placed on the root of the sd,there are ONLY 2 reasons the phone doesnt find it:
    1)sd NOT FAT32(or possibly bad)
    2)file incorrectly named

    you might try a different sd if your 100% sure those 2 things are correct
    iowabowtech likes this.
  7. PSUBALL10

    PSUBALL10 Well-Known Member

    PB31IMG.zip checks out, it matches.

    The card is definitely FAT32 and the file is named correctly. I could try another card, but that card was working fine in the phone before i started this process.

    If i try a new SD card can i just boot the phone into HBOOT or do i need to go thru the entire command prompt again?
  8. scotty85

    scotty85 Guides Guide

    if you reboot the phone,youll need to do it all again. im not certain if the misc image will change by just powering off and then back into hboot. worse thing that will happen is a"main version higher" error and youll have to boot and start over.

    not sure what else to tell you...

    either the card is inside a folder,not FAT32,the card is bad or needs reformatted,or the file is not corectly named.

    you verify the file by downloading an md5 sum checker,like the one listed in the first post. use that to find an md5 for your downloads,and compare them to the ones listed underneath all the files :)
    iowabowtech likes this.
  9. PSUBALL10

    PSUBALL10 Well-Known Member

    Ok i tried another SD card and i am getting the same results. Does it matter that when it boots to HBOOT it continues to switch between HBOOT and HBOOT USB PLUG and FASTBOOT and FASTBOOT USB
  10. scotty85

    scotty85 Guides Guide

    Hmmm,thats not normal. Might try it with the phone unplugged.
    iowabowtech likes this.
  11. PSUBALL10

    PSUBALL10 Well-Known Member

    Still not working after unplugging after it loads to HBOOT. Any other ideas on what i can do?
  12. kicksave41

    kicksave41 Member

    Just to be clear....these procedures would allow a user that has never rooted and received the GB OTA to gain root access?
  13. iowabowtech

    iowabowtech root@android:/ # Moderator

    Yes.
  14. scotty85

    scotty85 Guides Guide


    You are leaving he PB31IMG.zip zipped,correct? Did you verify the md5?
    iowabowtech likes this.
  15. PSUBALL10

    PSUBALL10 Well-Known Member

    Yep, and everything checked out. I am trying it again from the beginning this morning on my work computer. So far the only thing that appeared strange was when i got into clockwork i was getting an "error verifying extendedcommand" Is this a problem?

    UPDATE: No clue what i did different but it appears to be working correctly now, thank you very much for the help! :)
  16. scotty85

    scotty85 Guides Guide

    Find your PB31IMG on your phone with a file manager and tell us exactly how your phone sees it.
    iowabowtech likes this.
  17. PSUBALL10

    PSUBALL10 Well-Known Member

    I spoke to soon, after installing the PB31IMG it contiunes to just reboot. Gets to the droid eye hangs up and then starts the boot all over again......

    UPDATE: Reinstalled the PB31IMG thru HBOOT and it loaded fine.
  18. ETPW

    ETPW Member

    Guys help me out if you dont mind. Im new to rooting and have a DINC 2 2.3.4. It was on 2.2 and updated to 2.3.4. I wished I would have opted no for it but anyhow...
    Been reading this thread since it started and cant get pass the first few steps.
    My computer doesnt recognize my phone when turned off to download usb driver. When its turned on it does recognize it but says it cant fiind software when I try to update it.
    Another issue is when I open the revoked page and paste the md-5 it says custom and waiting for device. When I plug my phone in it does nothing.
    I would appreciate any help as trying to figure this out is taking up to much of my time. So Im turning to you.
    Thanks again.
  19. scotty85

    scotty85 Guides Guide

    dont forget you need to have USB debugging checked on in your applications/development settings.

    all i did was let the windows,and let the wizard install the drivers,and it worked for me.

    best advice i can give is to l read the unrevoked wiki(the page you downloaded the drivers from) on installing the drivers,and install them in that manner. put the download somewhere you fain find it,put your phone in fastboot by selecting "fastboot" from the "hboot" menu. get to hboot by powering off,then holding the vol down rocker while powering on.

    once youre in fastboot, youll need to find your device in "device manager" if yourusing windows,right click on it,and update the drivers. pick search your computer for drivers,then navigate to your download.

    in a nuthsell :)


    im not sure what youre doing here... you are a lil confused about something. when you click file,then custom recovery,you need to find and click on the recovery 5.0.2.0 image. you dont need to past the md5 anywhere.

    after you get the drivers installed,and pick your custom recovery,it will be easier. :)

    do you know if you are slcd? or amoled? if youre amoled,you techincally could just run unrevoked without changing the recovery. it will install an older one,but if youre amoled youll be compatible so its not too big of a deal.
    iowabowtech likes this.
  20. ETPW

    ETPW Member

    Thanks Scotty. I will try what you suggested. I actually started doing what you mentioned with md5 before I posted and it still didn't work. Usb debugging is checked on.
    Not sure if i have an scld or amoled. Don't really know what that means either lol. Tell me how I can find out.
    Thanks again.
  21. scotty85

    scotty85 Guides Guide

    amoled or slcd refers to the screen type. you can find out what you have by checking settings/about phone/hardware

    if you have 002 you have amoled
    003 you have slcd

    slcd is newer,and attempting to run some older firmwares,recoveries,roms,etc. casues the inc to have just a black screen(functional,but not visible)

    so if you have an 002,you can skip the change to custom recovery part,if you want to. :)
    iowabowtech likes this.
  22. ETPW

    ETPW Member

    Hardware version is 0001. Am I screwed?
  23. Rooter28

    Rooter28 Member


    If you have a Dinc 2 as your post says this will not work and you should use Alpharevx's Revolutinary tool.
  24. iowabowtech

    iowabowtech root@android:/ # Moderator

    Yeah sounds like possibly a wrong phone situation. Dinc2 = no go with this method. Mistype or is that actually the phone you're running?
  25. SCREWd2V

    SCREWd2V New Member

    hey guys. new incredible 2 user. had a droid inc 1 and droid x which i had rooted so i'm somewhat savey lol and this should be simple right??!?

    but.....
    murphy's law always tends to creep up and bite me in the ass from time to time.

    so following instructions that are given by the OP. downloaded all the files, doing the deal, but can't seem to get the drivers installed correctly.

    get to the h-boot screen, go to usb h-boot. install the drivers how the unrevoked link explains. after complete still in hboot android driver says its installed with bootloader good to go. when i do fast boot, then reboot, my device driver goes back to other devices with the android 1.0. wtf!

    so i try going back into hboot, then when i get there my device driver has it installed already. tried uninstalling it, and reinstalling it.... but when i reboot its back to the same deal. no "Android for ADB" still the other devices with the android 1.0 so unrevoked doesn't recognize it. FML. done this about 4 times now and tried looking in this thread for similar posts but cant find any info on this.... help!

    also FYI after i reboot i get a message on my computer about if i want to allow LT-bootloader or boot something access and when i say yes, it takes me to verizonwireless asking me if i want to install drivers to help my pc communicate with my device. so i installed, same problem. tried uninstalling and saying no 2nd time around after doing the hboot, still same problem.

    hope i can find some help with this situation.

    thanks folks
Thread Status:
Not open for further replies.

Share This Page