[How-To] Root, Custom Recovery, NANDroid Backup


Last Updated:

  1. Mobstergunz

    Mobstergunz Well-Known Member Developer This Topic's Starter

    Joined:
    Sep 5, 2011
    Messages:
    2,896
    Likes Received:
    1,444
    Ok so theres SDK's, and JDK's, and drivers and ..... ahhhhhhhh!!!!! lol all this stuff to know! Don't worry, when it's laid out in an easy to read way, and you actually take the time to read it (<-- Key), this is all fairly simple.

    Requirements:
    -Make sure you have a good charge on your phone. I suggest starting with a full charge.
    -From the home screen of your phone press Menu > Settings > Applications > Development > check mark "USB debugging". This is necessary to root the phone.
    -You need to download Android Terminal Emulator from the market (free)

    Instructions:
    Root
    1) On your computer, download and install THESE DRIVERS on your PC
    2) On your computer, download LG_Esteem_Root.zip.
    3) On your computer, make a folder right on your desktop and name it "fun" or anything you want.
    4) On your computer, using 7zip, winzip, winrar or whatever tool you want, take the contents out of Lg_Esteem_Root.zip that you downloaded in step 2, and place those contents into your "fun" folder you created in step 3.
    5) Plug your USB cable into the computer and then into your phone.
    6) Assuming you followed instructions and enabled USB debugging, you should see an icon in your notification status bar on your phone that says "USB Debugging". Pull down notification status bar and select "charge only"
    7) Inside of the "fun" folder, double click a file called run.bat ...

    You should see the following on your computer screen:
    IMPORTANT: Please notice below the same code is repeated 4 times when this exploit is run. Be aware of this. You are not stuck in a loop. This is intentional and how it's supposed to work.
    Recovery
    STOP
    It is very very important you read THIS LINK before continuing.
    STOP

    IMPORTANT - You will want to turn swype off for this portion, trust me. Open any field you normally type text into such as a text message and long press in the input field. A menu will ask you to select an input method, you want android.

    1) On your computer, download Flash_Image.zip.
    2) On your computer, Download VM701_recovery.img
    3) Connect your phone to your computer using the USB cable, pull down notification status bar and select "mount storage" (or similar verbiage)
    4) On your computer, using 7zip, winzip, winrar or whatever tool you want, take the file "flash_image" out of flash_image.zip that you downloaded in step 1, and place "flash_image" on the root of your phones SD card
    IMPORTANT Do not just drag and drop flash_image.zip onto your sd card. The file you are moving is named flash_image, not flash_image.zip
    5) Drag and drop VM701_recovery.img which you downloaded in step 2, onto the root of your SD card.
    IMPORTANT This is a .img file so drag and drop it onto the SD. No need to use 7zip or any other tool to open it.
    6) Unmount your SDcard from your PC and then you can unplug the phone from the PC
    7) Open android terminal emulator you downloaded above and type su [press enter] You should now have a popup asking you to grant the terminal superuser permission, select "always allow"
    8) After granting permission you may now have a spacing issue in the emulator so please close it by doing Menu > Reset Term.
    9) Reopen the emulator and proceed with the following ....
    IMPORTANT - These lines are very specific. If you make a spelling mistake, you'll get an error. If you miss a space, you'll get an error. If you do not enter them EXACTLY as shown below, you'll get an error. Period. If you get an error, you've made a mistake. Try retyping the line you got an error on.

    ----press enter after each line-----
    su
    mount -o remount, rw /system
    cp /sdcard/flash_image /system/bin
    cd /system/bin
    chmod 777 flash_image
    flash_image recovery /sdcard/BobZhome_VM701_recovery
    reboot recovery

    You navigate the recovery as follows:
    Volume button up - Move cursor up
    Volume button down - Move cursor down
    Back button - Go back to the previous screen
    Camera button - select

    Making your first NANDroid backup
    1) From your custom recovery, use the volume down button to move down to highlight the "Backup/Restore" line.
    2) Press the camera button to enter the "Backup/Restore" menu
    3) Press the camera button again to select "backup" and watch it go
    4) Select the reboot system now option from recovery and wait a minute until you're back at your android home screen.

    Thanks:
    - BobzHome - custom recovery
    - csrow - pointing out root method
    - Revolutionary - Creating root exploit (source)
    - Androidcentral.com.
    - Team Hydro
     

    Advertisement
    psxzombie, m4p, lanceg and 4 others like this.
  2. thebryceee

    thebryceee Well-Known Member

    Joined:
    Feb 28, 2012
    Messages:
    2,245
    Likes Received:
    233
    When I type in "chmod 777 flash_image", it says "Unable to chmod flash_image: No such file or directory". USB is unmounted and unplugged. Getting frustrated.

    Edit: I restarted Terminal emulator and it worked. I guess that's what you meant by "reopen" lol.
     
  3. Vexen

    Vexen Well-Known Member

    Joined:
    Jan 1, 2012
    Messages:
    55
    Likes Received:
    0
    mediafire wont let me download all it says is still not downloading, try repairing. any other way to get the recovery image?
     
  4. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    Joined:
    May 13, 2011
    Messages:
    5,625
    Likes Received:
    1,532
  5. Vexen

    Vexen Well-Known Member

    Joined:
    Jan 1, 2012
    Messages:
    55
    Likes Received:
    0
    thanks, but no dice, it still takes me to the same mediafire page, the links aren't broken, but for some reason it just says try repairing over and over
     
  6. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    Joined:
    May 13, 2011
    Messages:
    5,625
    Likes Received:
    1,532
    Just tried it again. Worked for me. It has to be your server.
     
  7. Vexen

    Vexen Well-Known Member

    Joined:
    Jan 1, 2012
    Messages:
    55
    Likes Received:
    0
    idk its just that particular file, all other mediafire files work
     
  8. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    Joined:
    May 13, 2011
    Messages:
    5,625
    Likes Received:
    1,532
    Go to McDonalds or someplace with free WiFi and try downloading from there.
     
  9. jon4hhh

    jon4hhh New Member

    Joined:
    Jul 24, 2012
    Messages:
    1
    Likes Received:
    0
    type bobzhome in front of vm701 recovery
     
  10. superman3000

    superman3000 Member

    Joined:
    Aug 1, 2012
    Messages:
    11
    Likes Received:
    0
    had to rename the file on sd card to match commands
     
  11. g60madman

    g60madman Well-Known Member Developer

    Joined:
    Oct 12, 2011
    Messages:
    1,816
    Likes Received:
    2,690
    Thanks Mobster it worked perfect on my Wife's phone. The only thing that needes to be changed is the following line that I highlighted red.


     
    Mobstergunz likes this.
  12. lanceg

    lanceg Well-Known Member

    Joined:
    Jun 7, 2011
    Messages:
    246
    Likes Received:
    27
    About to give this a shot, but first let me say thank you for such an excellent write up!
     
  13. creed10

    creed10 Well-Known Member

    Joined:
    Apr 4, 2012
    Messages:
    421
    Likes Received:
    60
    When I open run.bat, it says I have to press the enter key to continue. I do, and then it just gets stuck at
    *daemon not running. starting it now*
    *daemon started succesfully*
    It doesn't do anything else. I've already followed all other steps
     
  14. FybrOptx

    FybrOptx Member

    Joined:
    Feb 19, 2011
    Messages:
    5
    Likes Received:
    1
    Had to add .img after BobZhome but other than that it worked great! Thanks!
     
    m4p likes this.
  15. m4p

    m4p Active Member

    Joined:
    Dec 13, 2012
    Messages:
    31
    Likes Received:
    6
    Thank you. It kept saying no such file existed, but after putting in the .img it worked perfect.
     
  16. psxzombie

    psxzombie New Member

    Joined:
    Dec 24, 2012
    Messages:
    1
    Likes Received:
    0
    make sure your USB port is feeding 5V. My USB port on the front of my desktop did the same as you, but then I used the USB port on the back of the desktop. All is well.

    Good luck.
     
  17. nastagol

    nastagol Member

    Joined:
    Jan 5, 2013
    Messages:
    23
    Likes Received:
    3
    why recovery? i know nothing about that , does superuser comes with the root?
     
  18. nastagol

    nastagol Member

    Joined:
    Jan 5, 2013
    Messages:
    23
    Likes Received:
    3
    should i download the optimus slider driver? or this one would work great?
     
  19. nastagol

    nastagol Member

    Joined:
    Jan 5, 2013
    Messages:
    23
    Likes Received:
    3
    yep did same thing to me and followed what you said work greatly , thaks! :)
     
  20. nastagol

    nastagol Member

    Joined:
    Jan 5, 2013
    Messages:
    23
    Likes Received:
    3
    ok nvm i rooted it, do i need to make a custom recovery? or its optional what does it gives?
     
  21. nastagol

    nastagol Member

    Joined:
    Jan 5, 2013
    Messages:
    23
    Likes Received:
    3
    what do ou mean by restarting?
     
  22. ChibiTora

    ChibiTora Member

    Joined:
    Jan 12, 2013
    Messages:
    5
    Likes Received:
    0
    So, I went through every step, to the T. And when I get to the recovery stage, I don't see a root on my sd card.
    Also, the script only ran once for me. (It's entirely possible that I did something wrong. I'm new to all of this)
    root.JPG
     
  23. HaTrEd360

    HaTrEd360 Well-Known Member

    Joined:
    Aug 18, 2012
    Messages:
    1,363
    Likes Received:
    167
    You're lucky I'm still here cuz no one else really comes on here for thia phone anymore lol. The root of the sd card isn't a folder or anything. That just means put them on your sdcard. It needs to be just on the sdcard. NO FOLDERS. Okay? Make sense? :D Also have you confirmed that you are rooted? After you are rooted, open up Superuser app and scroll to the left. Then click on the "tap to check for updates" text, and update the binary. If you get errors, download a update binary fixer app from the Play Store. :]
     
  24. tonzs0420

    tonzs0420 New Member

    Joined:
    Nov 3, 2012
    Messages:
    1
    Likes Received:
    0
    can someone please help iam stuck on second to last step- flash_image recovery /sdcard/BobZhome_VM701_recovery, can someone please tell me acactly what I need to input for this to work?
     
  25. vTizzle

    vTizzle Active Member

    Joined:
    Nov 5, 2011
    Messages:
    44
    Likes Received:
    0
    Im not having any luck with the last step either, typed everything exactly and precisely as shown, and im getting an error saying that there is no such file
     

Share This Page

Loading...