1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

[how-to] root: Gingerbread 2.3.3


Last Updated:

  1. TheSentinel

    TheSentinel Active Member This Topic's Starter

    Joined:
    Jul 22, 2011
    Messages:
    31
    Likes Received:
    12
    ---------------------------------------------------------------------------------------------
    READ THROUGH THESE INSTRUCTIONS AT LEAST TWICE. MAKE SURE YOU DOWNLOAD EVERYTHING NECESSARY BEFORE STARTING THE ROOTING PROCESS.
    ---------------------------------------------------------------------------------------------

    DOWNLOADS:
    Here is the software that you will need to use to get S-OFF:
    Revolutionary

    Here is the superuser .zip file (to get root, the software only gets S-OFF which allows root):
    http://goo-inside.me/superuser/su-2.3.6.3-efgh-signed.zip

    You need to install these HTC fastboot drivers before using the above program:
    public:revolutionary [RootWiki]

    ---------------------------------------------------------------------------------------------
    ***Make sure that you have USB debugging turned 'ON' and Fastboot turned 'OFF'***

    USB debugging:
    Settings > Applications > Development > USB debugging 'checked'

    Fastboot:
    Settings > Power > Fast boot 'unchecked'

    ---------------------------------------------------------------------------------------------

    During the process, the application will ask if you would like to download and install ClockworkMod Recovery. Go ahead and enter 'Y'. It will install CWM.

    After the S-OFF process, reboot the phone. Add the superuser.zip file you downloaded to your sdcard, if you already haven't. Boot into recovery and flash the superuser.zip.

    CONGRATULATIONS! You're now rooted and ready to begin flashing! Don't forget to do a NANDROID backup as well!
     

    Advertisement
    hvrc, stealthtt24, eitucatsuj and 7 others like this.
  2. DFA1

    DFA1 Well-Known Member

    Joined:
    Nov 14, 2009
    Messages:
    210
    Likes Received:
    10
    Waaaaahoooooooo!!!!
     
  3. NightAngel79

    NightAngel79 Bounty Hunter Administrator Moderator

    Joined:
    May 11, 2010
    Messages:
    22,203
    Likes Received:
    7,491
    Thanks for the How to! :)

    Gonna go ahead and sticky this thread
     
  4. seejoshplay

    seejoshplay Well-Known Member

    Joined:
    May 3, 2011
    Messages:
    131
    Likes Received:
    8
    question:

    Once you boot into recovery (by pressing vol down and power), how do you flash superuser.zip?

    would someone mind posting a screenshot? thanks.
     
  5. TheSentinel

    TheSentinel Active Member This Topic's Starter

    Joined:
    Jul 22, 2011
    Messages:
    31
    Likes Received:
    12
    In CWM:

    -select 'Install zip from sdcard' (move down using volume 'down' and select using the 'power button')

    -select 'choose zip from sdcard'

    -select the 'su-2.3.6.3-efgh-signed.zip' on your sdcard

    -select 'Yes - install su-2.3.6.3-efgh-signed.zip'


    It will do the rest for you. Then just go back till you get to the main menu and select 'reboot system now'.

    Hope that helps!
     
    Grub likes this.
  6. Grub

    Grub New Member

    Joined:
    Dec 11, 2009
    Messages:
    2
    Likes Received:
    0
    Got what might a noob question. I have plenty of experience flashing to the Motorola Droid but the DINC2 is a different animal. I have rooted the phone and achieved S-off but Clockwork Mod Recovery has not been flashed to the phone. The only way I can get to CMOD is by going thru Revolutionary. I cannot boot into CMOD directly from the phone. Am I doing something wrong?
     
  7. wildtouch83

    wildtouch83 Well-Known Member

    Joined:
    Mar 5, 2010
    Messages:
    405
    Likes Received:
    24
    do you have to leave Fast Boot unchecked after applying the zip?
     
  8. millkim

    millkim New Member

    Joined:
    Aug 15, 2011
    Messages:
    1
    Likes Received:
    0
    Success! The most confusing part was realizing that I had to enter the serial number after I clicked the link for the download... too many pop-ups, too small of a computer screen... ;-) That was almost as easy as the unrEVOked root for my Inc1! Now to find some decent ROMs...
     
  9. Grub

    Grub New Member

    Joined:
    Dec 11, 2009
    Messages:
    2
    Likes Received:
    0
    Problem somewhat solved. I went to the Android Market and download Rom Manager and flashed it from site. I can boot to Clockwork Mod Recovery from within ROM Manager. Handy little app.
     
  10. falconae

    falconae New Member

    Joined:
    Aug 10, 2011
    Messages:
    3
    Likes Received:
    0
    Everything seemed to install fine per the instructions above. I could start SU but it would not actually do anything. I then DL'd ROM manager, it to would not work but told me the problem was with permissions. So I re DL'd SU from the market and everything fired right up :)
     
  11. greatgoogamoog

    greatgoogamoog New Member

    Joined:
    Aug 10, 2011
    Messages:
    4
    Likes Received:
    0
    YES! It worked like a charm!

    (sent via wifi tether...just as a test, you know)

    Goog
     
  12. TheSentinel

    TheSentinel Active Member This Topic's Starter

    Joined:
    Jul 22, 2011
    Messages:
    31
    Likes Received:
    12
    I'm also working on a detailed set of instructions to revert back to the factory ROM with factory hboot. I'll try to get it up by the weekend.
     
  13. godintraining

    godintraining New Member

    Joined:
    Aug 16, 2011
    Messages:
    1
    Likes Received:
    0
    Successfully achieved S-OFF using this method. However, it failed to install CMR.
    Installed ROM Manager from Market and attempted to install Flash CMR from the app, received "error occurred while attempting to run privileged commands" error.

    Attempted again after reinstalling ROM Manager... same result.

    Any suggestions?

    UPDATE:
    Used the method here to get CWM onto the phone:
    http://forum.xda-developers.com/showthread.php?p=14693680
     
  14. falconae

    falconae New Member

    Joined:
    Aug 10, 2011
    Messages:
    3
    Likes Received:
    0
    GIT, what I said above also would apply to your issue, (that was the permissions error I got) so I just re-DL'd SU and it fired right up.

    -Falc
     
  15. 06gixx

    06gixx New Member

    Joined:
    Apr 1, 2011
    Messages:
    4
    Likes Received:
    0
    my radio isnt workin after doing this.. any ideas?
     
  16. KrippyKreme

    KrippyKreme Well-Known Member

    Joined:
    Jun 1, 2011
    Messages:
    363
    Likes Received:
    31
    Blank
     
  17. wildtouch83

    wildtouch83 Well-Known Member

    Joined:
    Mar 5, 2010
    Messages:
    405
    Likes Received:
    24
    your cellular radio?
     
  18. wildtouch83

    wildtouch83 Well-Known Member

    Joined:
    Mar 5, 2010
    Messages:
    405
    Likes Received:
    24
    anyone know about this?
     
  19. KrippyKreme

    KrippyKreme Well-Known Member

    Joined:
    Jun 1, 2011
    Messages:
    363
    Likes Received:
    31
    Downloaded the Virtuous ROM; isn't there supposed to be a clock/weather widget for the homescreen? I notice as I'm scrolling through widgets, a lot of HTC ones say false.
     
  20. tcraig72

    tcraig72 Well-Known Member

    Joined:
    Jun 27, 2010
    Messages:
    54
    Likes Received:
    2
    I can't get passed "waiting for device" when I run revolutionary....anyone else have this problem?

    **edit**
    My device has been recognized and now the beta key I enter is "invalid". I'm on a Dinc2. Any ideas?
     
  21. john14

    john14 Member

    Joined:
    Aug 15, 2011
    Messages:
    5
    Likes Received:
    0
    pls what is the link to get latest gingerbraed for my HTC incredible 2
     
  22. KrippyKreme

    KrippyKreme Well-Known Member

    Joined:
    Jun 1, 2011
    Messages:
    363
    Likes Received:
    31
    blank
     
  23. KrippyKreme

    KrippyKreme Well-Known Member

    Joined:
    Jun 1, 2011
    Messages:
    363
    Likes Received:
    31

    Use lower case letters, not upper case how you see it in CMD.
     
  24. KrippyKreme

    KrippyKreme Well-Known Member

    Joined:
    Jun 1, 2011
    Messages:
    363
    Likes Received:
    31
    Anyone?
     
  25. APOPHiS420

    APOPHiS420 Well-Known Member

    Joined:
    Jun 13, 2011
    Messages:
    471
    Likes Received:
    52
    Yeah tried that and still got the "Invalid beta key, aborting..." message
     

Share This Page

Loading...