How To Root HTC Wildfire S A510C CDMA Virgin Mobile!


Last Updated: 2013-07-01 13:30:58
  1. rgsgroup2005

    rgsgroup2005 New Member

    First, I'd like to thank Chlinkchlink, Heritz (from XDA), and Superoneclick application for your help and original Root.zip File! Wouldn't work without this!

    I Finally found the perfect method to root this Virgin Mobile Device with S-On (Or OFF)! I Spent 3 days on my customers phone at my computer shop figuring a good method without read/write or freeze errors. I Simply EXTRACTED the SUPERUSER and ROOT files from SUPERONECLICK application and PASTED those files into the ROOT.ZIP File provided. Result? The ULTIMATE ROOT.ZIP MODIFICATION! Below are the methods.... :cool:

    Forget to mention... "I AM NOT RESPONSIBLE IF YOU BRICK/BREAK/THROUGH YOUR PHONE OUT THE WINDOW/ Etc!" That can only happen if you fail to backup your device or fail to read my steps and HTC Dev. Thanks and HAPPY ROOTING!

    Follow The HTC Dev method to unlock your bootloader. Sorry. Due to rules I am too new to submit links. :mad:

    Then install clockworkmod recovery like you would through adb on your computer. Download from attachment. make sure you Extract it!

    Place the clockworkrecovery image inside your Android Adb folder. Place your phone in bootloader usb mode and plug it into the computer. Open command prompt and browse to the folder where you placed the recovery
    example how:
    cd c:/

    cd Android

    Now Flash this bad recovery!
    example on cmd prompt:

    fastboot flash recovery recovery-clockwork-5.0.2.8-marvelc.img

    Now you have clockworkmod recovery!

    Now hit Recovery on your cell...

    Get My Modified Root.Zip File on link attached.

    Now mount USB Storage and make sure your phone is still plugged in to computer.

    Copy my modified Root.zip file you downloaded into the root of your MicroSD Card.

    Unmount USB and flash the Root.zip file.

    Reboot phone and you are now rooted! Donate / Like Me/ And good comments if I helped you!!! :cool:

    Attached Files:


    Advertisement
    encryptd, celita, badboytoast and 5 others like this.
  2. CafeKampuchia

    CafeKampuchia Well-Known Member

    I moved this thread to the All Things Root section since it was about rooting.
    badboytoast likes this.
  3. jorychi

    jorychi Member

    I've been working all night, and had just about given up, decided to google ONE LAST TIME and came to this beautiful post.

    That WORKED!

    Thank you thank you thank you!

    :D
  4. tuss

    tuss New Member

    Hoping someone can help me out. All has worked great up until this point:

    "Unmount USB and flash the Root.zip file "

    I'm not sure what to do here. I have placed the root.zip file in the root directory (stand alone zip file on the sd card, not extracted). Do I use ClockworkMod Recovery --> Install zip from sdcard --> choose zip from sdcard --> root.zip or do I go to the bootloader menu and flash it somehow.

    Much appreciated
  5. tuss

    tuss New Member

    OK. Never mind on the last question. Figured out what I needed to do from the xda-developer website.

    It all works great. Thank you!
  6. jeremy4436

    jeremy4436 New Member

    U Are a life saver!!!!!!!!!!!!
    Been on this for 4 days (wife pissed)
    Now a happier me........ and a happier wife (she has me back)
  7. rinoltz

    rinoltz New Member

    It worked for me too. Awesome. Thank you very much.
  8. jjoshua20213

    jjoshua20213 New Member

    I cant seem to be able to get into the clockwork recovery menu. After flashing the mod I click recovery and my phone just restarts. Boot loader is unlocked. What am I doing wrong?
  9. CafeKampuchia

    CafeKampuchia Well-Known Member

    Joshua, welcome to Android Forums :hello:

    You aren't doing anything wrong. ClockworkMod isn't working right with some of the newer stock ROMs. For now try the hints in this thread t see if you can get it going:
    BLACK SCREEN RECOVERY Solved!! - xda-developers
  10. after you click recovery from HBOOT how long will it take to reboot.... i just have an HTC logo on my phone with a white background....
  11. Caro332

    Caro332 Well-Known Member

    Like Cafe said, some devices have that problem. If your device come with the white HTC screen, at the moment there is no solution...Just have to wait.
  12. savoiu

    savoiu Member

    Has anyone gotten this to work with ROM 3.01.652.1 710RD? I believe this is the latest update on VirginMobile. I've tried many a thing and neither has worked so far. Just found this thread and I'm wondering if it works before I get stuck with a white screen like the user a few posts above.

    Thanks,
    Nick
  13. g2nickk

    g2nickk New Member

    You are amazing!
  14. usaqil

    usaqil New Member

    how do i flash root file
  15. Drakons

    Drakons New Member

    Wow is Clockwork Recovery just a massive garbage program? All it does is constantly crash or won't load when I'm trying to use it. There is another way better program but it won't do your root.zip as it doesn't see it.

    So irritating how everyone sets everything up for CWM and it's garbage.

    Team Win is the program just remembered it. Works every time but it won't see the damm Root.zip.
  16. jonny wad

    jonny wad Well-Known Member

    Try this one...
    http://androidforums.com/wildfire-s-all-things-root/480954-guide-how-root-wildfire-s-s-finally.html
  17. Tarrnation

    Tarrnation New Member

    This procedure worked flawlessly for me on a Virgin Mobile Wildfire S (HTC_A510c). Thank you so much!!! :D

    Now how do I get rid of the annoying "virgin mobile" splash screen every time the phone is turned on/off? I found a guide to do this here but it requires the phone to be S-OFF (mine is S-ON after rooting).

    Any help would be much appreciated.... please keep in mind that this is my first time rooting an android device.
  18. badboytoast

    badboytoast Well-Known Member

    Does anyone have a copy of the twrp recovery 2.2.2? Or could lead me to it! Thanks in advance
  19. savoiu

    savoiu Member

    Was this a recently purchased Wildfire S? What version stock ROM?

    Thanks,
    Nick
  20. Sequoyah517

    Sequoyah517 Member

    I am trying this weekend, will you be on here? I am gonna try to find links to get the files i need for this method.
  21. jesselyons2002

    jesselyons2002 New Member

    It didnt work for me

Share This Page