1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

How to Root Motorola Electrify 2.3.5 for Dummies Guide


  1. iiTweaKz

    iiTweaKz New Member

    100% Working. How to Root your Motorola Electrify 2.3.5 for Dummies Guide.

    Tested on: 2.3.5 version. When you bought your phone from your USCellular Store it came with 2.3.5

    Last night I spent about 5 hours going from forum to forum, webpage to webpage, trying to find a "complete" guide on How to root your Motorola Electrify 2.3.5.

    This guide is being made to make it easier, quicker and simpler for alot of others who have zero knowledge of how to root and do not understand certain steps or "little" tweaks that can fix a seemingly un-rootable phone.


    Step 1.

    Click the Menu Icon at the bottom right hand corner of your phone. Make sure the tab across the top says "All apps" Scroll down and click "Settings" After this scroll down to the bottom and click "About phone" Look for "Android Version" and make sure it says 2.3.5 under it. Now hit the back icon (The Arrow at the bottom of your phone) and click on "Applications" next click on "Development" at the top you will see "USB debugging" click it on. Make sure it has a Green Check Mark.

    Step 2.

    Hit the Menu Icon again and scroll down to and click "Play Store" at the top right hand corner of the screen click the Magnifying Glass and type in "Superuser" and hit enter.
    You will see under apps "Superuser" with "ChainsDD" wrote under it. Click it. Download, Accept and Install. You may be asked to update binaries, but you can't until your rooted, so don't worry about it. (You may see a "#" in your notifications bar at the top of the screen. If you slide down your bar you will see a message like this" # su binary outdated" With sub-text stating "Tap to update su binary" Just leave it there and dont worry about it until later.)

    Step 3 - Time to move to your Computer!

    Now we download the drivers!

    Click the windows icon at the bottom left corner of your computer and click on control panel.
    Click on "System and Maintenance" then click "System" and look for "System Type" it should say 32-bit or 64-bit Operating System. Alternatively click the windows icon and type in the search bar "System" and follow the previous steps.

    Now that you have found your System type, we will download the drivers!

    32-Bit - http://teamuscellula...&attach_id=1165

    64-Bit - http://teamuscellula...&attach_id=1166

    You can save the zip file anywhere, I recommend saving it to your desktop.

    Double click on the folder you downloaded (Either 32bit.zip or 64bit.zip) and then click on Motorola_End_User_Driver_Installation and run the setup.

    Step 4. Are we done yet?

    We are almost there!

    Now we need to create a folder for the root files.

    Click on the windows icon at the bottom left hand corner and click on "Computer" now click on your C: drive. Right click in blank space, go to new and click on folder. Name it "Root"

    Now we have 2 more downloads left, I recommend saving the files to yourdesktop after you click the links.

    ADB Package - http://gititbit.ch/AFAS

    Torpedo Root File - http://www.mediafire...epxfa1a993334rn

    After you are finished downloading, right click on the adb-fastboot.zip and click "Extract All... " Then click browse and locate the folder you previously made by clicking on computer>(C:)>Root

    Move the Torpedo root file there too.

    Step 5.

    Now connect your Phone to your computer using a USB cable. (One should have come with your Phone) After doing this, your computer will start "Installing device drivers" automatically. Just wait until it finishes.

    Back to my Phone!

    Look back at your phone now, there should be a Grey USB Icon in your notification bar at the top of the screen. Slide it down and click on USB Settings.
    Click on "Charge Only" (This step is not necessary, but I find it makes it alot more successful)

    The Final Stretch!!!

    Back to your computer. Click Start>Run> type CMD and hit OK. Or Click Start, type run and click on it, then type CMD and hit OK.

    Now for the fun part! [​IMG]

    Here is a picture of exactly what your screen should look like: [​IMG]

    Type this in the command prompt
    • cd C:\Root
    • adb push photon-torpedo.tar /data/tmp
    • adb shell
    • cd /data/tmp
    • /bin/tar xf /data/tmp/photon-torpedo.tar
    • /data/tmp/photon-torpedo.sh
    • /data/tmp/install-su.sh
    You will get an error message after you type /data/tmp/photon-torpedo.sh
    The error message will say this.

    ERROR: ld.so: object 'libpcprofile.so' cannot be loaded as audit interface: unde
    fined symbol: la_version; ignored.
    Fatal server error:
    Server is already active for display 0
    If this server is no longer running, remove /tmp/.X0-lock
    and start again.
    Please consult the The X.Org Foundation support
    at X.Org Wiki - Home
    for help.
    ddxSigGiveUp: Closing log
    bash: groups: command not found
    root@localhost:/data/tmp#

    All you do now is simply type /data/tmp/install-su.sh and hit enter.

    Please double check the picture I posted above to make sure your screen looks the exact same!!!

    Now you are rooted! But do you want to be sure? YES!

    Go back to your phone now ( you can leave it plugged into the computer, its fine) Click on Menu>Play Store and search for "Root Checker" You should see an app named "Root Checker Basic" by joeykrim download and follow on-screen instructions on your phone. Once finished, just open Root Check Basic and Click on "Verify Root Access"It Should say Congratulations! This device has root access!


    Sources: Big Thanks to mdthomann Over at Android Forums and to
    gr33nd3vil - For all the links to the Downloads [​IMG]


    Like I said this guide is a compilation work of my own comprised of information gathered all over the web after 5 hours of work trying to make sure I could root my phone without bricking it.

    Thanks for your time and I hope you enjoyed the Guide [​IMG]

    Advertisement
    :
    elnaog, JKDS87, evaldez89 and 2 others like this.
  2. jpilgram2010

    jpilgram2010 New Member

    so I type in the first line of the command line commands, and it says "cannot stat 'photon-torpedo.tar': No such file or directory" and nothing else works
  3. meandyoulord

    meandyoulord New Member

    every time I go into CMD I get this error " 'adb' is not recognized as an internal or external command, operable program or batch file. " Is this a windows 7 issue? And is there a way to get by it?
  4. iiTweaKz

    iiTweaKz New Member

    No it isn't a windows issue, I actually ran into this problem myself.

    when in the command prompt make sure you type a capital C:\Root

    because a lower case one (c:\Root) will give you the "adb is not recognized error

    make your the word Root is spelled the same way you named your folder.

    For example if you named your folder Root but are typing C:\root it could "Possibly" not find the folder.
  5. iiTweaKz

    iiTweaKz New Member

    My best advice is to

    1: make sure your typing it in with spaces and such

    2: If your typing it in correctly, i have to ask, did you have 2.3.4 on your phone at one point? Or was it 2.3.5 when you purchased it from the store.

    3: If both the above questions are answered already, then make sure your torpedo file and the adb file are both in the root folder on your C: drive.

    Let me know if none of this helps, also, refer to the picture in my post,,,

    Make sure your type a capital C:\Root, because c:\Root can cause some funky problems.
  6. Pittsteelrs

    Pittsteelrs Member

    I got the electrify when it 1st came out, I had to update to 2.3.5. Does this mean that this root method will not work? Did my phone have to come from the store with 2.3.5? I was rooted when I had 2.3.4 but since the update Ive lost root. Can I get it back now with 2.3.5?
  7. Pittsteelrs

    Pittsteelrs Member

    Hey, I had the same problem but I finally figured it out after ALOT of research. DO NOT EXTRACT THE PHOTON file before putting it in the "root" folder. That is the problem. Once I went back and moved the whole folder from my desktop directly into the "root" folder without extracting it, it worked perfectly. You are suppose to extract the adb-fastboot one into the root folder, but not the photon-torpedo one, just move the whole photon-torpedo file (still zipped, not extracted) into the root folder. Then it will work, or at least it did for me after doing that and I was getting the exact same error as you so you probably did what I did and extracted that file as well instead of just moving it. Hope that helps.
    elnaog likes this.
  8. papelr

    papelr New Member

    I have gotten successfully to the CMD prompt all the way up to the "/bin..." part. After that it says not found and the process cant go any farther. Any help would be appreciated. Thanks
  9. Pittsteelrs

    Pittsteelrs Member

    My only advice (mine did the same thing at first) is to make sure you put the whole downloaded file (still zipped, not extracted) into the root folder you created. Once I did that (for the photon file, not the adb ) it worked for me.
  10. Pittsteelrs

    Pittsteelrs Member

    Also, after you do that you should restart the whole process.
  11. papelr

    papelr New Member

    the photon file comes by itself as a .tar file, and I'm not quite sure what you mean by putting the whole file into the root since it is only a single .tar file. Ive looked in the download file and just cant accomplish your advice. the adb files extracted just like they were supposed to, just not the photon. I have no idea what to do now
  12. Pittsteelrs

    Pittsteelrs Member

    Did you extract the photon file and place it into the root folder you created?
  13. papelr

    papelr New Member

    I placed it in the root folder, but the download only came with the single .tar file, nothing to extract
  14. Pittsteelrs

    Pittsteelrs Member

    What I'm asking is, when you first downloaded the adb file to your desktop it was zipped. You then are suppose to right click on it and "extract all" into the root folder you created correct? Then you download the photon (click the link and save to desktop). When I did this the first time, I well then right clicked on the "photon" file (sitting on my desktop ) and then "extracted all" into the same rootfolder I created that just like I did with the adb file. Instead if doing that, DO NOT extract the photon file (sitting on your desktop )and ingot he root folder. Instead open the root folder and simply. Drag the file straight from the desktop into the root folder. Then start the command process over from the top.
  15. Pittsteelrs

    Pittsteelrs Member

    OK, sounds like you did it right, my only other suggestion then is to recheck what you are typing in the cod section. It has to be Exact. Spaces and all, if it looks like there is a space in something, put the space when you type it. This got me a few times til I realized it had to be exact. Make sure you only type in what is circled in red in the picture showed in the wlakthru and make sure it is EXACT, spaces and all.
  16. papelr

    papelr New Member

    I have done exactly what you suggested but still after the "/bin..." I get the not found message
  17. Pittsteelrs

    Pittsteelrs Member

    Hmmm, I don't know then. That's exactly what happened to me until I redownloaded the file and moved it. Exact same spot, same error message. I was leaving out the space between tar xf and xf /data. I don't man, sorry.
  18. ProcrastiNate

    ProcrastiNate New Member

    Thanks for this guide. I decided to try and I seem to be stuck at the last step. I get the expected error message when entering the photon-torpedo.tar line, but the line after where you need to enter the install su.sh I get an error as well. It says I don't have sufficient permissions. When I installed root checker, it says I have root.
  19. rbeckett

    rbeckett New Member

    this may be a stupid question but can someone tell me what are the benifits and perks to rooting your phone?
  20. agroom

    agroom Active Member

    I bought mine with 2.3.4 and updated it to 2.3.5. I got it back in Nov/Dec 2012 I think and tried rooting it then via another tutorial. If I remember correctly, it was almost identical; however, the install files could have been different/updated.

    I just went through the OPs instructions and got a slightly different output in the cmd window after the /bin/tar xf /data/tmp/photon-torpedo.tar command (photo attached). I just continued with the rest of the commands anyway and after complete I got the root checker app and said I was A-OKAY!

    I then updated the su binary successfully, so I think it still worked!

    BTW - TYVM iiTweaKz!

    Attached Files:

  21. mattbluesman

    mattbluesman New Member

    I got exactly what I was supposed to but when I check for root it says no. I've tried 3 times to no avail. any suggestions?

  22. When i run the las command i keep getting the following error

    $ /data/tmp/photon-torpedo.sh
    /data/tmp/photon-torpedo.sh
    ERROR: ld.so: object 'libpcprofile.so' cannot be loaded as audit interface: unde
    fined symbol: la_version; ignored.
    Fatal server error:
    Server is already active for display 0
    If this server is no longer running, remove /tmp/.X0-lock
    and start again.

    Please consult the The X.Org Foundation support
    at X.Org Wiki - Home
    for help.
    ddxSigGiveUp: Closing log
    /data/tmp/photon-torpedo.sh: line 5: /lib/libphoton-torpedo.so: Permission denie
    d
    ERROR: ld.so: object 'libphoton-torpedo.so' cannot be loaded as audit interface:
    invalid ELF header; ignored.
    Fatal server error:
    Server is already active for display 0
    If this server is no longer running, remove /tmp/.X0-lock
    and start again.

    Please consult the The X.Org Foundation support
    at X.Org Wiki - Home
    for help.
    ddxSigGiveUp: Closing log
    $
    $
    $ /data/tmp/install-su.sh
    /data/tmp/install-su.sh
    Usage: mount [-r] [-w] [-o options] [-t type] device directory
    cp: /system/bin/su: Read-only file system
    Unable to chmod /system/bin/su: Read-only file system
    Usage: mount [-r] [-w] [-o options] [-t type] device directory
    rm failed for /lib/libphoton-torpedo.so, Permission denied
    $


    Any suggestions?
    mjjmama143 likes this.
  23. Cityinnova

    Cityinnova New Member

    Thanks a lot. Was able to root my Motorola Electrify.

    Downloaded all the files and followed the instructions. Though sometimes the result was not exactly as stated, the end result was exactly as promised.

    Congratulations! This device has root access!

    May be one day I would be able to unlock my bootloader as well. Though the Photon and Electrify are similar in hardware, the guides and instructions for the Photon do not work for the Electrify.

    Thanks once again.
  24. BoppinMidge

    BoppinMidge Active Member

    So I'm trying to use this but the adb package link doesnt work. I found your same tutorial on team uscellular but in place of the adb package is some developer sdk, how do I use that?
  25. brobinson2000

    brobinson2000 New Member

    How do I unroot after following this procedure?
Loading...

Share This Page