1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

how to root my xperia pro


  1. raultunk

    raultunk New Member

    How to root my xperia pro

    Advertisement
  2. salmananjum

    salmananjum New Member

    It depends upon the firmware you have got. .62 firmware cannot be rooted without unlocking the bootloader . Firmware below .62 can be easily rooted. Goto XDA Developer Forum to get the instruction.
  3. Madaditya

    Madaditya Member

    Note this is only for Unlocked Bootloaders.

    Downloads
    1.Flashtool-http://androxyde.github.com/index.html?1355542614000
    2.Kernels
    ----->Mt11i_4.1.A.0.562- https://www.dropbox.com/s/ykgfqhns3u41uaf/MT11i_4.1.A.0.562_Kernel.ftf

    ----->Mt16_4.1.B.0.587-https://www.dropbox.com/s/00a739as8boms6w/MK16_4.1.B.0.587_Kernel.ftf

    ----->Mt16_4.1.B.0.431-http://www.4shared.com/file/I7OvtE7m/XPERIA_PRO_MK16i_431_STOCK_KER.html#


    Instructions
    1.Install the flashtool on your Pc.
    2. Go to C:/ Drive > flashtool > firmwares > delete everything present and Put the kernel (Mt11i_4.1.A.0.562)
    3. Run Flashtool click on the flashing icon ( left side below "file" option)
    Select flashmode > ok
    Setup should be like this > select OK
    4.Follow the steps connect your mobile and flash.
    Flashtool may show error after flashing kernel, no worries. Even your build number, android version won't change. Everything would remain same. So please don't go to phone settings to check anything.
    5.Close Flashtool and run DoomLord's tool.
    6.Then again Flash the kernel .587/431(according to steps 2 and 3) Whichever you were using before,Restart and check for 'Superuser' installed
    Enjoy!

    Credits To 'Nabeel' at Sony Developers!
    And DoomLord Ofcourse!!
    Press thanks:good: if Helped .:thumbup:
  4. rajeev12304

    rajeev12304 New Member

    I am using Sony Xperia Pro (Mk16a) with Android 4.0.4 (4.1.B.0.587). I have unlocked the bootloader. But I am unable to root my phone. I have searched all the way and tried almost every method but I couldn't succeed. I downgraded android from ICS to GB (android 2.3). I tried using flashtool and flashing it with "MT11i_4.1.A.0.562_kernel.ftf" and the using "doomlord_v1_xperia-2011-ics-root-emu-busybox-su" and also tried to use "DooMLoRD_v4_ROOT-zergRush-busybox-su_2". I tried also with superoneclick v2.3.3 and "rootmk16". I have backed up my original firmware from SUS. Firstly I was getting error "adb server out of date. killing. daemon not starting". Somehow, I managed to fix it but even though I can't root my phone. I am attaching files which shows the error. While following the method as said on "forum.xda-developers. com/showthread. php?t=1286885" and also on "forum.xda-developers. com/showthread. php?t=1865796". In the prcoess after flasing the kernel MT11i_4.1.A.0.562, I cannot boot my phone to follow the steps. So I have to flash it again to original firmware. I have USB debugging mode on, unkown sources checked and connectivity set to MSC mode. Please help me to root it. images link "tinypic. com/view. php?pic=2z65d38&s=5" "tinypic. com/view. php?pic=10d8q6g&s=5" "tinypic. com/r/14t3hab/5"

Share This Page