How to Root Nexus One on 2.3.4


Last Updated:

  1. elidoperezmd

    elidoperezmd Well-Known Member This Topic's Starter

    Joined:
    Oct 24, 2010
    Messages:
    85
    Likes Received:
    2
    Hi all, i uodated manually to 2.3.4 and want to root but cant find a guide, how can i do this?

    Thanks for your help, and time!
     

    Advertisement
  2. mkrmec

    mkrmec Well-Known Member

    Joined:
    Oct 27, 2009
    Messages:
    236
    Likes Received:
    10
    2.3.3 cannot be rooted on Nexus, why do you think 2.3.4 can :D

    If it's rooted somebody will post the exploit. Untill now it hasn't happened yet.
     
  3. mparker762

    mparker762 Member

    Joined:
    Apr 8, 2011
    Messages:
    10
    Likes Received:
    3
    ???? Lots of guys are running rooted stock 2.3.3 and 2.3.4. It's a Nexus - you don't need to use an exploit to achieve root, you just need to add a couple of files (su, busybox) to it.
     
  4. Hook

    Hook Ever since DU... ;-) VIP Member

    Joined:
    Mar 17, 2010
    Messages:
    1,351
    Likes Received:
    639
    See this thread, it has pretty good information though you should augment it with some research.

    http://androidforums.com/nexus-all-...ndroid-2-3-3-seems-disable-superoneclick.html

    At the very end of the thread, someone posts a new One Click method that purports to work, so you may want to try that first.

    Always, always research. I don't do this stuff until I think I have a clear understanding of what to do and why. It doesn't matter if it turns out I'm wrong about something, if I have a framework, I can at least work back and figure out where my wrong assumption was.
     
  5. mkrmec

    mkrmec Well-Known Member

    Joined:
    Oct 27, 2009
    Messages:
    236
    Likes Received:
    10
    Cool, nice to know I didn't know it 2.3.3 was rooted. Well it's not rootable with oneclick atleast there's that :D

    As I know you can't just install crap if you don't have root, even on a nexus with it's ability to unlock the bootloader wich doesn't give you root.

    But what do I know I run CyanogenMod since 2.1 came out.
     
  6. sun428

    sun428 New Member

    Joined:
    Oct 10, 2010
    Messages:
    2
    Likes Received:
    0
  7. elidoperezmd

    elidoperezmd Well-Known Member This Topic's Starter

    Joined:
    Oct 24, 2010
    Messages:
    85
    Likes Received:
    2
    Wow... i did not expect this many replies, ill get to it right now and post my experience rooting afterwards, thanks very much
     
  8. mparker762

    mparker762 Member

    Joined:
    Apr 8, 2011
    Messages:
    10
    Likes Received:
    3
    Sure, but since you can root a nexus by the simple expedient of unlocking the bootloader, flashing clockwork recovery, then flashing su.zip to the system folder there's really no need for something like oneclick except that it's three clicks instead of one. I've always been puzzled why such programs even exist for the nexus phones at all. The only thing I can think of is that they're probably what the exploit authors are using as development systems; finding the exploits that will be needed by non-nexus phones a year later when they finally get that version.
     
  9. mkrmec

    mkrmec Well-Known Member

    Joined:
    Oct 27, 2009
    Messages:
    236
    Likes Received:
    10
    Yeah you're right, everyone these days wants the phone rooted without being unlocked, I forgot about flashing CWM directly :D Dum Dum :D
     
  10. Kabulldust

    Kabulldust New Member

    Joined:
    May 6, 2011
    Messages:
    1
    Likes Received:
    0
    Just use GingerBreak 1.2 roots 2.3.3 very simply.
     
  11. elidoperezmd

    elidoperezmd Well-Known Member This Topic's Starter

    Joined:
    Oct 24, 2010
    Messages:
    85
    Likes Received:
    2
    GingerBreak 1.2 did not work to root 2.3.4. Ill try the other options above and will report
     
  12. elidoperezmd

    elidoperezmd Well-Known Member This Topic's Starter

    Joined:
    Oct 24, 2010
    Messages:
    85
    Likes Received:
    2
  13. Shanton01

    Shanton01 New Member

    Joined:
    May 9, 2011
    Messages:
    1
    Likes Received:
    0
    You may want to try again. I am running 2.3.4 on my Nexus and these steps worked perfectly for me. Took a total of about 5 minutes to get rooted with these steps. "Fastboot devices" runs with no visible change, but the following fastboot command will push the recovery image.

    Note: when in the Bootloader, you have to click "Bootloader", then click "Fastboot" in order for the fastboot command to run. They did not include that 2nd step in their instructions. Without going back, the fastboot command will just sit there waiting.
     
  14. elidoperezmd

    elidoperezmd Well-Known Member This Topic's Starter

    Joined:
    Oct 24, 2010
    Messages:
    85
    Likes Received:
    2
    DO i need to have my bootloader unlocked in order to root?
     
  15. weirdoooxp

    weirdoooxp Member

    Joined:
    Jun 15, 2011
    Messages:
    6
    Likes Received:
    0
  16. N1nja

    N1nja Well-Known Member

    Joined:
    Jun 29, 2010
    Messages:
    63
    Likes Received:
    5
    That looks like the easiest guide I've seen so far :) but yet it still manages to not work as smoothly as they make it seem.
    Upon trying to run fastboot-oem unlock it returns the message "adbwinapi.dll is missing". A google search returned that that piece comes from having the Android SDK and AVD thing installed. Why does rooting seem like such the daunting task?
     
  17. lunatic59

    lunatic59 Moderati ergo sum Moderator

    Joined:
    Jun 12, 2010
    Messages:
    29,217
    Likes Received:
    20,530
    Yep. And unlocking the bootloader will wipe all data from your phone.
     
  18. N1nja

    N1nja Well-Known Member

    Joined:
    Jun 29, 2010
    Messages:
    63
    Likes Received:
    5
    What about my issue? Just got the SDK and AVD thing and it still gives me "adpwinapi.dll missing"
    Not worried about whats on the phone, got all that backed up.
     
  19. lunatic59

    lunatic59 Moderati ergo sum Moderator

    Joined:
    Jun 12, 2010
    Messages:
    29,217
    Likes Received:
    20,530
    Are you invoking the fastboot command from the c:\fastboot folder or from the [path where you installed the SDK]\android-sdk-windows\tools folder? If you are using the c:\fastboot folder, the go to the tools folder of the SDK and copy the files "adb.exe", "AdbWinApi.dll" and "ddms.bat" to the fastboot folder. Then try it again.
     
  20. N1nja

    N1nja Well-Known Member

    Joined:
    Jun 29, 2010
    Messages:
    63
    Likes Received:
    5
    Thanks, how ever I'm booted on one of my three linux distros and trying it this way.
    It gives me permission denied when doing "./fastboot-linux oem unlock" even when logged in as root.
    Looks like I might have to go back to windows to give it a whirl with your tip.
     
  21. lunatic59

    lunatic59 Moderati ergo sum Moderator

    Joined:
    Jun 12, 2010
    Messages:
    29,217
    Likes Received:
    20,530
    You said you installed the Android SDK. Open a terminal window and change to the tools folder and try "./fastboot devices" to make sure the phone is listed. Then try "./fastboot oem unlock"
     
  22. N1nja

    N1nja Well-Known Member

    Joined:
    Jun 29, 2010
    Messages:
    63
    Likes Received:
    5
    How would I go about doing the devices command in Windows since that's where the SDK is installed, I don't see a "devices" in the tools folder just "fastboot" and it also gives me the adbwinapi.dll missing.
    Maybe I should stick with Linux and keep looking into the permission denied? Has anyone here rooted their N1 in Linux?
     
  23. lunatic59

    lunatic59 Moderati ergo sum Moderator

    Joined:
    Jun 12, 2010
    Messages:
    29,217
    Likes Received:
    20,530
    This should be the contents of your tools folder in the SDK folders:

    You'll notice that the files you are getting prompted are missing are listed.

    There is no devices command it is an operator for fastboot. At the command line type:

    Code (Text):
    1. c:\Users\jsmith\Desktop\android-sdk-windows\tools>[B]fastboot devices[/B]
    You should see your device listed as a number.

    That is assuming you installed the SDK to your desktop and that your username is "jsmith".
     
  24. N1nja

    N1nja Well-Known Member

    Joined:
    Jun 29, 2010
    Messages:
    63
    Likes Received:
    5
    "fastboot devices" returns the adbwinapi.dll is missing.
    Thanks for all the help thus far. Normally I can figure stuff out fairly easy but for some reason when it comes to tinkering with this phone it just gets me.
     
  25. N1nja

    N1nja Well-Known Member

    Joined:
    Jun 29, 2010
    Messages:
    63
    Likes Received:
    5
    Ok, I found and downloaded adbwinapi.dll from the intertoobs and put one each of it in my fasboot folder and sdk/tools folders. Now I can get a little farther, when typing in "fastboot-windows oem unlock" it returns "waiting for device". What am I supposed to do at that point? Is it a waiting game or should it quickly popup the warning on my phone?
     

Share This Page

Loading...