How To Root Samsung Galaxy S 4G Basic Tutorial


Last Updated:

  1. Jimmy.tech

    Jimmy.tech Banned This Topic's Starter

    Joined:
    Dec 14, 2010
    Messages:
    16
    Likes Received:
    2
    Today i m sharing basic tutorial of how to Root Samsung Galaxy S 4G. It is one of the best, easy and safe way to root Galaxy S 4G. Checkout the below the below step to root your Samsung Galaxy S 4G.

     

    Advertisement
    OldFlyer and proudemo94 like this.
  2. zuben el genub

    zuben el genub Well-Known Member

    Joined:
    Jan 24, 2011
    Messages:
    6,531
    Likes Received:
    1,928
    Just a note that a lot of AV programs say Rage is a trojan. NOD32 did, and I think someone said that Avast or AVG did too.

    Also reboot computer after installing Samsung drivers. It doesn't ask you to, or offer to, but you do need to. I got hung up on waiting for device until I rebooted. I hadn't rebooted after I installed the Samsung Driver.
    Z
     
  3. eastbayarb

    eastbayarb Active Member

    Joined:
    Mar 15, 2011
    Messages:
    44
    Likes Received:
    1
    The link to SAMSUNG_USB_Driver_for_Mobile_Phones_x86.rar is not working

    also, you should enable USB debugging first before you start (don't connect the USB cable until you do this) by going to Menu > Settings > Applications > Development.
     
    kristenrose likes this.
  4. adambarrios

    adambarrios New Member

    Joined:
    Aug 4, 2011
    Messages:
    3
    Likes Received:
    1
    Do you know how to root while you're on gingerbread 2.3.3 and you're no able to get into download mode our recovery? Ever since I flashed the update I can't seem to get back into download mode so I'm stick and I can't root now. Thanks
     
  5. sirrazi

    sirrazi New Member

    Joined:
    Aug 15, 2011
    Messages:
    1
    Likes Received:
    0
    i downloaded everything thing u said but for some reason i get stuck on waiting for device... superoneclicks says NOT RESPONDING! (i did wait for like 15 mins too) but no luck..
     
  6. jschofield

    jschofield New Member

    Joined:
    Jan 20, 2012
    Messages:
    1
    Likes Received:
    0
    Shouldnt this be removed? superoneclick does not root gingerbread 2.3.3, 2.3.5 or 2.3.6.
     
  7. eviera

    eviera New Member

    Joined:
    Mar 1, 2012
    Messages:
    3
    Likes Received:
    0
    I did root the phone. how do I uninstall applications installed by default now?
     
  8. eviera

    eviera New Member

    Joined:
    Mar 1, 2012
    Messages:
    3
    Likes Received:
    0
    OK; I managed to root the phone. Now, how do I uninstall applications installed by default?
     
  9. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Joined:
    Sep 10, 2010
    Messages:
    27,513
    Likes Received:
    20,287
    Hello eviera!
    Sorry about the late reply but you can use an app called titanium backup available in the play store. I would recommend buying the ProKey for it also because you can freeze apps before uninstalling them.
    Very well worth the 7 or 8 bucks it costs, but is one of the many apps that root users can benefit from:)
     
  10. diskjockey18

    diskjockey18 New Member

    Joined:
    Aug 14, 2014
    Messages:
    1
    Likes Received:
    0
    I know this is a long dead topic but I am about to throw multiple electronics out a window.I have now run this version of Superclick along with a few others I have found with no success. I am hitting the same roadblocks each time. :dontknow:

    MODEL: SGH-T959V
    FIRMWARE: 2.3.6
    BASEBAND: T959V UVKJ6

    I have erased the phone a few times and rebooted to 2.3.6 to start fresh.

    I took this from SC. I cut out the initial code as it went through with no problem. It all gets hung up with Busybox I think.... Failed whoami? It then continues to get all jacked up and sits without progression at "Shell rooting device step 5"

    ls -l /system/xbin/su > /data/local/tmp/output 2>&1
    export TEMPRANDOM=44938
    export PS1=END:$TEMPRANDOM;cat /data/local/tmp/output
    /system/xbin/su: No such file or directory
    END:44938export PS1=""


    ls -l /system/bin/su > /data/local/tmp/output 2>&1
    export TEMPRANDOM=32082
    export PS1=END:$TEMPRANDOM;cat /data/local/tmp/output
    /system/bin/su: No such file or directory
    END:32082export PS1=""

    chmod 755 /data/local/tmp/busybox > /data/local/tmp/output 2>&1
    export TEMPRANDOM=20197
    export PS1=END:$TEMPRANDOM;cat /data/local/tmp/output
    END:20197export PS1=""

    /data/local/tmp/busybox whoami > /data/local/tmp/output 2>&1
    export TEMPRANDOM=82615
    export PS1=END:$TEMPRANDOM;cat /data/local/tmp/output
    whoami: unknown uid 2000
    END:82615export PS1=""

    rm /data/local/tmp/boomsh > /data/local/tmp/output 2>&1
    export TEMPRANDOM=72599
    export PS1=END:$TEMPRANDOM;cat /data/local/tmp/output
    rm failed for /data/local/tmp/boomsh, No such file or directory
    END:72599export PS1=""

    rm /data/local/tmp/sh > /data/local/tmp/output 2>&1
    export TEMPRANDOM=77310
    export PS1=END:$TEMPRANDOM;cat /data/local/tmp/output
    rm failed for /data/local/tmp/sh, No such file or directory
    END:77310export PS1=""

    chmod 700 /data/local/tmp/zergRush > /data/local/tmp/output 2>&1
    export TEMPRANDOM=88593
    export PS1=END:$TEMPRANDOM;cat /data/local/tmp/output
    Unable to chmod /data/local/tmp/zergRush: No such file or directory
    END:88593export PS1=""

    cd /data/local/tmp/ > /data/local/tmp/output 2>&1
    export TEMPRANDOM=61012
    export PS1=END:$TEMPRANDOM;cat /data/local/tmp/output
    END:61012export PS1=""

    export TEMPRANDOM=80448;export PS1=END:$TEMPRANDOM;./zergRush
    ./zergRush: not found
    END:80448export PS1=""

    I feel that the obvious reason is that my phone is not properly prepared to be given Root. I can not for the life of me figure out what I may be ignoring. Any help would be greatly appreciated.

    Thanks in advance :smokingsomb:
     
  11. awreathafranklin

    awreathafranklin New Member

    Joined:
    Nov 3, 2014
    Messages:
    3
    Likes Received:
    0
    New development! Odin recognizes my phone! I still have the "firmware upgrade encountered" error and Windows still gives me the same USB malfunction error but Odin sees it! I haven't enabled USB debugging though.
     
  12. Vermontguy

    Vermontguy New Member

    Joined:
    Jul 14, 2015
    Messages:
    3
    Likes Received:
    2
    I have tried two different schemes to root my S4 with lollipop including oneclickroot to no avaial.
    I am running Kaspersky AV. can I or should I root in safe mode? I have tried stopping Kaspersky before root but still not successful. Any suggestions?
     

Share This Page

Loading...