How to root Samsung Galaxy S Gingerbread 2.3.6


Last Updated: 2013-07-12 01:27:18
  1. chloe_2013

    chloe_2013 New Member

    I've been searching youtube videos about rooting my Galaxy S however I can't find a link of the file that I need to download and use in Odin HELP! :confused::confused:

    Advertisement
  2. Liamo_210

    Liamo_210 Well-Known Member

    Welcome to the forums.
    I found that this is an easy rooting guide to follo http://forum.xda-developers.com/showthread.php?t=1852546
    Would you please verify if your baseband version is JW4 as if it is you can skip the first section of the above guide and go straight to rooting.
    IF you have any questions about rooting please ask and i have moved your thread to the all things root galaxy s section. ;) :D
    Thanks
    Jesus56Gon likes this.
  3. alscott

    alscott Active Member


    Total noob here looking to root with a view to installing a custom ROM and Ive just found this thread.
    My phone setup is
    Firmware 2.3.6
    Baseband I9000XXJW4
    Kernel 2.6.35.7-I9000XXJW4-CL1043937se.infra@SEP-62#2
    Build no.Gingerbread.XXJW4
    1) So if I follow the link you gave can I just flash the chainfire root which is a kernal? as Im on JW4.
    2) I also have android recovery 3e, will this make any difference or will the 3e be replaced by flashing cf root.
    Feels like Ive read a million posts and learnt a bit before arriving here but some clarification would be great.
  4. Liamo_210

    Liamo_210 Well-Known Member

    Yes you can go straight too the rooting step since you are on xxjw4 and it should be fine. Then you can proceed to the flashing ROM instructions. :rolleyes:
  5. alscott

    alscott Active Member

    Just checked by dialing *#1234# and the Phone and PDA are i9000XXJW4 but the CSC is i9000OXAJW5, does this make any difference. Sorry to be revisiting this point just want to be sure Im not going to brick my phone. Thanks again for a response and your patients.
  6. Liamo_210

    Liamo_210 Well-Known Member

    All I now if its xxjw4 under baseband then your good.
  7. alscott

    alscott Active Member

    Cheers Liamo this worked for me after a bit of panick. I flashed the cf-root with odin and it failed and all I got was a picture of a pc and a phone on a black screen. I removed the battery and repowered which gave me same result. When I plugged the phone into my pc it didnt register in odin, there wasnt a beep when I connected either and it didnt appear to be charging. Aaaaahhhhh. Panicked, then tried three button salute (vol down, home and power) which took me back to download mode. Flashed cf-root again and success. TF..
  8. Liamo_210

    Liamo_210 Well-Known Member

    Glad yo see it worked. I too have got scared a few times when flashing a ROM but usually you just try again and its fine
    alscott likes this.
  9. Jesus56Gon

    Jesus56Gon Member

    Hi Liamo, I am having problems with my SGS when using several apps at a time it hangs up and I have to turn it off and on.
    Looking for similar problems in this forum I saw your root guide. Seems good to me.
    My phone is having only 363,52MB RAM and I think that is the problem. But I don't know how to increase that RAM.
    ROM is 1,87GB o/w 1,59GB are free
    Internal storage has large free space too.

    Do you think I can fix it by installing the custom ROM ??

    My phone data are:
    Firmware 2.3.6
    Baseband I9000BGJW1
    Kernel 2.6.35.7-1187857dpi@DELL128#2
    Build no.GINGERBREAD.BGJW5
  10. Liamo_210

    Liamo_210 Well-Known Member

    Flashing a custom ROM definetly made my phone faster . I would recommend cyanogen mod 10 as it worked for me. And of your having any trouble don't be afraid to ask.
  11. Rash

    Rash Well-Known Member

    Hi bud..
    Unfortunately you can't increase internal ram, you need to manage it better...
    Have you flashed a custom rom (its what android is all about).. Flash better kernels etc..

    With regards to phone hanging check app in the store "watchdog" it will monitor apps & alert which app is using heavy ram or cpu etc..
    But your best bet (trust me :thumbup: on this & you'll remember me the rest of your life) change firmware try out icecream sandwich firmware 4.0.x or above jellybean 4.2.2)..it's what I'm running..
    It will be like you purchased a new phone.. :)

    Sent from my blazing SGS I9000 using Tapatalk 2
    Jesus56Gon likes this.
  12. Jesus56Gon

    Jesus56Gon Member

    Thanks Rush. I didn't know there is no way to increase internal ram.

    Regarding your recommendation on "change the firmware" I will try. First I need to read more about it to understand what I am doing.
    That could be done with Liamo link http://forum.xda-developers.com/showthread.php?t=1852546 prev. in this thread. Correct?
    But I found out by dialing *#1234# that I am not in BaseBand JW4 but in JW1 instead.
    Any suggestion to work it out?
  13. Liamo_210

    Liamo_210 Well-Known Member

    Yes you just flash JW4 as explained in the first step. Then you proceed to rooting.

    PS just in case your having doubts I did this exactly and it worked fine.
  14. Liamo_210

    Liamo_210 Well-Known Member

    Mate if I don't reply im a bit ive probably fallen asleep its half 12 here (at night) but I'll answer any other questions you got tonight or in the morning. :thumbup:
  15. Jesus56Gon

    Jesus56Gon Member

    Liamo, I need help.

    Installation is in a loop when flashing the custom ROM.

    Trying to summarize the steps done of the [GUIDE] How to root and update your Galaxy S to ICS in your link

    http://forum.xda-developers.com/showthread.php?t=1852546

    - Installation of JW4 was fine
    - The root part was also fine
    - but Flashing Custom ROM does not. I think the reason is because I put galaxymtd.zip file under ..\sdcard\download\ instead of \sdcard only, but I have no way to move it or to recover the phone.

    I tried to install JW4 with ODIN again, but the phone doesn't reboot now. The sequence is:
    - While wiping data the msg in the phone says: "E:format_volume: rfs format failed on /dv/block/stl10 (don't know if it is bad or not)
    - The cache wipe is complete.
    - Next I removed the battery and started the phone in download mode
    - Installed JW4 with ODIN with success but the phone is in "Android System Recovery <3e>" sending a lot of RED msgs, like:
    - E:copy_dbdata_media: Can't mount /dbdata your storage not prepared yet. please use UI menu for format and reboot actions. ,,,, etc....

    Any idea on how to continue?
  16. Liamo_210

    Liamo_210 Well-Known Member

    Firstly does the phone still start up normaly or is it not functional?
    also can you still get in to download mode as if you can redo the cache wipe and try flash a custom rom again. Usually when it fails for me i just retry flashing the custom rom and its all fine.
  17. Jesus56Gon

    Jesus56Gon Member

    Hi Liamo,
    The phone is not functional at all. It is in a never ending startup.

    But both, Recovery function and Download function do work.
    So I have tried to reinstall JW4 with ODIN again.
    - I booted in recovery mode and did a wipe data/factory reset and wipe cache.
    - Next I removed the battery and started the phone in download mode
    - Installed JW4 with ODIN with success but the phone is in "Android System Recovery <3e>" sending a lot of RED msgs, like:
    - "E:copy_dbdata_media: Can't mount /dbdata your storage not prepared yet. please use UI menu for format and reboot actions". ,,,, etc....
    - IT DOESN'T continue the normal startup, as it did the first time.
    I have the option to "reboot system now" but when I've done the startup enters in a never ending process.
    I don't know how to restore my phone.
  18. Liamo_210

    Liamo_210 Well-Known Member

    K mate. Your phone is stuck in a boot loop. As you already installed jw4 successfully the first time try reinstall the custom tom as shown in the guide. So go straight to the third step.
  19. Liamo_210

    Liamo_210 Well-Known Member

    Or you could return phone to stock/ factory and start the process again
  20. Jesus56Gon

    Jesus56Gon Member

    Hi Liamo,
    I saw a similar problem in this thread http://forum.xda-developers.com/showthread.php?t=984140. having problems with mounting /dbdata

    Tried the solution: Flash dbdata.rfs and then flash again JW4 and I am happy
    :). My phone now starts normally. :)

    Will continue with ICS in another while.
  21. Liamo_210

    Liamo_210 Well-Known Member

    One more thing. If you want flash jelly bean. You follow the exact same guide but instead of using the ICS link they provided get a jelly bean ROM from cyanogen mod. I'd reccomend a stable one for a more bug free experience.

    So to recap you could flash a jelly bean ROM from cyanogen mod.
  22. Jesus56Gon

    Jesus56Gon Member

    Hi Liamo, My phone is in ICS successfully.
    Thanks a lot.
    Liamo_210 likes this.
  23. Liamo_210

    Liamo_210 Well-Known Member

    Great news glad i was able to help
  24. ANX2988

    ANX2988 New Member

    Hi how you doing i hope you're well. i am new to rooting but i have been trying, for about 5 hours, to root my sgs i1900.

    i keep meeting dead links or removed files and have read countless tutorials. i finally thought i was going to do it using the tutorial you posted, because this thread is relatively new. but again one of the links leads to "this file has been removed", the odin download from the tutorial has been removed.

    do you know of another safe place to download this odin so that i can root my phone, or any other way for me to do this successfully. i just want to root my phone, and i am getting very frustrated having tried to do it for this long and still no root in sight.

    Im already running android 2.3.6 xxjw4 which i downloaded through samsung kies. if you could help i would be grateful. but for now, i give up, and i'm going to bed.
  25. Liamo_210

    Liamo_210 Well-Known Member

    ANX2988 likes this.

Share This Page