How to root Samsung Stellar


  1. xanderful

    xanderful Member

    I will take no credit for this and it is pretty sloppy but it will at least get the ball rolling for this device.
    I was able to get root on this device by following section 2 on this thread.

    [GUIDE][VZW GSIII Edition]How to root your Galaxy SIII & More!(ROMs/CWM/Stock) - xda-developers

    Yes it is for the samung galaxy SIII, but it works for the Samsung Galaxy Stellar also.


    I only got root for my phone,

    If you follow the link,
    DO NOT DO ANYTHING AFTER SECTION 1 STEP 8 !!!!!!!!!!!!!!!!


    ---Updated----

    The root method will still work after the most recent update.

    Here is a quick guide to rooting the Stellar:

    First:

    I am not liable for anything this will do to your device. Rooting is relatively safe, going beyond that can mess up your device ( ALWAYS BACKUP YOUR DEVICE)
    I take no credit for the links and the root method, hit up the link and leave a thanks or donate to the guy who originally found wrote the guide.


    Last READ!!! XDA Adroidforums RootzWiki before rooting or doing anything more than the normal day to day stuff on a android/windows/iphone.
    Windows OS only:

    1. Download the following files
    Samnsung Drivers
    RootDebugFS (Suppport the GOO!!!)

    2. Install the samsung drivers to the pc and unzip RootDebug to a folder on the desktop

    3. Connect the device to the computer, ( preferably with the OEM cable), you should hear the Ba-Doink sound once the device is detected.

    4. On the device go to the device setttings, turn on USB Debugging ( setting --> Developer options --> USB Debugging), and check Installation of Unknown Sources ( setting --> security ---> Unknown Sources).

    Make sure no other tether programs or emulators are running ( if you do turn off or unistall and then restart the phone).

    5. Next, locate the folder the RootDebugFS was unzipped to, open the folder. Right Click the file and run as admin ( I dont know if the program needs admin permissions but it doesnt hurt), WinXP double click.
    Once the program opens press 1 and hit enter. Windows 8, I was able to root from the OS. If you think you are having issues with your OS, try another computer.

    6. Follow all of the prompts and dont unplug the phone until it is done rooting ( it will let you know).

    7. Once it is done, look in your apps folder for superuser. If it is there that is a good sign, open the app and update the app ( info screen and select update binary). If it updates you're rooted!!!

    If you have issues, try redownloading the rooting program, rerooting a few times. Try after a fresh restart, and if you are really wanting root, factory reset ( BACKUP your stuff ( read how to backup android devices on the sites above) you will loose important stuff!!!).

    Once rooted, I recommend paying for and downloading Titanium backup.
    Set it up with a free account with Box.com or Dropbox.com. You will have to setup the account in the app, (issues google it) that way you can run a backup with titanium backup and have it automatically upload your backup to one of the sites.

    Also Pay for Dropsync, with root, you can upload any file off your device to dropbox. If you want you can sync you complete phone to dropbox and anytime you make a change will sync it with dropbox.

    The biggest reason is, and BEST thing about root, loose an app, delete a picture, completely crash your ROM ( TWRP for Stellar), your phone items are recoverable.

    Advertisement
    :
    mcarrion78 likes this.
  2. xanderful

    xanderful Member

    Ok I went ahead and did the last few steps also. I would not recommend flashing anything though. It goes into a nasty boot loop if you do it wrong.

    If someone could make a good image of the recovery partition, that would be nice =)
  3. xanderful

    xanderful Member

    Yeah do not use the ez unlock tool, will mess your phone up.....FYI
  4. sovereign73811

    sovereign73811 Active Member

    Um, yeah...I'm stuck in an infinite recovery loop and so far not even Odin will let me reflash any firmware.

    UPDATE: OK so that was weird, I decided to load the GS3 Casual Java Program and then plug the phone to the computer. Turning on the phone and suddenly...presto, the loop ended! I'm not sure if the program had anything to do with it but after hours of working with Odin and several other recovery roms, it seemed to be key.

    Oh yeah and sorry for my manners (lack thereof). I may be new to this forum but I've had a little experience with android for a year with my old Optimus V so I know some things about rooting, flashing, and modifying the Android platform. The Samsung Stellar is, is...a stellar step up from the Optimus V. I hope I can contribute to the Android community and share taking a bite of big Apple.

    Another update: As I was attempting to restore the old stock recovery I rebooted the phone and I have that wonderful triangle saying "System software not authorized by Verizon Wireless has been found on your phone. Please Turn off your phone..." Attempts to backup failed unfortunately so...anyone have one?
  5. xanderful

    xanderful Member

    Yeah, I believe I got this same message. I was testing my backups with the recovery image also. To get back into the OS, I had to boot as if i was booting into Odin and then cancel it. This seemed to get me into the OS.
  6. mcarrion78

    mcarrion78 New Member

    can someone get me a stock system dump. i deleted some system apps (amazon, kindle , etc.0 and i mustve deleted something i shouldnt have cuz i keep getting a system ui force close trying to close the helpful tips window
  7. sovereign73811

    sovereign73811 Active Member

    Wish I had the same result, but I still can't seem to get in the OS. This means the only way to be able to get the phone back is a stock ROM.

    Index of /romdump

    I think you can use this to get the stock ROM off of the phone without having to go into recovery mode or odin mode.

    Let's see if that helps. I wish we could get a stock recovery ROM...

    Dang it, I can't get ANY recovery image into the phone with Odin!
  8. mcarrion78

    mcarrion78 New Member

    id really like to get all the system apps. i deleted some after rooting and i believe thats where my force close came from. was running just fine before i started deleting them.
  9. james1552

    james1552 Member

    hello all. practically new user here. I just got thus phone and plan on rooting once I get home from school today. just wondering is there a guide on safe to remove apps? like can I remove the kindle app without bricking? I've rooted before but new to Verizon and Samsung. I obviously know not to remove google apps and system apps. just wondering are the Amazon and Verizon apps safe to remove?
  10. sovereign73811

    sovereign73811 Active Member

    OK, I can help you with rooting your device pretty easily.

    Go to the first post of this thread and go to the link. Head for the section that says "Section 2: How to Root/ Unlock bootloader/ Flash Custom recovery(Windows)" and follow those instructions as they worked for rooting. STOP at step 7 for the sake of the phone.

    STOP AFTER YOU ROOT. Do NOT try to unlock the bootloader or recovery or flash any other recovery or any of the custom ROMs as they do NOT work for the Stellar! Don't be supid like me who just had to try and now has a wonderful brick after this.


    BE CAREFUL about deleting the stock apps. If you have read the previous posts here on the forum deleting the apps have dire consequences and will destabilize the OS (darn you Verizon).

    One last thing: no one has put up a stock ROM yet and we (OK I too but really...we all) can use a stock ROM to go by so that the Android Developers can start cracking the codes of the Stellar. If you could be ever so kind and find a way to backup and upload a stock ROM I would be very grateful.

    As soon as you root the device, this seems to be the most non-invasive way of getting it. Follow this link:

    http://android.podtwo.com/romdump/

    Don't forget you will need the Android SDK (ADB) for this. I also can give you a hand there since I have dealt with ADB before.
  11. sovereign73811

    sovereign73811 Active Member

    UPDATE: There is a better way to dump the ROM using romdump: Through the phone of course!

    http://forum.xda-developers.com/showthread.php?t=1771347

    All you need is the Terminal Emulator from the Google Play store (and the romdump file in your microSD card).

    If anyone can provide that I would be most grateful!
  12. james1552

    james1552 Member

    I'm actually running a Mac, don't have windows so :l

    Is it safe to do the mac method to root or not? I tried, and for some reason I can't get the casual app to detect just my phone. It detects 2 devices for some reason, and too my knowledge I have no other emulator or anything running, and only my Stellar plugged in...

    Though I think it could be a Mac issue too, because I can't even get the Android File Transfer app to detect my phone either, and since ICS and Samsung removed Mass Storage my computer isn't detecting the device at all, except for in Casual so :l. That and the SDK link on the XDA thread is down, so I can't get it...

    Once I get my Linux Laptops keyboard replaced I'll try on there too.

    EDIT: yea, I can't even root because the Casual app keeps insisting I have two devices plugged in :/

    That and for the mac guide on the thread they gave me an EXE for the samsung drivers, which is useless on a Mac...
  13. sovereign73811

    sovereign73811 Active Member

    I wonder if you can try using Linux via CD.

    First: My only alternative to you right now is to find a way to get onto Windows somewhere because the best way to get it done is the method I gave...a Windows program sadly.

    Second: The Casual program simply DOES NOT work for the Stellar. I wasn't able to root at all and because it is for the S III, trying to restore recovery and bootloaders resulted in bricking my brickin' phone.

    Yeah, you having a Mac complicates things. Although there are ways to root without having the computer without having stock ROMs I wouldn't advise doing anything with the phone right now because the only way for you to root this right now is to flash some custom recovery or system ROMs...which none exist for the Stellar right now.

    I'm sorry about that.
  14. moondeath

    moondeath Member

    Weee I have my phone rooted for less then 24 hours then I use the LCD Density app and now my phone turns black after the samsung logo, now I have a totally useless paperweight.

    I hope that you guys have some sort of progress soon or I'm going to be in a world of hell.
  15. sovereign73811

    sovereign73811 Active Member

    So when it boots it does...nothing? Is it just the screen?

    If any of you are reading this and have a working rooted Stellar, we can really use a stock backup to get our phones back...
  16. moondeath

    moondeath Member

    Yep, the samsung logo appears then it vibrates once then sits there with a lit black screen with nothing on it, no sound and I can't get into the shell from adb it doesn't even recognize the device being plugged in.

    I assume when I ran the LCD Density Changer application it corrupted the build.prop some how, I'm really depressed I've only had this phone for a week and sadly the sim card in this phone fits none of my older phones with sim card ports in it... so i'm phoneless until someone gets a stock rom uploaded here and and can flash it via odin.
  17. sovereign73811

    sovereign73811 Active Member

    I hope you don't see it as rude if I may say that...misery loves company; I've only had the phone working for EXACTLY one week.
  18. moondeath

    moondeath Member

    Well someone has to be nice enough to give us their stock rom dump soon I can't believe as amazingly fast as this phone is and new that there isn't someone to do the job...

    And my phone will be a week old on saturday and I bricked it yesterday on Wednesday. So, I'm using a very old month to month phone till I get a stock rom to fix this beautiful little thing.
  19. sovereign73811

    sovereign73811 Active Member

    Hey just curious, can you get into the stock recovery mode and not just Odin mode?
  20. moondeath

    moondeath Member

    Yep.
  21. sovereign73811

    sovereign73811 Active Member

    I know this sounds funny but since you can get into the stock recovery, load up the Verizon system repair program ( you can find it on Verizon's site I'm sure). Maybe that might reset your OS and be able to get back into your phone. This does mean you will need to re-root your phone but if it works you can then make a backup of your working phone.
  22. moondeath

    moondeath Member

    I can't find it I googled my heart out and searched their page.
  23. sovereign73811

    sovereign73811 Active Member

    Dang you're right. Verizon you may have killer coverage but your tech service is worse than a black hole.

    I have the program installed. It was some Pc software that was in the phone itself. I'm away from my computer right now but let me see if I can upload that for you within two hours. Sit tight!
  24. moondeath

    moondeath Member

    Well I'm leaving now at (4:03 P.M. GMT-6 Mountain Daylight) to go to work I'll be back around 9 PM my time and hopefully whatever it is will work. I'm getting close to driving to Sante Fe just to return this phone.
Loading...

Share This Page