How to Root Stock GB 2.3.3?


Last Updated: 2011-10-09 03:31:32
  1. 1st_Paladin

    1st_Paladin Well-Known Member

    Hi,

    I've been trying to root my Desire after upgrading it from 2.2. to the stock 2.3.3. which I downloaded from HTC Dev website.

    I've tried Gingerbreak 1.1 and 1.2

    unRevoked 3 from their website

    I was able to get S-Off using tools from unRevoked website. It also installed ClockworkMod.

    I tried using ClockworkMod in Recovery Mode to install firmware. Unfortunately all I get is Revolutionary on the screen and it just stops there. There's no option to select firmware.

    Has anyone managed to root stock GB 2.3.3? If yes, please share your experience.

    Many thanks.

    Advertisement
  2. SUroot

    SUroot Well-Known Member Developer

    The process is use revolutionary.io for s-off and then fastboot flash a recovery. Once you have recovery, you flash the SU zip on the revolutionary.io wiki.

    However that last step isnt needed to flash a rom.

    Not sure what you're on about with "firmware", you should perhaps clarify that as its not a term we use.
    1st_Paladin likes this.
  3. 1st_Paladin

    1st_Paladin Well-Known Member

    Thanks for your quick reply. Yes you are quite right and I apologise for using the wrong term. Yes I was referring to the su-2.3.6.3-efgh-signed.zip file (From unrevoked website). How do I flash it? What software do I use?

    Many thanks for your help.
  4. SUroot

    SUroot Well-Known Member Developer

    First you need to download a recovery and use fastboot to flash it. Whats your PVT Version from Hboot screen (it will be 1-4)?

    If its 4, you need to check the erase size because if it is 40,000 you cannot use Clockwork mod 2.5.0.7 (which is the best version of cwm) - See the rooting guide for unrevoked for info on this and downloads for recovery.

    Then read the fastboot faq to learn about fastboot flashing.

    Once you have recovery, you can "install zip from SD card".

    I know you already have cwm recovery, but if its not 2.5.0.7, you should get rid of it.
  5. 1st_Paladin

    1st_Paladin Well-Known Member

    Thanks again.

    PVT is 3
    Revolutionary CWM v4.0.1.4.

    How do I check Clockwork Mod version?

    I will read up the fastboot flashing.

    Thanks again for your help.

  6. SUroot

    SUroot Well-Known Member Developer

    You know the clockwork version. You've just told me its 4.something.

    You can download 2.5.0.7 from the ultimate toolbox thread. You need the password Rastaman posted at the end of the thread
    1st_Paladin likes this.
  7. 1st_Paladin

    1st_Paladin Well-Known Member

    Thanks again. I tried using Android Loader 1.6 and 2.05 to no avail. I was trying to flash CWM 2.5.7. While loading, my phone would shut down and then won't start up into Bootloader mode. I need to take out the battery to restart the phone. Is there anything else I can try?

    Many thanks for your help.
  8. SUroot

    SUroot Well-Known Member Developer

    You could do what I actually told you to do instead of some random approach ;)
  9. Rastaman-FB

    Rastaman-FB Well-Known Member

    as su root said, read the fastboot faq, you also need the drivers which i believe is mentioned there too

    trust me youll thanks us for it later as it will give you knowledge about exactly what you are doing and thus being able to sort stuff out without a problem in future
    1st_Paladin likes this.
  10. 1st_Paladin

    1st_Paladin Well-Known Member

    Thanks for your help. This is a great forum. Took my phone back to HTC Service Centre. Turns out that my board was faulty. So they replaced it. It got me back to 2.2. I was able to use Revolutionary to root. Clockwork Mod 2.5.7 is simply wonderful. I'm still digesting the partitioning of SD card. Once I get that right, will get to ROMs.

    Thanks again for your help.
  11. Rastaman-FB

    Rastaman-FB Well-Known Member

    hmm they repaired it even with a revolutionary hboot?
  12. 1st_Paladin

    1st_Paladin Well-Known Member

    Yes they did.

    In the end, this is what I did to flash the ROMs. I'm writing this in the hope that it will help someone else. It took me over a week and many late nights. As I look back it could have been simpler.

    1. I started out with 2.2 after HTC replaced my faulty board. My bootloader is 0.92 with S-On.
    2. I used Revolution based on the instructions that SURoot wrote
    http://androidforums.com/desire-all...voked-windows-updated-15th-august-2011-a.html

    It installed ClockWork Mod 2.5.0.7 which is simply fantastic and rooted my Desire.

    3. Where I got stuck is the partitioning of the SD card. I tried following instructions from the FAQ but I couldn't figure out the exact steps. I was using RCMIX S ROMs v1.8 but couldn't get the phone to recognize my SD card although the phone could boot, synch with Gmail, Calendar. Market did not appear at all. When I tried RCMIX S v2.0 it failed to even boot.

    I was using the instructions from
    http://androidforums.com/desire-all...artitions-updated-10th-august-2011-a.html#”8”

    and

    http://androidforums.com/desire-all...mware-player-updateded-8th-august-2011-a.html

    and

    http://androidforums.com/desire-all...artitions-updated-10th-august-2011-a.html#”8”

    4. The steps that worked for me turned out to be:

    a. Delete existing partition
    b. Create new primary partition with 1024 unused space
    c. The primary partition was formatted as FAT32
    d. For the unused space, I created another primary partion and formatted it as EXT4 (for some strange reason, I tried EXT2, EXT3 and could not get the phone to recognise the SD card. Only EXT4 worked)

    I worked this out from these instructions
    How to partition SD Card for Desire? - xda-developers

    5. Finally after many attempts, RCMIX S v2.0 finally booted up after approxmately 20 minutes. I was using ClockWork Mod 2.5.0.7 to install from ROM from specified ZIP file on SD card

    RCMIX S v2.0 is great and I really like it. It's given my trusty Desire a new lease of life.

    Thank you all for faithfully posting detailed instructions, answering n00b questions, posting the tools and hosting them.

    Looking back it is really quite straight forward. I'm hoping that this little write up will help another n00b avoid the pain I went through.

Share This Page