How to "root" the LG Ally


  1. Vmanisme

    Vmanisme Well-Known Member

    LOOK BELOW THIS POST FOR STEPS ON ROOTING THE LG ALLY:

    MAKE SURE TO SCROLL ALL THE WAY DOWN TO MAKE SURE YOU ARE READING THE LATEST STEPS TO ROOT. IF YOU NEED HELP WITH GETTING LINUX PM ME.


    IF YOU HAVE QUESTIONS ABOUT ROOT PLEASE ASK HERE:
    http://androidforums.com/all-things...stions-here-dont-flood-root-topic-please.html
    That will help us prevent this topic from becoming too big and make it hard to read, thank you.

    Advertisement
  2. kfazz

    kfazz Member

    Updated steps for root:
    (this assumes linux with adb in the current directory)
    wget http://zenthought.org/tmp/asroot2
    wget http://bit.ly/brI0EV (superuser 2.1)
    extract this and copy Superuser.apk and su to your sdcard
    ./adb push asroot2 /data/local/ && ./adb shell chmod 0755 /data/local/asroot2
    ./adb shell
    /data/local/asroot2 /system/bin/sh
    (at this point your $ prompt should be a # meaning you are root)
    mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system
    cat /sdcard/Superuser.apk > /system/apps/Superuser.apk
    cat /sdcard/su > /system/bin/su
    chmod 06755 /system/bin/su

    install terminal emulator on phone and try su to test, you should get a dialog that says "this app wants root access Allow Deny"
  3. cdsmith

    cdsmith Well-Known Member

    These steps were pretty much perfect! Thank you! Two notes: first, the path in the third from last step is /system/app/, not /system/apps/.

    Second, I noticed that asroot2 seemed to only give a root shell when the SD card was mounted on the computer. Otherwise, it would claim success, but still give '$' as the prompt and mount failed with a permission error. However, once a root shell was obtained, I needed to unmount the SD card from the computer, so that it's again available as /sdcard. Hope that saves some people a few minutes of confusion.
  4. Crepiduse

    Crepiduse Member

    Corrected steps

    LINUX

    Step 1:
    Mount SD Card in Phone!

    In Terminal:

    1) wget http://zenthought.org/tmp/asroot2
    2) wget http://bit.ly/brI0EV
    3) ./adb push asroot2 /data/local/
    4) ./adb shell chmod 0755 /data/local/asroot2
    5) ./adb shell

    A $ prompt from the android will open now:

    1) /data/local/asroot2 /system/bin/sh

    (at this point your $ prompt should be a # meaning you are root, if not, type exit and then begin over, when you open the new ./adb shell you will be # root)

    When you get # shell, UNMOUNT the sdcard!!!!! This will make the correct link available. Then continue on.

    2) mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system
    3) cat /sdcard/Superuser.apk > /system/app/Superuser.apk
    4) cat /sdcard/su > /system/bin/su
    5) chmod 06755 /system/bin/su
    Stefenatefun, Vanski, ivesjd and 3 others like this.
  5. heffe2001

    heffe2001 Well-Known Member

    Has anybody tried any of the wireless tethering on their Ally since they rooted it? Curious to see if that works now.
  6. Vmanisme

    Vmanisme Well-Known Member

    I tried it but as soon as the app opens it says that its not supported, but i think theyre gonna make it work, well crepiduse said he will so its all on him or kfazz i guess.
  7. cdsmith

    cdsmith Well-Known Member

    I did try. The most commonly recommended wireless tether app requires a kernel with netfilter support, which is NOT installed on the LG Ally. However, another app called Barnacle Wifi Tether seems to get somewhere. Got it to create the network, connected via a laptop (Ubuntu 10.4), but was not able to get any data transfer. I stopped before figuring out what the problem was.
  8. heffe2001

    heffe2001 Well-Known Member

    These directions SHOULD work for Windows, just make sure you use the drivers from pdanet, as they work in XP/Vista/7, x32 & x64. Most of these instructions are from Crepiduse. I HAVE NOT TESTED THIS AT ALL, BUT THIS SHOULD WORK JUST LIKE THE LINUX DIRECTIONS. I'M NOT RESPONSIBLE FOR YOU BRICKING YOUR PHONE, YOU HAVE BEEN WARNED... Also, if someone would test this and report back if it works or not, that'd be great, lol.

    My pre-configured pack with batch file for the initial parts of the root process is available here... Let me know if you get errors pushing the files up to the phone (not sure if the sdk uses the standard windows \, or the linux / on the windows side, lol).

    Windows

    Part 1

    Mount SD Card in Phone!

    1) download windows client pack for pdanet for your flavor of windows and install drivers for debug access (or my pack I already pre-configured for root on the Ally) Download PdaNet

    2) download android sdk for windows & extract to a folder (c:\android\sdk for example)
    3) download http://zenthought.org/tmp/asroot2 and place in your c:\android\sdk folder
    4) wget http://bit.ly/brI0EV

    To make things easier, I would create a folder under the c:\android\sdk\tools called su (md c:\android\sdk\tools\su) and copy the asroot2, and the contents of the zip file over to this (just the su file, and the apk file, the rest shouldn't matter). Alternately, I'll post up a pre-configured folder you can extract into your c: root, and run the allyroot batch file in the c:\android\sdk\tools folder from there with everything where it should be for these directions...

    5) bring up a command prompt in windows (might have to be administrator-level cmd, not sure)
    6) Change into the folder you created in step 2 (cd c:\android\sdk\tools in my example)
    7) adb push su/asroot2 /data/local/
    8) adb push su/su /sdcard/su (unless you've already done #4)
    9) adb push su/Superuser.apk /sdcard/Superuser.apk
    10) adb shell chmod 0755 /data/local/asroot2
    11) adb shell


    A $ prompt from the android will open now (this should also be where the Allyroot.bat file should drop you, with the above steps already completed):

    Part 2
    Enter these commands from the $ prompt above:

    1) /data/local/asroot2 /system/bin/sh

    (at this point your $ prompt should be a # meaning you are root, if not, type exit and then begin over, when you open the new ./adb shell you will be # root)

    When you get # shell, UNMOUNT the sdcard!!!!! This will make the correct link available. Then continue on.

    2) Use the menu option on the phone to disable sharing the SD card via USB
    2a) mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system
    3) cat /sdcard/Superuser.apk > /system/app/Superuser.apk
    4) cat /sdcard/su > /system/bin/su
    5) chmod 06755 /system/bin/su
  9. flyinjoe13

    flyinjoe13 Well-Known Member

    I'm trying to do this through Ubuntu so i'm assuming I need to download the Android SDK for linux (which I did), but i'm obviously doing something wrong because when I try to run the ./adb commands, I get an error about the file or directory not found.

    Anyone have any ideas why I would be having trouble with the adb commands? Do I need to extract the sdk to a certain location?
  10. Vmanisme

    Vmanisme Well-Known Member

    you need to point the terminal to your adb location if its on desktop do:
    cd ~/Desktop
  11. heffe2001

    heffe2001 Well-Known Member

    Did anybody try the windows directions I posted, I'm curious to see if it worked out ok.
  12. philly

    philly New Member

    Yeah i tried those steps on windows (vista x64) and i get all the way until it says "SUCCESS: Enjoy the shell" (supposedly gaining root access) except the prompt never changes from $ to #. it just stays stuck unrooted. i've tried this method several times with the same result. Also my sd card was mounted when i was doing this as i know some people have had that problem before.
    Vanski likes this.
  13. Vmanisme

    Vmanisme Well-Known Member

    Read the topic better, it says:


    When you get # shell, UNMOUNT the sdcard!!!!! This will make the correct link available. Then continue on.

    2) Use the menu option on the phone to disable sharing the SD card via USB
    3) cat /sdcard/Superuser.apk > /system/app/Superuser.apk
    4) cat /sdcard/su > /system/bin/su
    5) chmod 06755 /system/bin/su
    Vanski likes this.
  14. Vmanisme

    Vmanisme Well-Known Member

    Vanski likes this.
  15. icon123

    icon123 Well-Known Member

    At first I didn't get root, then I exited like you mentioned and adb shell back in and I was at root.

    I think you missed this step:

    2a) mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system

    Thanks for the write up.

    Edit: BTW, thanks for the parts!
  16. 12stringchap

    12stringchap Active Member

    He's right. This is what was catching me..
    Also the allybat file, I was getting permission denied on the sd transfers so I did it manually.
  17. vbplayr2000

    vbplayr2000 New Member

    I attempted using the zipped file and following the instruction for Windows based systems.

    However, I repeatedly got "Error: device not found"

    I can see the SD card within Windows Explorer.

    Do I need to specify a drive name in the commands, if it is other than C:? I don't think it is able to see the drive unless I specify.
  18. flyinjoe13

    flyinjoe13 Well-Known Member

    I got that same error when trying to do it through Ubuntu. I just can't figure out why i'm having so many issues with this. I'm following all of the steps to the letter, but it just ain't working.

    BTW, in case I ever get past the adb steps, when you say to unmount the SD card, does that mean to unmount it from the computer or does it mean to go into the 'Settings\SD Card and phone storage' and unmount it from there?
    Vanski likes this.
  19. vbplayr2000

    vbplayr2000 New Member

    I believe I got it to root (although, there is no indication in the instructions to tell you if you are successful). I have the SuperUser icon in my downloaded apps now.

    FYI - The SD card should be unmounted through the phone via SD Card & Phone Storage > Unmount SD Card.

    Then, you should perform the operation described as 2a in the previous post and follow the rest of the instruction in Part 2 of the original post.

    I do have some confusion about how to use it.....what are the best apps for the LG Ally that require root access?

    I also am unclear how PdaNet is supposed to function. I cannot connect to my device using the taskbar shortcut (GUI tools) and can only connect via the command prompt after a couple of attempts.

    Any guidance on how to use this once the rooting is complete would be appreciated.

    Thanks for the instruction and assistance. :cool:
  20. heffe2001

    heffe2001 Well-Known Member

    I'm betting if you're getting an access denied, it's quite possible the commands need to be changed like follows:

    Instead of:
    adb push su\asroot2 /data/local/
    change it to:
    adb push su/asroot2 /data/local/

    Makes it more difficult that I don't have a physical Ally in hand to try it on, but at least it's got the adb working in Windows. Now if we could just get someone to write a nice little vb app that would do all that for you, and just drop you at a rooted phone, lol.

    Make sure after you run the .bat file, to continue with the steps in part 2 (and you WILL need to add the mount command, I'll edit my directions to add that step back in).
  21. Crux.V

    Crux.V Member

    The windows instructions work very well. Here is my post from lgallyforums.com (my responses are in bold):

    the obligatory "screen shot or it didn't happen"

    [​IMG]
    gradiusnine likes this.
  22. icon123

    icon123 Well-Known Member

    See above about installing terminal emulator to the phone...
    gradiusnine likes this.
  23. Crux.V

    Crux.V Member

    This is what you should see after opening the terminal emulator on the Ally and typing in "su". You should actually be prompted by the "superuser permissions" program that you need to give the terminal emulator root access (in which you need to click "allow"). After that you should see the "#" prompt.

    [​IMG]
    gradiusnine likes this.
  24. lawizard

    lawizard Active Member

    OK, I'm going nuts here. I have downloaded all of the sdk stuff for windows. I have Pdanet on my phone and computer. I have tried doing steps 5 through 11 to no avail. For the first 10 times I couldn't get past the $. I did everything the directions said to do at the $ and never got to the # sign. The last two times, I wind up with a device not found message. My SD card is mounted. Debugging is on. What do I need to do to correct this.
    I am using a Windows 7 operating system and my LG Ally.
  25. philly

    philly New Member

    thats the exact problem i was having. i saw that Crux.V said that taking the sd card out completly allowed him to get to the root prompt so i'll try that when i get home n post here if it works...

Share This Page