How To Root VM Samsung Intercept FROYO 2.2.2 (Easy Way) {Updated 6/24/12}


  1. JALStudios

    JALStudios Well-Known Member

    Hey guys! I am going to be showing you how to root your Samsung Intercept VM the easy way! I have listed the download links towards the bottom of the post!


    **NOTE** I HAVE SWITCHED OVER TO T-MOBILE BUT I AM STILL OFFERING SUPPORT ON ALL OF MY THREADS!!! I MAY BE SLOWER ON RESPONDING THEN USUAL BUT I AM STILL OFFERING SUPPORT!


    (THESE ARE NOT DOWNLOAD LINKS!!!!)
    InterceptRoot.apk (Android App)
    BROM_1.3.1.zip (ROM)
    Ubunto6.0.zip (ROM)
    IceCreamFROYO1.2.zip (ROM)
    Pandemic.zip (ROM)
    Crap_Kernel1.5.zip (Kernel)
    StockKernel_2.1.zip (Kernel)
    StockROM_2.1.zip (ROM)
    StockKernel_FROYO2.2.zip (Kernel)
    StockROM_FROYO2.2.zip (ROM)
    Stock_Recovery.zip (Recovery Mode)
    All the files should take about 550 megabytes! This is a rather LARGE folder to download but you do get a bunch of different ROMS and even get all the STOCK stuff in case you want to UNROOT!! Download link will be at the bottom of the page! If you would like to help contribute, make a Mirror of the link for me and post it in the reply box! I could not find many websites that let you upload 550 megabytes for Free!

    Follow the steps below on how to root the Samsung Intecept! NOTE:::: I have not tried this on the Sprint version so if you are on sprint DO AT YOUR OWN RISK!!

    Step 1: Download and install the InterceptRoot.apk on your Intercept!

    Step 2: Open the app and click "Permanent Root". It should take about 2-10 minutes to root and reboot!

    Step 3: Open the app again and click on "Flash CM01 Recovery". This should only take 30 seconds! If it worked right it should reboot into the recovery mode!

    Step 4: Go to "Mounts And Storage" and click Mount USB Drive!

    Step 5: Transfer the BROM or any other ROM and the Crap_Kernel1.5!

    Step 6: Unmount and go to "Wipe". You need to click "Format Cache"!

    Step 7: Go to "Install Zip From SD Card". Now install the Crap_Kernel1.5! Then you can reboot into system!

    Step 8: Go back to Recovery Mode...(Volume Down, Call Send, Call End).

    Step 9: Install ROM! **NOTE** If you are installing a ROM with the 1% battery mod DON'T Wipe Cache or Factory Reset because it will make it BOOTLOOP! The 2 ROMS that i have included that have that 1% Battery Mod is the BROM_1.3.1 and Ubunto6.0. The rest of the ROMS you need to Factory Reset and Wipe Cache!

    Step 10: Reboot to system! The first boot may take about 5-12 minutes! Don't worry if you read the message above then it should not BOOTLOOP!


    FAQ:
    Q. When I Booted into the ROM it just force closes everything!
    A. Flash back Stock...NOT STOCK RECOVERY!! And then retry the steps again!

    Q. I have a continuous BootLoop!!!
    A. If you did not read the message above then that is probably why you BootLooped it!! All you have to do is Re-Flash the Crap_Kernel1.5 and then Flash the stock rom and the try to flash the Custom ROM again!

    [COLOR=Blue]Q. [COLOR=Red]When I go to boot into the system it just goes to a black screen with nothing!
    [COLOR=Blue]A. [COLOR=Red]You just SEMI-Bricked it! But not to worry, it is very easy to fix! All you have to do is Flash the Stock Kernel, Stock Rom, And Stock Recovery and retry the WHOLE process over again!

    [COLOR=Blue]Q. [COLOR=Red]My Intercept is completely UNRESPONSIVE and I cannot get back to Recovery Mode!
    [COLOR=Blue]A. [COLOR=Red]Well you just BRICKED your phone! There is only 1 way to fix that and that is to try and use the SWUpgrade tool to fix that. I am not going into detail about that so just YouTube it and you should find something!


    [COLOR=Black]Download All The Files Here:
    [COLOR=Red]InterceptRoot.apk--[COLOR=Black]http://www.mediafire.com/?njk2vxjurk3w540[/COLOR]
    BROM_1.3.1--[COLOR=Black]http://www.mediafire.com/?v4bwxr89bb3ryne[/COLOR]
    Ubunto6.0--[COLOR=Black]http://www.mediafire.com/?4qm6a8lt518v2vl[/COLOR]
    Crap_Kernel1.5--[COLOR=Black]http://www.mediafire.com/?35v24q2ez0y4db8[/COLOR]
    IceCreamFROYO1.2--[COLOR=Black]http://www.mediafire.com/?40s75f6erkwqka1[/COLOR]
    Pandemic--[COLOR=Black]http://www.mediafire.com/?tyeghzwc57fdw37[/COLOR]
    StockKernel2.1--[COLOR=Black]http://www.mediafire.com/?njk2vxjurk3w540[/COLOR]
    StockROM2.1--[COLOR=Black]http://www.mediafire.com/download.php?5xreqq7iqfa6ofd[/COLOR]
    StockRecovery--[COLOR=Black]http://www.mediafire.com/download.php?ysbnq07a4j2z999[/COLOR]
    StockKernelFROYO2.2--[COLOR=Black]http://www.mediafire.com/download.php?cmpsuh38m3kgu12[/COLOR]
    StockROMFROYO2.2--[COLOR=Black]http://www.mediafire.com/download.php?ccaxz8y1tvvdwmv
    [/COLOR][/COLOR]
    If there are any other questions or if you are having a problem that I did not leave in the FAQ then just comment below! I do constantly check my threads! [COLOR=Red]Please read below on[/COLOR] [COLOR=Red]IMPORTANT information that you need to know about rooting your phone!



    IMPORTANT INFORMATION ABOUT ROOTING YOUR PHONE:

    When you root your phone you may void any warranty that you have! I have not had any problem with that so far on Virgin Mobile but I do think that Sprint's Intercept will void the warranty when rooted!! When you go to install a ROM make sure that the ROM you are installing is for YOUR DEVICE!! If you install a Sprint ROM on a VIRGIN MOBILE Intercept it will change your BASEBAND...Your BASEBAND is required for 3G, Wifi, and GPS! And you cannot change your baseband back after it has been altered! So if you are having problems with your 3G connectivity or your WIFI or even your GPS you need to check your BASEBAND by going into the settings and clicking "ABOUT PHONE" and look for BaseBand! If you are on Virgin Mobile the baseband should say EC07! If you are on Sprint then it should say DL05! If it says anything other than that then basically you got yourself a $100 paperweight! Also another thing that you should take into consideration is Flashing or Porting ROMS from other Devices such as an HTC Thunderbolt which is a Sense 3.0 device! It would be very hard and difficult to do that! And if you some how do get this to be ported it will be very slow because the Intercept can barely run the 2.2 FROYO! It would be much easier to port another ROM with 2.2 on it! But also know that if you fail doing this you can BRICK up your phone for good! Most of the ROMS for the Intercept are trying to make the Intercept FASTER and make the Battery Life Better!! And the BROM has definitely done so! So it really does make sense to Root this device! Also the kernel Crap_Kernel1.5 makes this device Wifi Tether USABLE! The original stock kernel does not support Wifi Tether!! THERE IS ONLY ONE THING THAT I HIGHLY SUGGEST BEFORE YOU ROOT YOUR DEVICE! YOU NEED TO HAVE WARRANTY ON YOUR PHONE BECAUSE THIS PHONE ALTHOUGH I POSTED AN EASY WAY TO DO IT, IS STILL A HARD PHONE TO ROOT! WHEN I TRIED TO ROOT MY FIRST INTERCEPT I BRICKED IT UP AND I HAD VIRGIN MOBILE SEND ME ANOTHER ONE!! SO IF YOU BRICK UP THE PHONE ALL YOU HAVE TO DO IS HAVE THEM SEND YOU ANOTHER ONE!!
    [/COLOR][/COLOR][/COLOR][/COLOR][/COLOR][/COLOR][/COLOR][/COLOR][/COLOR][/COLOR]

    Advertisement
    :
    BxRosie04 and AirCatHeavy like this.
  2. kendalf

    kendalf New Member

    are the kernels included in the roms? I reinstalled the froyo stock VM rom after using brom1.3 with crap1.5 for a while and my phone says its got kernel 2.6.32.9, no longer crappy kernal.
  3. JALStudios

    JALStudios Well-Known Member



    When you flash the stock Rom and some other different Roms they have a kernel with them. So after you flash the Rom all you have to do is flash that Kernel.

    When you flash the stock ROM it will automatically install the stock kernel with it. So after every ROM flash you can just flash the kernel that you like!


    I hope this answered you question. Feel free to leave another comment with other questions!
    AirCatHeavy likes this.
  4. markzombie82

    markzombie82 Well-Known Member

    Just a note if you take the fb01 update this will not work but swupgrader will flash recovery and you can find it on sdx. Not to pick but i can see the questions coming.
    AirCatHeavy likes this.
  5. AirCatHeavy

    AirCatHeavy Well-Known Member

    What is fb01 update and how do you check to see if you have it or not ?

    JAL thanks for posting this. My Intercept needs to be rooted or it is unusable due to mysterious excessive bandwidth usage I cannot stop other than putting the phone into flight mode.

    Why do you think you Bricked your phones? I dont have a warranty so if it gets bricked it's toast. I dont mind that so much as it's on the VM $25/mo plan and if I have to replace it I will not be able to get that plan back.

    thank for your efforts
  6. NEWBIEHELPPLS

    NEWBIEHELPPLS New Member

    ROOTED with both roms and txt message wont work says full i got 16gb card how do I give phone more memory or fix this????
  7. NEWBIEHELPPLS

    NEWBIEHELPPLS New Member

    help me please how do i find all the vm shit in the phone and get it out? also i need help with last post and would like to find vamp. rom and kern. for vm intercept 2.2.2 help pls ill donate 20 bucks when i get it working properly its rooted but busybox dont want to install version 1.20 cant find older version someone said it would work PLEASE GUYS HELP ME TXT ME ANYTIME WITH INFO 2056754851 Justin Mc.
  8. BxRosie04

    BxRosie04 Member

    Hi JAL!

    I'm about to root my Intercept and I was downloading all the necessary files when I noticed that the link you provided for StockKernel2.1 is the same as the link you gave for InterceptRoot.apk. Could you please provide the correct download link for StockKernel2.1?

    Thanks! :)
  9. JALStudios

    JALStudios Well-Known Member

    I apologize about the link problem! You really don't need all the stock stuff unless you want to go back stock. And the 2.1 Stock kernel is the ORIGINAL Android Kernel back for the 2.1 Update (NOT 2.2.2 FROYO). Also if wanted to go back to the beginning then you can use the 2.2.2 FROYO Kernel for the 2.1 ROM. I should be updating the Thread soon so just look back for the link but for now you could use the 2.2.2 FROYO Kernel. BUT I STRONGLY ENCOURAGE YOU TO USE A CUSTOM ROM EVEN WHEN YOU ARE FLASHING BACK STOCK!!!! The custom kernels give you extra capabilities such as Wifi Tether!


    I hope this helped you and many more to come!
  10. BxRosie04

    BxRosie04 Member

    @JAL: cool! I just finished rooting and flashing Ubunto 6.0 and BROM 1.3.1 (initially, I had a problem with BROM force closing everything, but I followed your steps in FAQ #1 and it works just fine now). Up until now, I've noticed three peculiarities:

    1-I can't access the photo gallery from the camera app. Each time I take a picture and click on the thumbnail in the lower right hand corner, the Gallery app force closes on me. Is there a fix for this? I can still access the photo by closing out of the Camera app and manually going into the Gallery, but if I want to share pics at a moment's notice, the whole process becomes a bit of a hassle over time.

    2-The Voicemail Notifier is constantly running (as shown by the constant presence of the VM Notifier notification in the status bar). Is this normal for BRom? Is it costly in terms of internal RAM? Any fix for it?

    3-I was trying to install Titanium Backup and as soon as the load bar gets to "Installing..." the Google Play store app force closes. Any idea why? As it turns out, this is the case with any other app I try to d/l from the Play Store:-/.

    Thanks again! ;)
  11. ragnarkar

    ragnarkar Well-Known Member

    If you don't mind resetting your phone (you'll lose all of the data but get to do a clean install), you can get the Almost Stock ROM and install that first:

    [ROM][UPDATE 10/11/2011][bROM v1.3.1-Last Release for A While!!] - SDX-Developers Forum

    Then install Intercept Root, flash CM01 again, then install Crappy Kernel, and BROM as instructed by the OP.

    When I first tried the instructions, my phone would close every app as soon as it launched in BROM and I noticed the low disk space indicator at the top. Wiping the phone clean using Almost Stock helped.
  12. JALStudios

    JALStudios Well-Known Member

    With the Voicemail thing running 24/7 is because it waits for a voicemail to come. You could probably disable it! I am currently on the Galaxy S2 for T-Mobile (I switched carriers but I am still working with Virgin Mobile Devices) and it has the voicemail running 24/7.

    I Hope this answered your question.
  13. retrofitz

    retrofitz New Member

    My question about rooting my VM Intercept is this- I use it almost only for wifi so I don't pay to keep the 3G active except for maybe twice a year when I think I will need it.

    If I'm rooted and I try to reactivate the phone, will VM somehow be able to detect that it's rooted and say "no" because of terms of service?

    Thanks!
  14. JALStudios

    JALStudios Well-Known Member

    Nope....You should be able to just hook it back up with them with NO PROBLEMS!! I have done this before!
  15. ThinkDPr

    ThinkDPr New Member

    @JALStudios,

    Thanks for this thread! I just used it to root my Intercept (VM) and the process went pretty well. I made it through all of the instructions and installed bROM. :thumbup:

    I'm getting the apps not responding/force close for my apps issue so I'll see what I can do about it. :hmmmm2:

    My main questions relates to your instructions. Shouldn't your "**NOTE** If you are installing a ROM with the 1% battery mod DON'T Wipe Cache or Factory Reset because it will make it BOOTLOOP! The 2 ROMS that i have included that have that 1% Battery Mod is the BROM_1.3.1 and Ubunto6.0. The rest of the ROMS you need to Factory Reset and Wipe Cache!" be at Step 6 instead of Step 9? Once I got to Step 6 and went into 'Wipe' there wasn't an option that was called 'Format Cache' so I essentially skipped that step. The install went through even though I'm having that small force close issue.

    Again thanks for this thread because it was very useful to me.
  16. thor1701

    thor1701 Member

    hello, new to this website, wanted to say how cool it was and how easy it was to root my phone.....i do have an issue however....

    i followed your instructions to the letter
    first i went with the [COLOR=Blue][COLOR=Red][COLOR=Blue][COLOR=Red][COLOR=Blue][COLOR=Red][COLOR=Blue][COLOR=Red][COLOR=Black][COLOR=Red]IceCreamFROYO1.2,
    and all it would do is say all my apps would stop running and had to close
    then i switched to [/COLOR][/COLOR][/COLOR][/COLOR][/COLOR][/COLOR][/COLOR][/COLOR][/COLOR][/COLOR]
    [COLOR=Blue][COLOR=Red][COLOR=Blue][COLOR=Red][COLOR=Blue][COLOR=Red][COLOR=Blue][COLOR=Red][COLOR=Black][COLOR=Red]BROM_1.3.1, which seemed to be fine, cept it was GREEN! lol wish i could change that, anyways the problem with that is...i have lost all 3g, there is no mention at all anyware in the settings about 3g, i did not notice it till i went outside my home, as my phone is always connected to the network.....
    another problem i have, which i have had since i have owned the phone, transfering files from the computer to the phone and vice versa through the usb cable causes the phone to lock up and my explorer to lock up, till i unplug the usb cable, then everything is fine again
    but the main issue is the no 3g, no mention of it anyware on the phone
    mine is a virgin mobile intercept m910
    i will admit, things run faster now that i rooted it

    [/COLOR][/COLOR][/COLOR][/COLOR][/COLOR][/COLOR][/COLOR][/COLOR][/COLOR][/COLOR]
  17. JALStudios

    JALStudios Well-Known Member

    If the apps were FORCE closing or weren't working then you can just factory reset! DO NOT FACTORY RESET BROM, IT WILL BOOTLOOP! I would suggest just going back to the original ROM and factory reset it if it keeps force closing! Also this method works with pretty much any other ROM... So you can just search Android Forums or XDA Developers for other Samsung Intercept ROMS!
    thor1701 likes this.
  18. InterceptVM245

    InterceptVM245 New Member

    Ok.. followed your steps line by line.. ended up on a bootloop no matter which rom I installed. I did the complete reset back to stock, to include the stock recovery as you suggested and start from square one..

    stock rom (with the stock recovery...) boots and now sits on a black screen.. can't load a new kernel or rom due to the stock recovery!

    To top it off.. I'm modern and run Windows 7... so no usb drivers for me. All I get is unknown device, so I can't use the damn SWUpdate to flash CM01 Recovery...

    I am now loading up VM Ware and installing a mock up of Windows XP to see if I can get the phone to show up there with the drivers... but as it stands, no dice. 0230 hrs and I think I may need a new phone.

    The wife may just kill me in the morning. :|
  19. JALStudios

    JALStudios Well-Known Member

    Well it sounds like you bricked up your phone. With the Samsung Intercept it is VERY easy to brick. I bricked one of my Intercepts before.


    Can you boot into the stock recovery?
  20. InterceptVM245

    InterceptVM245 New Member

    Yeah I sure can. This is exactly what I see -->

    1) Samsung Bootup with the bar on the bottom
    2) Virgin Mobile's audio/visual boot screen
    3) BLACKNESS GALORE! lol

    I can go into the recovery mode.

    I am on the hunt (however so very unsuccessful) for Windows 7 USB drivers... I can't find the power cord to my very old dell windows xp laptop.. lol I am even at the point of installing XP Mode on this box just to see if I can use the usb drivers THAT way.. Unknown devices has a nasty habit of not showing in a VM.

    Advice sir?
  21. InterceptVM245

    InterceptVM245 New Member

    Okay, I have spent all day tearing my house apart for a dell power cord.. lol No luck. But in the time, I also looked and looked and looked for more information on fixing this damn thing. Found something.

    My mother in law happens to have a netbook running Windows XP.. I will be using that tonight to run SWUpdate and put CM01 back on the phone. With that, I can properly fix this darn thing.

    I also figured out what I did wrong.. CM01 has three wipe options.. After looking at the guide here : [GUIDE] - How to install Custom Kernel/ROM on your Intercept using CM01 Recovery - SDX-Developers Forum, I found out I was using the wrong wipe..

    You said to select "Wipe" and "Format Cache".. I figured you meant to do a Data/Cache wipe followed by "Wipe Cache" - from this text "The rest of the ROMS you need to Factory Reset and Wipe Cache!"..

    The guide made it clear.. DO NOT FACTORY RESET.

    So, I need to instead do a Wipe Dalvik Cache followed by a Wipe Cache - then install the Kernel/ROM.

    I think when I did the factory reset whatever was left in the Dalvik Cache was causing the phone to not boot. Since I still have access to the recovery, I'm hoping that means it isn't fully bricked.

    Your thoughts before I try this? The wife leaves tomorrow for a weekend in El Paso, Texas for a wedding.. leaving me at home.. all alone.. I'd like her to have the cell for the trip. Thanks in advance for the help!
  22. JALStudios

    JALStudios Well-Known Member

    If you can boot into the recovery then you are Semi-Bricked. You still have some life in your phone! The way most people brick up the Intercept is either Flashing a Sprint Intercept recovery or flashing a Sprint ROM (that changes the baseband) and it can't be changed back.
  23. InterceptVM245

    InterceptVM245 New Member

    Okay! I got the mother-in-law's netbook... (mine runs 7.....) and I got the CM01 Recovery re-installed !!

    I wiped the correct way this time.. and I installed bROM, rebooted, than CrapKernel.. rebooted again.. I'm sitting on the glowing bROM v1.3 in green, it vibrates once.. pause.. than twice.. and repeats. *sigh*..

    Please tell me there is a fix..
  24. JALStudios

    JALStudios Well-Known Member

    Install the Kernel before you install the ROM! It seems like there is a problem with flashing the custom ROM with the stock Kernel!
  25. ragnarkar

    ragnarkar Well-Known Member

    IMO, this is a low-quality phone. I took the plunge to hack and root it with the intention of getting a new phone (the HTC 4G from VM) if it ever bricked. If you brick it, just do yourself a favor and buy the phone you deserve. If not, then you can overclock it and wait till it runs out of juices for good before getting something new.
Loading...

Share This Page