How to root [Without ADB]


  1. soapinmouth

    soapinmouth Well-Known Member

    So it seems alot of people are having problems getting ADB I myself included, so I used this method instead from the Droid forums.

    one tip though is I used skyfire instead of the default browser because the download didn't seem to work right, and because fo that all the lines of code should have an s at the end of the word download ("download" -> "downloads")

    Droid X Hacks - Droid Forum - Verizon Droid & the Motorola Droid Forum


    Advertisement
  2. jfulcher

    jfulcher Member

    You could also just download the zip to your PC, mount your phone to yoru computer, create a folder called roothack or something like that, extract the zip there and do everything the same way. Probably easier than downloading on the phone, renaming etc.

    Great idea though.
  3. bobomatic

    bobomatic Well-Known Member

    ok i have DroidXRoot_v2.zip on my droidx. i cant find. "Open the download folder and then long press on the file "resource.ashx" i find the folder, but not the ashx file.

    ok. think i got it.
  4. Android_LIFE

    Android_LIFE Well-Known Member

    You don't have to rename the zip file if you download it to your Droid X.
    Its not hard and doesn't complicate a thing if you download directly to the phone. :rolleyes:;)
    Simply open Astro File Manager, navigate to sdcard/download folder.
    Tap and hold on the zip file and select extract.
    Extract the files to the download folder, its fine...
    I had my wifi & bluetooth turned on prior to starting the Android terminal emulator process.

    Hope this helps. :D
    Dmordarski likes this.
  5. NickBaragona

    NickBaragona Well-Known Member

    Yesss finally! It worked! Thanks a lot!
  6. bobomatic

    bobomatic Well-Known Member

    yes sir! thats what had me hung up for a while. finally i thought what the hell, and went through the emulator process and it worked...if you dont see the. "resource.ashx" file that your supposed to rename, dont worry about it. i never saw it, just extract zip and do the emulator process.
  7. Legato

    Legato Well-Known Member

    I LOVE you. This FINALLY worked. I tried for hours to Root the wife's incredible, tried 10 different ways, no go. Tried two different ways to root my X last night, no dice....

    this i got first try. You are the MAN!
  8. scary alien

    scary alien not really so scary Moderator

    You wouldn't believe how many folks have issues being able to transfer files to/from their PC to their phone or using adb. USB / connectivity between the phone and PC is THE biggest issue most folks seem to have (or at least the ones trying to root their Eris, anyway).

    Having an alternative like this will allow (for good or bad :eek:) some folks to root that otherwise would never be able to. There's a similar "phone-only" method for rooting the Eris that's been a lifeline to a lot of folks.

    The OP did a great service to the folks on this forum for posting this.

    Also, be careful if you do root: not all folks should root just for the sake of rooting. You need to understand what is going on and what the implications / consequences are. You can really get yourself in trouble (for example, if you delete the wrong app/file) and end-up bricking your phone. There is currently no good recovery method (i.e., being able to install a custom recovery or make a Nandroid backup)--so, proceed cautiously. I do think adding more cautions / disclaimers would be prudent at the top of all such instructions. Thanks.
  9. Naughty#9

    Naughty#9 Active Member

    i was able to root mine this way. i tried adb for an eternity.

    thanks.
  10. jfulcher

    jfulcher Member

    I'm not talking about sending stuff with ADB. I'm talking about putting the phone in mass storage mode and plugging it into the computer. Copying it just like you would MP3s to the computer. To me it's a more difficult step to download it on the phone, find it, rename it etc than to just download it to the PC and copy it to the phone - it's just not that hard.

    It's great that the OP created steps to run ON the phone for everything else, I just think the downloading process could be made a little more simple.

    I'm sorry, but if someone can't figure out how to mount the phone to a drive letter in windows (or whatever OS) then do they really need to be rooting their phone?
  11. scary alien

    scary alien not really so scary Moderator

    +1, I actually do agree with you (wasn't trying to be contrary to you in my reply, just wanted to point-out the issues re. connectivity).

    Rooting is a decision that should not be made lightly and I think folks should be more informed about the potential downsides.
  12. Dmordarski

    Dmordarski Well-Known Member

    Thanks for the walk through breakdown, I am now using wireless tether... Long live droid!
  13. Polymathic

    Polymathic New Member

    rooted, sh!t removed, and netbook tethered.

    rooting took a couple of tries.

    all in all, easy and awesome.

    thanks everyone.
  14. VDubBugMan53

    VDubBugMan53 Well-Known Member

    ok so i was having issues where i would get all the way to the end and type su and i would get access denied

    tried over and over and over and over with noting

    maybe it is supposed to be obvious but it apparently was not for me but i went in to astro and installed superuser.apk (make sure your non market apps box is checked) and installed it

    went back in to the Emulator and typed su and then BAM!! got #
  15. Legato

    Legato Well-Known Member

    Since i've never gotten ADB to work on any of my PCs, does anyone know the commands i'd need to use to reroot my phone after the OTA update to 2.2 using just Better Terminal app??Is it the same commands?
  16. beangrower

    beangrower Well-Known Member

    bump this up. i would like to know this as well.

    i have terminal emulator and the rageagainstthecage-arm5.bin, busybox, su, superuser.apk files in my sd card.
  17. Legato

    Legato Well-Known Member

    i ended up using this method to root my phone. Took 15 min to install SDK and the usb driver then reboot. After that one click and i was rooted in under a few minutes. XD
    llamakc likes this.
  18. llamakc

    llamakc Well-Known Member

    This also worked for me on Linux.
  19. akkkmed

    akkkmed Guest

    I was so excited for this, since I can't get ADB to work either.
    But I am totally stuck at this step. No matter what terminal app I use, it says these commands/files don't exist.

    Now open your terminal app and type the following commands:
    Code:
    cd /sqlite_stmt_journals
    cp /sdcard/download/exploid ./exploid
    chmod 755 exploid
    ./exploid
  20. soapinmouth

    soapinmouth Well-Known Member

    Ccreason I havnt updated this post is because I didn't use the official 2.2 ota so I havnt even looked at the new root method. Il try n look if I get some free time today
  21. beangrower

    beangrower Well-Known Member

    here, try this method:
    Much simpler guide for rooting (no pc required) - Droid Forum - Verizon Droid & the Motorola Droid Forum

    i used this to root my 2.2 ota via android terminal emulator. also shows how to unroot (never tried that yet). root worked fine for me.


  22. akkkmed

    akkkmed Guest

    Thanks beangrower. I followed the steps to a tee. For the third command, it says access denied......
  23. crunkman989

    crunkman989 Member

    So Im at the first command line which is:
    cd /sqlite_stmt_journals

    when I put that in....I get the next line which says:
    cd: can't cd to /sqlite_stmt_journals

    Anyone know why I get this command line message?
  24. dvschnk

    dvschnk Member

    I would like to know too. Crunk, were you rooted in 2.1? I was just wondering because I was, and after 2.2 ota, I lost root, but I still had the superuser ninja in my app drawer. I knew I lost root because wifi tether wouldn't work. I tried this method, but got the can't cd to /sqlite_stmt_journals

    I ended up using the 1 click .bat file to root. That was a test of patience for me. Couldn't get adb to detect my device in pc mode with the latest moto drivers until I reinstalled the drivers in pc mode w/o debugging, and then once the drivers were detected, switched on debugging. Another weird thing was that I had to run the .bat file twice. The first time it removed my old superuser ninja, then it installed it again.
  25. quickaudi

    quickaudi Well-Known Member Contributor

    Man, I got stuck at chmod 777 rage*.bin

    Says no such file or directory
Loading...

Share This Page