[HOW-TO] Simplified Root + Recovery + Custom ROM

Last Updated:

  1. yogi-4

    yogi-4 Well-Known Member

    Do not use Rom Manager to flash a ROM. AndyOpie wrote this in a different thread... I'm just going to copy and past his quote:

    "ROM Manager is actually something you might reconsider keeping on your phone as you can do more with it than you realize. You can install an update to an existing ROM,install a kernel,and a theme using the install ROM from sd card option(you must not try to install a new ROM as it will only wipe cache partition and dalvik cache).
    You can delete and rename and restore a backup using the manage backup option.
    You can fix permissions if your having force close problems with an app.
    You can backup an installed ROM."

    AndyOpie, hope you don't mind me qouting you, but I felt this info was relivent. I don't want to see the op screw up his phone the first time. Good luck man!!

  2. mikeyr29

    mikeyr29 Member

    ok, if not using RM to flash the rom then how do i go about flashing it? (sorry if its already been explained in the thread...)
  3. yogi-4

    yogi-4 Well-Known Member

    You put it at the root of the sd card. Look at the first post of this thread and it will explain it.
  4. Thanks for the instructions. The only other device I've rooted/installed CM7 on is my Nook Color, which was beyond easy. I've been avoiding doing anything to my OV just because other directions I've read looked too complicated. After reading the steps, I finally sat down last night to give it a shot.

    This wasn't much tougher than doing my NC. I had to reboot and run Gingerbreak a second time, but everything else worked perfectly. I freaking love these forums. Now I have a fully functional droid phone as opposed to the clunky, locked down OS that came with the phone initially. Now I'm just playing with overclocking settings. It keeps locking up/rebooting at 807. Guess I didn't get super lucky with the phone, but I'm thrilled with what I've got now otherwise :D

    ETA: The Green Machine skin is quite nice, too.
  5. droidlg

    droidlg Member

    So do i copy the .zip or unzip and copy contents of zip to my sd card ?
  6. droidlg

    droidlg Member

    props to whoever created this its bad ass and runs so smooth to dont mind that you used adw launcher not the biggest fan of it but i do use it off and on but just wanted to say thanks its pretty cool didnt install the green machine though
  7. Whyzor

    Whyzor Well-Known Member

    DO NOT unzip, just copy the .zip files onto /sdcard.
    droidlg likes this.
  8. mikeyr29

    mikeyr29 Member

    Anyone having any problems with phone calls being hung up on? my phone worked fantastically until today. all of a sudden (with good service mind you) the call just hangs up. it didnt give me the "call was dropped" logo and im not pressing end call by accident. when i receive a call and answer it, it hangs up almost immediately. when i place a call i get about 10 seconds and then it hangs up. this is extraordinarily aggravating. any suggestions?
  9. jkdmoore

    jkdmoore Well-Known Member

    I have rooted and running Backside IHO 09192011, but my navigation app is just gone, I love that thing (do alot of traveling) how can i get it back?
  10. Whyzor

    Whyzor Well-Known Member

    It's probably a problem with that ROM, there are more updated IHO builds since then. that's not a problem I've heard others reporting so likely it just requires rewiping (in recovery mode) and reflashing.
  11. Petrah

    Petrah Psychotic Female

    Is the navigation app included in BACKside? I don't have it with mine either (10042011). I don't use it so I didn't notice it was gone.
  12. Whyzor

    Whyzor Well-Known Member

    It's part of Google Maps, so you may have to install or update that.
    dgodwin1 likes this.
  13. Petrah

    Petrah Psychotic Female

    Google Maps... evil. Pure evil I tell you!

  14. genosse

    genosse New Member

    Just rooted, and tried to flash a rom for the first time.

    Followed the OP's instructions to the letter, flashed the BACKside ROM, gapps.zip and rebooted.

    It spun on the boot screen for a bit (green droid with the circle around it) and then froze. Power button does nothing.

    Is it safe to remove the battery and reboot? Is there maybe something that I accidentally missed?

    Thanks to all

    EDIT: I missed wiping the dalvik cache in the advanced settings. Did this, and re-formatted the cache and partitions, then reflashed the rom. Everything looks to be working fine.
  15. yogi-4

    yogi-4 Well-Known Member

    Nah, if you made it that far... something just glitched. Try rebooting and give it some time. If the same thing happens, try formatting the cache and everything again... maybe multiple times to make sure everything is wiped then reflash the ROM and gapps. Sometimes this happens.
    genosse likes this.
  16. andyo

    andyo Member

    Hi guys, new here. I got a Optimus V with 2.2.2. Everything went fine until step 7. I cannot boot in clockworkmod ( recovery mode. I just get a blank (black) screen, but from what I can tell, apparently the menu is working. If I press the camera button first, it reboots, which is the first option. If I play with the up/down volume buttons, then it doesn't, which I think it's going through the menu, but I just can't see anything.

    Help would be much appreciated, I've been hours at this, googling has turned nothing.
  17. bigsupersquid

    bigsupersquid Well-Known Member

  18. andyo

    andyo Member

    god, thanks a lot! It was super frustrating, that page was coming up in many of my google searches, but the android central forums were having some kind of DNS problem, I couldn't access them.
  19. andyo

    andyo Member

    Hmm so I guess I have to install xionia? I tried what's in the edited part

    I think I messed up. I thought this meant install the CM ROM and I could access the recovery screen after this. Now the phone won't boot up at all. I think it's going into recovery mode but still with a blank screen. It just won't boot normally and I don't see anything.
  20. andyo

    andyo Member

    OK sorry but I'm dying here. Googling isn't turning up anything useful. I cannot boot, and I'm only getting the blank screen (after LG and Virgin splash screen without sound). "adb devices" tells me I'm in recovery mode, and "adb reboot" doesn't do anything, just reboots the same. But again, I cannot see any of the options of recovery due to the screen issue. fastboot doesn't work, "fastboot devices" doesn't show my phone, or anything at all, it only goes back to the prompt.

    What I think I need to do is to flash either a kernel or a ROM via adb directly (not from recovery screen). Googling turns up confusing stuff like this, which besides not being entirely clear to me, I don't know if it's the right thing to do at this point.
  21. mkbkr1

    mkbkr1 Well-Known Member

    Take a look at the sticky " Fix Black Screen ....". Sounds like you have a newer V with the different screen and drivers.

  22. andyo

    andyo Member

    Yeah, that's the thread linked above, unfortunately I'm past that. I can't seem to do anything at all, unless it's from adb. I think I need to reflash either the kernel or the ROM via adb. If anyone would, please let me know if this is possible. It seems so from the thread I linked in my previous post, but I don't really understand it fully, or even know for sure that's what I need to do.
  23. andyo

    andyo Member

    Just in case, it was solved using Android Screencast, I then could see the options, and installed the ROM.
  24. jmfolcik

    jmfolcik Well-Known Member

    LG Optimus V

    usb debugging mode on (shows little dude when connected to computer)
    installed the gingerbreak 1.2 app
    I always get
    GingerBreak: Not sure what happened here. Either the exploit failed or the reboot failed. Please reboot manually and see if you have SuperUser !
    And no, no superuser app shows up after rebooting.
    Tried this with formatted SD card formatted on PC, and by phone itself. Tried with USB cable connected to computer, and without. Many reboots. There aren't any steps to this to mess up! What gives? Where's the log file to tell me what the generic message is based on?
  25. yogi-4

    yogi-4 Well-Known Member

    If your using that method... it could take 4 or 5 tries in a row to get it to root. Since your running 2.2.1, you can also try the other method using Rom Tools. You can check out my 'How To' in my signature if you like.

Share This Page