How to stop "data usage" pop-up display?Support

Last Updated:

  1. felixbast

    felixbast New Member

    Hi forum members,

    This is my first message in this forum. I am using android eclair 2.1 in samsung galaxy3 phone. One annoying blue pop-up displaying very so often in my phone is info regarding how much data was used. Something like this:

    Usage made: 0.04MB. You have: 1848.87 MB left in your account. Valid upto Feb 14 2011

    Sometimes when i get a call in mornings, i have to click "OK" some 20 times before i can answer the phone, REALLY ANNOYING and i found no way to block this message from appearing.

    Any tips?


  2. senthiln

    senthiln New Member

    I am also having the same issue. From time to an alert box with data usage details are displayed. This message comes from service provider ( BSNL, Airtel etc). When I leave the phone idle some time there are too many such pop ups. I have to press OK button so many times before starting to use the phone or apps. It is annoying. It also turns on the the screen frequently after turning off the screen. This results in unwanted batter usage.

    How to turn of the notifications from Airtel or BSNL ?

    How to tell android to suppress those pop-ups?

    How to tell android not to turn on the screen for these annoying pop-ups?

    I find the android settings tab to be too simple and rigid. It doesn't give me the necessary configuration options.
  3. clipsnotebook

    clipsnotebook New Member

    Hiya All,
    I face the same "pop-up" issue with my samsung galaxy s2. If the phone is idel for 30 mins or so, I have to click ok multiple times before I can start using the phone. Is there a way to switch off this automatic data usage popup? I am on Airtel and use the 98 rupees prepaid gprs plan

    Any pointers or solution would be very helpful.. Thanks.
  4. chanchan05

    chanchan05 The Doctor Guide

    I think you're getting the notifications from Airtel because of your plans. If you have an Airtel installed app on your phone, that may be the one making the notifications. android doesnt have settings for those because the popups you are seeing is not an Android feature. My sister does not have unlimited data on her phone but popups do not show.
  5. clipsnotebook

    clipsnotebook New Member

    Thanks for your prompt reply. I do not have any airtel app on my phone - thankfully I did not purchase this from airtel. Would you be kind enough to check if your sister's phone has cell broadcasts turned off? I am not sure if that is the real culprit since the popups are randomly timed.
  6. mathai86

    mathai86 New Member

    Hi Guys.. I too have the same issue of popups regarding data usage. I use a vodafone connection and have discussed this issue with the customer care and they have no idea on it.

    So this issue is confirmed to be from the mobile itself and not the provider. It would be great if some one could provide me a solution regarding this. Thanks in advance.
  7. Harry2

    Harry2 Well-Known Member

    Maybe advertising?
    A new kind of "AirPush" spam?

    As pre-caution I would install 'Addons Detector' and let it do an analyse scan of my apps on the phone.
    After the scan I set the filter at 'Push Notifications' for a better overview.

    Good luck!
  8. fixticks

    fixticks Member

    This is a network service i think. I tried MTN customer care, they say they will see if it can be disabled, they also use the service to show how much credit you have used and balance after any call or text.

    wake up to 20 notifications should be their slogan, may sell more.
    #very annoyed
  9. fixticks

    fixticks Member

    Nothing has happened yet, I however noticed that on iphone 3g, the numerous notifications are not there for data usage, but appear whenever the user makes a call or sends a text message.
    One of the customer care reps had said it is a phone thing, hmmm, more research needed.
  10. felixbast

    felixbast New Member


    I have upgraded to Gingerbread 2.3.6, rooted and installed "AdFree" app (this need root access), and now this annoyance is solved yippee!

    "Felix Bast"
  11. srvcrazy

    srvcrazy New Member

    hello felix-blast

    i rooted my samsung galaxy s2 and installed adfree app.. i still get the popop. help me configure it.
  12. fixticks

    fixticks Member

    can u post a screen shot.?
  13. annievink

    annievink Member

    i hve the same problem in my galaxy mini 2.3.5 n its quite annoying! plz help :(
  14. annievink

    annievink Member

    here's the screen shot from my phone :
  15. annievink

    annievink Member

    i hve the same problem n its quite annoying! here's the screen shot :
    plz help :(
  16. ChanderS

    ChanderS New Member

    I have the same problem on my phone with BSNL connection.

    The only time I find this notification useful is when I have not taken a data connection. (I take internet connectivity on a monthly basis from time to time when I feel like it.) At such times, my phone (probably the apps in my phone) still connects automatically to the internet and starts using up my money, which has been prepaid for call charges only, towards data connectivity. The popup notification then shows both the bytes used and the amount charged, thus warning me to turn off the unwanted but forcibly made internet connection so that it will not eat up all my money. But then, within a short while it again connects to the net by itself. (This is actually a separate story, and it was only today that I found out ways to remain disconnected from the net when I have not paid for data connectivity.)

    Still waiting to see if anyone can provide a solution for stopping those pesky popups. Until then, what I can suggest is: whenever you are leaving your phone idle for a while, disconnect it from the internet so that those annoying messages don't accumulate. Re-connect to the internet only when you are actually going online; keep it turned off at all other times.
  17. talkative

    talkative New Member

    Attached Files:

  18. fixticks

    fixticks Member

    I was able to get the messages to stop.
    Called customer care more than 4 times (i know xD) but eventually I got someone who properly understood what am going through, they patched me through to tech department and said the notifications are a service they provide, and is not phone generated.
    They made me wait an hour or so to deactivate them, however now I do not get popups showing how much I have used for a phone call or text message. But it's a happy trade off.
  19. endriod

    endriod New Member

    i too was searching an answer for the same problem, its too annoying, tapping the screen frequently was such a waste, i then stumbled upon an app which i think is of great help.

    As a matter of fact, these messages are USSD protocol used by GSM cellular(used for wap browsing), so i searched the app store and got an app called 'balance update/ USSD blocker' and downloaded it

    when downloaded it prompted me to settings where i could control the frequency of this messages as well as block messages by matching some of the keywords, IT WORKS !!!

    so you can try this too, hope it helps
  20. ChanderS

    ChanderS New Member

    The Android app "Balance Update / USSD blocker" works! (Available free in the Google Play app store.) Thanks so much, "talkative".

    (Maybe the earlier name was "Quiet Balance"?)

    I should have checked back soon after my earlier post. Slipped my mind as I was occupied in cancelling all those useless notifications...

    (BSNL mobile net connection on Samsung Galaxy Note; still on GB 2.3.6)
  21. Bhat1976

    Bhat1976 New Member

    Balance update / USSD blocker works very well. I had a problem in installing in installing though. It was due to google password problem. GTalk password can not be changed. For downloading the app from google play, it requires the mobile to be known to Google play (associated with your google id).
    If you have any trouble with it, people advise to reset to factory defaults. You do NOT need to do this. In mobile, Go to settings -> manage applications. Go to individual google applications such as google market, gmail and gtalk. Clear the data for the applications. Then enable gmail sync. After that your mobile would be known to google under your id. Then you can proceed to installing the app.
  22. aeonaxan

    aeonaxan New Member

  23. atulct

    atulct New Member

    These Apps have stopped working since Android 4.2.2

    Any solution in sight now?
  24. kiranrj1

    kiranrj1 New Member

    There is an application in Play store USSD to Notification. This application routes the USSD Messages to its log. So the messages will not be popped up, but will be available in the log file, which we can check any time. This is really useful and user friendly.
  25. asachdeva

    asachdeva New Member

    ussdtonotification does not work on 4.2.2. I had to switch of mobile data all together to get rid of the pop up dialogs. Is there an app that works on Android version 4.2.2.

    I urgently need something to stop the pop ups.

Share This Page