1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

Support How to STOP galaxy from automatically turning on and connecting to WiFi?


  1. CellularGuy

    CellularGuy Member

    I think this may have started since the last system update, but my galaxy SII now auto-connects to any WiFi network in range. This is incredibly frustrating because it drains the battery like crazy.

    The other night, for instance, I had a fully charged battery before I went to bed (I had the WiFi off), but the next morning the WiFi had turned on automatically and my battery was at around 50%. Very frustrating.

    I read in another forum post that "forgetting" networks will stop the phone from auto-connecting, but that's not an option for me because the security keys for the networks I use sometimes are long and impossible to remember.

    How can I STOP the phone from automatically turning on the WiFi?

    Advertisement
  2. mortalic

    mortalic Member

    My wife's S2 has the same problem, does anyone know what the fix is?
    t.burninator and godsdragon like this.
  3. alb

    alb Member

    Go to Menu - Settings - More Settings - Mobile Networks - Connection Optimizer and uncheck Sprint Connection Optimizer.

    I had the same problem and finally found the solution on one of the forums.
  4. mortalic

    mortalic Member

    That worked great, thanks.
    t.burninator likes this.
  5. CellularGuy

    CellularGuy Member

    thank you!
    t.burninator likes this.
  6. slowrunner262

    slowrunner262 New Member

    I'm having the same problem but I'm not seeing the "more settings/mobile networks " etc.....how do I find this?
  7. Method760

    Method760 Well-Known Member

    Someone really needs to make a sticky, same question seems to be asked this whole week.
  8. Method760

    Method760 Well-Known Member

    Menu>Settings>Under Wireless and Networks choose More>Mobile Networks>Sprint Connections Optimizer>Uncheck the box for it.
    CellularGuy and slowrunner262 like this.
  9. afsound

    afsound New Member

    I was going nuts since this recent HORRIBLE system wifi update. I want complete control. Now I have it back.

    THANK YOU
  10. WindEnergy7

    WindEnergy7 Active Member

    I have a Galxy S II that we use for WindEnergy7 to support customers and communicate with our solar panel installers, inspectors and others. We can be on a roof installing solar all day with no place to plug in and charge. So, battery life is important to manage.

    Recently the phone got an update and I have had a hard time keeping it charged now. About all I try to do is keep the 4G OFF unless I need it, and I also turn off the Wifi, again only if I need it do I ever turn these on. Both of those features will drain a battery quickly.

    Since this update I can be out installing solar panel kits and the phone keeps automatically turning on Wifi when I DO NOT WANT IT. I keep turning it off but it just pops back on automatically. How can I turn that BACK TO HOW IT WORKED BEFORE? I looked at settings for Wifi and see no control for it to stop auto launching or whatever it's doing? PLS ADVISE.
  11. alanzer

    alanzer Well-Known Member

    It could be the Connections Optimizer. Go to Settings>More>Mobile Networks>Connections Optimizer. Uncheck the box and see if that helps out.
    WindEnergy7 and Method760 like this.
  12. Method760

    Method760 Well-Known Member

    ^^^Yes that will fix it and its answer and I think the previous 3 posts...
  13. DragonSlayer95

    DragonSlayer95 Resident Air Bender Moderator

    Merged into existing update thread.
    Method760 likes this.
  14. WindEnergy7

    WindEnergy7 Active Member

    Yes, thanks for the answer and it looks like that will fix it. EXCELLENT!
  15. grcswoosh

    grcswoosh Member

    Thanks so much, this was soooooo annoying. Why did Sprint need to hide this so deep?
  16. alanzer

    alanzer Well-Known Member

    My guess is that they want to make you use wireless and relieve traffic on their mobile network whenever possible. Even though they say we have unlimited data usage. They always have random 'tips' on their site saying that using wifi helps save battery.

    I personally find it annoying that they want to choose when we use certain things. It should be up to the user, not them.
  17. iTzKPanda

    iTzKPanda AF's resident panda

    Using wifi does save battery compared to using 4G.
    But they want people to use as little data as possible. Which is understandable, but annoying at the same time.
  18. Zinja

    Zinja Well-Known Member

    ladies and gentleman using my gs3 and disabling the connections optimizer is not working. Wifi keeps turning on. I also suspect that providers are trying to get consumers to utilize their own wifi connection as opposed to provider data connections.

    Is anybody aware of an app that takes care of this? I need to disable wifi and I don't want to turn it on. It's draining my battery.
  19. alanzer

    alanzer Well-Known Member

    I helped a friend with a S3 disable his Connections Optimizer and it worked. You might try clearing your cache prior to booting the phone, then go disable it. My S2 works great with the Optimizer disabled, so I don't know of any apps at the moment.

    Did the S3 have any kind of update recently? Maybe Sprint is trying to force people to use their annoying Optimizer. Which would seal their fate upon my contract completion in a couple months.
    Zinja likes this.
  20. Zinja

    Zinja Well-Known Member

    I have cleared cache in internet settings. is this what you are referring to?

    are there any other caches is that I can clear?

    I have been processing some updates but I'm not sure when exactly I started having this problem it's been a couple months. since I am using a sprint airave to boost my connection I don't need wifi connection on. but it keeps turning on.

    I will advise the thread how this fix worked.
  21. Zinja

    Zinja Well-Known Member

    Wifi turned on again.

    I am also using Snapdragon battery guru. I'm wondering if it is doing this for me.
  22. iTzKPanda

    iTzKPanda AF's resident panda

    You can download DS Battery Saver from the play store. It turns off wi-fi for you when you turn your phone off as well as put it into deep sleep so not much battery drain should occur while the screen isn't on.
    Zinja likes this.
  23. Zinja

    Zinja Well-Known Member

    I'm going to download DS battery saver. Will this affect my ability to make and get phone calls? Do you have any tips to get through that aspect?
  24. iTzKPanda

    iTzKPanda AF's resident panda

    No, you should be able to receive phone calls and texts like normal. You just might receive notifications later than you normally would.

    And within the app, you can add apps to a white list that prevents the app from putting it into deep sleep. :)
    Zinja likes this.
  25. Zinja

    Zinja Well-Known Member

    After I uninstalled SnapDragon Battery Guru, my WiFi has stayed off all morning. First time in months.

    I have installed DS Battery Saver, going to give the free app a shot for a while.

    Poster, you mention an ability to customize. I take it you have the paid version?:confused:

Share This Page