How to stop web pages loading in "mobile" view?Support


Last Updated:

  1. jojitsu

    jojitsu Well-Known Member This Topic's Starter

    Joined:
    Feb 28, 2010
    Messages:
    77
    Likes Received:
    6
    Hi all, sorry if this has been covered before or I'm just being stupid and overlooking a simple setting, but I'm pretty sure on my old HTC Hero there was an option in the settings to always load web pages in either mobile form, or the full web page (classic)... Is this something that I can do in the settings on the Nexus one, because I do find it a little annoying having to regulary reload pages in "classic" view?

    Many thanks for any info. :cool:
     

    Advertisement
  2. DannStarr

    DannStarr Active Member

    Joined:
    Feb 28, 2010
    Messages:
    27
    Likes Received:
    1
    Yeah i'd like to know this too.

    Jailbroken iphones could install something called "UA Faker" which meant that the web site you were visiting did not know you were visiting from a mobile browser and so loaded the full version of the site. Anything like this for Android 2.1?
     
  3. modern

    modern Well-Known Member

    Joined:
    Nov 26, 2009
    Messages:
    52
    Likes Received:
    18
    On my Desire rom, its under browser settings. Tap more, settings, and uncheck mobile view.
     
  4. daffyduck

    daffyduck Well-Known Member

    Joined:
    Sep 16, 2009
    Messages:
    754
    Likes Received:
    42
    Also make sure you have the correct APN settings.....

    I had to make some modifications from WAP to Internet on Vodafone in the UK.
     
  5. jojitsu

    jojitsu Well-Known Member This Topic's Starter

    Joined:
    Feb 28, 2010
    Messages:
    77
    Likes Received:
    6
    Well there is nothing in the settings, and I'm pretty sure my APN setting are just how they should be.... Bummer 8(
     
  6. grainysand

    grainysand Well-Known Member

    Joined:
    Feb 4, 2010
    Messages:
    1,580
    Likes Received:
    175
    None of the above. On a stock Nexus, type:

    about:debug

    Then check your settings. You should now be able to choose whether or not to view websites in mobile version.
     
    vang and DannStarr like this.
  7. jojitsu

    jojitsu Well-Known Member This Topic's Starter

    Joined:
    Feb 28, 2010
    Messages:
    77
    Likes Received:
    6
    Sorry if I sound dumb, but where do I type "about:debug"?........ I don't quite understand.. Thanks for the help ;)
     
  8. grainysand

    grainysand Well-Known Member

    Joined:
    Feb 4, 2010
    Messages:
    1,580
    Likes Received:
    175
    The address bar where you usually type URLs.
     
  9. jojitsu

    jojitsu Well-Known Member This Topic's Starter

    Joined:
    Feb 28, 2010
    Messages:
    77
    Likes Received:
    6
    really... doesn't seem to alter any of the settings on my standard nexus... Thanks for trying tho.
     
  10. grainysand

    grainysand Well-Known Member

    Joined:
    Feb 4, 2010
    Messages:
    1,580
    Likes Received:
    175
    No? Not to be obvious, but did you also press go like you would when entering any URL?

    When you go to settings, you should get a new section called "Debug." Under that, there's an option called UAString, where you can choose whether to have your browser load sites as Android, desktop, or iPhone.
     
  11. jojitsu

    jojitsu Well-Known Member This Topic's Starter

    Joined:
    Feb 28, 2010
    Messages:
    77
    Likes Received:
    6
    no, no extra settings for me.. it automatically changes the text to "about:%20debug", and when I look in my settings there is no change... I'm on a standard nexus one in the uk, using an orange sim card..
     
  12. grainysand

    grainysand Well-Known Member

    Joined:
    Feb 4, 2010
    Messages:
    1,580
    Likes Received:
    175
    about:debug

    No space between the colon and "debug." No nothing. Type it in exactly like that.
     
    defiantbeast likes this.
  13. jojitsu

    jojitsu Well-Known Member This Topic's Starter

    Joined:
    Feb 28, 2010
    Messages:
    77
    Likes Received:
    6
    brilliant, it's done!!! I was going wrong because of a space being automatically placed after the ":" and that seemed to make all the difference! Thanks so much for the info, I would have never figured that out! And to be honest, I have no idea how that worked! Thanks again! 8)
     
  14. RedMist

    RedMist Well-Known Member

    Joined:
    Apr 17, 2009
    Messages:
    190
    Likes Received:
    7
    This definitely does not work for me.

    When I type about:debug and click Go, the keyboard disappears. That is all.

    Is this some kind of joke? It's not firefox.
     
  15. grainysand

    grainysand Well-Known Member

    Joined:
    Feb 4, 2010
    Messages:
    1,580
    Likes Received:
    175
    Click go. Menu soft key, more, settings. Scroll down and you should find "debug."
     
  16. bravegirl

    bravegirl New Member

    Joined:
    Jan 18, 2010
    Messages:
    1
    Likes Received:
    0
    Thanks!! Worked perfectly for me.
     
  17. Rcartwright

    Rcartwright New Member

    Joined:
    Dec 28, 2011
    Messages:
    2
    Likes Received:
    0
    You are a genius. I was having the same issue with my Kindle Fire and debug trick worked!
     
  18. Rcartwright

    Rcartwright New Member

    Joined:
    Dec 28, 2011
    Messages:
    2
    Likes Received:
    0
    I should of been more specie....

    Grainysand directed. About:debug. At the URL line.

    Settings then changed to disable Mobil page loading on my kindle fire.

    Thanks

    Richard Cartwright
     
  19. Red Rooster

    Red Rooster New Member

    Joined:
    Oct 8, 2012
    Messages:
    1
    Likes Received:
    0
    On NEXUS 7: To open Desktop web pages, not Mobile...

    For those on Nexus 7, when a mobile page loads by default but you want the Desktop page: in the "Customize/Options" un-labeled button (3 vertical dots, top right) button, there is an option to "Request Desktop site".

    I appreciate that this is obvious, but can be easily missed!
     
  20. Darkat70

    Darkat70 Member

    Joined:
    Dec 12, 2010
    Messages:
    15
    Likes Received:
    1
    Nothing happens for me in the nexus stock browser, dolphin browser has settings to required version. The about:config is used in firefox. Doesn't do anything on my mobile tho. I usually just check request desktop when i want the full website. :D
     

Share This Page

Loading...