How to successfully Mount the Epic 4GTips

Last Updated:

  1. Richie18

    Richie18 Member

    vehgas and jayrey81 like this.
  2. O'Jackie

    O'Jackie Active Member

    The Samsung link leads to an error message which says "The product you are searching for has no downloads."

    I've tried both the ports in the front and the ones in the back of the pc - none of them work with the Epic.
  3. Richie18

    Richie18 Member

    Fixed the link. Should just be click and download. What message/error are you getting when you plug in the Epic?
  4. Keybeeetsss

    Keybeeetsss Well-Known Member

    Same here...
  5. O'Jackie

    O'Jackie Active Member

    "USB Device Not Recognized"

    I tried connecting the phone to a friend's pc and they had no Samsung drivers or any Android drivers on it for that matter (they've got an iPhone), and Windows recognized the Epic right away and file transfers using drop & drag in Windows explorer worked without any problems. The only difference is that they were running an older version of USB and I used their cable.

    I'm going to try my cable with the Epic on their pc and see if it could actually be an issue with the USB cable itself.

    For now, none of the ports on my pc work with the Epic. :mad:
  6. O'Jackie

    O'Jackie Active Member

    Instead of the after-market micro USB cable I had purchased as a backup, I used the one that was originally supplied with the phone. No error messages this time and file transfers are working without any issues. BTW, with this particular cable, I was also able to plug into a USB hub and there were no problems with file transfers.

    Thanks to all for the previous suggestions !
    vehgas likes this.
  7. dawankler

    dawankler Well-Known Member

    I've noticed that this phone is way more sensitive to cables than my G1 was for data connections. I was baffled by a similar problem using an LG branded and another knockoff Micro USB cable. As soon as I switched to the Samsung cable or a Blackberry branded cable the phone behaved as its supposed to.

    The cheaper cables work just fine for charging so I just switched my cheap cables to the charges and leave the OEM cable hooked to the computer.
  8. Keybeeetsss

    Keybeeetsss Well-Known Member

    I myself hav no problems with the phone mounting to transfer files; it jus won't show up as far as when using USB debugging or getting the drivers to happen; no deal there (for me)
  9. Dulanic

    Dulanic Member

    I have to say, the epic is picky as hell with USB and it is rather annoying. I seem to have to reconnect it non stop.... it is using a USB on the front of my PC. The cord is too short to deal with the ports on the back of my PC. I have ordered a couple cables off of monoprice and will see how those work. Ordered a 15ft cable to keep that plugged into the back.
  10. robl45

    robl45 Well-Known Member

    i have same issue, no problems with SD card but adb stuff will not work, just connects then disconnects, works first time on the wifes laptop though so i'm just using that to do adb if I need to.
  11. bls

    bls Well-Known Member

    One thing that helped me do this without installing any new drivers, or switching cables, was turning off the USB Debugging Mode on the phone.

    I noticed that when I plugged the USB cable into the PC and the Epic, the Epic had a warning notification about the phone being in USB Debugging mode (or something to that effect). Here's how you turn that off, so that you get the screen the Samsung people say you should see (and Windows will see your phone correctly).

    1) At home screen, hit Menu button, then Settings / Applications / Development.
    2) Uncheck the "USB Debugging" checkbox.
    3) Plug the USB cable into the phone.
    4) The PC should recognize the phone by name. The Epic screen should give you the three options: Charging; Mass Storage; and Tethered Mode.

    Incidentally, that's the same menu where you can allow the screen to go to sleep while plugged in. If you're like me and charge your phone near your bedside at night, you've noticed that the screen stays on indefinitely; uncheck "Stay Awake" to let it sleep. [Of course, if you plug your phone in during the day and listen to music or whatever, you may want to leave this checked.]
  12. Howard Packer

    Howard Packer Well-Known Member

    When I would plug in to my PC, I got some messages on my PC stating that I was plugged in to a USB 1 (instead of 2) port. Tried other ports, and got the same message. Checked my motherboard manual, and all ports are USB2.

    Re-ran and changed cables, and that sorted it out. Never figured out why. Could this have been the reason?
  13. kurtiebird

    kurtiebird New Member

    Mine is pretty inconsistent. Every once in a great while, I will get the Charging/Mass Storage/Tethered Mode message, but usually I do not. I've tried it on two different computers, using different USB ports.

    IMO, it is unacceptable for a brand new device to have these kind of problems for such a basic function.

    For now, I have to take my SD card out to get files to it, kind of a PITA, but until I stumble on some solution, that's the only thing that consistently works. I've tried the USB drivers, they don't help at all.
  14. gme109

    gme109 Well-Known Member

  15. Flaspeneer

    Flaspeneer Well-Known Member

    Buy a PC. Then you might have practical advice for people who need answers without expecting them to spend a thousand dollars.
  16. evperry

    evperry Well-Known Member

    Mounts to my macbook pro but NOT to my macbook air. no drivers nothing.

    i will also try my imac to see if it mounts there with no problem.

    debug is OFF.

  17. jayrey81

    jayrey81 New Member

    this is definitely the way to go... quick question, what's the best place to find the drivers... in case this one goes out of date?
  18. rodspencer

    rodspencer New Member


    PURCHASE A POWERED USB DEVICE THAT WORKS OFF ELECTRICITY. Epic Phone doesn't produce enough electricity on usb port to work correctly.
  19. M4ngo

    M4ngo New Member --> Support --> Type in product name --> Downloads --> Software

    or Samsung and click Software. There's a .zip file you can download there.
  20. LogicalSoul

    LogicalSoul New Member

    I have a Desktop with Windows 7 Ultimate and a Sony Vaio laptop with Windows 7 Home Edition. Both Systems are 64-Bit. I can't seem to get the desktop or the laptop to read my Samsung Epic 4G that I bought from Sprint.

    Any ideas or suggestions where I can find the right drivers?

    Thank You so much
  21. badankles

    badankles Well-Known Member

    i know this doesn't directly answer the issues, but just to share my experience. i have vista 32-bit laptop and have never needed to manually download drivers. after connecting via usb, windows installed the driver automatically (most likely from the internet). i have encountered where the usb port doesn't work, even though it has worked before. it works when switched to a different port.
  22. vehgas

    vehgas New Member

    Wasted 2 Hours thinking I was using the original sprint/samsung cord but was using an aftermarket one too. I did also download the driver at the top and set usb debug to off and works great on WIN 7 laptop.

    I should have known. Samsung's camcorders require their specific cord too.

    Thanks for everyones help.

Share This Page